Ver. 2.1.1
This commit is contained in:
parent
58c4a529a8
commit
f0e48139b9
1
.gitignore
vendored
1
.gitignore
vendored
@ -48,3 +48,4 @@ wireshark-1.2.10.tar.bz2
|
||||
/wireshark-2.0.2.tar.bz2
|
||||
/wireshark-2.0.3.tar.bz2
|
||||
/wireshark-2.1.0.tar.bz2
|
||||
/wireshark-2.1.1.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
61e1777076fd52253fe6644f757d1ebc wireshark-2.1.0.tar.bz2
|
||||
f67839cb60121ba80f60600b2bfd3c88 wireshark-2.1.1.tar.bz2
|
||||
|
@ -4,20 +4,6 @@ Date: Wed Jan 6 09:37:49 2016 +0100
|
||||
|
||||
Add pkgconfig entry
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 913e064..30f8107 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -57,6 +57,9 @@ EXTRA_PROGRAMS = wireshark-gtk wireshark tshark tfshark capinfos captype editcap
|
||||
dist_pkgdata_DATA = COPYING manuf services cfilters colorfilters dfilters \
|
||||
smi_modules ipmap.html pdml2html.xsl
|
||||
|
||||
+pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfig_DATA = wireshark.pc
|
||||
+
|
||||
#
|
||||
# Install global profiles in the "profiles" subdirectory
|
||||
#
|
||||
diff --git a/wireshark.pc.in b/wireshark.pc.in
|
||||
index 5889178..1e1b62f 100644
|
||||
--- a/wireshark.pc.in
|
||||
|
@ -16,7 +16,7 @@ index 06c1d9a..bf521f1 100644
|
||||
#include <ws_version_info.h>
|
||||
#ifdef HAVE_LIBSMI
|
||||
#include <epan/oids.h>
|
||||
@@ -413,7 +414,7 @@ about_folders_page_new(void)
|
||||
@@ -421,7 +422,7 @@ about_folders_page_new(void)
|
||||
"capture files");
|
||||
|
||||
/* temp */
|
||||
@ -59,7 +59,7 @@ index 733fc55..a1068cd 100644
|
||||
#include "wsutil/plugins.h"
|
||||
#include "wsutil/copyright_info.h"
|
||||
#include "ws_version_info.h"
|
||||
@@ -210,7 +211,7 @@ AboutDialog::AboutDialog(QWidget *parent) :
|
||||
@@ -213,7 +214,7 @@ AboutDialog::AboutDialog(QWidget *parent) :
|
||||
message += about_folders_row("\"File\" dialogs", get_last_open_dir(), "capture files");
|
||||
|
||||
/* temp */
|
||||
@ -141,30 +141,30 @@ index 7bd072e..db9bd85 100644
|
||||
tempfile_ = new QTemporaryFile(tempname, this);
|
||||
tempfile_->open();
|
||||
|
||||
diff --git a/wsutil/Makefile.common b/wsutil/Makefile.common
|
||||
index 4913be5..8a78194 100644
|
||||
--- a/wsutil/Makefile.common
|
||||
+++ b/wsutil/Makefile.common
|
||||
@@ -71,7 +71,8 @@ LIBWSUTIL_COMMON_SRC = \
|
||||
time_util.c \
|
||||
type_util.c \
|
||||
unicode-utils.c \
|
||||
- ws_mempbrk.c
|
||||
+ ws_mempbrk.c \
|
||||
+ wstmpdir.c
|
||||
|
||||
# Header files that don't declare replacement functions for functions
|
||||
# present in the APIs/ABIs of some, but not all, targets.
|
||||
@@ -128,7 +129,8 @@ libwsutil_nonrepl_INCLUDES = \
|
||||
utf8_entities.h \
|
||||
ws_cpuid.h \
|
||||
ws_mempbrk.h \
|
||||
diff --git a/wsutil/Makefile.am b/wsutil/Makefile.am
|
||||
index 95c57d2..acd7837 100644
|
||||
--- a/wsutil/Makefile.am
|
||||
+++ b/wsutil/Makefile.am
|
||||
@@ -89,7 +89,8 @@ libwsutil_nonrepl_INCLUDES = \
|
||||
utf8_entities.h \
|
||||
ws_cpuid.h \
|
||||
ws_mempbrk.h \
|
||||
- ws_mempbrk_int.h
|
||||
+ ws_mempbrk_int.h\
|
||||
+ ws_mempbrk_int.h \
|
||||
+ wstmpdir.h
|
||||
|
||||
# Header files that are not generated from other files
|
||||
LIBWSUTIL_COMMON_INCLUDES = \
|
||||
# Header files for functions in libwsutil's ABI on this platform.
|
||||
libwsutil_abi_INCLUDES = \
|
||||
@@ -154,7 +155,8 @@ libwsutil_la_SOURCES = \
|
||||
time_util.c \
|
||||
type_util.c \
|
||||
unicode-utils.c \
|
||||
- ws_mempbrk.c
|
||||
+ ws_mempbrk.c \
|
||||
+ wstmpdir.c
|
||||
|
||||
if HAVE_OS_X_FRAMEWORKS
|
||||
libwsutil_la_SOURCES += cfutils.c cfutils.h
|
||||
diff --git a/wsutil/tempfile.c b/wsutil/tempfile.c
|
||||
index 7391fbf..9add952 100644
|
||||
--- a/wsutil/tempfile.c
|
||||
|
@ -7,8 +7,8 @@
|
||||
|
||||
Summary: Network traffic analyzer
|
||||
Name: wireshark
|
||||
Version: 2.1.0
|
||||
Release: 4%{?dist}
|
||||
Version: 2.1.1
|
||||
Release: 1%{?dist}
|
||||
License: GPL+
|
||||
Group: Applications/Internet
|
||||
Url: http://www.wireshark.org/
|
||||
@ -452,6 +452,10 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
#%{_datadir}/aclocal/*
|
||||
|
||||
%changelog
|
||||
* Sun Jul 24 2016 Peter Hatina <phatina@gmail.com> - 2.1.1-1
|
||||
- Ver. 2.1.1
|
||||
- See https://www.wireshark.org/docs/relnotes/wireshark-2.1.1.html
|
||||
|
||||
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-4
|
||||
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user