rebuild with gtk3
fix gdk crash
This commit is contained in:
parent
97be54da4a
commit
ee47273ea8
12
wireshark-0011-gdk.patch
Normal file
12
wireshark-0011-gdk.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 3ee58d9..f9af3af 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1531,7 +1531,6 @@ fi
|
||||
if test "$have_gtk" = "yes" ; then
|
||||
# If we have GTK then add flags for it.
|
||||
|
||||
- CPPFLAGS="-DGDK_PIXBUF_DISABLE_DEPRECATED $CPPFLAGS"
|
||||
CPPFLAGS="-DGDK_DISABLE_DEPRECATED $CPPFLAGS"
|
||||
if test \( $gtk_config_major_version -eq 3 -a $gtk_config_minor_version -ge 10 \) ; then
|
||||
## Allow use of deprecated & disable deprecated warnings if Gtk >= 3.10;
|
@ -2,7 +2,7 @@
|
||||
|
||||
%global with_adns 0
|
||||
%global with_lua 1
|
||||
%global with_gtk2 1
|
||||
%global with_gtk2 0
|
||||
|
||||
%if 0%{?rhel} != 0
|
||||
#RHEL:
|
||||
@ -21,7 +21,7 @@
|
||||
Summary: Network traffic analyzer
|
||||
Name: wireshark
|
||||
Version: 1.12.3
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPL+
|
||||
Group: Applications/Internet
|
||||
Source0: http://wireshark.org/download/src/%{name}-%{version}.tar.bz2
|
||||
@ -46,6 +46,7 @@ Patch8: wireshark-0008-move-default-temporary-directory-to-var-tmp.patch
|
||||
Patch9: wireshark-0009-Fix-paths-in-a-wireshark.desktop-file.patch
|
||||
# Update, when pushed upstream: https://code.wireshark.org/review/#/c/3770/
|
||||
Patch10: wireshark-0010-fields-print-format.patch
|
||||
Patch11: wireshark-0011-gdk.patch
|
||||
|
||||
Url: http://www.wireshark.org/
|
||||
BuildRequires: libpcap-devel >= 0.9
|
||||
@ -167,6 +168,7 @@ Cflags: -I\${includedir}" > wireshark.pc.in
|
||||
%patch8 -p1 -b .tmp_dir
|
||||
%patch9 -p1 -b .fix_paths
|
||||
%patch10 -p1 -b .fields-print-format
|
||||
%patch11 -p1 -b .gdk
|
||||
|
||||
%build
|
||||
%ifarch s390 s390x sparcv9 sparc64
|
||||
@ -370,6 +372,10 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
%{_datadir}/aclocal/*
|
||||
|
||||
%changelog
|
||||
* Mon Feb 2 2015 Peter Hatina <phatina@redhat.com> - 1.12.3-2
|
||||
- rebuild with gtk3
|
||||
- fix gdk crash
|
||||
|
||||
* Thu Jan 8 2015 Peter Hatina <phatina@redhat.com> - 1.12.3-1
|
||||
- Ver. 1.12.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user