Ver. 1.12.5
This commit is contained in:
parent
22b5a493e1
commit
d2308abcb8
1
.gitignore
vendored
1
.gitignore
vendored
@ -39,3 +39,4 @@ wireshark-1.2.10.tar.bz2
|
||||
/wireshark-1.12.2.tar.bz2
|
||||
/wireshark-1.12.3.tar.bz2
|
||||
/wireshark-1.12.4.tar.bz2
|
||||
/wireshark-1.12.5.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
acfa156fd35cb66c867b1ace992e4b5b wireshark-1.12.4.tar.bz2
|
||||
9ee199dde4f36a3d71f7b81dd6764e93 wireshark-1.12.5.tar.bz2
|
||||
|
@ -1,92 +0,0 @@
|
||||
diff --git a/epan/ftypes/ftype-integer.c b/epan/ftypes/ftype-integer.c
|
||||
index 2bf81d6..3f9bbc1 100644
|
||||
--- a/epan/ftypes/ftype-integer.c
|
||||
+++ b/epan/ftypes/ftype-integer.c
|
||||
@@ -230,7 +230,7 @@ integer_repr_len(fvalue_t *fv _U_, ftrepr_t rtype _U_)
|
||||
}
|
||||
|
||||
static void
|
||||
-integer_to_repr(fvalue_t *fv, ftrepr_t rtype _U_, char *buf)
|
||||
+integer_to_repr(fvalue_t *fv, ftrepr_t rtype, char *buf)
|
||||
{
|
||||
guint32 val;
|
||||
|
||||
@@ -240,7 +240,12 @@ integer_to_repr(fvalue_t *fv, ftrepr_t rtype _U_, char *buf)
|
||||
} else
|
||||
val = fv->value.sinteger;
|
||||
|
||||
- guint32_to_str_buf(val, buf, 11);
|
||||
+ if (rtype == FTREPR_DISPLAY_HEX) {
|
||||
+ // This format perfectly fits into 11 bytes.
|
||||
+ g_sprintf(buf, "0x%08x", val);
|
||||
+ } else {
|
||||
+ guint32_to_str_buf(val, buf, 11);
|
||||
+ }
|
||||
}
|
||||
|
||||
static int
|
||||
@@ -250,9 +255,14 @@ uinteger_repr_len(fvalue_t *fv _U_, ftrepr_t rtype _U_)
|
||||
}
|
||||
|
||||
static void
|
||||
-uinteger_to_repr(fvalue_t *fv, ftrepr_t rtype _U_, char *buf)
|
||||
+uinteger_to_repr(fvalue_t *fv, ftrepr_t rtype, char *buf)
|
||||
{
|
||||
- guint32_to_str_buf(fv->value.uinteger, buf, 11);
|
||||
+ if (rtype == FTREPR_DISPLAY_HEX) {
|
||||
+ // This format perfectly fits into 11 bytes.
|
||||
+ g_sprintf(buf, "0x%08x", fv->value.uinteger);
|
||||
+ } else {
|
||||
+ guint32_to_str_buf(fv->value.uinteger, buf, 11);
|
||||
+ }
|
||||
}
|
||||
|
||||
static gboolean
|
||||
diff --git a/epan/ftypes/ftype-string.c b/epan/ftypes/ftype-string.c
|
||||
index 3893823..7e67292 100644
|
||||
--- a/epan/ftypes/ftype-string.c
|
||||
+++ b/epan/ftypes/ftype-string.c
|
||||
@@ -57,6 +57,7 @@ string_repr_len(fvalue_t *fv, ftrepr_t rtype)
|
||||
{
|
||||
switch (rtype) {
|
||||
case FTREPR_DISPLAY:
|
||||
+ case FTREPR_DISPLAY_HEX:
|
||||
return (int)strlen(fv->value.string);
|
||||
|
||||
case FTREPR_DFILTER:
|
||||
@@ -71,6 +72,7 @@ string_to_repr(fvalue_t *fv, ftrepr_t rtype, char *buf)
|
||||
{
|
||||
switch (rtype) {
|
||||
case FTREPR_DISPLAY:
|
||||
+ case FTREPR_DISPLAY_HEX:
|
||||
strcpy(buf, fv->value.string);
|
||||
return;
|
||||
|
||||
diff --git a/epan/ftypes/ftypes.h b/epan/ftypes/ftypes.h
|
||||
index 5304277..63b7d0a 100644
|
||||
--- a/epan/ftypes/ftypes.h
|
||||
+++ b/epan/ftypes/ftypes.h
|
||||
@@ -95,6 +95,7 @@ typedef struct _ftype_t ftype_t;
|
||||
/* String representation types. */
|
||||
enum ftrepr {
|
||||
FTREPR_DISPLAY,
|
||||
+ FTREPR_DISPLAY_HEX,
|
||||
FTREPR_DFILTER
|
||||
};
|
||||
|
||||
diff --git a/epan/print.c b/epan/print.c
|
||||
index 5a7ed61..6dd2222 100644
|
||||
--- a/epan/print.c
|
||||
+++ b/epan/print.c
|
||||
@@ -1799,7 +1799,10 @@ gchar* get_node_field_value(field_info* fi, epan_dissect_t* edt)
|
||||
* FT_NONE can be checked when using -T fields */
|
||||
return g_strdup("1");
|
||||
default:
|
||||
- dfilter_string = fvalue_to_string_repr(&fi->value, FTREPR_DISPLAY, NULL);
|
||||
+ dfilter_string = fvalue_to_string_repr(
|
||||
+ &fi->value,
|
||||
+ fi->hfinfo->display == BASE_HEX ? FTREPR_DISPLAY_HEX : FTREPR_DISPLAY,
|
||||
+ NULL);
|
||||
if (dfilter_string != NULL) {
|
||||
return dfilter_string;
|
||||
} else {
|
@ -2,7 +2,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index 3ee58d9..f9af3af 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1531,7 +1531,6 @@ fi
|
||||
@@ -1539,7 +1539,6 @@ fi
|
||||
if test "$have_gtk" = "yes" ; then
|
||||
# If we have GTK then add flags for it.
|
||||
|
@ -20,8 +20,8 @@
|
||||
|
||||
Summary: Network traffic analyzer
|
||||
Name: wireshark
|
||||
Version: 1.12.4
|
||||
Release: 2%{?dist}
|
||||
Version: 1.12.5
|
||||
Release: 1%{?dist}
|
||||
License: GPL+
|
||||
Group: Applications/Internet
|
||||
Source0: http://wireshark.org/download/src/%{name}-%{version}.tar.bz2
|
||||
@ -44,9 +44,7 @@ Patch7: wireshark-0007-Install-autoconf-related-file.patch
|
||||
Patch8: wireshark-0008-move-default-temporary-directory-to-var-tmp.patch
|
||||
# Fedora-specific
|
||||
Patch9: wireshark-0009-Fix-paths-in-a-wireshark.desktop-file.patch
|
||||
# Update, when pushed upstream: https://code.wireshark.org/review/#/c/3770/
|
||||
Patch10: wireshark-0010-fields-print-format.patch
|
||||
Patch11: wireshark-0011-gdk.patch
|
||||
Patch10: wireshark-0010-gdk.patch
|
||||
|
||||
Url: http://www.wireshark.org/
|
||||
BuildRequires: libpcap-devel >= 0.9
|
||||
@ -167,8 +165,7 @@ Cflags: -I\${includedir}" > wireshark.pc.in
|
||||
%patch7 -p1 -b .install_autoconf
|
||||
%patch8 -p1 -b .tmp_dir
|
||||
%patch9 -p1 -b .fix_paths
|
||||
%patch10 -p1 -b .fields-print-format
|
||||
%patch11 -p1 -b .gdk
|
||||
%patch10 -p1 -b .gdk
|
||||
|
||||
%build
|
||||
%ifarch s390 s390x sparcv9 sparc64
|
||||
@ -411,6 +408,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
%{_datadir}/aclocal/*
|
||||
|
||||
%changelog
|
||||
* Wed May 13 2015 Peter Hatina <phatina@redhat.com> - 1.12.5-1
|
||||
- Ver. 1.12.5
|
||||
|
||||
* Thu Mar 26 2015 Richard Hughes <rhughes@redhat.com> - 1.12.4-2
|
||||
- Add an AppData file for the software center
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user