Ver. 2.1.0

This commit is contained in:
Peter Hatina 2016-06-14 22:33:08 +02:00
parent 34cad2b428
commit c9a65bf7d7
11 changed files with 75 additions and 249 deletions

1
.gitignore vendored
View File

@ -47,3 +47,4 @@ wireshark-1.2.10.tar.bz2
/wireshark-2.0.1.tar.bz2
/wireshark-2.0.2.tar.bz2
/wireshark-2.0.3.tar.bz2
/wireshark-2.1.0.tar.bz2

View File

@ -1 +1 @@
62dc20f5a77542feed2e38f18db8ae3b wireshark-2.0.3.tar.bz2
61e1777076fd52253fe6644f757d1ebc wireshark-2.1.0.tar.bz2

View File

@ -11,7 +11,7 @@ diff --git a/capchild/capture_sync.c b/capchild/capture_sync.c
index 2f9d2cc..b18e47f 100644
--- a/capchild/capture_sync.c
+++ b/capchild/capture_sync.c
@@ -382,6 +382,7 @@ sync_pipe_start(capture_options *capture_opts, capture_session *cap_session, voi
@@ -375,6 +375,7 @@ sync_pipe_start(capture_options *capture_opts, capture_session *cap_session, voi
gchar *signal_pipe_name;
#else
char errmsg[1024+1];
@ -19,7 +19,7 @@ index 2f9d2cc..b18e47f 100644
int sync_pipe[2]; /* pipe used to send messages from child to parent */
enum PIPES { PIPE_READ, PIPE_WRITE }; /* Constants 0 and 1 for PIPE_READ and PIPE_WRITE */
#endif
@@ -730,8 +731,11 @@ sync_pipe_start(capture_options *capture_opts, capture_session *cap_session, voi
@@ -728,8 +729,11 @@ sync_pipe_start(capture_options *capture_opts, capture_session *cap_session, voi
dup2(sync_pipe[PIPE_WRITE], 2);
ws_close(sync_pipe[PIPE_READ]);
execv(argv[0], argv);
@ -41,7 +41,7 @@ index 2f9d2cc..b18e47f 100644
int sync_pipe[2]; /* pipe used to send messages from child to parent */
int data_pipe[2]; /* pipe used to send data from child to parent */
#endif
@@ -998,8 +1003,11 @@ sync_pipe_open_command(char** argv, int *data_read_fd,
@@ -1003,8 +1008,11 @@ sync_pipe_open_command(char** argv, int *data_read_fd,
ws_close(sync_pipe[PIPE_READ]);
ws_close(sync_pipe[PIPE_WRITE]);
execv(argv[0], argv);

View File

@ -3,14 +3,13 @@ Date: Fri, 13 Sep 2013 14:36:55 +0400
Subject: [PATCH] Restore Fedora-specific groups
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
diff --git a/wireshark.desktop b/wireshark.desktop
index 9e3ddcd..828eca7 100644
index 334db48..669c6f1 100644
--- a/wireshark.desktop
+++ b/wireshark.desktop
@@ -108,4 +108,4 @@ Terminal=false
MimeType=application/vnd.tcpdump.pcap;application/x-pcapng;application/x-snoop;application/x-iptrace;application/x-lanalyzer;application/x-nettl;application/x-radcom;application/x-etherpeek;application/x-visualnetworks;application/x-netinstobserver;application/x-5view;application/x-tektronix-rf5;
MimeType=application/vnd.tcpdump.pcap;application/x-pcapng;application/x-snoop;application/x-iptrace;application/x-lanalyzer;application/x-nettl;application/x-radcom;application/x-etherpeek;application/x-visualnetworks;application/x-netinstobserver;application/x-5view;application/x-tektronix-rf5;application/x-micropross-mplog;application/x-apple-packetlogger;application/x-endace-erf;application/ipfix;application/x-ixia-vwr;
# Category entry according to:
# http://standards.freedesktop.org/menu-spec/1.0/
-Categories=System;Monitor;Qt;
+Categories=Application;Network;Qt;
-Categories=Network;Monitor;Qt;
+Categories=Application;Network;Monitor;Qt;

View File

@ -8,7 +8,7 @@ diff --git a/Makefile.am b/Makefile.am
index 913e064..30f8107 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,6 +55,9 @@ EXTRA_PROGRAMS = wireshark-gtk wireshark tshark tfshark capinfos captype editcap
@@ -57,6 +57,9 @@ EXTRA_PROGRAMS = wireshark-gtk wireshark tshark tfshark capinfos captype editcap
dist_pkgdata_DATA = COPYING manuf services cfilters colorfilters dfilters \
smi_modules ipmap.html pdml2html.xsl
@ -18,43 +18,22 @@ index 913e064..30f8107 100644
#
# Install global profiles in the "profiles" subdirectory
#
diff --git a/configure.ac b/configure.ac
index dc8c307..dedd1a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3101,6 +3101,7 @@ AC_CONFIG_HEADERS(config.h)
AC_OUTPUT(
Makefile
doxygen.cfg
+ wireshark.pc
asn1/Makefile
_CUSTOM_ASN1_AC_OUTPUT_
asn1/acp133/Makefile
diff --git a/wireshark.pc.in b/wireshark.pc.in
index 826b230..fec2d25 100644
index 5889178..1e1b62f 100644
--- a/wireshark.pc.in
+++ b/wireshark.pc.in
@@ -1,14 +1,11 @@
-prefix=@CMAKE_INSTALL_PREFIX@
-exec_prefix=${prefix}
-libdir=@ABSOLUTE_CMAKE_INSTALL_LIBDIR@
-sharedlibdir=${libdir}
-includedir=${prefix}/include/wireshark
-plugindir=@PLUGIN_INSTALL_DIR@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@
@@ -6,9 +6,9 @@ sharedlibdir=${libdir}
plugindir=@plugindir@
Name: wireshark
-Description: wireshark network packet dissection library
-Version: @PROJECT_VERSION@
-
-Requires:
-Libs: -L${libdir} -L${sharedlibdir} -lwireshark
-Cflags: -I${includedir}
Name: Wireshark
-Description: Network Packet Dissection Library
-Version: @VERSION@
+Description: Network Traffic Analyzer
+Version: @PACKAGE_VERSION@
+Requires: Qt glib-2.0 gmodule-2.0
-Requires: glib-2.0, gmodule-2.0, gthread-2.0
-Libs: -L${libdir} -lwireshark
-Cflags: -I${includedir}/wireshark
+Requires: Qt, glib-2.0, gmodule-2.0, gthread-2.0
+Libs: -L@libdir@ -lwireshark -lwiretap
+Cflags: -DWS_VAR_IMPORT=extern -DHAVE_STDARG_H -DWS_MSVC_NORETURN= -I@includedir@/wireshark -I@includedir@/wireshark/epan

View File

@ -1,127 +0,0 @@
commit fa2961b8614827f170351d8d3a21961ffc28eabb
Author: Peter Lemenkov <lemenkov@gmail.com>
Date: Wed Jan 6 09:41:45 2016 +0100
Install autoconf-related file
diff --git a/Makefile.am b/Makefile.am
index 30f8107..0b13c6f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,6 +58,9 @@ dist_pkgdata_DATA = COPYING manuf services cfilters colorfilters dfilters \
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = wireshark.pc
+autoconfigdir = $(datadir)/aclocal
+autoconfig_DATA = wireshark.m4
+
#
# Install global profiles in the "profiles" subdirectory
#
diff --git a/wireshark.m4 b/wireshark.m4
new file mode 100644
index 0000000..d8015d8
--- /dev/null
+++ b/wireshark.m4
@@ -0,0 +1,101 @@
+dnl AM_PATH_WIRESHARK([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
+dnl Test for wireshark development files, and define WIRESHARK_CFLAGS,
+dnl WIRESHARK_LIBS and WIRESHARK_VERSION.
+dnl
+AC_DEFUN([AM_PATH_WIRESHARK],[
+ AC_ARG_WITH(wireshark-prefix,
+ [ --with-wireshark-prefix=PFX Prefix where wireshark libraries are installed (optional)],
+ wireshark_config_prefix="$withval", wireshark_config_prefix="")
+
+ wireshark_found=no
+ if test "$wireshark_config_prefix" != "" ; then
+ AM_PATH_GLIB_2_0(,,,[gmodule])
+ WIRESHARK_CFLAGS="-DWS_VAR_IMPORT=extern -DWS_MSVC_NORETURN= -I$wireshark_config_prefix/include/wireshark -I$wireshark_config_prefix/include/wireshark/epan -I/usr/include/wireshark -I/usr/include/wireshark/epan $GLIB_CFLAGS"
+ WIRESHARK_LIBS="-L$wireshark_config_prefix/lib -lwireshark -lwiretap $GLIB_LIBS"
+ wireshark_found=yes
+ else
+ PKG_PROG_PKG_CONFIG()
+ PKG_CHECK_MODULES(WIRESHARK, wireshark, wireshark_found=yes)
+ fi
+
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_CLIBS="$LIBS"
+ CFLAGS="$CFLAGS $WIRESHARK_CFLAGS"
+ LIBS="$WIRESHARK_LIBS $LIBS"
+ min_wireshark_version=ifelse([$1], ,0.0.0,[$1])
+ if test $wireshark_found = yes; then
+ AC_MSG_CHECKING(for wireshark version >= $min_wireshark_version)
+ wireshark_found=no
+ AC_TRY_RUN([
+#include <stdlib.h>
+#include <stdio.h>
+#include <string.h>
+#include <gmodule.h>
+#include <epan/packet.h>
+#include <epan/prefs.h>
+
+int
+main()
+
+{
+ int ws_major_version, ws_minor_version, ws_micro_version;
+ int major, minor, micro;
+ char **tmp_version;
+
+ tmp_version = (char *) strdup("$min_wireshark_version");
+ major = 0;
+ minor = 0;
+ micro = 0;
+ sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro);
+ free(tmp_version);
+ tmp_version = (char *) epan_get_version();
+ sscanf(tmp_version, "%d.%d.%d",
+ &ws_major_version, &ws_minor_version, &ws_micro_version);
+
+ if (ws_major_version > major ||
+ (ws_major_version == major && ws_minor_version > minor) ||
+ (ws_major_version == major && ws_minor_version == minor &&
+ ws_micro_version >= micro))
+ return 0;
+
+ printf("\n*** An old version of wireshark (%d.%d.%d) was found.\n",
+ ws_major_version, ws_minor_version, ws_micro_version);
+ printf("*** You need a version of wireshark not older than %d.%d.%d. ",
+ major, minor, micro);
+ return 1;
+}
+ ], wireshark_found=yes)
+ fi
+
+ if test "$wireshark_found" != no; then
+ AC_LANG_PUSH(C)
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([
+#include <stdlib.h>
+#include <stdio.h>
+#include <string.h>
+#include <gmodule.h>
+#include <epan/packet.h>
+#include <epan/prefs.h>
+], [puts(epan_get_version());])], [WIRESHARK_VERSION=`./conftest$ac_exeext`],
+wireshark_found=no)
+
+ AC_LANG_POP
+ fi
+
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+
+ if test "$wireshark_found" != no; then
+ AC_MSG_RESULT(yes)
+ ifelse([$2],, :, [$2])
+ else
+ AC_MSG_RESULT(no)
+ WIRESHARK_CFLAGS=""
+ WIRESHARK_LIBS=""
+ WIRESHARK_VERSION=""
+ ifelse([$3], , :, [$3])
+ fi
+ AC_SUBST(WIRESHARK_CFLAGS)
+ AC_SUBST(WIRESHARK_LIBS)
+ AC_SUBST(WIRESHARK_VERSION)
+])

View File

@ -1,22 +1,22 @@
commit b32de2f6e35b4e7d6ea4d0477db91b12861c09d6
commit 26725d2cdac4bca0f779cf6fbbcd96a00912d1b9
Author: Peter Hatina <phatina@gmail.com>
Date: Tue Jan 12 13:56:59 2016 +0100
Move default temporary directory to /var/tmp
diff --git a/ui/gtk/about_dlg.c b/ui/gtk/about_dlg.c
index 0ed474a..fb3275b 100644
index 06c1d9a..bf521f1 100644
--- a/ui/gtk/about_dlg.c
+++ b/ui/gtk/about_dlg.c
@@ -30,6 +30,7 @@
@@ -29,6 +29,7 @@
#include <wsutil/filesystem.h>
#include <wsutil/copyright_info.h>
#include <wsutil/ws_version_info.h>
+#include <wsutil/wstmpdir.h> /* for get_tmp_dir() */
+#include <wsutil/wstmpdir.h> /* for get_tmp_dor() */
#include <ws_version_info.h>
#ifdef HAVE_LIBSMI
#include <epan/oids.h>
#endif
@@ -407,7 +408,7 @@ about_folders_page_new(void)
@@ -413,7 +414,7 @@ about_folders_page_new(void)
"capture files");
/* temp */
@ -26,11 +26,11 @@ index 0ed474a..fb3275b 100644
/* pers conf */
diff --git a/ui/gtk/proto_help.c b/ui/gtk/proto_help.c
index 79cafd4..47eec6c 100644
index 8632feb..dc9a2a0 100644
--- a/ui/gtk/proto_help.c
+++ b/ui/gtk/proto_help.c
@@ -37,6 +37,8 @@
#include "../file.h"
#include "../../file.h"
+#include <wsutil/wstmpdir.h> /* for get_tmp_dir() */
@ -48,7 +48,7 @@ index 79cafd4..47eec6c 100644
for (i = 0; i < PH_CONF_DIRS; i++) {
diff --git a/ui/qt/about_dialog.cpp b/ui/qt/about_dialog.cpp
index c0899a0..4fada89 100644
index 733fc55..a1068cd 100644
--- a/ui/qt/about_dialog.cpp
+++ b/ui/qt/about_dialog.cpp
@@ -49,6 +49,7 @@
@ -58,8 +58,8 @@ index c0899a0..4fada89 100644
+#include "wsutil/wstmpdir.h" /* for get_tmp_dir() */
#include "wsutil/plugins.h"
#include "wsutil/copyright_info.h"
#include "wsutil/ws_version_info.h"
@@ -184,7 +185,7 @@ AboutDialog::AboutDialog(QWidget *parent) :
#include "ws_version_info.h"
@@ -210,7 +211,7 @@ AboutDialog::AboutDialog(QWidget *parent) :
message += about_folders_row("\"File\" dialogs", get_last_open_dir(), "capture files");
/* temp */
@ -69,7 +69,7 @@ index c0899a0..4fada89 100644
/* pers conf */
message += about_folders_row("Personal configuration",
diff --git a/ui/qt/iax2_analysis_dialog.cpp b/ui/qt/iax2_analysis_dialog.cpp
index e1ef186..b672b31 100644
index eb76952..bb815f6 100644
--- a/ui/qt/iax2_analysis_dialog.cpp
+++ b/ui/qt/iax2_analysis_dialog.cpp
@@ -41,6 +41,8 @@
@ -95,7 +95,7 @@ index e1ef186..b672b31 100644
rev_tempfile_->open();
diff --git a/ui/qt/rtp_analysis_dialog.cpp b/ui/qt/rtp_analysis_dialog.cpp
index 87322df..fbe9ffa 100644
index e12da20..87be751 100644
--- a/ui/qt/rtp_analysis_dialog.cpp
+++ b/ui/qt/rtp_analysis_dialog.cpp
@@ -38,6 +38,8 @@
@ -107,7 +107,7 @@ index 87322df..fbe9ffa 100644
#include <QFileDialog>
#include <QMessageBox>
#include <QPushButton>
@@ -321,10 +323,10 @@ RtpAnalysisDialog::RtpAnalysisDialog(QWidget &parent, CaptureFile &cf, struct _r
@@ -323,10 +325,10 @@ RtpAnalysisDialog::RtpAnalysisDialog(QWidget &parent, CaptureFile &cf, struct _r
// We keep our temp files open for the lifetime of the dialog. The GTK+
// UI opens and closes at various points.
@ -121,10 +121,10 @@ index 87322df..fbe9ffa 100644
rev_tempfile_->open();
diff --git a/ui/qt/rtp_audio_stream.cpp b/ui/qt/rtp_audio_stream.cpp
index 1346a4d..4d34a3b 100644
index 7bd072e..db9bd85 100644
--- a/ui/qt/rtp_audio_stream.cpp
+++ b/ui/qt/rtp_audio_stream.cpp
@@ -33,6 +33,7 @@
@@ -37,6 +37,7 @@
#include <ui/rtp_stream.h>
#include <wsutil/nstime.h>
@ -132,9 +132,9 @@ index 1346a4d..4d34a3b 100644
#include <QAudioFormat>
#include <QAudioOutput>
@@ -71,7 +72,7 @@ RtpAudioStream::RtpAudioStream(QObject *parent, _rtp_stream_info *rtp_stream) :
@@ -75,7 +76,7 @@ RtpAudioStream::RtpAudioStream(QObject *parent, _rtp_stream_info *rtp_stream) :
visual_sample_rate_, SPEEX_RESAMPLER_QUALITY_MIN, NULL);
ws_codec_resampler_skip_zeros(visual_resampler_);
speex_resampler_skip_zeros(visual_resampler_);
- QString tempname = QString("%1/wireshark_rtp_stream").arg(QDir::tempPath());
+ QString tempname = QString("%1/wireshark_rtp_stream").arg(get_tmp_dir());
@ -142,34 +142,34 @@ index 1346a4d..4d34a3b 100644
tempfile_->open();
diff --git a/wsutil/Makefile.common b/wsutil/Makefile.common
index e24f015..49f0a95 100644
index 4913be5..8a78194 100644
--- a/wsutil/Makefile.common
+++ b/wsutil/Makefile.common
@@ -71,7 +71,8 @@ LIBWSUTIL_SRC = \
ws_mempbrk.c \
u3.c \
@@ -71,7 +71,8 @@ LIBWSUTIL_COMMON_SRC = \
time_util.c \
type_util.c \
unicode-utils.c \
- ws_version_info.c
+ ws_version_info.c \
- ws_mempbrk.c
+ ws_mempbrk.c \
+ wstmpdir.c
# Header files that don't declare replacement functions for functions
# present in the APIs/ABIs of some, but not all, targets.
@@ -128,7 +129,8 @@ libwsutil_nonrepl_INCLUDES = \
ws_diag_control.h \
utf8_entities.h \
ws_cpuid.h \
ws_mempbrk.h \
ws_mempbrk_int.h \
- ws_version_info.h
+ ws_version_info.h \
- ws_mempbrk_int.h
+ ws_mempbrk_int.h\
+ wstmpdir.h
# Header files that are not generated from other files
LIBWSUTIL_INCLUDES = \
LIBWSUTIL_COMMON_INCLUDES = \
diff --git a/wsutil/tempfile.c b/wsutil/tempfile.c
index 93bd66f..757b6c8 100644
index 7391fbf..9add952 100644
--- a/wsutil/tempfile.c
+++ b/wsutil/tempfile.c
@@ -44,6 +44,7 @@
@@ -36,6 +36,7 @@
#include "tempfile.h"
#include <wsutil/file_util.h>
@ -177,7 +177,7 @@ index 93bd66f..757b6c8 100644
#ifndef __set_errno
#define __set_errno(x) errno=(x)
@@ -146,7 +147,7 @@ mkdtemp (char *path_template)
@@ -142,7 +143,7 @@ mkdtemp (char *path_template)
*/
char *get_tempfile_path(const char *filename)
{
@ -186,7 +186,7 @@ index 93bd66f..757b6c8 100644
}
#define MAX_TEMPFILES 3
@@ -203,7 +204,7 @@ create_tempfile(char **namebuf, const char *pfx)
@@ -198,7 +199,7 @@ create_tempfile(char **namebuf, const char *pfx, const char *sfx)
tf[idx].path = (char *)g_malloc(tf[idx].len);
}
@ -195,7 +195,7 @@ index 93bd66f..757b6c8 100644
#ifdef _WIN32
_tzset();
@@ -237,7 +238,7 @@ create_tempfile(char **namebuf, const char *pfx)
@@ -232,7 +233,7 @@ create_tempfile(char **namebuf, const char *pfx, const char *sfx)
/**
* Create a directory with the given prefix (e.g. "wireshark"). The path
@ -204,7 +204,7 @@ index 93bd66f..757b6c8 100644
*
* @param namebuf
* @param pfx A prefix for the temporary directory.
@@ -265,7 +266,7 @@ create_tempdir(char **namebuf, const char *pfx)
@@ -260,7 +261,7 @@ create_tempdir(char **namebuf, const char *pfx)
/*
* We can't use get_tempfile_path here because we're called from dumpcap.c.
*/
@ -214,7 +214,7 @@ index 93bd66f..757b6c8 100644
while (g_snprintf(td_path[idx], td_path_len[idx], "%s%c%s" TMP_FILE_SUFFIX, tmp_dir, G_DIR_SEPARATOR, pfx) > td_path_len[idx]) {
td_path_len[idx] *= 2;
diff --git a/wsutil/tempfile.h b/wsutil/tempfile.h
index f595632..5e22227 100644
index 1dca2df..bb3160c 100644
--- a/wsutil/tempfile.h
+++ b/wsutil/tempfile.h
@@ -45,7 +45,7 @@ WS_DLL_PUBLIC char *get_tempfile_path(const char *filename);
@ -226,7 +226,7 @@ index f595632..5e22227 100644
*
* @param namebuf [in,out] If not NULL, receives the full path of the temp file.
* Must NOT be freed.
@@ -56,7 +56,7 @@ WS_DLL_PUBLIC int create_tempfile(char **namebuf, const char *pfx);
@@ -58,7 +58,7 @@ WS_DLL_PUBLIC int create_tempfile(char **namebuf, const char *pfx, const char *s
/**
* Create a directory with the given prefix (e.g. "wireshark"). The path

View File

@ -4,10 +4,10 @@ Subject: [PATCH] Fix paths in a wireshark.desktop file
diff --git a/wireshark.desktop b/wireshark.desktop
index 828eca7..eef3503 100644
index 669c6f1..f7df1f3 100644
--- a/wireshark.desktop
+++ b/wireshark.desktop
@@ -69,8 +69,8 @@ Comment[fi]=Verkkoliikenne analysaattori
@@ -102,8 +102,8 @@ Comment[tr]=Ağ trafiği çözümleyicisi
Comment[vi]=Trình phân tích giao thông mạng
Comment[uk]=Аналізатор мережевого трафіку
Icon=wireshark
@ -16,5 +16,5 @@ index 828eca7..eef3503 100644
+TryExec=/usr/sbin/wireshark
+Exec=/usr/sbin/wireshark %f
Terminal=false
MimeType=application/vnd.tcpdump.pcap;application/x-pcapng;application/x-snoop;application/x-iptrace;application/x-lanalyzer;application/x-nettl;application/x-radcom;application/x-etherpeek;application/x-visualnetworks;application/x-netinstobserver;application/x-5view;application/x-tektronix-rf5;
MimeType=application/vnd.tcpdump.pcap;application/x-pcapng;application/x-snoop;application/x-iptrace;application/x-lanalyzer;application/x-nettl;application/x-radcom;application/x-etherpeek;application/x-visualnetworks;application/x-netinstobserver;application/x-5view;application/x-tektronix-rf5;application/x-micropross-mplog;application/x-apple-packetlogger;application/x-endace-erf;application/ipfix;application/x-ixia-vwr;
# Category entry according to:

View File

@ -10,10 +10,10 @@ epan/epan.h include is missing in configuration test program. This is
needed to define epan_get_version() as char *. Failure to doing so uses
a 32-bit integer as a string address --> segfault.
diff --git a/wireshark.m4 b/wireshark.m4
diff --git a/wireshark-autoconf.m4 b/wireshark-autoconf.m4
index d8015d8..6d7b177 100644
--- a/wireshark.m4
+++ b/wireshark.m4
--- a/wireshark-autoconf.m4
+++ b/wireshark-autoconf.m4
@@ -33,6 +33,7 @@ AC_DEFUN([AM_PATH_WIRESHARK],[
#include <gmodule.h>
#include <epan/packet.h>

View File

@ -1,26 +0,0 @@
diff --git a/ui/qt/color_utils.cpp b/ui/qt/color_utils.cpp
index e150a14..4fcbe9d 100644
--- a/ui/qt/color_utils.cpp
+++ b/ui/qt/color_utils.cpp
@@ -99,7 +99,7 @@ const color_t ColorUtils::toColorT(const QColor color)
QRgb ColorUtils::alphaBlend(const QColor &color1, const QColor &color2, qreal alpha)
{
- alpha = qBound(0.0, alpha, 1.0);
+ alpha = qBound<qreal>(0.0, alpha, 1.0);
int r1 = color1.red() * alpha;
int g1 = color1.green() * alpha;
diff --git a/ui/qt/main_window_slots.cpp b/ui/qt/main_window_slots.cpp
index 3c9a616..56dd3ea 100644
--- a/ui/qt/main_window_slots.cpp
+++ b/ui/qt/main_window_slots.cpp
@@ -2226,7 +2226,7 @@ void MainWindow::zoomText()
mono_font_ = QFont(wsApp->monospaceFont());
qreal zoom_size = wsApp->monospaceFont().pointSize() * 2 * qPow(1.1, recent.gui_zoom_level);
zoom_size = qRound(zoom_size) / 2.0;
- zoom_size = qMax(zoom_size, 1.0);
+ zoom_size = qMax<qreal>(zoom_size, 1.0);
mono_font_.setPointSizeF(zoom_size);
emit monospaceFontChanged(mono_font_);
}

View File

@ -7,7 +7,7 @@
Summary: Network traffic analyzer
Name: wireshark
Version: 2.0.3
Version: 2.1.0
Release: 1%{?dist}
License: GPL+
Group: Applications/Internet
@ -27,16 +27,12 @@ Patch4: wireshark-0004-adds-autoconf-macro-file.patch
Patch5: wireshark-0005-Restore-Fedora-specific-groups.patch
# Will be proposed upstream
Patch6: wireshark-0006-Add-pkgconfig-entry.patch
# Will be proposed upstream
Patch7: wireshark-0007-Install-autoconf-related-file.patch
# Fedora-specific
Patch8: wireshark-0008-move-default-temporary-directory-to-var-tmp.patch
# Fedora-specific
Patch9: wireshark-0009-Fix-paths-in-a-wireshark.desktop-file.patch
# Fedora-specific, see https://bugzilla.redhat.com/1274831
Patch10: wireshark-0010-Patch-fixing-the-wireshark-autoconf-macros.patch
# Qt-specific
Patch11: wireshark-0011-Fix-FTBFS-Qt-Color-utils-arm.patch
%package cli
Summary: Network traffic analyzer
@ -169,11 +165,9 @@ and plugins.
%patch4 -p1 -b .add_autoconf
%patch5 -p1 -b .restore_group
%patch6 -p1 -b .add_pkgconfig
%patch7 -p1 -b .install_autoconf
%patch8 -p1 -b .tmp_dir
%patch9 -p1 -b .fix_paths
%patch10 -p1 -b .64bit
%patch11 -p1 -b .ftbfs_arm
%build
%ifarch s390 s390x sparcv9 sparc64
@ -221,7 +215,8 @@ autoreconf -ivf
--disable-warnings-as-errors \
--with-plugins=%{_libdir}/%{name}/plugins \
--with-libnl \
--disable-androiddump
--disable-androiddump \
--disable-randpktdump
#remove rpath
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
@ -251,7 +246,7 @@ mkdir -p "${IDIR}/epan/wmem"
mkdir -p "${IDIR}/wiretap"
mkdir -p "${IDIR}/wsutil"
mkdir -p %{buildroot}/%{_sysconfdir}/udev/rules.d
install -m 644 color.h config.h register.h "${IDIR}/"
install -m 644 config.h register.h "${IDIR}/"
install -m 644 cfile.h file.h "${IDIR}/"
install -m 644 epan/*.h "${IDIR}/epan/"
install -m 644 epan/crypt/*.h "${IDIR}/epan/crypt"
@ -416,6 +411,7 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
%{_mandir}/man1/dftest.*
%{_mandir}/man1/randpkt.*
%{_mandir}/man1/reordercap.*
%{_mandir}/man4/extcap.*
%dir %{_datadir}/wireshark
%{_datadir}/wireshark/*
%if %{with_lua}
@ -452,9 +448,13 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
%{_includedir}/wireshark
%{_libdir}/lib*.so
%{_libdir}/pkgconfig/*
%{_datadir}/aclocal/*
#%{_datadir}/aclocal/*
%changelog
* Tue Jun 14 2016 Peter Hatina <phatina@gmail.com> - 2.1.0-1
- Ver. 2.1.0
- See https://www.wireshark.org/docs/relnotes/wireshark-2.1.0.html
* Thu Apr 28 2016 Peter Hatina <phatina@redhat.com> - 2.0.3-1
- Ver. 2.0.3