Ver. 1.10.6

Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
Peter Lemenkov 2014-03-08 19:36:22 +04:00
parent 9dcc3e979a
commit 88032ffad5
9 changed files with 34 additions and 58 deletions

1
.gitignore vendored
View File

@ -30,3 +30,4 @@ wireshark-1.2.10.tar.bz2
/wireshark-1.10.3.tar.bz2 /wireshark-1.10.3.tar.bz2
/wireshark-1.10.4.tar.bz2 /wireshark-1.10.4.tar.bz2
/wireshark-1.10.5.tar.bz2 /wireshark-1.10.5.tar.bz2
/wireshark-1.10.6.tar.bz2

View File

@ -1 +1 @@
a66894a62f05e1e7a3156a807f3296ea wireshark-1.10.5.tar.bz2 c67435039d67ef1757bfff0ab88824ab wireshark-1.10.6.tar.bz2

View File

@ -214,7 +214,7 @@ index 10782b0..e7b3c18 100644
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 69eb75f..610cea7 100644 index c5c1193..9c547b3 100644
--- a/epan/CMakeLists.txt --- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt +++ b/epan/CMakeLists.txt
@@ -1083,6 +1083,7 @@ set(DISSECTOR_SRC @@ -1083,6 +1083,7 @@ set(DISSECTOR_SRC

View File

@ -52,7 +52,7 @@ Fix "malformed packet" and tidy up a bit.
svn path=/trunk/; revision=51740 svn path=/trunk/; revision=51740
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 610cea7..83e975d 100644 index 9c547b3..22fd862 100644
--- a/epan/CMakeLists.txt --- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt +++ b/epan/CMakeLists.txt
@@ -972,6 +972,7 @@ set(DISSECTOR_SRC @@ -972,6 +972,7 @@ set(DISSECTOR_SRC

View File

@ -4,7 +4,7 @@ Subject: [PATCH] Add pkgconfig entry
diff --git a/Makefile.am b/Makefile.am diff --git a/Makefile.am b/Makefile.am
index eb735a5..2844c90 100644 index f3e313c..07efc02 100644
--- a/Makefile.am --- a/Makefile.am
+++ b/Makefile.am +++ b/Makefile.am
@@ -50,6 +50,9 @@ bin_PROGRAMS = \ @@ -50,6 +50,9 @@ bin_PROGRAMS = \
@ -18,10 +18,10 @@ index eb735a5..2844c90 100644
# Wireshark configuration files are put in $(pkgdatadir). # Wireshark configuration files are put in $(pkgdatadir).
# #
diff --git a/configure.ac b/configure.ac diff --git a/configure.ac b/configure.ac
index 1356d9a..8691bbf 100644 index 488d8d0..0c1ed4d 100644
--- a/configure.ac --- a/configure.ac
+++ b/configure.ac +++ b/configure.ac
@@ -2543,6 +2543,7 @@ AC_CONFIG_HEADERS(config.h) @@ -2549,6 +2549,7 @@ AC_CONFIG_HEADERS(config.h)
AC_OUTPUT( AC_OUTPUT(
Makefile Makefile
doxygen.cfg doxygen.cfg

View File

@ -4,7 +4,7 @@ Subject: [PATCH] Install autoconf-related file
diff --git a/Makefile.am b/Makefile.am diff --git a/Makefile.am b/Makefile.am
index 2844c90..3053bda 100644 index 07efc02..2ce4527 100644
--- a/Makefile.am --- a/Makefile.am
+++ b/Makefile.am +++ b/Makefile.am
@@ -53,6 +53,9 @@ EXTRA_PROGRAMS = wireshark tshark capinfos editcap mergecap dftest \ @@ -53,6 +53,9 @@ EXTRA_PROGRAMS = wireshark tshark capinfos editcap mergecap dftest \

View File

@ -6,28 +6,6 @@ Glib no longer offers this macro so we have to fallback to C90 memmove.
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com> Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
diff --git a/epan/dissectors/packet-ssl-utils.c b/epan/dissectors/packet-ssl-utils.c
index 1ab3c8d..0f1ad44 100644
--- a/epan/dissectors/packet-ssl-utils.c
+++ b/epan/dissectors/packet-ssl-utils.c
@@ -1633,7 +1633,7 @@ ssl_private_decrypt(guint len, guchar* encr_data, SSL_PRIVATE_KEY* pk)
ssl_debug_printf("pcry_private_decrypt: stripping %d bytes, decr_len %" G_GSIZE_MODIFIER "u\n",
rc, decr_len);
ssl_print_data("decrypted_unstrip_pre_master", decr_data_ptr, decr_len);
- g_memmove(decr_data_ptr, &decr_data_ptr[rc], decr_len - rc);
+ memmove(decr_data_ptr, &decr_data_ptr[rc], decr_len - rc);
decr_len -= rc;
out:
@@ -1670,7 +1670,7 @@ out:
ssl_debug_printf("pcry_private_decrypt: stripping %d bytes, decr_len %d\n",
rc, decr_len);
ssl_print_data("decrypted_unstrip_pre_master", decr_data_ptr, decr_len);
- g_memmove(decr_data_ptr, &decr_data_ptr[rc], decr_len - rc);
+ memmove(decr_data_ptr, &decr_data_ptr[rc], decr_len - rc);
decr_len -= rc;
#endif /* SSL_FAST */
gcry_mpi_release(text);
diff --git a/packaging/macosx/native-gtk/glibconfig.h b/packaging/macosx/native-gtk/glibconfig.h diff --git a/packaging/macosx/native-gtk/glibconfig.h b/packaging/macosx/native-gtk/glibconfig.h
index e0a9589..2730202 100644 index e0a9589..2730202 100644
--- a/packaging/macosx/native-gtk/glibconfig.h --- a/packaging/macosx/native-gtk/glibconfig.h
@ -41,16 +19,3 @@ index e0a9589..2730202 100644
#define GLIB_MAJOR_VERSION 2 #define GLIB_MAJOR_VERSION 2
#define GLIB_MINOR_VERSION 12 #define GLIB_MINOR_VERSION 12
#define GLIB_MICRO_VERSION 9 #define GLIB_MICRO_VERSION 9
diff --git a/ui/export_object_smb.c b/ui/export_object_smb.c
index dec3de9..59ccaa2 100644
--- a/ui/export_object_smb.c
+++ b/ui/export_object_smb.c
@@ -254,7 +254,7 @@ gpointer dest_memory_addr;
/* ...then, put the chunk of the file in the right place */
if (!file->is_out_of_memory) {
dest_memory_addr = entry->payload_data + chunk_offset;
- g_memmove(dest_memory_addr, eo_info->payload_data, eo_info->payload_len);
+ memmove(dest_memory_addr, eo_info->payload_data, eo_info->payload_len);
}
}

View File

@ -1,5 +1,11 @@
From: Peter Hatina <phatina@redhat.com>
Date: Mon, 3 Mar 2014 12:01:36 +0100
Subject: [PATCH] Reorganize Capture Dialog layout
Change-Id: Iafe20f3a8509c83e821ce4abc9bd91bd1bb002dd
diff --git a/ui/gtk/capture_dlg.c b/ui/gtk/capture_dlg.c diff --git a/ui/gtk/capture_dlg.c b/ui/gtk/capture_dlg.c
index 0c57825..ccbc805 100644 index a4ef2dc..700f23a 100644
--- a/ui/gtk/capture_dlg.c --- a/ui/gtk/capture_dlg.c
+++ b/ui/gtk/capture_dlg.c +++ b/ui/gtk/capture_dlg.c
@@ -4637,7 +4637,7 @@ capture_prep_cb(GtkWidget *w _U_, gpointer d _U_) @@ -4637,7 +4637,7 @@ capture_prep_cb(GtkWidget *w _U_, gpointer d _U_)
@ -11,7 +17,7 @@ index 0c57825..ccbc805 100644
gtk_scrolled_window_set_shadow_type(GTK_SCROLLED_WINDOW(swindow), GTK_SHADOW_IN); gtk_scrolled_window_set_shadow_type(GTK_SCROLLED_WINDOW(swindow), GTK_SHADOW_IN);
view = gtk_tree_view_new (); view = gtk_tree_view_new ();
@@ -5045,30 +5045,6 @@ fprintf(stderr, "Adding the default filter \"%s\"???\n", global_capture_opts.def @@ -5044,30 +5044,6 @@ capture_prep_cb(GtkWidget *w _U_, gpointer d _U_)
row++; row++;
@ -42,7 +48,7 @@ index 0c57825..ccbc805 100644
/* Capture limits frame */ /* Capture limits frame */
limit_fr = frame_new("Stop Capture Automatically After..."); limit_fr = frame_new("Stop Capture Automatically After...");
gtk_box_pack_start(GTK_BOX (left_vb), limit_fr, TRUE, TRUE, 0); gtk_box_pack_start(GTK_BOX (left_vb), limit_fr, TRUE, TRUE, 0);
@@ -5108,15 +5084,13 @@ fprintf(stderr, "Adding the default filter \"%s\"???\n", global_capture_opts.def @@ -5107,15 +5083,13 @@ capture_prep_cb(GtkWidget *w _U_, gpointer d _U_)
ws_gtk_grid_attach_extended(GTK_GRID (limit_grid), stop_packets_lb, 2, row, 1, 1, ws_gtk_grid_attach_extended(GTK_GRID (limit_grid), stop_packets_lb, 2, row, 1, 1,
(GtkAttachOptions)(GTK_FILL), (GtkAttachOptions)(GTK_FILL), 0, 0); (GtkAttachOptions)(GTK_FILL), (GtkAttachOptions)(GTK_FILL), 0, 0);
@ -59,7 +65,7 @@ index 0c57825..ccbc805 100644
(GtkAttachOptions)(GTK_FILL), (GtkAttachOptions)(GTK_FILL), 0, 0); (GtkAttachOptions)(GTK_FILL), (GtkAttachOptions)(GTK_FILL), 0, 0);
stop_filesize_adj = (GtkAdjustment *) gtk_adjustment_new(0.0, stop_filesize_adj = (GtkAdjustment *) gtk_adjustment_new(0.0,
@@ -5124,11 +5098,11 @@ fprintf(stderr, "Adding the default filter \"%s\"???\n", global_capture_opts.def @@ -5123,11 +5097,11 @@ capture_prep_cb(GtkWidget *w _U_, gpointer d _U_)
stop_filesize_sb = gtk_spin_button_new (stop_filesize_adj, 0, 0); stop_filesize_sb = gtk_spin_button_new (stop_filesize_adj, 0, 0);
gtk_spin_button_set_wrap (GTK_SPIN_BUTTON (stop_filesize_sb), TRUE); gtk_spin_button_set_wrap (GTK_SPIN_BUTTON (stop_filesize_sb), TRUE);
gtk_widget_set_size_request(stop_filesize_sb, 80, -1); gtk_widget_set_size_request(stop_filesize_sb, 80, -1);
@ -73,7 +79,7 @@ index 0c57825..ccbc805 100644
(GtkAttachOptions)(GTK_FILL), (GtkAttachOptions)(GTK_FILL), 0, 0); (GtkAttachOptions)(GTK_FILL), (GtkAttachOptions)(GTK_FILL), 0, 0);
value = size_unit_combo_box_set_value(global_capture_opts.autostop_filesize); value = size_unit_combo_box_set_value(global_capture_opts.autostop_filesize);
@@ -5136,13 +5110,35 @@ fprintf(stderr, "Adding the default filter \"%s\"???\n", global_capture_opts.def @@ -5135,13 +5109,35 @@ capture_prep_cb(GtkWidget *w _U_, gpointer d _U_)
row++; row++;
@ -110,7 +116,7 @@ index 0c57825..ccbc805 100644
(GtkAttachOptions)(GTK_FILL), (GtkAttachOptions)(GTK_FILL), 0, 0); (GtkAttachOptions)(GTK_FILL), (GtkAttachOptions)(GTK_FILL), 0, 0);
stop_duration_adj = (GtkAdjustment *) gtk_adjustment_new(0.0, stop_duration_adj = (GtkAdjustment *) gtk_adjustment_new(0.0,
@@ -5150,11 +5146,11 @@ fprintf(stderr, "Adding the default filter \"%s\"???\n", global_capture_opts.def @@ -5149,11 +5145,11 @@ capture_prep_cb(GtkWidget *w _U_, gpointer d _U_)
stop_duration_sb = gtk_spin_button_new (stop_duration_adj, 0, 0); stop_duration_sb = gtk_spin_button_new (stop_duration_adj, 0, 0);
gtk_spin_button_set_wrap (GTK_SPIN_BUTTON (stop_duration_sb), TRUE); gtk_spin_button_set_wrap (GTK_SPIN_BUTTON (stop_duration_sb), TRUE);
gtk_widget_set_size_request(stop_duration_sb, 80, -1); gtk_widget_set_size_request(stop_duration_sb, 80, -1);
@ -124,7 +130,7 @@ index 0c57825..ccbc805 100644
(GtkAttachOptions)(GTK_FILL), (GtkAttachOptions)(GTK_FILL), 0, 0); (GtkAttachOptions)(GTK_FILL), (GtkAttachOptions)(GTK_FILL), 0, 0);
value = time_unit_combo_box_convert_value(global_capture_opts.autostop_duration); value = time_unit_combo_box_convert_value(global_capture_opts.autostop_duration);
@@ -5165,7 +5161,7 @@ fprintf(stderr, "Adding the default filter \"%s\"???\n", global_capture_opts.def @@ -5164,7 +5160,7 @@ capture_prep_cb(GtkWidget *w _U_, gpointer d _U_)
display_fr = frame_new("Display Options"); display_fr = frame_new("Display Options");
gtk_box_pack_start(GTK_BOX (right_vb), display_fr, TRUE, TRUE, 0); gtk_box_pack_start(GTK_BOX (right_vb), display_fr, TRUE, TRUE, 0);
@ -133,7 +139,7 @@ index 0c57825..ccbc805 100644
gtk_container_set_border_width(GTK_CONTAINER(display_vb), DLG_OUTER_MARGIN); gtk_container_set_border_width(GTK_CONTAINER(display_vb), DLG_OUTER_MARGIN);
gtk_container_add(GTK_CONTAINER(display_fr), display_vb); gtk_container_add(GTK_CONTAINER(display_fr), display_vb);
@@ -5178,7 +5174,7 @@ fprintf(stderr, "Adding the default filter \"%s\"???\n", global_capture_opts.def @@ -5177,7 +5173,7 @@ capture_prep_cb(GtkWidget *w _U_, gpointer d _U_)
gtk_widget_set_tooltip_text(sync_cb, gtk_widget_set_tooltip_text(sync_cb,
"Using this option will show the captured packets immediately on the main screen. " "Using this option will show the captured packets immediately on the main screen. "
"Please note: this will slow down capturing, so increased packet drops might appear."); "Please note: this will slow down capturing, so increased packet drops might appear.");
@ -142,7 +148,7 @@ index 0c57825..ccbc805 100644
/* "Auto-scroll live update" row */ /* "Auto-scroll live update" row */
auto_scroll_cb = gtk_check_button_new_with_mnemonic("_Automatically scroll during live capture"); auto_scroll_cb = gtk_check_button_new_with_mnemonic("_Automatically scroll during live capture");
@@ -5186,19 +5182,19 @@ fprintf(stderr, "Adding the default filter \"%s\"???\n", global_capture_opts.def @@ -5185,19 +5181,19 @@ capture_prep_cb(GtkWidget *w _U_, gpointer d _U_)
gtk_widget_set_tooltip_text(auto_scroll_cb, gtk_widget_set_tooltip_text(auto_scroll_cb,
"This will scroll the \"Packet List\" automatically to the latest captured packet, " "This will scroll the \"Packet List\" automatically to the latest captured packet, "
"when the \"Update List of packets in real time\" option is used."); "when the \"Update List of packets in real time\" option is used.");
@ -165,7 +171,7 @@ index 0c57825..ccbc805 100644
gtk_container_set_border_width(GTK_CONTAINER(resolv_vb), DLG_OUTER_MARGIN); gtk_container_set_border_width(GTK_CONTAINER(resolv_vb), DLG_OUTER_MARGIN);
gtk_container_add(GTK_CONTAINER(resolv_fr), resolv_vb); gtk_container_add(GTK_CONTAINER(resolv_fr), resolv_vb);
@@ -5207,14 +5203,14 @@ fprintf(stderr, "Adding the default filter \"%s\"???\n", global_capture_opts.def @@ -5206,14 +5202,14 @@ capture_prep_cb(GtkWidget *w _U_, gpointer d _U_)
gtk_toggle_button_set_active(GTK_TOGGLE_BUTTON(m_resolv_cb), gtk_toggle_button_set_active(GTK_TOGGLE_BUTTON(m_resolv_cb),
gbl_resolv_flags.mac_name); gbl_resolv_flags.mac_name);
gtk_widget_set_tooltip_text(m_resolv_cb, "Perform MAC layer name resolution while capturing."); gtk_widget_set_tooltip_text(m_resolv_cb, "Perform MAC layer name resolution while capturing.");
@ -182,7 +188,7 @@ index 0c57825..ccbc805 100644
t_resolv_cb = gtk_check_button_new_with_mnemonic( t_resolv_cb = gtk_check_button_new_with_mnemonic(
"Resolve _transport-layer name"); "Resolve _transport-layer name");
@@ -5222,7 +5218,7 @@ fprintf(stderr, "Adding the default filter \"%s\"???\n", global_capture_opts.def @@ -5221,7 +5217,7 @@ capture_prep_cb(GtkWidget *w _U_, gpointer d _U_)
gbl_resolv_flags.transport_name); gbl_resolv_flags.transport_name);
gtk_widget_set_tooltip_text(t_resolv_cb, gtk_widget_set_tooltip_text(t_resolv_cb,
"Perform transport layer name resolution while capturing."); "Perform transport layer name resolution while capturing.");
@ -191,7 +197,7 @@ index 0c57825..ccbc805 100644
e_resolv_cb = gtk_check_button_new_with_mnemonic( e_resolv_cb = gtk_check_button_new_with_mnemonic(
"Use _external network name resolver"); "Use _external network name resolver");
@@ -5230,7 +5226,7 @@ fprintf(stderr, "Adding the default filter \"%s\"???\n", global_capture_opts.def @@ -5229,7 +5225,7 @@ capture_prep_cb(GtkWidget *w _U_, gpointer d _U_)
gbl_resolv_flags.use_external_net_name_resolver); gbl_resolv_flags.use_external_net_name_resolver);
gtk_widget_set_tooltip_text(e_resolv_cb, gtk_widget_set_tooltip_text(e_resolv_cb,
"Use the (system's) configured name resolver (e.g., DNS) to resolve network names."); "Use the (system's) configured name resolver (e.g., DNS) to resolve network names.");

View File

@ -20,8 +20,8 @@
Summary: Network traffic analyzer Summary: Network traffic analyzer
Name: wireshark Name: wireshark
Version: 1.10.5 Version: 1.10.6
Release: 4%{?dist} Release: 1%{?dist}
License: GPL+ License: GPL+
Group: Applications/Internet Group: Applications/Internet
Source0: http://wireshark.org/download/src/%{name}-%{version}.tar.bz2 Source0: http://wireshark.org/download/src/%{name}-%{version}.tar.bz2
@ -72,10 +72,11 @@ Patch21: wireshark-0021-Remove-g_memmove.patch
# W.i.p. patch. See also: # W.i.p. patch. See also:
# https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9561 # https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9561
Patch22: wireshark-0022-Fix-IP-types.patch Patch22: wireshark-0022-Fix-IP-types.patch
# Backported from upstream # No longer necessary - will be removed in the next release (1.12.x)
Patch23: wireshark-0023-Copy-over-r54544-from-trunk.patch Patch23: wireshark-0023-Copy-over-r54544-from-trunk.patch
# Fedora-specific # Fedora-specific
Patch24: wireshark-0024-Fix-paths-in-a-wireshark.desktop-file.patch Patch24: wireshark-0024-Fix-paths-in-a-wireshark.desktop-file.patch
# Fedora-specific
Patch25: wireshark-0025-Fix-Capture-Dialog-layout.patch Patch25: wireshark-0025-Fix-Capture-Dialog-layout.patch
Url: http://www.wireshark.org/ Url: http://www.wireshark.org/
@ -193,7 +194,7 @@ and plugins.
#%patch20 -p1 -b .fix_previous_backport #%patch20 -p1 -b .fix_previous_backport
%patch21 -p1 -b .remove_g_memmove %patch21 -p1 -b .remove_g_memmove
%patch22 -p1 -b .rtpproxy_ip_types %patch22 -p1 -b .rtpproxy_ip_types
%patch23 -p1 -b .rare_bug_with_sniffer_traces #%patch23 -p1 -b .rare_bug_with_sniffer_traces
%patch24 -p1 -b .fix_paths %patch24 -p1 -b .fix_paths
%patch25 -p1 -b .fix_capture_dlg_layout %patch25 -p1 -b .fix_capture_dlg_layout
@ -394,6 +395,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_datadir}/aclocal/* %{_datadir}/aclocal/*
%changelog %changelog
* Sat Mar 08 2014 Peter Lemenkov <lemenkov@gmail.com> - 1.10.6-1
- Ver. 1.10.6
* Fri Mar 7 2014 Peter Hatina <phatina@redhat.com> - 1.10.5-4 * Fri Mar 7 2014 Peter Hatina <phatina@redhat.com> - 1.10.5-4
- Fix Capture Dialog layout on low resolution displays - Fix Capture Dialog layout on low resolution displays
- Resolves: #1071313 - Resolves: #1071313