fix pie patch

This commit is contained in:
Radek Vokál 2008-07-18 12:42:56 +00:00
parent 977e92ccaf
commit 62e591eb84
2 changed files with 43 additions and 43 deletions

View File

@ -1,45 +1,7 @@
diff -up wireshark-0.99.7-SVN-23507/Makefile.in.pie wireshark-0.99.7-SVN-23507/Makefile.in diff -up wireshark-1.0.2/gtk/Makefile.in.pie wireshark-1.0.2/gtk/Makefile.in
--- wireshark-0.99.7-SVN-23507/Makefile.in.pie 2007-11-20 05:34:36.000000000 -0500 --- wireshark-1.0.2/gtk/Makefile.in.pie 2008-07-10 19:39:52.000000000 +0200
+++ wireshark-0.99.7-SVN-23507/Makefile.in 2007-11-20 15:00:25.000000000 -0500 +++ wireshark-1.0.2/gtk/Makefile.in 2008-07-18 14:39:30.000000000 +0200
@@ -1004,7 +1004,7 @@ noinst_HEADERS = \ @@ -1009,14 +1009,14 @@ distclean-compile:
wireshark_optional_objects = @GETOPT_O@ @STRERROR_O@ \
@STRCASECMP_O@ @STRNCASECMP_O@ @MKSTEMP_O@ @STRPTIME_O@
-@ENABLE_STATIC_FALSE@wireshark_LDFLAGS = -export-dynamic
+@ENABLE_STATIC_FALSE@wireshark_LDFLAGS = -export-dynamic -pie
@ENABLE_STATIC_TRUE@wireshark_LDFLAGS = -Wl,-static -all-static
# Libraries and plugin flags with which to link wireshark.
@@ -1030,7 +1030,7 @@ wireshark_LDADD = \
@LIBGNUTLS_LIBS@ \
@PORTAUDIO_LIBS@
-@ENABLE_STATIC_FALSE@tshark_LDFLAGS = -export-dynamic
+@ENABLE_STATIC_FALSE@tshark_LDFLAGS = -export-dynamic -pie
@ENABLE_STATIC_TRUE@tshark_LDFLAGS = -Wl,-static -all-static
# Libraries and plugin flags with which to link tshark.
@@ -1610,14 +1610,14 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/version_info.Po@am__quote@
.c.o:
-@am__fastdepCC_TRUE@ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
+@am__fastdepCC_TRUE@ $(COMPILE) $(PIECFLAGS) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
@am__fastdepCC_FALSE@ $(COMPILE) -c $<
.c.obj:
-@am__fastdepCC_TRUE@ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `$(CYGPATH_W) '$<'`
+@am__fastdepCC_TRUE@ $(COMPILE) $(PIECFLAGS) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `$(CYGPATH_W) '$<'`
@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
diff -up wireshark-0.99.7-SVN-23507/gtk/Makefile.in.pie wireshark-0.99.7-SVN-23507/gtk/Makefile.in
--- wireshark-0.99.7-SVN-23507/gtk/Makefile.in.pie 2007-11-20 05:34:33.000000000 -0500
+++ wireshark-0.99.7-SVN-23507/gtk/Makefile.in 2007-11-20 15:01:33.000000000 -0500
@@ -979,14 +979,14 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/wsp_stat.Po@am__quote@ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/wsp_stat.Po@am__quote@
.c.o: .c.o:
@ -56,3 +18,41 @@ diff -up wireshark-0.99.7-SVN-23507/gtk/Makefile.in.pie wireshark-0.99.7-SVN-235
@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po @am__fastdepCC_TRUE@ mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@ @AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@ @AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
diff -up wireshark-1.0.2/Makefile.in.pie wireshark-1.0.2/Makefile.in
--- wireshark-1.0.2/Makefile.in.pie 2008-07-10 19:39:55.000000000 +0200
+++ wireshark-1.0.2/Makefile.in 2008-07-18 14:39:30.000000000 +0200
@@ -1037,7 +1037,7 @@ noinst_HEADERS = \
wireshark_optional_objects = @GETOPT_O@ @STRERROR_O@ \
@STRCASECMP_O@ @STRNCASECMP_O@ @MKSTEMP_O@ @STRPTIME_O@
-@ENABLE_STATIC_FALSE@wireshark_LDFLAGS = -export-dynamic
+@ENABLE_STATIC_FALSE@wireshark_LDFLAGS = -export-dynamic -pie
@ENABLE_STATIC_TRUE@wireshark_LDFLAGS = -Wl,-static -all-static
# Libraries and plugin flags with which to link wireshark.
@@ -1069,7 +1069,7 @@ wireshark_DEPENDENCIES = \
@INET_PTON_LO@ \
@INET_NTOP_LO@
-@ENABLE_STATIC_FALSE@tshark_LDFLAGS = -export-dynamic
+@ENABLE_STATIC_FALSE@tshark_LDFLAGS = -export-dynamic -pie
@ENABLE_STATIC_TRUE@tshark_LDFLAGS = -Wl,-static -all-static
# Libraries and plugin flags with which to link tshark.
@@ -1743,14 +1743,14 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/version_info.Po@am__quote@
.c.o:
-@am__fastdepCC_TRUE@ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
+@am__fastdepCC_TRUE@ $(COMPILE) $(PIECFLAGS) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
@am__fastdepCC_FALSE@ $(COMPILE) -c $<
.c.obj:
-@am__fastdepCC_TRUE@ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `$(CYGPATH_W) '$<'`
+@am__fastdepCC_TRUE@ $(COMPILE) $(PIECFLAGS) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `$(CYGPATH_W) '$<'`
@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@

View File

@ -17,7 +17,7 @@ Source0: http://wireshark.org/download/src/%{name}-%{version}.tar.gz
Source1: wireshark.pam Source1: wireshark.pam
Source2: wireshark.console Source2: wireshark.console
Source3: wireshark.desktop Source3: wireshark.desktop
Patch1: wireshark-0.99.7-pie.patch Patch1: wireshark-1.0.2-pie.patch
Patch3: wireshark-nfsv4-opts.patch Patch3: wireshark-nfsv4-opts.patch
Patch4: wireshark-0.99.7-path.patch Patch4: wireshark-0.99.7-path.patch
Patch5: wireshark-nfsv41.patch Patch5: wireshark-nfsv41.patch