bring back pie

This commit is contained in:
Radek Vokál 2010-03-24 11:43:08 +00:00
parent ddc891d809
commit 3eb82fd431
3 changed files with 20 additions and 64 deletions

View File

@ -1,58 +0,0 @@
diff -up wireshark-1.0.2/gtk/Makefile.in.pie wireshark-1.0.2/gtk/Makefile.in
--- wireshark-1.0.2/gtk/Makefile.in.pie 2008-07-10 19:39:52.000000000 +0200
+++ wireshark-1.0.2/gtk/Makefile.in 2008-07-18 14:39:30.000000000 +0200
@@ -1009,14 +1009,14 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/wsp_stat.Po@am__quote@
.c.o:
-@am__fastdepCC_TRUE@ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
+@am__fastdepCC_TRUE@ $(COMPILE) $(PIECFLAGS) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
@am__fastdepCC_FALSE@ $(COMPILE) -c $<
.c.obj:
-@am__fastdepCC_TRUE@ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `$(CYGPATH_W) '$<'`
+@am__fastdepCC_TRUE@ $(COMPILE) $(PIECFLAGS) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `$(CYGPATH_W) '$<'`
@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
diff -up wireshark-1.0.2/Makefile.in.pie wireshark-1.0.2/Makefile.in
--- wireshark-1.0.2/Makefile.in.pie 2008-07-10 19:39:55.000000000 +0200
+++ wireshark-1.0.2/Makefile.in 2008-07-18 14:39:30.000000000 +0200
@@ -1037,7 +1037,7 @@ noinst_HEADERS = \
wireshark_optional_objects = @GETOPT_O@ @STRERROR_O@ \
@STRCASECMP_O@ @STRNCASECMP_O@ @MKSTEMP_O@ @STRPTIME_O@
-@ENABLE_STATIC_FALSE@wireshark_LDFLAGS = -export-dynamic
+@ENABLE_STATIC_FALSE@wireshark_LDFLAGS = -export-dynamic -pie
@ENABLE_STATIC_TRUE@wireshark_LDFLAGS = -Wl,-static -all-static
# Libraries and plugin flags with which to link wireshark.
@@ -1069,7 +1069,7 @@ wireshark_DEPENDENCIES = \
@INET_PTON_LO@ \
@INET_NTOP_LO@
-@ENABLE_STATIC_FALSE@tshark_LDFLAGS = -export-dynamic
+@ENABLE_STATIC_FALSE@tshark_LDFLAGS = -export-dynamic -pie
@ENABLE_STATIC_TRUE@tshark_LDFLAGS = -Wl,-static -all-static
# Libraries and plugin flags with which to link tshark.
@@ -1743,14 +1743,14 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/version_info.Po@am__quote@
.c.o:
-@am__fastdepCC_TRUE@ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
+@am__fastdepCC_TRUE@ $(COMPILE) $(PIECFLAGS) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
@am__fastdepCC_FALSE@ $(COMPILE) -c $<
.c.obj:
-@am__fastdepCC_TRUE@ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `$(CYGPATH_W) '$<'`
+@am__fastdepCC_TRUE@ $(COMPILE) $(PIECFLAGS) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `$(CYGPATH_W) '$<'`
@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@

View File

@ -0,0 +1,11 @@
diff -up wireshark-1.2.6/ltmain.sh.libpie wireshark-1.2.6/ltmain.sh
--- wireshark-1.2.6/ltmain.sh.libpie 2010-01-27 17:13:14.000000000 +0100
+++ wireshark-1.2.6/ltmain.sh 2010-03-23 17:39:43.000000000 +0100
@@ -2499,7 +2499,6 @@ static const void *lt_preloaded_setup()
symtab_cflags=
for arg in $LTCFLAGS; do
case $arg in
- -pie | -fpie | -fPIE) ;;
*) symtab_cflags="$symtab_cflags $arg" ;;
esac
done

View File

@ -15,7 +15,7 @@ Version: 1.2.6
%if %{svn_version}
Release: 0.%{svn_version}%{?dist}
%else
Release: 2%{?dist}
Release: 3%{?dist}
%endif
License: GPL+
Group: Applications/Internet
@ -29,7 +29,6 @@ Source1: wireshark.pam
Source2: wireshark.console
Source3: wireshark.desktop
Source4: wireshark-autoconf.m4
Patch1: wireshark-1.0.2-pie.patch
Patch2: wireshark-nfsv4-opts.patch
Patch3: wireshark-0.99.7-path.patch
Patch4: wireshark-1.1.2-nfs41-backchnl-decode.patch
@ -38,6 +37,7 @@ Patch6: wireshark-1.2.4-enable_lua.patch
Patch7: wireshark-1.2.4-disable_warning_dialog.patch
Patch8: wireshark-1.2.6-nfs40-backchnl-decode.patch
Patch9: wireshark-1.2.6-smb-find-full-dir-info.patch
Patch10: wireshark-libtool-pie.patch
Url: http://www.wireshark.org/
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -111,7 +111,6 @@ and plugins.
%else
%setup -q -n %{name}-%{version}
%endif
#%patch1 -p1 -b .pie
%patch2 -p1
%patch3 -p1
%patch4 -p1
@ -124,6 +123,7 @@ and plugins.
%patch7 -p1 -b .dialog
%patch8 -p1
%patch9 -p1
%patch10 -p1
%build
%ifarch s390 s390x sparcv9 sparc64
@ -133,9 +133,9 @@ export PIECFLAGS="-fpie"
%endif
# FC5+ automatic -fstack-protector-all switch
export RPM_OPT_FLAGS=${RPM_OPT_FLAGS//-fstack-protector/-fstack-protector-all}
export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS"
export CXXFLAGS="$RPM_OPT_FLAGS $CPPFLAGS"
export LDFLAGS="$LDFLAGS -lm -lcrypto"
export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS $PIECFLAGS"
export CXXFLAGS="$RPM_OPT_FLAGS $CPPFLAGS $PIECFLAGS"
export LDFLAGS="$LDFLAGS -lm -lcrypto -pie"
%if %{svn_version}
./autogen.sh
%endif
@ -323,6 +323,9 @@ rm -rf $RPM_BUILD_ROOT
%{_sbindir}/idl2wrs
%changelog
* Wed Mar 24 2010 Radek Vokal <rvokal@redhat.com> - 1.2.6-3
- bring back -pie
* Tue Mar 16 2010 Jeff Layton <jlayton@redhat.com> - 1.2.6-2
- add patch to allow decode of NFSv4.0 callback channel
- add patch to allow decode of more SMB FIND_FILE infolevels