Wireshark ver. 1.10.4

- Don't apply upsteamed patches no. 13, 14, 15, 16, 17
- Fix variable overflow (patch no. 18)
- Updated RTPproxy dissector (backported three more patches from trunk)

Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
Peter Lemenkov 2013-12-18 12:52:10 +04:00
parent 4459b55d8d
commit 3a1a1b5cf9
6 changed files with 110 additions and 29 deletions

1
.gitignore vendored
View File

@ -28,3 +28,4 @@ wireshark-1.2.10.tar.bz2
/wireshark-1.10.1.tar.bz2
/wireshark-1.10.2.tar.bz2
/wireshark-1.10.3.tar.bz2
/wireshark-1.10.4.tar.bz2

View File

@ -1 +1 @@
ceb4b2bac5607d948e00bd950461be1c wireshark-1.10.3.tar.bz2
48b59af6c560adacd86078e9d4b109e5 wireshark-1.10.4.tar.bz2

View File

@ -154,6 +154,47 @@ Clean up indentation.
svn path=/trunk/; revision=53742
From Peter Lemenkov via https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9556
Cosmetic change in a LF field representation in the RTPproxy dissector
Don't display any value for LF field
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
svn path=/trunk/; revision=54045
From Peter Lemenkov via https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9558
Mark generated fields as generated in RTPproxy dissector
This patch is cosmetic. It just marks generated fields as generated (to avoid confusion)
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
svn path=/trunk/; revision=54123
From Peter Lemenkov:
"This patch removes misleading dereferencing operator from the
array's name. E.g. consider the following declaration:
guint32 ipaddr[4];
ipaddr points to the address of an array of guint32's, while &ipaddr
points to the first' guint32 object. E.g. &ipaddr == &ipaddr[0]. The
value is the same, but has different type which is necessary
sometimes. However inet_pton treats latest argument as void*, and
this information is left anyway. So no need to bother with types and
let's just pass pointer to the array."
https://bugs.wireshark.org/bugzilla/attachment.cgi?id=12304
From me: Remove dereferencing operator from 'ipaddr' in two calls to
wmem_memdup().
svn path=/trunk/; revision=54156
diff --git a/AUTHORS b/AUTHORS
index 10782b0..e7b3c18 100644
--- a/AUTHORS
@ -192,10 +233,10 @@ index 937f522..73217d7 100644
packet-rudp.c \
diff --git a/epan/dissectors/packet-rtpproxy.c b/epan/dissectors/packet-rtpproxy.c
new file mode 100644
index 0000000..0afee3a
index 0000000..2c8fba3
--- /dev/null
+++ b/epan/dissectors/packet-rtpproxy.c
@@ -0,0 +1,1387 @@
@@ -0,0 +1,1386 @@
+/* packet-rtpproxy.c
+ * RTPproxy command protocol dissector
+ * Copyright 2013, Peter Lemenkov <lemenkov@gmail.com>
@ -425,11 +466,6 @@ index 0000000..0afee3a
+ { 0, NULL }
+};
+
+static const value_string flowcontroltypenames[] = {
+ { '\n', "Yes"},
+ { 0, NULL }
+};
+
+static gint ett_rtpproxy = -1;
+
+static gint ett_rtpproxy_request = -1;
@ -483,11 +519,14 @@ index 0000000..0afee3a
+ another_tree = proto_item_add_subtree(ti, ett_rtpproxy_tag);
+ ti = proto_tree_add_item(another_tree, hf_rtpproxy_mediaid, tvb, new_offset+1, 0, ENC_ASCII | ENC_NA);
+ proto_item_append_text(ti, "<skipped>");
+ PROTO_ITEM_SET_GENERATED(ti);
+ }
+ else{
+ ti = proto_tree_add_item(rtpproxy_tree, hf_rtpproxy_tag, tvb, begin, new_offset - begin, ENC_ASCII | ENC_NA);
+ if ((guint)new_offset == begin)
+ if ((guint)new_offset == begin){
+ proto_item_append_text(ti, "<skipped>"); /* A very first Offer/Update command */
+ PROTO_ITEM_SET_GENERATED(ti);
+ }
+ another_tree = proto_item_add_subtree(ti, ett_rtpproxy_tag);
+ proto_tree_add_item(another_tree, hf_rtpproxy_mediaid, tvb, new_offset+1, end - (new_offset+1), ENC_ASCII | ENC_NA);
+ }
@ -660,6 +699,7 @@ index 0000000..0afee3a
+ /* Only port is supplied */
+ ti = proto_tree_add_item(rtpproxy_tree, hf_rtpproxy_notify_ipv4, tvb, begin, 0, ENC_ASCII | ENC_NA);
+ proto_item_append_text(ti, "<skipped>");
+ PROTO_ITEM_SET_GENERATED(ti);
+ proto_tree_add_item(rtpproxy_tree, hf_rtpproxy_notify_port, tvb, begin, end - begin, ENC_ASCII | ENC_NA);
+ }
+}
@ -953,17 +993,17 @@ index 0000000..0afee3a
+ /* Extract IP */
+ tmp = tvb_find_line_end(tvb, offset, -1, &new_offset, FALSE);
+ if (tvb_find_guint8(tvb, offset, -1, ':') == -1){
+ inet_pton(AF_INET, (char*)tvb_get_ephemeral_string(tvb, offset, tmp), &ipaddr);
+ inet_pton(AF_INET, (char*)tvb_get_ephemeral_string(tvb, offset, tmp), ipaddr);
+ addr.type = AT_IPv4;
+ addr.len = 4;
+ addr.data = ep_memdup(&ipaddr, 4);
+ addr.data = ep_memdup(ipaddr, 4);
+ proto_tree_add_item(rtpproxy_tree, hf_rtpproxy_ipv4, tvb, offset, tmp, ENC_ASCII | ENC_NA);
+ }
+ else{
+ inet_pton(AF_INET6, (char*)tvb_get_ephemeral_string(tvb, offset, tmp), &ipaddr);
+ inet_pton(AF_INET6, (char*)tvb_get_ephemeral_string(tvb, offset, tmp), ipaddr);
+ addr.type = AT_IPv6;
+ addr.len = 16;
+ addr.data = ep_memdup(&ipaddr, 16);
+ addr.data = ep_memdup(ipaddr, 16);
+ proto_tree_add_item(rtpproxy_tree, hf_rtpproxy_ipv6, tvb, offset, tmp, ENC_ASCII | ENC_NA);
+ }
+
@ -1426,9 +1466,9 @@ index 0000000..0afee3a
+ {
+ "LF",
+ "rtpproxy.lf",
+ FT_UINT8,
+ BASE_DEC,
+ VALS(flowcontroltypenames),
+ FT_NONE,
+ BASE_NONE,
+ NULL,
+ 0x0,
+ NULL,
+ HFILL

View File

@ -18,7 +18,7 @@ index eb735a5..2844c90 100644
# Wireshark configuration files are put in $(pkgdatadir).
#
diff --git a/configure.ac b/configure.ac
index 6c05883..5cae378 100644
index 1356d9a..8691bbf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2543,6 +2543,7 @@ AC_CONFIG_HEADERS(config.h)

View File

@ -0,0 +1,31 @@
From: Bill Meier <wmeier@newsguy.com>
Date: Tue, 17 Dec 2013 21:18:15 +0000
Subject: [PATCH] Copy over from Trunk
------------------------------------------------------------------------
r54181 | wmeier | 2013-12-17 10:02:47 -0500 (Tue, 17 Dec 2013) | 8 lines
From "bd": Fix " Wireshark stops showing new packets but dumpcap keeps writing them to the temp file"
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9571
From me: Fixed in a slightly different manner than sugested in the patch attached to the bug.
------------------------------------------------------------------------
svn path=/trunk-1.10/; revision=54196
diff --git a/dumpcap.c b/dumpcap.c
index 4d42e71..7098f0c 100644
--- a/dumpcap.c
+++ b/dumpcap.c
@@ -3653,8 +3653,8 @@ capture_loop_start(capture_options *capture_opts, gboolean *stats_known, struct
if ((cur_time - upd_time) > DUMPCAP_UPD_TIME) { /* wrap just causes an extra update */
#else
gettimeofday(&cur_time, NULL);
- if ((cur_time.tv_sec * 1000000 + cur_time.tv_usec) >
- (upd_time.tv_sec * 1000000 + upd_time.tv_usec + DUMPCAP_UPD_TIME*1000)) {
+ if (((guint64)cur_time.tv_sec * 1000000 + cur_time.tv_usec) >
+ ((guint64)upd_time.tv_sec * 1000000 + upd_time.tv_usec + DUMPCAP_UPD_TIME*1000)) {
#endif
upd_time = cur_time;

View File

@ -20,8 +20,8 @@
Summary: Network traffic analyzer
Name: wireshark
Version: 1.10.3
Release: 9%{?dist}
Version: 1.10.4
Release: 1%{?dist}
License: GPL+
Group: Applications/Internet
Source0: http://wireshark.org/download/src/%{name}-%{version}.tar.bz2
@ -50,16 +50,18 @@ Patch10: wireshark-0010-Add-pkgconfig-entry.patch
Patch11: wireshark-0011-Install-autoconf-related-file.patch
# Fedora-specific
Patch12: wireshark-0012-move-default-temporary-directory-to-var-tmp.patch
# Backported from upstream.
# No longer necessary - will be removed in the next release (1.12.x)
Patch13: wireshark-0013-Copy-over-r49999-from-trunk.patch
# Backported from upstream.
# No longer necessary - will be removed in the next release (1.12.x)
Patch14: wireshark-0014-Fix-https-bugs.wireshark.org-bugzilla-show_bug.cgi-i.patch
# Backported from upstream.
# No longer necessary - will be removed in the next release (1.12.x)
Patch15: wireshark-0015-From-Dirk-Jagdmann-Make-sure-err_str-is-initialized.patch
# Backported from upstream.
# No longer necessary - will be removed in the next release (1.12.x)
Patch16: wireshark-0016-Crash-when-selecting-Decode-As-based-on-SCTP-PPID.-B.patch
# Backported from upstream.
# No longer necessary - will be removed in the next release (1.12.x)
Patch17: wireshark-0017-Fix-https-bugs.wireshark.org-bugzilla-show_bug.cgi-i.patch
# Backported from upstream.
Patch18: wireshark-0018-Copy-over-from-Trunk.patch
Url: http://www.wireshark.org/
BuildRequires: libpcap-devel >= 0.9
@ -166,11 +168,12 @@ and plugins.
%patch10 -p1 -b .add_pkgconfig
%patch11 -p1 -b .install_autoconf
%patch12 -p1 -b .tmp_dir
%patch13 -p1 -b .allow_64kpackets_for_usb
%patch14 -p1 -b .dont_die_during_sip_dissection
%patch15 -p1 -b .fix_main_window
%patch16 -p1 -b .fix_sctp
%patch17 -p1 -b .fix_global_pinfo
#%patch13 -p1 -b .allow_64kpackets_for_usb
#%patch14 -p1 -b .dont_die_during_sip_dissection
#%patch15 -p1 -b .fix_main_window
#%patch16 -p1 -b .fix_sctp
#%patch17 -p1 -b .fix_global_pinfo
%patch18 -p1 -b .fix_overflow
%build
%ifarch s390 s390x sparcv9 sparc64
@ -369,6 +372,12 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_datadir}/aclocal/*
%changelog
* Wed Dec 18 2013 Peter Lemenkov <lemenkov@gmail.com> - 1.10.4-1
- Ver. 1.10.4
- Don't apply upsteamed patches no. 13, 14, 15, 16, 17
- Fix variable overflow (patch no. 18)
- Updated RTPproxy dissector (backported three more patches from trunk)
* Tue Dec 10 2013 Peter Hatina <phatina@redhat.com> - 1.10-3-9
- remove python support