New version 3.0.0
This commit is contained in:
parent
126f16518b
commit
2313f2df47
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (wireshark-2.6.6.tar.xz) = b781c3b34dc76a3d8e60dc2b9b4e46a11994440b8df7b56134521ea9a77b27b0719a600db60d7f3d65f15972a5db2a7e85a8bf60d7217fce498fb5668de8fe56
|
||||
SHA512 (SIGNATURES-2.6.6.txt) = ecdbb7a97a98fcf466cac75cd121e2dd6378fb98aca99b6a8853b7c7128a4985aa11edf8912c2f0a26575c90b288221aa19021b78c67623cd461719f8f14835d
|
||||
SHA512 (wireshark-3.0.0.tar.xz) = 917708b5edc25609536c7bd7cf4ae32a901fd99118302138dc0bf6f1ad092a8e5069a917cc8cf6cb77190f54e50623a4eba1ee10ffc225ee3051b50cf02a0963
|
||||
SHA512 (SIGNATURES-3.0.0.txt) = b45ef6ba54be291f0be3741e40d94d54bd2eeefd7175b0d6c66345a0da43404cf4a6e1a33c165738b67d93b0693b25fe1e32678de5f736e41b585dd0daa60101
|
||||
|
@ -1,18 +0,0 @@
|
||||
From: =?UTF-8?q?Radek=20Vok=C3=A1l?= <rvokal@fedoraproject.org>
|
||||
Date: Tue, 15 Dec 2009 08:36:27 +0000
|
||||
Subject: [PATCH] enable Lua support
|
||||
|
||||
|
||||
diff --git a/epan/wslua/template-init.lua b/epan/wslua/template-init.lua
|
||||
index 3fe2aca..2b48f9b 100644
|
||||
--- a/epan/wslua/template-init.lua
|
||||
+++ b/epan/wslua/template-init.lua
|
||||
@@ -41,7 +41,7 @@ if running_superuser then
|
||||
local disabled_lib = {}
|
||||
setmetatable(disabled_lib,{ __index = function() error("this package ".. hint) end } );
|
||||
|
||||
- dofile = function() error("dofile " .. hint) end
|
||||
+-- dofile = function() error("dofile " .. hint) end
|
||||
loadfile = function() error("loadfile " .. hint) end
|
||||
loadlib = function() error("loadlib " .. hint) end
|
||||
require = function() error("require " .. hint) end
|
@ -26,7 +26,7 @@ index 2f9d2cc..b18e47f 100644
|
||||
- g_snprintf(errmsg, sizeof errmsg, "Couldn't run %s in child process: %s",
|
||||
- argv[0], g_strerror(errno));
|
||||
+ if (errno == EPERM || errno == EACCES)
|
||||
+ securitymsg = "\nAre you a member of the 'wireshark' group? Try running\n'usermod -a -G wireshark _your_username_' as root.";
|
||||
+ securitymsg = "\nAre you a member of the 'wireshark' group? Try running\n'usermod -a -G wireshark _your_username_' as root.";
|
||||
+ g_snprintf(errmsg, sizeof errmsg, "Couldn't run %s in child process: %s%s",
|
||||
+ argv[0], g_strerror(errno), securitymsg);
|
||||
+
|
||||
|
@ -6,41 +6,18 @@ Subject: [PATCH] Move /tmp to /var/tmp
|
||||
Fedora is using tmpfs which is limited by the size of RAM, thus we need
|
||||
to use different directory on different filesystem.
|
||||
---
|
||||
ui/gtk/about_dlg.c | 3 +-
|
||||
ui/qt/about_dialog.cpp | 3 +-
|
||||
ui/qt/iax2_analysis_dialog.cpp | 5 +--
|
||||
ui/qt/rtp_analysis_dialog.cpp | 5 +--
|
||||
ui/qt/rtp_audio_stream.cpp | 3 +-
|
||||
wsutil/Makefile.am | 6 ++--
|
||||
wsutil/tempfile.c | 9 +++---
|
||||
wsutil/tempfile.h | 4 +--
|
||||
wsutil/wstmpdir.c | 70 ++++++++++++++++++++++++++++++++++++++++++
|
||||
wsutil/wstmpdir.h | 39 +++++++++++++++++++++++
|
||||
10 files changed, 132 insertions(+), 15 deletions(-)
|
||||
8 files changed, 132 insertions(+), 11 deletions(-)
|
||||
create mode 100644 wsutil/wstmpdir.c
|
||||
create mode 100644 wsutil/wstmpdir.h
|
||||
|
||||
diff --git a/ui/gtk/about_dlg.c b/ui/gtk/about_dlg.c
|
||||
index 22ca841..6bcb527 100644
|
||||
--- a/ui/gtk/about_dlg.c
|
||||
+++ b/ui/gtk/about_dlg.c
|
||||
@@ -28,6 +28,7 @@
|
||||
#include <gtk/gtk.h>
|
||||
|
||||
#include <wsutil/filesystem.h>
|
||||
+#include <wsutil/wstmpdir.h> /* for get_tmp_dir() */
|
||||
#include <wsutil/copyright_info.h>
|
||||
#include <version_info.h>
|
||||
#ifdef HAVE_LIBSMI
|
||||
@@ -427,7 +428,7 @@ about_folders_page_new(void)
|
||||
"capture files");
|
||||
|
||||
/* temp */
|
||||
- about_folders_row(table, "Temp", g_get_tmp_dir(),
|
||||
+ about_folders_row(table, "Temp", get_tmp_dir(),
|
||||
"untitled capture files");
|
||||
|
||||
/* pers conf */
|
||||
diff --git a/ui/qt/about_dialog.cpp b/ui/qt/about_dialog.cpp
|
||||
index 31dc581..2f74285 100644
|
||||
--- a/ui/qt/about_dialog.cpp
|
||||
@ -133,26 +110,6 @@ index fde66c8..b9531d2 100644
|
||||
tempfile_ = new QTemporaryFile(tempname, this);
|
||||
tempfile_->open();
|
||||
|
||||
diff --git a/wsutil/Makefile.am b/wsutil/Makefile.am
|
||||
index 2af1b6c..aa149a2 100644
|
||||
--- a/wsutil/Makefile.am
|
||||
+++ b/wsutil/Makefile.am
|
||||
@@ -90,6 +90,7 @@ WSUTIL_PUBLIC_INCLUDES = \
|
||||
ws_pipe.h \
|
||||
ws_printf.h \
|
||||
wsjsmn.h \
|
||||
+ wstmpdir.h \
|
||||
wsgcrypt.h \
|
||||
wsgetopt.h \
|
||||
wspcap.h \
|
||||
@@ -168,6 +169,7 @@ libwsutil_la_SOURCES = \
|
||||
ws_pipe.c \
|
||||
wsgcrypt.c \
|
||||
wsjsmn.c \
|
||||
+ wstmpdir.c \
|
||||
xtea.c
|
||||
|
||||
if HAVE_PLUGINS
|
||||
diff --git a/wsutil/tempfile.c b/wsutil/tempfile.c
|
||||
index 8e1f8dc..dcf2f78 100644
|
||||
--- a/wsutil/tempfile.c
|
||||
|
@ -1,16 +1,3 @@
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 9e3b555..b0abd84 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -3069,7 +3069,7 @@ if(RPMBUILD_EXECUTABLE AND GIT_EXECUTABLE)
|
||||
endif()
|
||||
|
||||
execute_process(
|
||||
- COMMAND git describe --abbrev=8 --match v[1-9]*
|
||||
+ COMMAND git describe --always --abbrev=8 --match v[1-9]*
|
||||
OUTPUT_VARIABLE _git_description
|
||||
OUTPUT_STRIP_TRAILING_WHITESPACE
|
||||
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
|
||||
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
|
||||
index 0367cd1..6382a2c 100644
|
||||
--- a/wsutil/CMakeLists.txt
|
||||
@ -20,7 +7,7 @@ index 0367cd1..6382a2c 100644
|
||||
ws_pipe.h
|
||||
ws_printf.h
|
||||
+ wstmpdir.h
|
||||
wsjsmn.h
|
||||
wsjson.h
|
||||
xtea.h
|
||||
)
|
||||
@@ -118,6 +118,7 @@ set(WSUTIL_COMMON_FILES
|
||||
@ -29,5 +16,5 @@ index 0367cd1..6382a2c 100644
|
||||
ws_pipe.c
|
||||
+ wstmpdir.c
|
||||
wsgcrypt.c
|
||||
wsjsmn.c
|
||||
wsjson.c
|
||||
xtea.c
|
||||
|
@ -1,12 +1,11 @@
|
||||
%global with_lua 1
|
||||
%global with_portaudio 1
|
||||
%global with_maxminddb 1
|
||||
%global plugins_version 2.6
|
||||
%global plugins_version 3.0
|
||||
|
||||
Summary: Network traffic analyzer
|
||||
Name: wireshark
|
||||
Version: 2.6.6
|
||||
Release: 2%{?dist}
|
||||
Version: 3.0.0
|
||||
Release: 1%{?dist}
|
||||
Epoch: 1
|
||||
License: GPL+
|
||||
Url: http://www.wireshark.org/
|
||||
@ -15,10 +14,6 @@ Source0: https://wireshark.org/download/src/%{name}-%{version}.tar.xz
|
||||
Source1: https://www.wireshark.org/download/src/all-versions/SIGNATURES-%{version}.txt
|
||||
Source2: 90-wireshark-usbmon.rules
|
||||
|
||||
# Fedora-specific
|
||||
%if %{with_lua} && 0%{?fedora}
|
||||
Patch1: wireshark-0001-enable-Lua-support.patch
|
||||
%endif
|
||||
# Fedora-specific
|
||||
Patch2: wireshark-0002-Customize-permission-denied-error.patch
|
||||
# Will be proposed upstream
|
||||
@ -37,10 +32,6 @@ Requires: %{name}-cli = %{epoch}:%{version}-%{release}
|
||||
Requires: xdg-utils
|
||||
Requires: hicolor-icon-theme
|
||||
|
||||
%if %{with_portaudio} && 0%{?fedora}
|
||||
Requires: portaudio
|
||||
BuildRequires: portaudio-devel
|
||||
%endif
|
||||
%if %{with_maxminddb} && 0%{?fedora}
|
||||
Requires: libmaxminddb
|
||||
%endif
|
||||
@ -51,7 +42,6 @@ BuildRequires: elfutils-devel
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: gnutls-devel
|
||||
BuildRequires: gtk3-devel
|
||||
BuildRequires: krb5-devel
|
||||
BuildRequires: libcap-devel
|
||||
BuildRequires: libgcrypt-devel
|
||||
@ -81,10 +71,13 @@ BuildRequires: compat-lua-devel
|
||||
%endif
|
||||
Buildrequires: git
|
||||
%if 0%{?fedora}
|
||||
Buildrequires: python2-devel
|
||||
Buildrequires: python3-devel
|
||||
%endif
|
||||
Buildrequires: cmake
|
||||
#needed for sdjournal external capture interface
|
||||
BuildRequires: systemd-devel
|
||||
BuildRequires: libnghttp2-devel
|
||||
|
||||
Obsoletes: wireshark-qt, wireshark-gtk
|
||||
|
||||
%description
|
||||
@ -124,7 +117,6 @@ and plugins.
|
||||
%cmake -G "Unix Makefiles" \
|
||||
-DDISABLE_WERROR=ON \
|
||||
-DBUILD_wireshark=ON \
|
||||
-DENABLE_QT5=ON \
|
||||
%if %{with_lua} && 0%{?fedora}
|
||||
-DENABLE_LUA=ON \
|
||||
%else
|
||||
@ -138,14 +130,10 @@ and plugins.
|
||||
-DBUILD_randpktdump=OFF \
|
||||
-DBUILD_androiddump=OFF \
|
||||
-DENABLE_SMI=ON \
|
||||
%if %{with_portaudio} && 0%{?fedora}
|
||||
-DENABLE_PORTAUDIO=ON \
|
||||
%else
|
||||
-DENABLE_PORTAUDIO=OFF \
|
||||
%endif
|
||||
-DENABLE_PLUGINS=ON \
|
||||
-DENABLE_NETLINK=ON \
|
||||
-DBUILD_dcerpcidl2wrs=OFF \
|
||||
-DBUILD_sdjournal=ON \
|
||||
.
|
||||
|
||||
make %{?_smp_mflags}
|
||||
@ -230,7 +218,9 @@ getent group usbmon >/dev/null || groupadd -r usbmon
|
||||
%{_libdir}/wireshark/extcap/ciscodump
|
||||
%{_libdir}/wireshark/extcap/udpdump
|
||||
%{_libdir}/wireshark/extcap/sshdump
|
||||
%{_libdir}/wireshark/*.cmake
|
||||
%{_libdir}/wireshark/extcap/sdjournal
|
||||
%{_libdir}/wireshark/extcap/dpauxmon
|
||||
%{_libdir}/wireshark/cmake/*.cmake
|
||||
#the version wireshark uses to store plugins is only x.y, not .z
|
||||
%{_libdir}/wireshark/plugins/%{plugins_version}/epan/*.so
|
||||
%{_libdir}/wireshark/plugins/%{plugins_version}/wiretap/*.so
|
||||
@ -252,12 +242,15 @@ getent group usbmon >/dev/null || groupadd -r usbmon
|
||||
%{_mandir}/man1/captype.*
|
||||
%{_mandir}/man1/ciscodump.*
|
||||
%{_mandir}/man1/randpktdump.*
|
||||
%{_mandir}/man1/dpauxmon.*
|
||||
%{_mandir}/man1/sdjournal.*
|
||||
%{_mandir}/man4/extcap.*
|
||||
%if %{with_maxminddb} && 0%{?fedora}
|
||||
%{_mandir}/man1/mmdbresolve.*
|
||||
%endif
|
||||
%dir %{_datadir}/wireshark
|
||||
%{_datadir}/wireshark/*
|
||||
%{_docdir}/wireshark/*.html
|
||||
|
||||
%files devel
|
||||
%doc doc/README.* ChangeLog
|
||||
@ -266,6 +259,9 @@ getent group usbmon >/dev/null || groupadd -r usbmon
|
||||
%{_libdir}/pkgconfig/%{name}.pc
|
||||
|
||||
%changelog
|
||||
* Mon Mar 11 2019 Michal Ruprich <mruprich@redhat.com> - 1:3.0.0-1
|
||||
- New version 3.0.0
|
||||
|
||||
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1:2.6.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user