auto-import wireshark-0.99.1-0.pre1 on branch devel from
wireshark-0.99.1-0.pre1.src.rpm
This commit is contained in:
parent
e99fe10d96
commit
0fc81e129c
@ -0,0 +1 @@
|
||||
wireshark-0.99.1pre1.tar.gz
|
63
wireshark-nfsv4-opts.patch
Normal file
63
wireshark-nfsv4-opts.patch
Normal file
@ -0,0 +1,63 @@
|
||||
--- ethereal-0.10.14/epan/dissectors/packet-nfs.c.orig 2005-12-26 21:21:11.000000000 -0500
|
||||
+++ ethereal-0.10.14/epan/dissectors/packet-nfs.c 2006-01-02 13:57:05.000000000 -0500
|
||||
@@ -7040,6 +7040,8 @@ dissect_nfs_argop4(tvbuff_t *tvb, int of
|
||||
|
||||
if (ftree == NULL) return offset;
|
||||
|
||||
+ proto_item_append_text(tree, ", Ops(%d):", ops);
|
||||
+
|
||||
for (ops_counter=0; ops_counter<ops; ops_counter++)
|
||||
{
|
||||
opcode = tvb_get_ntohl(tvb, offset);
|
||||
@@ -7064,6 +7066,15 @@ dissect_nfs_argop4(tvbuff_t *tvb, int of
|
||||
|
||||
if (newftree == NULL) break;
|
||||
|
||||
+ if (opcode != NFS4_OP_PUTFH) {
|
||||
+ if (check_col(pinfo->cinfo, COL_INFO)) {
|
||||
+ col_append_fstr(pinfo->cinfo, COL_INFO, " %s",
|
||||
+ names_nfsv4_operation[opcode - 3].strptr);
|
||||
+ }
|
||||
+ }
|
||||
+ proto_item_append_text(tree, " %s",
|
||||
+ names_nfsv4_operation[opcode - 3].strptr);
|
||||
+
|
||||
switch(opcode)
|
||||
{
|
||||
case NFS4_OP_ACCESS:
|
||||
@@ -7391,6 +7402,8 @@ dissect_nfs_resop4(tvbuff_t *tvb, int of
|
||||
|
||||
if (ftree == NULL) return offset; /* error adding new subtree */
|
||||
|
||||
+ proto_item_append_text(tree, ", Ops(%d):", ops);
|
||||
+
|
||||
for (ops_counter = 0; ops_counter < ops; ops_counter++)
|
||||
{
|
||||
opcode = tvb_get_ntohl(tvb, offset);
|
||||
@@ -7418,6 +7431,17 @@ dissect_nfs_resop4(tvbuff_t *tvb, int of
|
||||
|
||||
offset = dissect_nfs_nfsstat4(tvb, offset, newftree, &status);
|
||||
|
||||
+ if (check_col(pinfo->cinfo, COL_INFO)) {
|
||||
+ if (status != NFS4_OK) {
|
||||
+ col_append_fstr(pinfo->cinfo, COL_INFO, " %s(%d)",
|
||||
+ names_nfsv4_operation[opcode - 3].strptr, status);
|
||||
+ } else if (opcode != NFS4_OP_PUTFH) {
|
||||
+ col_append_fstr(pinfo->cinfo, COL_INFO, " %s",
|
||||
+ names_nfsv4_operation[opcode - 3].strptr);
|
||||
+ }
|
||||
+ }
|
||||
+ proto_item_append_text(tree, " %s(%d)",
|
||||
+ names_nfsv4_operation[opcode - 3].strptr, status);
|
||||
/*
|
||||
* With the exception of NFS4_OP_LOCK, NFS4_OP_LOCKT, and
|
||||
* NFS4_OP_SETATTR, all other ops do *not* return data with the
|
||||
@@ -7662,7 +7686,7 @@ static const value_string nfsv3_proc_val
|
||||
static const vsff nfs4_proc[] = {
|
||||
{ 0, "NULL",
|
||||
dissect_nfs3_null_call, dissect_nfs3_null_reply },
|
||||
- { 1, "COMPOUND",
|
||||
+ { 1, "COMP",
|
||||
dissect_nfs4_compound_call, dissect_nfs4_compound_reply },
|
||||
{ 0, NULL, NULL, NULL }
|
||||
};
|
4
wireshark.console
Normal file
4
wireshark.console
Normal file
@ -0,0 +1,4 @@
|
||||
USER=root
|
||||
PROGRAM=/usr/sbin/wireshark
|
||||
SESSION=true
|
||||
FALLBACK=true
|
14
wireshark.desktop
Normal file
14
wireshark.desktop
Normal file
@ -0,0 +1,14 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=Wireshark Network Analyzer
|
||||
Name[fi]=Wireshark
|
||||
Name[sv]=Wireshark
|
||||
Comment=Wireshark traffic and network analyzer
|
||||
Comment[fi]=Verkkoanalysaattori
|
||||
Comment[sv]=Nätverkstrafikanalysator
|
||||
TryExec=wireshark
|
||||
Exec=wireshark
|
||||
Icon=wireshark.png
|
||||
Terminal=false
|
||||
Type=Application
|
||||
Categories=X-Red-Hat-Extra;Application;Network;GTK;
|
4
wireshark.pam
Normal file
4
wireshark.pam
Normal file
@ -0,0 +1,4 @@
|
||||
#%PAM-1.0
|
||||
auth include config-util
|
||||
account include config-util
|
||||
session include config-util
|
182
wireshark.spec
Normal file
182
wireshark.spec
Normal file
@ -0,0 +1,182 @@
|
||||
%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
|
||||
%define svn_version 18188
|
||||
|
||||
Summary: Network traffic analyzer
|
||||
Name: wireshark
|
||||
Version: 0.99.1
|
||||
Release: 0.pre1
|
||||
License: GPL
|
||||
Group: Applications/Internet
|
||||
Source0: http://www.wireshark.org/download/prerelease/%{name}-%{version}pre1.tar.gz
|
||||
Source1: wireshark.pam
|
||||
Source2: wireshark.console
|
||||
Source3: wireshark.desktop
|
||||
Patch1: wireshark-0.99.1-pie.patch
|
||||
Patch3: wireshark-nfsv4-opts.patch
|
||||
Patch4: wireshark-dialog-close.patch
|
||||
Url: http://www.wireshark.org/
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: libpcap-devel
|
||||
BuildRequires: net-snmp-devel >= 5.3
|
||||
BuildRequires: net-snmp-utils >= 5.3
|
||||
BuildRequires: zlib-devel, bzip2-devel
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: glib2-devel, gtk2-devel
|
||||
BuildRequires: elfutils-devel, krb5-devel
|
||||
BuildRequires: python, pcre-devel, libselinux
|
||||
BuildRequires: gnutls-devel
|
||||
BuildRequires: desktop-file-utils, automake, libtool
|
||||
Obsoletes: ethereal
|
||||
Provides: ethereal
|
||||
|
||||
|
||||
%package gnome
|
||||
Summary: Gnome desktop integration for wireshark and wireshark-usermode
|
||||
Group: Applications/Internet
|
||||
Requires: gtk2
|
||||
Requires: usermode >= 1.37
|
||||
Requires: wireshark = %{version}-%{release}
|
||||
Obsoletes: ethereal-gnome
|
||||
Provides: ethereal-gnome
|
||||
|
||||
|
||||
%description
|
||||
Wireshark is a network traffic analyzer for Unix-ish operating systems.
|
||||
|
||||
This package lays base for libpcap, a packet capture and filtering
|
||||
library, contains command-line utilities, contains plugins and
|
||||
documentation for wireshark. A graphical user interface is packaged
|
||||
separately to GTK+ package.
|
||||
|
||||
%description gnome
|
||||
Contains wireshark for Gnome 2 and desktop integration file
|
||||
|
||||
|
||||
%prep
|
||||
#%setup -q -n %{name}-%{version}-SVN-%{svn_version}
|
||||
%setup -q -n %{name}-%{version}pre1
|
||||
%patch1 -p1 -b .pie
|
||||
%patch3 -p1
|
||||
%patch4 -p1 -b .close
|
||||
|
||||
%build
|
||||
%ifarch s390 s390x
|
||||
export PIECFLAGS="-fPIE"
|
||||
%else
|
||||
export PIECFLAGS="-fpie"
|
||||
%endif
|
||||
# FC5+ automatic -fstack-protector-all switch
|
||||
export RPM_OPT_FLAGS=${RPM_OPT_FLAGS//-fstack-protector/-fstack-protector-all}
|
||||
export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS"
|
||||
export CXXFLAGS="$RPM_OPT_FLAGS $CPPFLAGS"
|
||||
export LDFLAGS="$LDFLAGS -lm -lcrypto"
|
||||
./autogen.sh
|
||||
%configure \
|
||||
--bindir=%{_sbindir} \
|
||||
--enable-zlib \
|
||||
--enable-ipv6 \
|
||||
--with-net-snmp \
|
||||
--with-gnu-ld \
|
||||
--disable-static \
|
||||
--disable-usr-local \
|
||||
--enable-gtk2 \
|
||||
--with-pic \
|
||||
--with-ssl \
|
||||
--with-plugindir=%{_libdir}/%{name}/plugins/%{version}
|
||||
time make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
# The evil plugins hack
|
||||
perl -pi -e 's|-L../../epan|-L../../epan/.libs|' plugins/*/*.la
|
||||
|
||||
make DESTDIR=$RPM_BUILD_ROOT install
|
||||
|
||||
#symlink tshark to tethereal
|
||||
ln -s tshark $RPM_BUILD_ROOT%{_sbindir}/tethereal
|
||||
|
||||
#empty?!
|
||||
rm -f $RPM_BUILD_ROOT%{_sbindir}/idl2wrs
|
||||
|
||||
# install support files for usermode, gnome and kde
|
||||
mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d
|
||||
install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d/wireshark
|
||||
mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps
|
||||
install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps/wireshark
|
||||
mkdir -p $RPM_BUILD_ROOT/%{_bindir}
|
||||
ln -s consolehelper $RPM_BUILD_ROOT/%{_bindir}/wireshark
|
||||
|
||||
# install man
|
||||
mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
|
||||
install -m 644 *.1 $RPM_BUILD_ROOT/%{_mandir}/man1
|
||||
|
||||
# Install python stuff.
|
||||
mkdir -p $RPM_BUILD_ROOT%{python_sitelib}
|
||||
install -m 644 tools/wireshark_be.py tools/wireshark_gen.py $RPM_BUILD_ROOT%{python_sitelib}
|
||||
|
||||
desktop-file-install --vendor fedora \
|
||||
--dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
|
||||
--add-category X-Fedora \
|
||||
%{SOURCE3}
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/pixmaps
|
||||
install -m 644 image/wsicon48.png $RPM_BUILD_ROOT/%{_datadir}/pixmaps/wireshark.png
|
||||
|
||||
|
||||
# Remove .la files
|
||||
rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}/plugins/%{version}/*.la
|
||||
|
||||
# Remove .la files in libdir
|
||||
rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc AUTHORS COPYING ChangeLog INSTALL NEWS README*
|
||||
%{_sbindir}/editcap
|
||||
#%{_sbindir}/idl2wrs
|
||||
%{_sbindir}/tshark
|
||||
%{_sbindir}/mergecap
|
||||
%{_sbindir}/text2pcap
|
||||
%{_sbindir}/dftest
|
||||
%{_sbindir}/capinfos
|
||||
%{_sbindir}/randpkt
|
||||
%{_sbindir}/dumpcap
|
||||
%{_sbindir}/tethereal
|
||||
%{python_sitelib}/*
|
||||
%{_libdir}/lib*
|
||||
%{_mandir}/man1/editcap.*
|
||||
%{_mandir}/man1/tshark.*
|
||||
%{_mandir}/man1/idl2wrs.*
|
||||
%{_mandir}/man1/mergecap.*
|
||||
%{_mandir}/man1/text2pcap.*
|
||||
%{_mandir}/man1/capinfos.*
|
||||
%{_mandir}/man1/dumpcap.*
|
||||
%{_mandir}/man4/wireshark-filter.*
|
||||
%{_libdir}/wireshark
|
||||
%config(noreplace) %{_sysconfdir}/pam.d/wireshark
|
||||
%config(noreplace) %{_sysconfdir}/security/console.apps/wireshark
|
||||
%{_datadir}/wireshark
|
||||
|
||||
%files gnome
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/applications/fedora-wireshark.desktop
|
||||
%{_datadir}/pixmaps/wireshark.png
|
||||
%{_bindir}/wireshark
|
||||
%{_sbindir}/wireshark
|
||||
%{_mandir}/man1/wireshark.*
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jun 13 2006 Radek Vokal <rvokal@redhat.com> 0.99.1-0.pre1
|
||||
- spec file changes
|
||||
|
||||
* Fri Jun 9 2006 Radek Vokal <rvokal@redhat.com> 0.99.1pre1-1
|
||||
- initial build for Fedora Core
|
Loading…
Reference in New Issue
Block a user