Ver. 1.12.9

Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
Peter Lemenkov 2016-01-08 13:23:25 +03:00
parent 8676769506
commit 0745176bae
7 changed files with 66 additions and 78 deletions

1
.gitignore vendored
View File

@ -43,3 +43,4 @@ wireshark-1.2.10.tar.bz2
/wireshark-1.12.6.tar.bz2 /wireshark-1.12.6.tar.bz2
/wireshark-1.12.7.tar.bz2 /wireshark-1.12.7.tar.bz2
/wireshark-1.12.8.tar.bz2 /wireshark-1.12.8.tar.bz2
/wireshark-1.12.9.tar.bz2

View File

@ -1 +1 @@
988a4595a4a87dafb3c4870ea40e89b5 wireshark-1.12.8.tar.bz2 c492c9354d3b5a0db4514c9d90167a2a wireshark-1.12.9.tar.bz2

View File

@ -8,10 +8,10 @@ because of permissions.
Signed-off-by: Jan Safranek <jsafrane@redhat.com> Signed-off-by: Jan Safranek <jsafrane@redhat.com>
diff --git a/capture_sync.c b/capture_sync.c diff --git a/capture_sync.c b/capture_sync.c
index 2f9d2cc..b18e47f 100644 index 9cf59ef..dc580e7 100644
--- a/capture_sync.c --- a/capture_sync.c
+++ b/capture_sync.c +++ b/capture_sync.c
@@ -374,6 +374,7 @@ sync_pipe_start(capture_options *capture_opts, capture_session *cap_session, voi @@ -376,6 +376,7 @@ sync_pipe_start(capture_options *capture_opts, capture_session *cap_session, voi
gchar *signal_pipe_name; gchar *signal_pipe_name;
#else #else
char errmsg[1024+1]; char errmsg[1024+1];
@ -19,7 +19,7 @@ index 2f9d2cc..b18e47f 100644
int sync_pipe[2]; /* pipe used to send messages from child to parent */ int sync_pipe[2]; /* pipe used to send messages from child to parent */
enum PIPES { PIPE_READ, PIPE_WRITE }; /* Constants 0 and 1 for PIPE_READ and PIPE_WRITE */ enum PIPES { PIPE_READ, PIPE_WRITE }; /* Constants 0 and 1 for PIPE_READ and PIPE_WRITE */
#endif #endif
@@ -649,8 +650,11 @@ sync_pipe_start(capture_options *capture_opts, capture_session *cap_session, voi @@ -690,8 +691,11 @@ sync_pipe_start(capture_options *capture_opts, capture_session *cap_session, voi
dup2(sync_pipe[PIPE_WRITE], 2); dup2(sync_pipe[PIPE_WRITE], 2);
ws_close(sync_pipe[PIPE_READ]); ws_close(sync_pipe[PIPE_READ]);
execv(argv[0], argv); execv(argv[0], argv);
@ -33,7 +33,7 @@ index 2f9d2cc..b18e47f 100644
sync_pipe_errmsg_to_parent(2, errmsg, ""); sync_pipe_errmsg_to_parent(2, errmsg, "");
/* Exit with "_exit()", so that we don't close the connection /* Exit with "_exit()", so that we don't close the connection
@@ -745,6 +749,7 @@ sync_pipe_open_command(char** argv, int *data_read_fd, @@ -786,6 +790,7 @@ sync_pipe_open_command(char** argv, int *data_read_fd,
PROCESS_INFORMATION pi; PROCESS_INFORMATION pi;
#else #else
char errmsg[1024+1]; char errmsg[1024+1];
@ -41,7 +41,7 @@ index 2f9d2cc..b18e47f 100644
int sync_pipe[2]; /* pipe used to send messages from child to parent */ int sync_pipe[2]; /* pipe used to send messages from child to parent */
int data_pipe[2]; /* pipe used to send data from child to parent */ int data_pipe[2]; /* pipe used to send data from child to parent */
#endif #endif
@@ -879,8 +884,11 @@ sync_pipe_open_command(char** argv, int *data_read_fd, @@ -955,8 +960,11 @@ sync_pipe_open_command(char** argv, int *data_read_fd,
ws_close(sync_pipe[PIPE_READ]); ws_close(sync_pipe[PIPE_READ]);
ws_close(sync_pipe[PIPE_WRITE]); ws_close(sync_pipe[PIPE_WRITE]);
execv(argv[0], argv); execv(argv[0], argv);

View File

@ -4,7 +4,7 @@ Subject: [PATCH] Add pkgconfig entry
diff --git a/Makefile.am b/Makefile.am diff --git a/Makefile.am b/Makefile.am
index c60d873..40a6e4d 100644 index d813784..a2f6017 100644
--- a/Makefile.am --- a/Makefile.am
+++ b/Makefile.am +++ b/Makefile.am
@@ -53,6 +53,9 @@ EXTRA_PROGRAMS = wireshark wireshark-qt tshark tfshark capinfos captype editcap @@ -53,6 +53,9 @@ EXTRA_PROGRAMS = wireshark wireshark-qt tshark tfshark capinfos captype editcap
@ -18,10 +18,10 @@ index c60d873..40a6e4d 100644
# Wireshark configuration files are put in $(pkgdatadir). # Wireshark configuration files are put in $(pkgdatadir).
# #
diff --git a/configure.ac b/configure.ac diff --git a/configure.ac b/configure.ac
index 20eb3b3..8c9b79c 100644 index baa47eb..6ea3c7b 100644
--- a/configure.ac --- a/configure.ac
+++ b/configure.ac +++ b/configure.ac
@@ -2779,6 +2779,7 @@ AC_CONFIG_HEADERS(config.h) @@ -2890,6 +2890,7 @@ AC_CONFIG_HEADERS(config.h)
AC_OUTPUT( AC_OUTPUT(
Makefile Makefile
doxygen.cfg doxygen.cfg

View File

@ -4,7 +4,7 @@ Subject: [PATCH] Install autoconf-related file
diff --git a/Makefile.am b/Makefile.am diff --git a/Makefile.am b/Makefile.am
index 40a6e4d..82f7fdf 100644 index a2f6017..a126b06 100644
--- a/Makefile.am --- a/Makefile.am
+++ b/Makefile.am +++ b/Makefile.am
@@ -56,6 +56,9 @@ EXTRA_PROGRAMS = wireshark wireshark-qt tshark tfshark capinfos captype editcap @@ -56,6 +56,9 @@ EXTRA_PROGRAMS = wireshark wireshark-qt tshark tfshark capinfos captype editcap

View File

@ -32,7 +32,7 @@ index 6de7daa..a644615 100644
for (i = 0; i < PH_CONF_DIRS; i++) { for (i = 0; i < PH_CONF_DIRS; i++) {
diff --git a/wsutil/Makefile.common b/wsutil/Makefile.common diff --git a/wsutil/Makefile.common b/wsutil/Makefile.common
index 75c31bd..81648a7 100644 index 0f8075b..8eddff4 100644
--- a/wsutil/Makefile.common --- a/wsutil/Makefile.common
+++ b/wsutil/Makefile.common +++ b/wsutil/Makefile.common
@@ -62,7 +62,8 @@ LIBWSUTIL_SRC = \ @@ -62,7 +62,8 @@ LIBWSUTIL_SRC = \

View File

@ -20,11 +20,11 @@
Summary: Network traffic analyzer Summary: Network traffic analyzer
Name: wireshark Name: wireshark
Version: 1.12.8 Version: 1.12.9
Release: 2%{?dist} Release: 1%{?dist}
License: GPL+ License: GPL+
Group: Applications/Internet Group: Applications/Internet
Source0: http://wireshark.org/download/src/%{name}-%{version}.tar.bz2 Source0: https://wireshark.org/download/src/%{name}-%{version}.tar.bz2
Source1: 90-wireshark-usbmon.rules Source1: 90-wireshark-usbmon.rules
# Fedora-specific # Fedora-specific
Patch1: wireshark-0001-enable-Lua-support.patch Patch1: wireshark-0001-enable-Lua-support.patch
@ -49,7 +49,7 @@ Patch10: wireshark-0010-Allow-redefining-all-ports-for-RADIUS.patch
# Fedora-specific, see https://bugzilla.redhat.com/1274831 # Fedora-specific, see https://bugzilla.redhat.com/1274831
Patch11: wireshark-0011-Patch-fixing-the-wireshark-autoconf-macros.patch Patch11: wireshark-0011-Patch-fixing-the-wireshark-autoconf-macros.patch
Url: http://www.wireshark.org/ Url: https://www.wireshark.org/
BuildRequires: libpcap-devel >= 0.9 BuildRequires: libpcap-devel >= 0.9
BuildRequires: libsmi-devel BuildRequires: libsmi-devel
BuildRequires: zlib-devel, bzip2-devel BuildRequires: zlib-devel, bzip2-devel
@ -149,23 +149,6 @@ and plugins.
%patch3 -p1 -b .profinet_crash %patch3 -p1 -b .profinet_crash
%patch4 -p1 -b .add_autoconf %patch4 -p1 -b .add_autoconf
%patch5 -p1 -b .restore_group %patch5 -p1 -b .restore_group
# Somebody forgot to add this file into tarball (fixed in wireshark-1.12.1)
echo "prefix=@CMAKE_INSTALL_PREFIX@
exec_prefix=\${prefix}
libdir=\${prefix}/@CMAKE_INSTALL_LIBDIR@
sharedlibdir=\${libdir}
includedir=\${prefix}/include/wireshark
plugindir=@PLUGIN_INSTALL_DIR@
Name: wireshark
Description: wireshark network packet dissection library
Version: @PROJECT_VERSION@
Requires:
Libs: -L\${libdir} -L\${sharedlibdir} -lwireshark
Cflags: -I\${includedir}" > wireshark.pc.in
%patch6 -p1 -b .add_pkgconfig %patch6 -p1 -b .add_pkgconfig
%patch7 -p1 -b .install_autoconf %patch7 -p1 -b .install_autoconf
%patch8 -p1 -b .tmp_dir %patch8 -p1 -b .tmp_dir
@ -299,7 +282,7 @@ SentUpstream: 2014-09-18
<screenshot type="default">https://raw.githubusercontent.com/hughsie/fedora-appstream/master/screenshots-extra/wireshark/a.png</screenshot> <screenshot type="default">https://raw.githubusercontent.com/hughsie/fedora-appstream/master/screenshots-extra/wireshark/a.png</screenshot>
<screenshot>https://raw.githubusercontent.com/hughsie/fedora-appstream/master/screenshots-extra/wireshark/b.png</screenshot> <screenshot>https://raw.githubusercontent.com/hughsie/fedora-appstream/master/screenshots-extra/wireshark/b.png</screenshot>
</screenshots> </screenshots>
<updatecontact>http://www.wireshark.org/lists/</updatecontact> <updatecontact>https://www.wireshark.org/lists/</updatecontact>
</application> </application>
EOF EOF
@ -412,6 +395,10 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
%{_datadir}/aclocal/* %{_datadir}/aclocal/*
%changelog %changelog
* Fri Jan 8 2016 Peter Lemenkov <lemenkov@gmail.com> - 1.12.9-1
- Ver. 1.12.9
- See https://www.wireshark.org/docs/relnotes/wireshark-1.12.9.html
* Tue Nov 3 2015 Peter Lemenkov <lemenkov@gmail.com> - 1.12.8-2 * Tue Nov 3 2015 Peter Lemenkov <lemenkov@gmail.com> - 1.12.8-2
- Fixed Wireshark detection in external projects using wireshark.m4 script. - Fixed Wireshark detection in external projects using wireshark.m4 script.
See https://bugzilla.redhat.com/1274831 for further details. See https://bugzilla.redhat.com/1274831 for further details.
@ -646,7 +633,7 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Mon Jun 17 2013 Peter Hatina <phatina@redhat.com> 1.10.0-1 * Mon Jun 17 2013 Peter Hatina <phatina@redhat.com> 1.10.0-1
- upgrade to 1.10.0 - upgrade to 1.10.0
- see http://www.wireshark.org/docs/relnotes/wireshark-1.10.0.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.10.0.html
* Mon Apr 08 2013 Peter Hatina <phatina@redhat.com> 1.8.6-5 * Mon Apr 08 2013 Peter Hatina <phatina@redhat.com> 1.8.6-5
- fix documentation build error - fix documentation build error
@ -662,7 +649,7 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Tue Mar 12 2013 Peter Hatina <phatina@redhat.com> 1.8.6-1 * Tue Mar 12 2013 Peter Hatina <phatina@redhat.com> 1.8.6-1
- upgrade to 1.8.6 - upgrade to 1.8.6
- see http://www.wireshark.org/docs/relnotes/wireshark-1.8.6.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.8.6.html
* Sun Feb 10 2013 Parag Nemade <paragn AT fedoraproject DOT org> - 1.8.5-3 * Sun Feb 10 2013 Parag Nemade <paragn AT fedoraproject DOT org> - 1.8.5-3
- Remove vendor tag from desktop file as per https://fedorahosted.org/fesco/ticket/1077 - Remove vendor tag from desktop file as per https://fedorahosted.org/fesco/ticket/1077
@ -673,11 +660,11 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Thu Jan 31 2013 Peter Hatina <phatina@redhat.com> - 1.8.5-1 * Thu Jan 31 2013 Peter Hatina <phatina@redhat.com> - 1.8.5-1
- upgrade to 1.8.5 - upgrade to 1.8.5
- see http://www.wireshark.org/docs/relnotes/wireshark-1.8.5.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.8.5.html
* Mon Dec 03 2012 Peter Hatina <phatina@redhat.com> - 1.8.4-1 * Mon Dec 03 2012 Peter Hatina <phatina@redhat.com> - 1.8.4-1
- upgrade to 1.8.4 - upgrade to 1.8.4
- see http://www.wireshark.org/docs/relnotes/wireshark-1.8.4.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.8.4.html
* Tue Oct 16 2012 Peter Hatina <phatina@redhat.com> - 1.8.3-2 * Tue Oct 16 2012 Peter Hatina <phatina@redhat.com> - 1.8.3-2
- backport dissector table fix - backport dissector table fix
@ -685,7 +672,7 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Thu Oct 11 2012 Peter Hatina <phatina@redhat.com> - 1.8.3-1 * Thu Oct 11 2012 Peter Hatina <phatina@redhat.com> - 1.8.3-1
- upgrade to 1.8.3 - upgrade to 1.8.3
- see http://www.wireshark.org/docs/relnotes/wireshark-1.8.3.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.8.3.html
* Tue Sep 4 2012 Jan Safranek <jsafrane@redhat.com> - 1.8.2-3 * Tue Sep 4 2012 Jan Safranek <jsafrane@redhat.com> - 1.8.2-3
- added back compatibility with RHEL6 - added back compatibility with RHEL6
@ -697,33 +684,33 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Thu Aug 16 2012 Jan Safranek <jsafrane@redhat.com> - 1.8.2-1 * Thu Aug 16 2012 Jan Safranek <jsafrane@redhat.com> - 1.8.2-1
- upgrade to 1.8.2 - upgrade to 1.8.2
- see http://www.wireshark.org/docs/relnotes/wireshark-1.8.2.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.8.2.html
* Fri Jul 27 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-2 * Fri Jul 27 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Tue Jul 24 2012 Jan Safranek <jsafrane@redhat.com> - 1.8.1-1 * Tue Jul 24 2012 Jan Safranek <jsafrane@redhat.com> - 1.8.1-1
- upgrade to 1.8.1 - upgrade to 1.8.1
- see http://www.wireshark.org/docs/relnotes/wireshark-1.8.1.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.8.1.html
* Mon Jun 25 2012 Jan Safranek <jsafrane@redhat.com> - 1.8.0 * Mon Jun 25 2012 Jan Safranek <jsafrane@redhat.com> - 1.8.0
- upgrade to 1.8.0 - upgrade to 1.8.0
- see http://www.wireshark.org/docs/relnotes/wireshark-1.8.0.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.8.0.html
* Wed May 23 2012 Jan Safranek <jsafrane@redhat.com> - 1.6.8-1 * Wed May 23 2012 Jan Safranek <jsafrane@redhat.com> - 1.6.8-1
- upgrade to 1.6.8 - upgrade to 1.6.8
- see http://www.wireshark.org/docs/relnotes/wireshark-1.6.8.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.6.8.html
* Mon May 21 2012 Jan Safranek <jsafrane@redhat.com> - 1.6.7-2 * Mon May 21 2012 Jan Safranek <jsafrane@redhat.com> - 1.6.7-2
- Removed dependency on GeoIP on RHEL. - Removed dependency on GeoIP on RHEL.
* Tue Apr 10 2012 Jan Safranek <jsafrane@redhat.com> - 1.6.7-1 * Tue Apr 10 2012 Jan Safranek <jsafrane@redhat.com> - 1.6.7-1
- upgrade to 1.6.7 - upgrade to 1.6.7
- see http://www.wireshark.org/docs/relnotes/wireshark-1.6.7.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.6.7.html
* Wed Mar 28 2012 Jan Safranek <jsafrane@redhat.com> - 1.6.6-1 * Wed Mar 28 2012 Jan Safranek <jsafrane@redhat.com> - 1.6.6-1
- upgrade to 1.6.6 - upgrade to 1.6.6
- see http://www.wireshark.org/docs/relnotes/wireshark-1.6.6.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.6.6.html
* Fri Mar 9 2012 Jan Safranek <jsafrane@redhat.com> - 1.6.5-2 * Fri Mar 9 2012 Jan Safranek <jsafrane@redhat.com> - 1.6.5-2
- fixed wireshark crashing when using combo box in import dialog (#773290) - fixed wireshark crashing when using combo box in import dialog (#773290)
@ -731,11 +718,11 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Wed Jan 11 2012 Jan Safranek <jsafrane@redhat.com> - 1.6.5-1 * Wed Jan 11 2012 Jan Safranek <jsafrane@redhat.com> - 1.6.5-1
- upgrade to 1.6.5 - upgrade to 1.6.5
- see http://www.wireshark.org/docs/relnotes/wireshark-1.6.5.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.6.5.html
* Fri Dec 2 2011 Jan Safranek <jsafrane@redhat.com> - 1.6.4-1 * Fri Dec 2 2011 Jan Safranek <jsafrane@redhat.com> - 1.6.4-1
- upgrade to 1.6.4 - upgrade to 1.6.4
- see http://www.wireshark.org/docs/relnotes/wireshark-1.6.4.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.6.4.html
- build with c-ares and libpcap (#759305) - build with c-ares and libpcap (#759305)
- fixed display of error message boxes on startup in gnome3 (#752559) - fixed display of error message boxes on startup in gnome3 (#752559)
@ -745,7 +732,7 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Wed Nov 2 2011 Jan Safranek <jsafrane@redhat.com> - 1.6.3-1 * Wed Nov 2 2011 Jan Safranek <jsafrane@redhat.com> - 1.6.3-1
- upgrade to 1.6.3 - upgrade to 1.6.3
- see http://www.wireshark.org/docs/relnotes/wireshark-1.6.3.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.6.3.html
* Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.2-5 * Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.2-5
- Rebuilt for glibc bug#747377 - Rebuilt for glibc bug#747377
@ -764,12 +751,12 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Fri Sep 9 2011 Jan Safranek <jsafrane@redhat.com> - 1.6.2-1 * Fri Sep 9 2011 Jan Safranek <jsafrane@redhat.com> - 1.6.2-1
- upgrade to 1.6.2 - upgrade to 1.6.2
- see http://www.wireshark.org/docs/relnotes/wireshark-1.6.2.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.6.2.html
* Thu Jul 21 2011 Jan Safranek <jsafrane@redhat.com> - 1.6.1-1 * Thu Jul 21 2011 Jan Safranek <jsafrane@redhat.com> - 1.6.1-1
- upgrade to 1.6.1 - upgrade to 1.6.1
- see http://www.wireshark.org/docs/relnotes/wireshark-1.6.1.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.6.1.html
* Thu Jun 16 2011 Jan Safranek <jsafrane@redhat.com> - 1.6.0-4 * Thu Jun 16 2011 Jan Safranek <jsafrane@redhat.com> - 1.6.0-4
- fixed previous incomplete fix - fixed previous incomplete fix
@ -787,11 +774,11 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Wed Jun 8 2011 Jan Safranek <jsafrane@redhat.com> - 1.6.0-1 * Wed Jun 8 2011 Jan Safranek <jsafrane@redhat.com> - 1.6.0-1
- upgrade to 1.6.0 - upgrade to 1.6.0
- see http://www.wireshark.org/docs/relnotes/wireshark-1.6.0.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.6.0.html
* Thu Jun 2 2011 Jan Safranek <jsafrane@redhat.com> - 1.4.7-1 * Thu Jun 2 2011 Jan Safranek <jsafrane@redhat.com> - 1.4.7-1
- upgrade to 1.4.7 - upgrade to 1.4.7
- see http://www.wireshark.org/docs/relnotes/wireshark-1.4.7.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.4.7.html
* Thu May 19 2011 Steve Dickson <steved@redhat.com> - 1.4.6-3 * Thu May 19 2011 Steve Dickson <steved@redhat.com> - 1.4.6-3
- Improved the NFS4.1 patcket dissectors - Improved the NFS4.1 patcket dissectors
@ -801,18 +788,18 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Tue Apr 19 2011 Jan Safranek <jsafrane@redhat.com> - 1.4.6-1 * Tue Apr 19 2011 Jan Safranek <jsafrane@redhat.com> - 1.4.6-1
- upgrade to 1.4.6 - upgrade to 1.4.6
- see http://www.wireshark.org/docs/relnotes/wireshark-1.4.6.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.4.6.html
* Mon Apr 18 2011 Jan Safranek <jsafrane@redhat.com> - 1.4.5-1 * Mon Apr 18 2011 Jan Safranek <jsafrane@redhat.com> - 1.4.5-1
- upgrade to 1.4.5 - upgrade to 1.4.5
- see http://www.wireshark.org/docs/relnotes/wireshark-1.4.5.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.4.5.html
* Sun Apr 03 2011 Cosimo Cecchi <cosimoc@redhat.com> - 1.4.4-2 * Sun Apr 03 2011 Cosimo Cecchi <cosimoc@redhat.com> - 1.4.4-2
- Use hi-res icons - Use hi-res icons
* Thu Mar 3 2011 Jan Safranek <jsafrane@redhat.com> - 1.4.4-1 * Thu Mar 3 2011 Jan Safranek <jsafrane@redhat.com> - 1.4.4-1
- upgrade to 1.4.4 - upgrade to 1.4.4
- see http://www.wireshark.org/docs/relnotes/wireshark-1.4.4.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.4.4.html
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3-3 * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
@ -823,7 +810,7 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Thu Jan 13 2011 Jan Safranek <jsafrane@redhat.com> - 1.4.3-1 * Thu Jan 13 2011 Jan Safranek <jsafrane@redhat.com> - 1.4.3-1
- upgrade to 1.4.3 - upgrade to 1.4.3
- see http://www.wireshark.org/docs/relnotes/wireshark-1.4.3.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.4.3.html
* Wed Jan 5 2011 Jan Safranek <jsafrane@redhat.com> - 1.4.2-5 * Wed Jan 5 2011 Jan Safranek <jsafrane@redhat.com> - 1.4.2-5
- fixed buffer overflow in ENTTEC dissector (#666897) - fixed buffer overflow in ENTTEC dissector (#666897)
@ -840,15 +827,15 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Mon Nov 22 2010 Jan Safranek <jsafrane@redhat.com> - 1.4.2-1 * Mon Nov 22 2010 Jan Safranek <jsafrane@redhat.com> - 1.4.2-1
- upgrade to 1.4.2 - upgrade to 1.4.2
- see http://www.wireshark.org/docs/relnotes/wireshark-1.4.2.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.4.2.html
* Mon Nov 1 2010 Jan Safranek <jsafrane@redhat.com> - 1.4.1-2 * Mon Nov 1 2010 Jan Safranek <jsafrane@redhat.com> - 1.4.1-2
- temporarily disable zlib until - temporarily disable zlib until
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=4955 is resolved (#643461) https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=4955 is resolved (#643461)
* Fri Oct 22 2010 Jan Safranek <jsafrane@redhat.com> - 1.4.1-1 * Fri Oct 22 2010 Jan Safranek <jsafrane@redhat.com> - 1.4.1-1
- upgrade to 1.4.1 - upgrade to 1.4.1
- see http://www.wireshark.org/docs/relnotes/wireshark-1.4.1.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.4.1.html
- Own the %%{_libdir}/wireshark dir (#644508) - Own the %%{_libdir}/wireshark dir (#644508)
- associate *.pcap files with wireshark (#641163) - associate *.pcap files with wireshark (#641163)
@ -860,11 +847,11 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Tue Aug 31 2010 Jan Safranek <jsafrane@redhat.com> - 1.4.0-1 * Tue Aug 31 2010 Jan Safranek <jsafrane@redhat.com> - 1.4.0-1
- upgrade to 1.4.0 - upgrade to 1.4.0
- see http://www.wireshark.org/docs/relnotes/wireshark-1.4.0.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.4.0.html
* Fri Jul 30 2010 Jan Safranek <jsafrane@redhat.com> - 1.2.10-1 * Fri Jul 30 2010 Jan Safranek <jsafrane@redhat.com> - 1.2.10-1
- upgrade to 1.2.10 - upgrade to 1.2.10
- see http://www.wireshark.org/docs/relnotes/wireshark-1.2.10.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.2.10.html
* Fri Jul 30 2010 Jan Safranek <jsafrane@redhat.com> - 1.2.9-4 * Fri Jul 30 2010 Jan Safranek <jsafrane@redhat.com> - 1.2.9-4
- Rebuilt again for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild - Rebuilt again for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
@ -877,7 +864,7 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Fri Jun 11 2010 Radek Vokal <rvokal@redhat.com> - 1.2.9-1 * Fri Jun 11 2010 Radek Vokal <rvokal@redhat.com> - 1.2.9-1
- upgrade to 1.2.9 - upgrade to 1.2.9
- see http://www.wireshark.org/docs/relnotes/wireshark-1.2.9.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.2.9.html
* Mon May 17 2010 Radek Vokal <rvokal@redhat.com> - 1.2.8-4 * Mon May 17 2010 Radek Vokal <rvokal@redhat.com> - 1.2.8-4
- removing traling bracket from python_sitearch (#592391) - removing traling bracket from python_sitearch (#592391)
@ -890,14 +877,14 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Thu May 6 2010 Radek Vokal <rvokal@redhat.com> - 1.2.8-1 * Thu May 6 2010 Radek Vokal <rvokal@redhat.com> - 1.2.8-1
- upgrade to 1.2.8 - upgrade to 1.2.8
- see http://www.wireshark.org/docs/relnotes/wireshark-1.2.8.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.2.8.html
* Tue Apr 6 2010 Radek Vokal <rvokal@redhat.com> - 1.2.7-2 * Tue Apr 6 2010 Radek Vokal <rvokal@redhat.com> - 1.2.7-2
- rebuild with GeoIP support (needs to be turned on in IP protocol preferences) - rebuild with GeoIP support (needs to be turned on in IP protocol preferences)
* Fri Apr 2 2010 Radek Vokal <rvokal@redhat.com> - 1.2.7-1 * Fri Apr 2 2010 Radek Vokal <rvokal@redhat.com> - 1.2.7-1
- upgrade to 1.2.7 - upgrade to 1.2.7
- see http://www.wireshark.org/docs/relnotes/wireshark-1.2.7.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.2.7.html
* Wed Mar 24 2010 Radek Vokal <rvokal@redhat.com> - 1.2.6-3 * Wed Mar 24 2010 Radek Vokal <rvokal@redhat.com> - 1.2.6-3
- bring back -pie - bring back -pie
@ -908,7 +895,7 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Fri Jan 29 2010 Radek Vokal <rvokal@redhat.com> - 1.2.6-1 * Fri Jan 29 2010 Radek Vokal <rvokal@redhat.com> - 1.2.6-1
- upgrade to 1.2.6 - upgrade to 1.2.6
- see http://www.wireshark.org/docs/relnotes/wireshark-1.2.6.html - see https://www.wireshark.org/docs/relnotes/wireshark-1.2.6.html
* Wed Jan 20 2010 Radek Vokal <rvokal@redhat.com> - 1.2.5-5 * Wed Jan 20 2010 Radek Vokal <rvokal@redhat.com> - 1.2.5-5
- minor spec file tweaks for better svn checkout support (#553500) - minor spec file tweaks for better svn checkout support (#553500)
@ -924,27 +911,27 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Fri Dec 18 2009 Radek Vokal <rvokal@redhat.com> - 1.2.5-1 * Fri Dec 18 2009 Radek Vokal <rvokal@redhat.com> - 1.2.5-1
- upgrade to 1.2.5 - upgrade to 1.2.5
- fixes security vulnaribilities, see http://www.wireshark.org/security/wnpa-sec-2009-09.html - fixes security vulnaribilities, see https://www.wireshark.org/security/wnpa-sec-2009-09.html
* Thu Dec 17 2009 Radek Vokal <rvokal@redhat.com> - 1.2.4-3 * Thu Dec 17 2009 Radek Vokal <rvokal@redhat.com> - 1.2.4-3
- split -devel package (#547899, #203642, #218451) - split -devel package (#547899, #203642, #218451)
- removing root warning dialog (#543709) - removing root warning dialog (#543709)
* Mon Dec 14 2009 Radek Vokal <rvokal@redhat.com> - 1.2.4-2 * Mon Dec 14 2009 Radek Vokal <rvokal@redhat.com> - 1.2.4-2
- enable lua support - http://wiki.wireshark.org/Lua - enable lua support - https://wiki.wireshark.org/Lua
- attempt to fix filter crash on 64bits - attempt to fix filter crash on 64bits
* Wed Nov 18 2009 Radek Vokal <rvokal@redhat.com> - 1.2.4-1 * Wed Nov 18 2009 Radek Vokal <rvokal@redhat.com> - 1.2.4-1
- upgrade to 1.2.4 - upgrade to 1.2.4
- http://www.wireshark.org/docs/relnotes/wireshark-1.2.4.html - https://www.wireshark.org/docs/relnotes/wireshark-1.2.4.html
* Fri Oct 30 2009 Radek Vokal <rvokal@redhat.com> - 1.2.3-1 * Fri Oct 30 2009 Radek Vokal <rvokal@redhat.com> - 1.2.3-1
- upgrade to 1.2.3 - upgrade to 1.2.3
- http://www.wireshark.org/docs/relnotes/wireshark-1.2.3.html - https://www.wireshark.org/docs/relnotes/wireshark-1.2.3.html
* Mon Sep 21 2009 Radek Vokal <rvokal@redhat.com> - 1.2.2-1 * Mon Sep 21 2009 Radek Vokal <rvokal@redhat.com> - 1.2.2-1
- upgrade to 1.2.2 - upgrade to 1.2.2
- http://www.wireshark.org/docs/relnotes/wireshark-1.2.2.html - https://www.wireshark.org/docs/relnotes/wireshark-1.2.2.html
* Mon Sep 14 2009 Bill Nottingham <notting@redhat.com> - 1.2.1-5 * Mon Sep 14 2009 Bill Nottingham <notting@redhat.com> - 1.2.1-5
- do not use portaudio in RHEL - do not use portaudio in RHEL
@ -960,11 +947,11 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Wed Jul 22 2009 Radek Vokal <rvokal@redhat.com> - 1.2.1 * Wed Jul 22 2009 Radek Vokal <rvokal@redhat.com> - 1.2.1
- upgrade to 1.2.1 - upgrade to 1.2.1
- http://www.wireshark.org/docs/relnotes/wireshark-1.2.1.html - https://www.wireshark.org/docs/relnotes/wireshark-1.2.1.html
* Tue Jun 16 2009 Radek Vokal <rvokal@redhat.com> - 1.2.0 * Tue Jun 16 2009 Radek Vokal <rvokal@redhat.com> - 1.2.0
- upgrade to 1.2.0 - upgrade to 1.2.0
- http://www.wireshark.org/docs/relnotes/wireshark-1.2.0.html - https://www.wireshark.org/docs/relnotes/wireshark-1.2.0.html
* Fri May 22 2009 Radek Vokal <rvokal@redhat.com> - 1.1.4-0.pre1 * Fri May 22 2009 Radek Vokal <rvokal@redhat.com> - 1.1.4-0.pre1
- update to latest development build - update to latest development build
@ -999,9 +986,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
* Wed Sep 10 2008 Radek Vokál <rvokal@redhat.com> 1.0.3-1 * Wed Sep 10 2008 Radek Vokál <rvokal@redhat.com> 1.0.3-1
- upgrade to 1.0.3 - upgrade to 1.0.3
- Security-related bugs in the NCP dissector, zlib compression code, and Tektronix .rf5 file parser have been fixed. - Security-related bugs in the NCP dissector, zlib compression code, and Tektronix .rf5 file parser have been fixed.
- WPA group key decryption is now supported. - WPA group key decryption is now supported.
- A bug that could cause packets to be wrongly dissected as "Redback Lawful Intercept" has been fixed. - A bug that could cause packets to be wrongly dissected as "Redback Lawful Intercept" has been fixed.
* Mon Aug 25 2008 Radek Vokál <rvokal@redhat.com> 1.0.2-3 * Mon Aug 25 2008 Radek Vokál <rvokal@redhat.com> 1.0.2-3
- fix requires for wireshark-gnome - fix requires for wireshark-gnome
@ -1016,7 +1003,7 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
- upgrade to 1.0.1 - upgrade to 1.0.1
* Sun Jun 29 2008 Dennis Gilmore <dennis@ausil.us> 1.0.0-3 * Sun Jun 29 2008 Dennis Gilmore <dennis@ausil.us> 1.0.0-3
- add sparc arches to -fPIE - add sparc arches to -fPIE
- rebuild for new gnutls - rebuild for new gnutls
* Tue Apr 1 2008 Radek Vokál <rvokal@redhat.com> 1.0.0-2 * Tue Apr 1 2008 Radek Vokál <rvokal@redhat.com> 1.0.0-2
@ -1075,7 +1062,7 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
- update to 0.99.5 prerelease - update to 0.99.5 prerelease
* Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.99.4-5 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.99.4-5
- rebuild for python 2.5 - rebuild for python 2.5
* Tue Nov 28 2006 Radek Vokal <rvokal@redhat.com> 0.99.4-4 * Tue Nov 28 2006 Radek Vokal <rvokal@redhat.com> 0.99.4-4
- rebuilt for new libpcap and net-snmp - rebuilt for new libpcap and net-snmp
@ -1084,7 +1071,7 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
- add htmlview to Buildrequires to be picked up by configure scripts (#216918) - add htmlview to Buildrequires to be picked up by configure scripts (#216918)
* Tue Nov 7 2006 Radek Vokal <rvokal@redhat.com> 0.99.4-2.fc7 * Tue Nov 7 2006 Radek Vokal <rvokal@redhat.com> 0.99.4-2.fc7
- Requires: net-snmp for the list of MIB modules - Requires: net-snmp for the list of MIB modules
* Wed Nov 1 2006 Radek Vokál <rvokal@redhat.com> 0.99.4-1 * Wed Nov 1 2006 Radek Vokál <rvokal@redhat.com> 0.99.4-1
- upgrade to 0.99.4 final - upgrade to 0.99.4 final
@ -1100,7 +1087,7 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
- Wireshark 0.99.3 fixes the following vulnerabilities: - Wireshark 0.99.3 fixes the following vulnerabilities:
- the SCSI dissector could crash. Versions affected: CVE-2006-4330 - the SCSI dissector could crash. Versions affected: CVE-2006-4330
- the IPsec ESP preference parser was susceptible to off-by-one errors. CVE-2006-4331 - the IPsec ESP preference parser was susceptible to off-by-one errors. CVE-2006-4331
- a malformed packet could make the Q.2931 dissector use up available memory. CVE-2006-4333 - a malformed packet could make the Q.2931 dissector use up available memory. CVE-2006-4333
* Tue Jul 18 2006 Radek Vokál <rvokal@redhat.com> 0.99.2-1 * Tue Jul 18 2006 Radek Vokál <rvokal@redhat.com> 0.99.2-1
- upgrade to 0.99.2 - upgrade to 0.99.2