Remove patch preventing install of regulatory.bin.5 man page

Include regulatory.bin.5 man page in distributed files
This commit is contained in:
John W. Linville 2019-08-28 16:00:35 -04:00
parent 71da626ceb
commit 10348fe72f
2 changed files with 9 additions and 45 deletions

View File

@ -1,38 +0,0 @@
diff -up wireless-regdb-2018.05.31/Makefile.install_db wireless-regdb-2018.05.31/Makefile
--- wireless-regdb-2018.05.31/Makefile.install_db 2018-07-05 15:17:03.698486949 -0400
+++ wireless-regdb-2018.05.31/Makefile 2018-07-05 15:20:33.537313703 -0400
@@ -41,7 +41,8 @@ REGDB_CHANGED = $(shell $(SHA1SUM) -c --
echo maintainer-clean $(REGDB_PUBKEY) $(REGDB_PUBCERT); \
fi)
-.PHONY: all clean mrproper install maintainer-clean install-distro-key
+.PHONY: all clean mrproper install maintainer-clean install-distro-key \
+ install_db install_bin
all: $(REGDB_CHANGED) regulatory.bin sha1sum.txt regulatory.db.p7s
@@ -115,15 +116,21 @@ install-distro-key: maintainer-clean $(D
# make maintainer-clean
# make
# sudo make install
-install: regulatory.bin.5.gz regulatory.db.5.gz
+install_bin: regulatory.bin.5.gz
install -m 755 -d $(DESTDIR)/$(CRDA_PATH)
install -m 755 -d $(DESTDIR)/$(CRDA_KEY_PATH)
- install -m 755 -d $(DESTDIR)/$(FIRMWARE_PATH)
if [ -f .custom ]; then \
install -m 644 -t $(DESTDIR)/$(CRDA_KEY_PATH)/ $(shell cat .custom); \
fi
install -m 644 -t $(DESTDIR)/$(CRDA_KEY_PATH)/ $(REGDB_UPSTREAM_PUBKEY)
install -m 644 -t $(DESTDIR)/$(CRDA_PATH)/ regulatory.bin
+ install -m 755 -d $(DESTDIR)/$(MANDIR)/man5/
+ install -m 644 -t $(DESTDIR)/$(MANDIR)/man5/ regulatory.bin.5.gz
+
+install_db: regulatory.db.5.gz
+ install -m 755 -d $(DESTDIR)/$(FIRMWARE_PATH)
install -m 644 -t $(DESTDIR)/$(FIRMWARE_PATH) regulatory.db regulatory.db.p7s
install -m 755 -d $(DESTDIR)/$(MANDIR)/man5/
- install -m 644 -t $(DESTDIR)/$(MANDIR)/man5/ regulatory.bin.5.gz regulatory.db.5.gz
+ install -m 644 -t $(DESTDIR)/$(MANDIR)/man5/ regulatory.db.5.gz
+
+install: install_bin install_db

View File

@ -2,7 +2,7 @@
Name: wireless-regdb
Version: 2019.06.03
Release: 4%{?dist}
Release: 5%{?dist}
Summary: Regulatory database for 802.11 wireless networking
License: ISC
@ -22,9 +22,6 @@ Source1: setregdomain
Source2: setregdomain.1
Source3: 85-regulatory.rules
# Split existing install rule into separate install_bin and install_db rules
Patch0: wireless-regdb-install_db.patch
%description
The wireless-regdb package provides the regulatory rules database
@ -35,21 +32,21 @@ with radio frequency regulatory rules around the world.
%prep
%setup -q
%patch0 -p1 -b .install_db
%build
: # Package installs a firmware-like, prebuilt binary from upstream...
%install
make install_db DESTDIR=%{buildroot} MANDIR=%{_mandir} \
make install DESTDIR=%{buildroot} MANDIR=%{_mandir} \
FIRMWARE_PATH=%{_firmwarepath}
install -D -pm 0755 %SOURCE1 %{buildroot}%{_sbindir}/setregdomain
install -D -pm 0644 %SOURCE2 %{buildroot}%{_mandir}/man1/setregdomain.1
install -D -pm 0644 %SOURCE3 %{buildroot}%{_udevrulesdir}/85-regulatory.rules
rm -rf %{buildroot}/usr/lib/crda
%files
%{_sbindir}/setregdomain
@ -58,11 +55,16 @@ install -D -pm 0644 %SOURCE3 %{buildroot}%{_udevrulesdir}/85-regulatory.rules
%{_firmwarepath}/regulatory.db.p7s
%{_mandir}/man1/setregdomain.1*
%{_mandir}/man5/regulatory.db.5*
%{_mandir}/man5/regulatory.bin.5*
%license LICENSE
%doc README
%changelog
* Wed Aug 28 2019 John W. Linville <linville@redhat.com> - 2019.06.03-5
- Remove patch preventing install of regulatory.bin.5 man page
- Include regulatory.bin.5 man page in distributed files
* Mon Aug 26 2019 John W. Linville <linville@redhat.com> - 2019.06.03-4
- Bump crda Provides and Obsoletes to ensure proper upgrades