update to 2.21
This commit is contained in:
parent
9764fdea91
commit
5c082f8e2c
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ which-2.16.tar.gz
|
||||
which-2.18.tar.gz
|
||||
which-2.19.tar.gz
|
||||
/which-2.20.tar.gz
|
||||
/which-2.21.tar.gz
|
||||
|
1
sources
1
sources
@ -1 +1,2 @@
|
||||
95be0501a466e515422cde4af46b2744 which-2.20.tar.gz
|
||||
097ff1a324ae02e0a3b0369f07a7544a which-2.21.tar.gz
|
||||
|
@ -1,41 +0,0 @@
|
||||
diff -up which-2.19/bash.c.afs which-2.19/bash.c
|
||||
--- which-2.19/bash.c.afs 2008-01-18 19:03:40.000000000 +0100
|
||||
+++ which-2.19/bash.c 2008-01-25 11:41:14.000000000 +0100
|
||||
@@ -34,7 +34,6 @@
|
||||
*/
|
||||
#define HAVE_GETGROUPS
|
||||
#undef SHELL
|
||||
-#undef AFS
|
||||
#undef NOGROUP
|
||||
|
||||
/*
|
||||
@@ -251,7 +250,7 @@ file_status (char const* name)
|
||||
|
||||
r = FS_EXISTS;
|
||||
|
||||
-#if defined (AFS)
|
||||
+ if (getenv("AFS")) {
|
||||
/* We have to use access(2) to determine access because AFS does not
|
||||
support Unix file system semantics. This may produce wrong
|
||||
answers for non-AFS files when ruid != euid. I hate AFS. */
|
||||
@@ -261,8 +260,9 @@ file_status (char const* name)
|
||||
r |= FS_READABLE;
|
||||
|
||||
return r;
|
||||
-#else /* !AFS */
|
||||
-
|
||||
+ }
|
||||
+ else /* !AFS */
|
||||
+ {
|
||||
/* Find out if the file is actually executable. By definition, the
|
||||
only other criteria is that the file has an execute bit set that
|
||||
we can use. The same with whether or not a file is readable. */
|
||||
@@ -305,7 +305,7 @@ file_status (char const* name)
|
||||
}
|
||||
|
||||
return r;
|
||||
-#endif /* !AFS */
|
||||
+ } /* !AFS */
|
||||
}
|
||||
|
||||
/* From bash-3.2 / general.c / line 534 ; Changes: Using 'strchr' instead of 'xstrchr'. */
|
10
which.spec
10
which.spec
@ -1,14 +1,13 @@
|
||||
Summary: Displays where a particular program in your path is located
|
||||
Name: which
|
||||
Version: 2.20
|
||||
Release: 13%{?dist}
|
||||
Version: 2.21
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3
|
||||
Group: Applications/System
|
||||
Source0: http://ftp.gnu.org/gnu/which/%{name}-%{version}.tar.gz
|
||||
Source1: which2.sh
|
||||
Source2: which2.csh
|
||||
Url: https://savannah.gnu.org/projects/which/
|
||||
Patch: which-2.19-afs.patch
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: readline-devel
|
||||
Requires(preun): /sbin/install-info
|
||||
@ -21,8 +20,6 @@ the specified program is in your PATH.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch -p1 -b .afs
|
||||
|
||||
%build
|
||||
%configure
|
||||
|
||||
@ -60,6 +57,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/*/*
|
||||
|
||||
%changelog
|
||||
* Mon Jun 27 2016 Than Ngo <than@redhat.com> - 2.21-1
|
||||
- update to 2.21
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.20-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
|
@ -1,5 +1,3 @@
|
||||
# Initialization script for csh
|
||||
|
||||
# export AFS if you are in AFS environment
|
||||
|
||||
# alias which 'alias | /usr/bin/which --tty-only --read-alias --show-dot --show-tilde'
|
||||
|
Loading…
Reference in New Issue
Block a user