update to 1.16.2
Signed-off-by: Tomas Hozza <thozza@redhat.com>
This commit is contained in:
parent
613f7f49ad
commit
bdee7caf1f
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@ wget-1.12.tar.bz2
|
|||||||
/wget-1.15.tar.xz
|
/wget-1.15.tar.xz
|
||||||
/wget-1.16.tar.xz
|
/wget-1.16.tar.xz
|
||||||
/wget-1.16.1.tar.xz
|
/wget-1.16.1.tar.xz
|
||||||
|
/wget-1.16.2.tar.xz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
78942cc0cce0a23e18114d982789e360 wget-1.16.1.tar.xz
|
50b67a11971ecc6d142e634e8436fc0f wget-1.16.2.tar.xz
|
||||||
|
@ -1,31 +0,0 @@
|
|||||||
From 5e3a76073157510b1040578e70cb1234759a730f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tim Ruehsen <tim.ruehsen@gmx.de>
|
|
||||||
Date: Sun, 4 Jan 2015 20:50:11 +0100
|
|
||||||
Subject: [PATCH] src/ftp-basic.c: Accept 5-digit port numbers in EPSV
|
|
||||||
responses
|
|
||||||
|
|
||||||
Reported-by: Adam Sampson <ats@offog.org>
|
|
||||||
---
|
|
||||||
src/ftp-basic.c | 6 ------
|
|
||||||
1 file changed, 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/ftp-basic.c b/src/ftp-basic.c
|
|
||||||
index f9b9ad2..fdd6114 100644
|
|
||||||
--- a/src/ftp-basic.c
|
|
||||||
+++ b/src/ftp-basic.c
|
|
||||||
@@ -788,12 +788,6 @@ ftp_epsv (int csock, ip_address *ip, int *port)
|
|
||||||
for (tport = 0, i = 0; i < 5 && c_isdigit (*s); i++, s++)
|
|
||||||
tport = (*s - '0') + 10 * tport;
|
|
||||||
|
|
||||||
- if (i >= 5)
|
|
||||||
- {
|
|
||||||
- xfree (respline);
|
|
||||||
- return FTPINVPASV;
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
/* Make sure that the response terminates correcty */
|
|
||||||
if (*s++ != delim)
|
|
||||||
{
|
|
||||||
--
|
|
||||||
2.1.0
|
|
||||||
|
|
@ -1,32 +0,0 @@
|
|||||||
From 26790c3583b0588d21aa47603f441ee75937a2e1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Cong Ma <cma@pmo.ac.cn>
|
|
||||||
Date: Mon, 15 Dec 2014 21:21:10 +0800
|
|
||||||
Subject: [PATCH] ftp: fix invalid pointer dereference in getftp() (tiny change)
|
|
||||||
|
|
||||||
---
|
|
||||||
src/ftp.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/ftp.c b/src/ftp.c
|
|
||||||
index a3b2cb6..34c3858 100644
|
|
||||||
--- a/src/ftp.c
|
|
||||||
+++ b/src/ftp.c
|
|
||||||
@@ -1350,7 +1350,6 @@ Error in server response, closing control connection.\n"));
|
|
||||||
|
|
||||||
/* Get the server to tell us if everything is retrieved. */
|
|
||||||
err = ftp_response (csock, &respline);
|
|
||||||
- *last_expected_bytes = ftp_expected_bytes (respline);
|
|
||||||
if (err != FTPOK)
|
|
||||||
{
|
|
||||||
/* The control connection is decidedly closed. Print the time
|
|
||||||
@@ -1366,6 +1365,7 @@ Error in server response, closing control connection.\n"));
|
|
||||||
con->csock = -1;
|
|
||||||
return FTPRETRINT;
|
|
||||||
} /* err != FTPOK */
|
|
||||||
+ *last_expected_bytes = ftp_expected_bytes (respline);
|
|
||||||
/* If retrieval failed for any reason, return FTPRETRINT, but do not
|
|
||||||
close socket, since the control connection is still alive. If
|
|
||||||
there is something wrong with the control connection, it will
|
|
||||||
--
|
|
||||||
libgit2 0.21.0
|
|
||||||
|
|
@ -3,9 +3,9 @@
|
|||||||
@@ -561,7 +561,7 @@
|
@@ -561,7 +561,7 @@
|
||||||
PACKAGE_NAME='wget'
|
PACKAGE_NAME='wget'
|
||||||
PACKAGE_TARNAME='wget'
|
PACKAGE_TARNAME='wget'
|
||||||
PACKAGE_VERSION='1.16.1'
|
PACKAGE_VERSION='1.16.2'
|
||||||
-PACKAGE_STRING='wget 1.16.1'
|
-PACKAGE_STRING='wget 1.16.2'
|
||||||
+PACKAGE_STRING='wget 1.16.1 (Red Hat modified)'
|
+PACKAGE_STRING='wget 1.16.2 (Red Hat modified)'
|
||||||
PACKAGE_BUGREPORT='bug-wget@gnu.org'
|
PACKAGE_BUGREPORT='bug-wget@gnu.org'
|
||||||
PACKAGE_URL=''
|
PACKAGE_URL=''
|
||||||
|
|
||||||
|
15
wget.spec
15
wget.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A utility for retrieving files using the HTTP or FTP protocols
|
Summary: A utility for retrieving files using the HTTP or FTP protocols
|
||||||
Name: wget
|
Name: wget
|
||||||
Version: 1.16.1
|
Version: 1.16.2
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
Url: http://www.gnu.org/software/wget/
|
Url: http://www.gnu.org/software/wget/
|
||||||
@ -10,8 +10,6 @@ Source: ftp://ftp.gnu.org/gnu/wget/wget-%{version}.tar.xz
|
|||||||
Patch1: wget-rh-modified.patch
|
Patch1: wget-rh-modified.patch
|
||||||
Patch2: wget-1.16.1-path.patch
|
Patch2: wget-1.16.1-path.patch
|
||||||
Patch3: wget-1.16-dont-run-failing-test.patch
|
Patch3: wget-1.16-dont-run-failing-test.patch
|
||||||
Patch4: wget-1.16.1-fix-ftp-crash.patch
|
|
||||||
Patch5: wget-1.16.1-5-digit-port-ftp-epsv-ipv6.patch
|
|
||||||
|
|
||||||
Provides: webclient
|
Provides: webclient
|
||||||
Provides: bundled(gnulib)
|
Provides: bundled(gnulib)
|
||||||
@ -36,10 +34,8 @@ support for Proxy servers, and configurability.
|
|||||||
%patch1 -p0 -b .rh_modified
|
%patch1 -p0 -b .rh_modified
|
||||||
%patch2 -p1 -b .path
|
%patch2 -p1 -b .path
|
||||||
# don't run the Test-proxied-https-auth.px test since it fails with OpenSSL
|
# don't run the Test-proxied-https-auth.px test since it fails with OpenSSL
|
||||||
# upstream is working on fix and will be fixed most probably in 1.16.1
|
# upstream is working on fix
|
||||||
%patch3 -p1 -b .test
|
%patch3 -p1 -b .test
|
||||||
%patch4 -p1 -b .ftp_crash
|
|
||||||
%patch5 -p1 -b .5_digit_port
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
if pkg-config openssl ; then
|
if pkg-config openssl ; then
|
||||||
@ -89,9 +85,8 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_infodir}/*
|
%{_infodir}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 1.16.1-4
|
* Wed Mar 04 2015 Tomas Hozza <thozza@redhat.com> - 1.16.2-1
|
||||||
- Rebuilt for Fedora 23 Change
|
- update to 1.16.2
|
||||||
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
|
|
||||||
|
|
||||||
* Mon Jan 12 2015 Tomas Hozza <thozza@redhat.com> - 1.16.1-3
|
* Mon Jan 12 2015 Tomas Hozza <thozza@redhat.com> - 1.16.1-3
|
||||||
- Fix wget to accept 5 digit port numbers in epsv responses over ipv6 (#1180777)
|
- Fix wget to accept 5 digit port numbers in epsv responses over ipv6 (#1180777)
|
||||||
|
Loading…
Reference in New Issue
Block a user