Update to 1.21.1
This commit is contained in:
parent
313e60c80c
commit
98c1199c2b
1
.gitignore
vendored
1
.gitignore
vendored
@ -18,3 +18,4 @@ wget-1.12.tar.bz2
|
||||
/wget-1.20.tar.gz
|
||||
/wget-1.20.1.tar.gz
|
||||
/wget-1.20.3.tar.gz
|
||||
/wget-1.21.1.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (wget-1.20.3.tar.gz) = e8b82b40e270296228094a78d47f81580bdbdea9e6b93fd61b37dccb39430aeb9bda5397dc53a31c952a61629383c7e2a8c8abf414c8a4dd369af6ecf2717e6c
|
||||
SHA512 (wget-1.21.1.tar.gz) = 784efbf9fe43a1671109e32a9c36237eb2d5c19cf756bf6f6e65517fb21464d3d94b1d6f491852d23b3ddff63e38fe6b60df9125c91b139993af59875e3a0712
|
||||
|
@ -1,34 +0,0 @@
|
||||
From 04b7369490344d014b05dee5d48ca78cd04733ce Mon Sep 17 00:00:00 2001
|
||||
From: Tim Rühsen <tim.ruehsen@gmx.de>
|
||||
Date: Sat, 22 Feb 2020 13:40:50 +0100
|
||||
Subject: [PATCH] * tests/unit-tests.c: Fix 'multiple definition of...' with gcc 10
|
||||
|
||||
---
|
||||
tests/unit-tests.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tests/unit-tests.c b/tests/unit-tests.c
|
||||
index 5fae8a2..f66e5e6 100644
|
||||
--- a/tests/unit-tests.c
|
||||
+++ b/tests/unit-tests.c
|
||||
@@ -37,7 +37,7 @@ as that of the covered work. */
|
||||
|
||||
#include "unit-tests.h"
|
||||
|
||||
-const char *program_argstring = "TEST";
|
||||
+extern const char *program_argstring;
|
||||
|
||||
static int tests_run;
|
||||
|
||||
@@ -69,7 +69,7 @@ all_tests(void)
|
||||
return NULL;
|
||||
}
|
||||
|
||||
-const char *program_name; /* Needed by lib/error.c. */
|
||||
+extern const char *program_name; /* Needed by lib/error.c. */
|
||||
|
||||
int
|
||||
main (int argc _GL_UNUSED, const char *argv[])
|
||||
--
|
||||
libgit2 0.28.2
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff --git a/src/ftp.c b/src/ftp.c
|
||||
index 03d7deb..94dc55f 100644
|
||||
--- a/src/ftp.c
|
||||
+++ b/src/ftp.c
|
||||
@@ -1974,6 +1974,7 @@ ftp_loop_internal (struct url *u, struct url *original_url, struct fileinfo *f,
|
||||
case HOSTERR: case CONIMPOSSIBLE: case FWRITEERR: case FOPENERR:
|
||||
case FTPNSFOD: case FTPLOGINC: case FTPNOPASV: case FTPNOAUTH: case FTPNOPBSZ: case FTPNOPROT:
|
||||
case UNLINKERR: case WARC_TMP_FWRITEERR: case CONSSLERR: case CONTNOTSUPPORTED:
|
||||
+ case VERIFCERTERR:
|
||||
#ifdef HAVE_SSL
|
||||
if (err == FTPNOAUTH)
|
||||
logputs (LOG_NOTQUIET, "Server does not support AUTH TLS.\n");
|
@ -1,52 +0,0 @@
|
||||
From 706e71564cadc7192ac21efbf51b661c967f35b5 Mon Sep 17 00:00:00 2001
|
||||
From: Tomas Hozza <thozza@redhat.com>
|
||||
Date: Tue, 24 Mar 2020 13:18:40 +0100
|
||||
Subject: [PATCH] Don't print message about loading crl or ca-cert files with --no-verbose
|
||||
|
||||
* src/gnutls.c (ssl_init): Use LOG_VERBOSE verbosity for informative
|
||||
message related to loading CRL or CA certificate file.
|
||||
|
||||
Before change [1], wget didn't produce any output related to loading CA
|
||||
certificates when --no-verbose option has been used. When --no-verbose
|
||||
option is used, only error messages and basic information should get
|
||||
printed. Information about loading CRL or CA certificate is probably not
|
||||
a basic information. Any error when loading the CRL or CA certificate
|
||||
will be still printed with --no-verbose.
|
||||
|
||||
Some users rely on wget not printing such information and they consider
|
||||
it a regression.
|
||||
|
||||
Reported as https://bugzilla.redhat.com/show_bug.cgi?id=1807267
|
||||
|
||||
[1] http://git.savannah.gnu.org/cgit/wget.git/commit/?id=e4a8fe84e2b813b65d91aec29298eecabe4850a5
|
||||
|
||||
Signed-off-by: Tomas Hozza <thozza@redhat.com>
|
||||
---
|
||||
src/gnutls.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/gnutls.c b/src/gnutls.c
|
||||
index e95ecea..7ab1f08 100644
|
||||
--- a/src/gnutls.c
|
||||
+++ b/src/gnutls.c
|
||||
@@ -172,7 +172,7 @@ ssl_init (void)
|
||||
else
|
||||
{
|
||||
ncerts += rc;
|
||||
- logprintf (LOG_NOTQUIET, _ ("Loaded CA certificate '%s'\n"), opt.ca_cert);
|
||||
+ logprintf (LOG_VERBOSE, _ ("Loaded CA certificate '%s'\n"), opt.ca_cert);
|
||||
}
|
||||
}
|
||||
|
||||
@@ -186,7 +186,7 @@ ssl_init (void)
|
||||
return false;
|
||||
}
|
||||
|
||||
- logprintf (LOG_NOTQUIET, _ ("Loaded CRL file '%s'\n"), opt.crl_file);
|
||||
+ logprintf (LOG_VERBOSE, _ ("Loaded CRL file '%s'\n"), opt.crl_file);
|
||||
}
|
||||
|
||||
DEBUGP (("Certificates loaded: %d\n", ncerts));
|
||||
--
|
||||
libgit2 0.28.5
|
||||
|
@ -1,37 +0,0 @@
|
||||
From 562eacb76a2b64d5dc80a443f0f739bc9ef76c17 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Tim=20R=C3=BChsen?= <tim.ruehsen@gmx.de>
|
||||
Date: Fri, 5 Apr 2019 13:01:57 +0200
|
||||
Subject: [PATCH] * src/iri.c (do_conversion): Remove unneeded debug lines
|
||||
|
||||
---
|
||||
src/iri.c | 5 -----
|
||||
1 file changed, 5 deletions(-)
|
||||
|
||||
diff --git a/src/iri.c b/src/iri.c
|
||||
index d00683cd..eef12dce 100644
|
||||
--- a/src/iri.c
|
||||
+++ b/src/iri.c
|
||||
@@ -152,11 +152,8 @@ do_conversion (const char *tocode, const char *fromcode, char const *in_org, siz
|
||||
*out = s = xmalloc (outlen + 1);
|
||||
done = 0;
|
||||
|
||||
- DEBUGP (("iconv %s -> %s\n", tocode, fromcode));
|
||||
-
|
||||
for (;;)
|
||||
{
|
||||
- DEBUGP (("iconv outlen=%d inlen=%d\n", outlen, inlen));
|
||||
if (iconv (cd, (ICONV_CONST char **) &in, &inlen, out, &outlen) != (size_t)(-1) &&
|
||||
iconv (cd, NULL, NULL, out, &outlen) != (size_t)(-1))
|
||||
{
|
||||
@@ -191,8 +188,6 @@ do_conversion (const char *tocode, const char *fromcode, char const *in_org, siz
|
||||
}
|
||||
else if (errno == E2BIG) /* Output buffer full */
|
||||
{
|
||||
- logprintf (LOG_VERBOSE,
|
||||
- _("Reallocate output buffer len=%d outlen=%d inlen=%d\n"), len, outlen, inlen);
|
||||
tooshort++;
|
||||
done = len;
|
||||
len = done + inlen * 2;
|
||||
--
|
||||
2.17.2
|
||||
|
19
wget.spec
19
wget.spec
@ -1,25 +1,18 @@
|
||||
Summary: A utility for retrieving files using the HTTP or FTP protocols
|
||||
Name: wget
|
||||
Version: 1.20.3
|
||||
Release: 9%{?dist}
|
||||
Version: 1.21.1
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Url: http://www.gnu.org/software/wget/
|
||||
Source: ftp://ftp.gnu.org/gnu/wget/wget-%{version}.tar.gz
|
||||
|
||||
Patch1: wget-1.17-path.patch
|
||||
Patch2: wget-1.20.3-remove-unneeded-debug-lines.patch
|
||||
# http://git.savannah.gnu.org/cgit/wget.git/commit/?id=04b7369490344d014b05dee5d48ca78cd04733ce
|
||||
Patch3: wget-1.20.3-Fix-multiple-definition-of-with-gcc-10.patch
|
||||
# http://git.savannah.gnu.org/cgit/wget.git/commit/?id=1656a1628c1d6ab81b0126c3c4540b2becd0558d
|
||||
Patch4: wget-1.20.3-bz1475861-ftp-verifcerterr-hadling.patch
|
||||
# http://git.savannah.gnu.org/cgit/wget.git/commit/?id=706e71564cadc7192ac21efbf51b661c967f35b5
|
||||
Patch5: wget-1.20.3-fix-verbosity-with---no-verbose.patch
|
||||
|
||||
Provides: webclient
|
||||
Provides: bundled(gnulib)
|
||||
# needed for test suite
|
||||
BuildRequires: make
|
||||
BuildRequires: perl-lib, perl-English, perl-HTTP-Daemon, python3
|
||||
BuildRequires: perl(lib), perl(English), perl(HTTP::Daemon), python3
|
||||
BuildRequires: gnutls-devel, pkgconfig, texinfo, gettext, autoconf, libidn2-devel, libuuid-devel, perl-podlators, libpsl-devel, libmetalink-devel, gpgme-devel, gcc, zlib-devel
|
||||
|
||||
%description
|
||||
@ -61,11 +54,12 @@ rm -rf $RPM_BUILD_ROOT
|
||||
rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
|
||||
|
||||
%find_lang %{name}
|
||||
%find_lang %{name}-gnulib
|
||||
|
||||
%check
|
||||
make check
|
||||
|
||||
%files -f %{name}.lang
|
||||
%files -f %{name}.lang -f %{name}-gnulib.lang
|
||||
%doc AUTHORS MAILING-LIST NEWS README COPYING doc/sample.wgetrc
|
||||
%config(noreplace) %{_sysconfdir}/wgetrc
|
||||
%{_mandir}/man1/wget.*
|
||||
@ -73,6 +67,9 @@ make check
|
||||
%{_infodir}/*
|
||||
|
||||
%changelog
|
||||
* Fri Jan 22 2021 Michal Ruprich <mruprich@redhat.com> - 1.21.1-1
|
||||
- Update to 1.21.1
|
||||
|
||||
* Thu Nov 19 2020 Michal Ruprich <mruprich@redhat.com> - 1.20.3-9
|
||||
- Use make macros
|
||||
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
|
||||
|
Loading…
Reference in New Issue
Block a user