New version 1.21.3
This commit is contained in:
parent
bb348f46e6
commit
8c07254037
1
.gitignore
vendored
1
.gitignore
vendored
@ -20,3 +20,4 @@ wget-1.12.tar.bz2
|
|||||||
/wget-1.20.3.tar.gz
|
/wget-1.20.3.tar.gz
|
||||||
/wget-1.21.1.tar.gz
|
/wget-1.21.1.tar.gz
|
||||||
/wget-1.21.2.tar.gz
|
/wget-1.21.2.tar.gz
|
||||||
|
/wget-1.21.3.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (wget-1.21.2.tar.gz) = 3e35f92604486ca459f26df97d392579f1d83a9254519e8ce249b410bacf70dddf716d6caa3b29fd4865163f60410b2b8ad1ca1f7bb3dbb2456386b7647b988d
|
SHA512 (wget-1.21.3.tar.gz) = 29889ecbf590dff0f39183d9e0621741d731a554d990e5c995a4644725dca62e8e19601d40db0ef7d62ebf54e5457c7409965e4832b6e60e4ccbc9c8caa30718
|
||||||
|
@ -1,22 +0,0 @@
|
|||||||
diff --git a/src/ftp.c b/src/ftp.c
|
|
||||||
index a1fcaa50..e821b0f3 100644
|
|
||||||
--- a/src/ftp.c
|
|
||||||
+++ b/src/ftp.c
|
|
||||||
@@ -2083,7 +2083,7 @@ ftp_loop_internal (struct url *u, struct url *original_url, struct fileinfo *f,
|
|
||||||
/* --dont-remove-listing was specified, so do count this towards the
|
|
||||||
number of bytes and files downloaded. */
|
|
||||||
{
|
|
||||||
- total_downloaded_bytes += qtyread;
|
|
||||||
+ total_downloaded_bytes += (qtyread - restval);
|
|
||||||
numurls++;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -2098,7 +2098,7 @@ ftp_loop_internal (struct url *u, struct url *original_url, struct fileinfo *f,
|
|
||||||
downloaded if they're going to be deleted. People seeding proxies,
|
|
||||||
for instance, may want to know how many bytes and files they've
|
|
||||||
downloaded through it. */
|
|
||||||
- total_downloaded_bytes += qtyread;
|
|
||||||
+ total_downloaded_bytes += (qtyread - restval);
|
|
||||||
numurls++;
|
|
||||||
|
|
||||||
if (opt.delete_after && !input_file_url (opt.input_filename))
|
|
@ -1,21 +0,0 @@
|
|||||||
diff --git a/src/gnutls.c b/src/gnutls.c
|
|
||||||
index 0ecf2c81..81fe9518 100644
|
|
||||||
--- a/src/gnutls.c
|
|
||||||
+++ b/src/gnutls.c
|
|
||||||
@@ -99,7 +99,6 @@ static gnutls_certificate_credentials_t credentials;
|
|
||||||
bool
|
|
||||||
ssl_init (void)
|
|
||||||
{
|
|
||||||
- fprintf(stderr,"SSL_INIT\n");
|
|
||||||
/* Becomes true if GnuTLS is initialized. */
|
|
||||||
const char *ca_directory;
|
|
||||||
DIR *dir;
|
|
||||||
@@ -237,8 +236,6 @@ cert to be of the same type.\n"));
|
|
||||||
void
|
|
||||||
ssl_cleanup (void)
|
|
||||||
{
|
|
||||||
- fprintf(stderr,"SSL_CLEANUP\n");
|
|
||||||
-
|
|
||||||
if (!ssl_initialized)
|
|
||||||
return;
|
|
||||||
|
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/src/wget.h.old b/src/wget.h
|
|
||||||
index 6f20eab..f422737 100644
|
|
||||||
--- a/src/wget.h.old
|
|
||||||
+++ b/src/wget.h
|
|
||||||
@@ -144,7 +144,7 @@ typedef int64_t wgint;
|
|
||||||
#define WGINT_MAX INT64_MAX
|
|
||||||
typedef wgint SUM_SIZE_INT;
|
|
||||||
|
|
||||||
-#define str_to_wgint strtol
|
|
||||||
+#define str_to_wgint strtoll
|
|
||||||
|
|
||||||
#include "options.h"
|
|
||||||
|
|
17
wget.spec
17
wget.spec
@ -1,14 +1,13 @@
|
|||||||
Summary: A utility for retrieving files using the HTTP or FTP protocols
|
Summary: A utility for retrieving files using the HTTP or FTP protocols
|
||||||
Name: wget
|
Name: wget
|
||||||
Version: 1.21.2
|
Version: 1.21.3
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Url: http://www.gnu.org/software/wget/
|
Url: http://www.gnu.org/software/wget/
|
||||||
Source: ftp://ftp.gnu.org/gnu/wget/wget-%{version}.tar.gz
|
Source: ftp://ftp.gnu.org/gnu/wget/wget-%{version}.tar.gz
|
||||||
|
|
||||||
Patch1: wget-1.17-path.patch
|
Patch1: wget-1.17-path.patch
|
||||||
Patch2: wget-1.21-segfault.patch
|
Patch2: wget-1.21.3-hsts-32bit.patch
|
||||||
Patch3: wget-1.21-ssl-init-output.patch
|
|
||||||
|
|
||||||
Provides: webclient
|
Provides: webclient
|
||||||
Provides: bundled(gnulib)
|
Provides: bundled(gnulib)
|
||||||
@ -31,6 +30,7 @@ BuildRequires: gpgme-devel
|
|||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
BuildRequires: libmetalink-devel
|
BuildRequires: libmetalink-devel
|
||||||
|
BuildRequires: git-core
|
||||||
|
|
||||||
%description
|
%description
|
||||||
GNU Wget is a file retrieval utility which can use either the HTTP or
|
GNU Wget is a file retrieval utility which can use either the HTTP or
|
||||||
@ -48,7 +48,12 @@ support for Proxy servers, and configurability.
|
|||||||
sed -i "s|\(PACKAGE_STRING='wget .*\)'|\1 (Red Hat modified)'|" configure
|
sed -i "s|\(PACKAGE_STRING='wget .*\)'|\1 (Red Hat modified)'|" configure
|
||||||
grep "PACKAGE_STRING='wget .* (Red Hat modified)'" configure || exit 1
|
grep "PACKAGE_STRING='wget .* (Red Hat modified)'" configure || exit 1
|
||||||
|
|
||||||
|
#I need to use patch2 only for x86
|
||||||
|
%ifarch i686
|
||||||
%autopatch -p1
|
%autopatch -p1
|
||||||
|
%else
|
||||||
|
%patch1 -p1 -b .path
|
||||||
|
%endif
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
@ -76,6 +81,7 @@ rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
|
|||||||
|
|
||||||
%check
|
%check
|
||||||
make check
|
make check
|
||||||
|
cat testenv/test-suite.log
|
||||||
|
|
||||||
%files -f %{name}.lang -f %{name}-gnulib.lang
|
%files -f %{name}.lang -f %{name}-gnulib.lang
|
||||||
%doc AUTHORS MAILING-LIST NEWS README COPYING doc/sample.wgetrc
|
%doc AUTHORS MAILING-LIST NEWS README COPYING doc/sample.wgetrc
|
||||||
@ -85,6 +91,9 @@ make check
|
|||||||
%{_infodir}/*
|
%{_infodir}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 15 2022 Michal Ruprich <mruprich@redhat.com> - 1.21.3-1
|
||||||
|
- New version 1.21.3
|
||||||
|
|
||||||
* Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.21.2-3
|
* Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.21.2-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user