- update to wget-1.10
- drop passive-ftp patch, already in 1.10 - drop CVS patch - drop LFS patch, similar fix in 1.10 - drop protdir patch, similar fix in 1.10 - drop actime patch, already in 1.10
This commit is contained in:
parent
ce996a5665
commit
8bdd1cba50
@ -1 +1 @@
|
||||
wget-1.9.1.tar.gz
|
||||
wget-1.10.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
e6051f1e1487ec0ebfdbda72bedc70ad wget-1.9.1.tar.gz
|
||||
caddc199d2cb31969e32b19fd365b0c5 wget-1.10.tar.gz
|
||||
|
104
wget-1.10-ctype.patch
Normal file
104
wget-1.10-ctype.patch
Normal file
@ -0,0 +1,104 @@
|
||||
OpenSSL 0.9.7 now includes ctype.h, and because OpenSSL's headers are included
|
||||
after safe-ctype.h, compilation bombs out. We include ctype.h to force the
|
||||
double-inclusion checks in ctype.h to be triggered when we include OpenSSL's
|
||||
headers, avoiding the whole mess.
|
||||
|
||||
--- wget-1.8.2/src/ftp.c 2002-12-13 20:27:59.000000000 -0500
|
||||
+++ wget-1.8.2/src/ftp.c 2002-12-13 20:27:54.000000000 -0500
|
||||
@@ -30,6 +30,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#ifdef HAVE_STRING_H
|
||||
--- wget-1.8.2/src/ftp-basic.c 2002-12-13 20:28:18.000000000 -0500
|
||||
+++ wget-1.8.2/src/ftp-basic.c 2002-12-13 20:28:12.000000000 -0500
|
||||
@@ -29,6 +29,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <assert.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
--- wget-1.8.2/src/ftp-ls.c 2002-12-13 20:28:36.000000000 -0500
|
||||
+++ wget-1.8.2/src/ftp-ls.c 2002-12-13 20:28:31.000000000 -0500
|
||||
@@ -30,6 +30,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#ifdef HAVE_STRING_H
|
||||
--- wget-1.8.2/src/http.c 2002-12-13 20:29:07.000000000 -0500
|
||||
+++ wget-1.8.2/src/http.c 2002-12-13 20:29:13.000000000 -0500
|
||||
@@ -30,6 +30,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <sys/types.h>
|
||||
--- wget-1.8.2/src/retr.c 2002-12-13 20:29:49.000000000 -0500
|
||||
+++ wget-1.8.2/src/retr.c 2002-12-13 20:29:55.000000000 -0500
|
||||
@@ -29,6 +29,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <sys/types.h>
|
||||
--- wget-1.8.2/src/main.c 2002-12-13 20:30:14.000000000 -0500
|
||||
+++ wget-1.8.2/src/main.c 2002-12-13 20:30:17.000000000 -0500
|
||||
@@ -30,6 +30,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#ifdef HAVE_UNISTD_H
|
||||
--- wget-1.8.2/src/progress.c 2002-12-13 20:30:07.000000000 -0500
|
||||
+++ wget-1.8.2/src/progress.c 2002-12-13 20:30:03.000000000 -0500
|
||||
@@ -29,6 +29,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#ifdef HAVE_STRING_H
|
||||
--- wget-1.8.2/src/recur.c 2002-12-13 20:30:46.000000000 -0500
|
||||
+++ wget-1.8.2/src/recur.c 2002-12-13 20:30:43.000000000 -0500
|
||||
@@ -29,6 +29,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#ifdef HAVE_STRING_H
|
||||
--- wget-1.8.2/src/res.c 2002-12-13 20:31:02.000000000 -0500
|
||||
+++ wget-1.8.2/src/res.c 2002-12-13 20:30:59.000000000 -0500
|
||||
@@ -71,6 +71,8 @@
|
||||
# include <config.h>
|
||||
#endif
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#ifdef HAVE_STRING_H
|
137
wget-1.10-path.patch
Normal file
137
wget-1.10-path.patch
Normal file
@ -0,0 +1,137 @@
|
||||
--- wget-1.10/doc/wget.texi.rhpath 2005-07-04 14:51:28.000000000 +0200
|
||||
+++ wget-1.10/doc/wget.texi 2005-07-04 14:59:44.000000000 +0200
|
||||
@@ -204,12 +204,12 @@
|
||||
Most of the features are fully configurable, either through command line
|
||||
options, or via the initialization file @file{.wgetrc} (@pxref{Startup
|
||||
File}). Wget allows you to define @dfn{global} startup files
|
||||
-(@file{/usr/local/etc/wgetrc} by default) for site settings.
|
||||
+(@file{/etc/wgetrc} by default) for site settings.
|
||||
|
||||
@ignore
|
||||
@c man begin FILES
|
||||
@table @samp
|
||||
-@item /usr/local/etc/wgetrc
|
||||
+@item /etc/wgetrc
|
||||
Default location of the @dfn{global} startup file.
|
||||
|
||||
@item .wgetrc
|
||||
@@ -2411,9 +2411,7 @@
|
||||
@cindex location of wgetrc
|
||||
|
||||
When initializing, Wget will look for a @dfn{global} startup file,
|
||||
-@file{/usr/local/etc/wgetrc} by default (or some prefix other than
|
||||
-@file{/usr/local}, if Wget was not installed there) and read commands
|
||||
-from there, if it exists.
|
||||
+@file{/etc/wgetrc} and read commands from there, if it exists.
|
||||
|
||||
Then it will look for the user's file. If the environmental variable
|
||||
@code{WGETRC} is set, Wget will try to load that file. Failing that, no
|
||||
@@ -2423,7 +2421,7 @@
|
||||
|
||||
The fact that user's settings are loaded after the system-wide ones
|
||||
means that in case of collision user's wgetrc @emph{overrides} the
|
||||
-system-wide wgetrc (in @file{/usr/local/etc/wgetrc} by default).
|
||||
+system-wide wgetrc (in @file{/etc/wgetrc} by default).
|
||||
Fascist admins, away!
|
||||
|
||||
@node Wgetrc Syntax
|
||||
--- wget-1.10/README.rhpath 2005-07-04 14:55:43.000000000 +0200
|
||||
+++ wget-1.10/README 2005-07-04 14:56:43.000000000 +0200
|
||||
@@ -33,7 +33,7 @@
|
||||
|
||||
Most of the features are configurable, either through command-line
|
||||
options, or via initialization file .wgetrc. Wget allows you to
|
||||
-install a global startup file (/usr/local/etc/wgetrc by default) for
|
||||
+install a global startup file (/etc/wgetrc by default) for
|
||||
site settings.
|
||||
|
||||
Wget works under almost all Unix variants in use today and, unlike
|
||||
--- wget-1.10/doc/sample.wgetrc.munged_for_texi_inclusion.rhpath 2005-07-04 14:53:58.000000000 +0200
|
||||
+++ wget-1.10/doc/sample.wgetrc.munged_for_texi_inclusion 2005-07-04 14:54:14.000000000 +0200
|
||||
@@ -7,7 +7,7 @@
|
||||
## not contain a comprehensive list of commands -- look at the manual
|
||||
## to find out what you can put into this file.
|
||||
##
|
||||
-## Wget initialization file can reside in /usr/local/etc/wgetrc
|
||||
+## Wget initialization file can reside in /etc/wgetrc
|
||||
## (global, for all users) or $HOME/.wgetrc (for a single user).
|
||||
##
|
||||
## To use the settings in this file, you will have to uncomment them,
|
||||
@@ -16,7 +16,7 @@
|
||||
|
||||
|
||||
##
|
||||
-## Global settings (useful for setting up in /usr/local/etc/wgetrc).
|
||||
+## Global settings (useful for setting up in /etc/wgetrc).
|
||||
## Think well before you change them, since they may reduce wget's
|
||||
## functionality, and make it behave contrary to the documentation:
|
||||
##
|
||||
--- wget-1.10/doc/sample.wgetrc.rhpath 2005-07-04 14:53:22.000000000 +0200
|
||||
+++ wget-1.10/doc/sample.wgetrc 2005-07-04 14:53:42.000000000 +0200
|
||||
@@ -7,7 +7,7 @@
|
||||
## not contain a comprehensive list of commands -- look at the manual
|
||||
## to find out what you can put into this file.
|
||||
##
|
||||
-## Wget initialization file can reside in /usr/local/etc/wgetrc
|
||||
+## Wget initialization file can reside in /etc/wgetrc
|
||||
## (global, for all users) or $HOME/.wgetrc (for a single user).
|
||||
##
|
||||
## To use the settings in this file, you will have to uncomment them,
|
||||
@@ -16,7 +16,7 @@
|
||||
|
||||
|
||||
##
|
||||
-## Global settings (useful for setting up in /usr/local/etc/wgetrc).
|
||||
+## Global settings (useful for setting up in /etc/wgetrc).
|
||||
## Think well before you change them, since they may reduce wget's
|
||||
## functionality, and make it behave contrary to the documentation:
|
||||
##
|
||||
--- wget-1.10/doc/wget.info.rhpath 2005-07-04 14:48:44.000000000 +0200
|
||||
+++ wget-1.10/doc/wget.info 2005-07-04 14:50:51.000000000 +0200
|
||||
@@ -121,7 +121,7 @@
|
||||
* Most of the features are fully configurable, either through
|
||||
command line options, or via the initialization file `.wgetrc'
|
||||
(*note Startup File::). Wget allows you to define "global"
|
||||
- startup files (`/usr/local/etc/wgetrc' by default) for site
|
||||
+ startup files (`/etc/wgetrc' by default) for site
|
||||
settings.
|
||||
|
||||
|
||||
@@ -2116,9 +2116,7 @@
|
||||
===================
|
||||
|
||||
When initializing, Wget will look for a "global" startup file,
|
||||
-`/usr/local/etc/wgetrc' by default (or some prefix other than
|
||||
-`/usr/local', if Wget was not installed there) and read commands from
|
||||
-there, if it exists.
|
||||
+`/etc/wgetrc' by default and read commands from there, if it exists.
|
||||
|
||||
Then it will look for the user's file. If the environmental variable
|
||||
`WGETRC' is set, Wget will try to load that file. Failing that, no
|
||||
@@ -2128,7 +2126,7 @@
|
||||
|
||||
The fact that user's settings are loaded after the system-wide ones
|
||||
means that in case of collision user's wgetrc _overrides_ the
|
||||
-system-wide wgetrc (in `/usr/local/etc/wgetrc' by default). Fascist
|
||||
+system-wide wgetrc (in `/etc/wgetrc' by default). Fascist
|
||||
admins, away!
|
||||
|
||||
|
||||
@@ -2593,7 +2591,7 @@
|
||||
## not contain a comprehensive list of commands -- look at the manual
|
||||
## to find out what you can put into this file.
|
||||
##
|
||||
- ## Wget initialization file can reside in /usr/local/etc/wgetrc
|
||||
+ ## Wget initialization file can reside in /etc/wgetrc
|
||||
## (global, for all users) or $HOME/.wgetrc (for a single user).
|
||||
##
|
||||
## To use the settings in this file, you will have to uncomment them,
|
||||
@@ -2602,7 +2600,7 @@
|
||||
|
||||
|
||||
##
|
||||
- ## Global settings (useful for setting up in /usr/local/etc/wgetrc).
|
||||
+ ## Global settings (useful for setting up in /etc/wgetrc).
|
||||
## Think well before you change them, since they may reduce wget's
|
||||
## functionality, and make it behave contrary to the documentation:
|
||||
##
|
5
wget-1.10-rh1.patch
Normal file
5
wget-1.10-rh1.patch
Normal file
@ -0,0 +1,5 @@
|
||||
--- wget-1.10/src/version.c.rh1
|
||||
+++ wget-1.10/src/version.c
|
||||
@@ -1 +1 @@
|
||||
-char *version_string = "1.10";
|
||||
+char *version_string = "1.10 (Red Hat modified)";
|
@ -18,16 +18,6 @@
|
||||
|
||||
@cindex quota
|
||||
@item -Q @var{quota}
|
||||
@@ -976,8 +974,7 @@
|
||||
really important, do not leave them lying in those files either---edit
|
||||
the files and delete them after Wget has started the download.
|
||||
|
||||
-For more information about security issues with Wget, @xref{Security
|
||||
-Considerations}.
|
||||
+@xref{Security Considerations}, for more information about security issues with Wget.
|
||||
|
||||
@cindex proxy
|
||||
@cindex cache
|
||||
@@ -1479,7 +1476,8 @@
|
||||
@item -A @var{acclist} --accept @var{acclist}
|
||||
@itemx -R @var{rejlist} --reject @var{rejlist}
|
||||
|
32
wget.spec
32
wget.spec
@ -1,21 +1,16 @@
|
||||
Summary: A utility for retrieving files using the HTTP or FTP protocols.
|
||||
Name: wget
|
||||
Version: 1.9.1
|
||||
Release: 22
|
||||
Version: 1.10
|
||||
Release: 2
|
||||
License: GPL
|
||||
Group: Applications/Internet
|
||||
Url: http://wget.sunsite.dk/
|
||||
Source: ftp://ftp.gnu.org/gnu/wget/wget-%{version}.tar.gz
|
||||
Source2: wget-1.5.3-ko.po
|
||||
Patch1: wget-1.8.2-ctype.patch
|
||||
Patch2: wget-1.9.1-passive.patch
|
||||
Patch3: wget-1.9.1-cvs20040122.patch
|
||||
Patch4: wget-1.9.1-rh1.patch
|
||||
Patch5: wget-1.9.1-path.patch
|
||||
Patch6: wget-1.9.1-LFS.patch
|
||||
Patch7: wget-1.9.1-protdir.patch
|
||||
Patch8: wget-1.9.1-actime.patch
|
||||
Patch9: wget-1.9.1-docsyntax.patch
|
||||
Patch1: wget-1.10-ctype.patch
|
||||
Patch2: wget-1.10-rh1.patch
|
||||
Patch3: wget-1.10-path.patch
|
||||
Patch4: wget-1.9.1-docsyntax.patch
|
||||
Provides: webclient
|
||||
Prereq: /sbin/install-info
|
||||
BuildRequires: perl, openssl-devel, pkgconfig, texinfo, gettext, autoconf
|
||||
@ -34,13 +29,8 @@ support for Proxy servers, and configurability.
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p0
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
|
||||
cp %{SOURCE2} $RPM_BUILD_DIR/wget-%{version}/po/ko.po
|
||||
|
||||
@ -79,6 +69,14 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_infodir}/*
|
||||
|
||||
%changelog
|
||||
* Mon Jul 04 2005 Karsten Hopp <karsten@redhat.de> 1.10-2
|
||||
- update to wget-1.10
|
||||
- drop passive-ftp patch, already in 1.10
|
||||
- drop CVS patch
|
||||
- drop LFS patch, similar fix in 1.10
|
||||
- drop protdir patch, similar fix in 1.10
|
||||
- drop actime patch, already in 1.10
|
||||
|
||||
* Wed Mar 02 2005 Karsten Hopp <karsten@redhat.de> 1.9.1-22
|
||||
- build with gcc-4
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user