Changing previous 32b fix to a proper one
This commit is contained in:
parent
32867d6fe3
commit
6f4fb3f2d9
@ -1,13 +1,207 @@
|
||||
diff --git a/src/hsts.c b/src/hsts.c
|
||||
index 0a01440..c4c26c9 100644
|
||||
index 0a014401..72c5e936 100644
|
||||
--- a/src/hsts.c
|
||||
+++ b/src/hsts.c
|
||||
@@ -293,7 +293,7 @@ hsts_read_database (hsts_store_t store, FILE *fp, bool merge_with_existing_entri
|
||||
if (*p == '#')
|
||||
continue;
|
||||
@@ -61,8 +61,8 @@ struct hsts_kh {
|
||||
};
|
||||
|
||||
- items_read = sscanf (p, "%255s %d %d %" SCNd64 " %" SCNd64,
|
||||
+ items_read = sscanf (p, "%255s %d %d %" SCNd32 " %" SCNd32,
|
||||
host,
|
||||
&port,
|
||||
&include_subdomains,
|
||||
struct hsts_kh_info {
|
||||
- time_t created;
|
||||
- time_t max_age;
|
||||
+ int64_t created;
|
||||
+ int64_t max_age;
|
||||
bool include_subdomains;
|
||||
};
|
||||
|
||||
@@ -166,7 +166,7 @@ end:
|
||||
static bool
|
||||
hsts_new_entry_internal (hsts_store_t store,
|
||||
const char *host, int port,
|
||||
- time_t created, time_t max_age,
|
||||
+ int64_t created, int64_t max_age,
|
||||
bool include_subdomains,
|
||||
bool check_validity,
|
||||
bool check_expired,
|
||||
@@ -216,21 +216,21 @@ bail:
|
||||
static bool
|
||||
hsts_add_entry (hsts_store_t store,
|
||||
const char *host, int port,
|
||||
- time_t max_age, bool include_subdomains)
|
||||
+ int64_t max_age, bool include_subdomains)
|
||||
{
|
||||
- time_t t = time (NULL);
|
||||
+ int64_t t = (int64_t) time (NULL);
|
||||
|
||||
/* It might happen time() returned -1 */
|
||||
- return (t == (time_t)(-1) ?
|
||||
+ return (t == -1) ?
|
||||
false :
|
||||
- hsts_new_entry_internal (store, host, port, t, max_age, include_subdomains, false, true, false));
|
||||
+ hsts_new_entry_internal (store, host, port, t, max_age, include_subdomains, false, true, false);
|
||||
}
|
||||
|
||||
/* Creates a new entry, unless an identical one already exists. */
|
||||
static bool
|
||||
hsts_new_entry (hsts_store_t store,
|
||||
const char *host, int port,
|
||||
- time_t created, time_t max_age,
|
||||
+ int64_t created, int64_t max_age,
|
||||
bool include_subdomains)
|
||||
{
|
||||
return hsts_new_entry_internal (store, host, port, created, max_age, include_subdomains, true, true, true);
|
||||
@@ -245,7 +245,7 @@ hsts_remove_entry (hsts_store_t store, struct hsts_kh *kh)
|
||||
static bool
|
||||
hsts_store_merge (hsts_store_t store,
|
||||
const char *host, int port,
|
||||
- time_t created, time_t max_age,
|
||||
+ int64_t created, int64_t max_age,
|
||||
bool include_subdomains)
|
||||
{
|
||||
enum hsts_kh_match match_type = NO_MATCH;
|
||||
@@ -276,11 +276,11 @@ hsts_read_database (hsts_store_t store, FILE *fp, bool merge_with_existing_entri
|
||||
size_t len = 0;
|
||||
int items_read;
|
||||
bool result = false;
|
||||
- bool (*func)(hsts_store_t, const char *, int, time_t, time_t, bool);
|
||||
+ bool (*func)(hsts_store_t, const char *, int, int64_t, int64_t, bool);
|
||||
|
||||
char host[256];
|
||||
int port;
|
||||
- time_t created, max_age;
|
||||
+ int64_t created, max_age;
|
||||
int include_subdomains;
|
||||
|
||||
func = (merge_with_existing_entries ? hsts_store_merge : hsts_new_entry);
|
||||
@@ -326,10 +326,9 @@ hsts_store_dump (hsts_store_t store, FILE *fp)
|
||||
struct hsts_kh *kh = (struct hsts_kh *) it.key;
|
||||
struct hsts_kh_info *khi = (struct hsts_kh_info *) it.value;
|
||||
|
||||
- if (fprintf (fp, "%s\t%d\t%d\t%lu\t%lu\n",
|
||||
+ if (fprintf (fp, "%s\t%d\t%d\t%" PRId64 "\t%" PRId64 "\n",
|
||||
kh->host, kh->explicit_port, khi->include_subdomains,
|
||||
- (unsigned long) khi->created,
|
||||
- (unsigned long) khi->max_age) < 0)
|
||||
+ khi->created, khi->max_age) < 0)
|
||||
{
|
||||
logprintf (LOG_ALWAYS, "Could not write the HSTS database correctly.\n");
|
||||
break;
|
||||
@@ -439,7 +438,7 @@ hsts_match (hsts_store_t store, struct url *u)
|
||||
bool
|
||||
hsts_store_entry (hsts_store_t store,
|
||||
enum url_scheme scheme, const char *host, int port,
|
||||
- time_t max_age, bool include_subdomains)
|
||||
+ int64_t max_age, bool include_subdomains)
|
||||
{
|
||||
bool result = false;
|
||||
enum hsts_kh_match match = NO_MATCH;
|
||||
@@ -464,9 +463,9 @@ hsts_store_entry (hsts_store_t store,
|
||||
* 'created' field too. The RFC also states that we have to
|
||||
* update the entry each time we see HSTS header.
|
||||
* See also Section 11.2. */
|
||||
- time_t t = time (NULL);
|
||||
+ int64_t t = (int64_t) time (NULL);
|
||||
|
||||
- if (t != (time_t)(-1) && t != entry->created)
|
||||
+ if (t != -1 && t != entry->created)
|
||||
{
|
||||
entry->created = t;
|
||||
entry->max_age = max_age;
|
||||
@@ -792,7 +791,7 @@ test_hsts_read_database (void)
|
||||
hsts_store_t table;
|
||||
char *file = NULL;
|
||||
FILE *fp = NULL;
|
||||
- time_t created = time(NULL) - 10;
|
||||
+ int64_t created = time(NULL) - 10;
|
||||
|
||||
if (opt.homedir)
|
||||
{
|
||||
@@ -801,9 +800,9 @@ test_hsts_read_database (void)
|
||||
if (fp)
|
||||
{
|
||||
fputs ("# dummy comment\n", fp);
|
||||
- fprintf (fp, "foo.example.com\t0\t1\t%lu\t123\n",(unsigned long) created);
|
||||
- fprintf (fp, "bar.example.com\t0\t0\t%lu\t456\n", (unsigned long) created);
|
||||
- fprintf (fp, "test.example.com\t8080\t0\t%lu\t789\n", (unsigned long) created);
|
||||
+ fprintf (fp, "foo.example.com\t0\t1\t%" PRId64 "\t123\n", created);
|
||||
+ fprintf (fp, "bar.example.com\t0\t0\t%" PRId64 "\t456\n", created);
|
||||
+ fprintf (fp, "test.example.com\t8080\t0\t%" PRId64 "\t789\n", created);
|
||||
fclose (fp);
|
||||
|
||||
table = hsts_store_open (file);
|
||||
diff --git a/src/hsts.h b/src/hsts.h
|
||||
index 6ecd5060..be048944 100644
|
||||
--- a/src/hsts.h
|
||||
+++ b/src/hsts.h
|
||||
@@ -46,7 +46,7 @@ bool hsts_store_has_changed (hsts_store_t);
|
||||
|
||||
bool hsts_store_entry (hsts_store_t,
|
||||
enum url_scheme, const char *, int,
|
||||
- time_t, bool);
|
||||
+ int64_t, bool);
|
||||
bool hsts_match (hsts_store_t, struct url *);
|
||||
|
||||
#endif /* HAVE_HSTS */
|
||||
diff --git a/src/http.c b/src/http.c
|
||||
index 2ecc11c9..6ccfc3a0 100644
|
||||
--- a/src/http.c
|
||||
+++ b/src/http.c
|
||||
@@ -1300,7 +1300,7 @@ parse_content_disposition (const char *hdr, char **filename)
|
||||
|
||||
#ifdef HAVE_HSTS
|
||||
static bool
|
||||
-parse_strict_transport_security (const char *header, time_t *max_age, bool *include_subdomains)
|
||||
+parse_strict_transport_security (const char *header, int64_t *max_age, bool *include_subdomains)
|
||||
{
|
||||
param_token name, value;
|
||||
const char *c_max_age = NULL;
|
||||
@@ -1330,7 +1330,7 @@ parse_strict_transport_security (const char *header, time_t *max_age, bool *incl
|
||||
* Also, time_t is normally defined as a long, so this should not break.
|
||||
*/
|
||||
if (max_age)
|
||||
- *max_age = (time_t) strtol (c_max_age, NULL, 10);
|
||||
+ *max_age = (int64_t) strtoll (c_max_age, NULL, 10);
|
||||
if (include_subdomains)
|
||||
*include_subdomains = is;
|
||||
|
||||
@@ -3184,9 +3184,6 @@ gethttp (const struct url *u, struct url *original_url, struct http_stat *hs,
|
||||
#else
|
||||
extern hsts_store_t hsts_store;
|
||||
#endif
|
||||
- const char *hsts_params;
|
||||
- time_t max_age;
|
||||
- bool include_subdomains;
|
||||
#endif
|
||||
|
||||
int sock = -1;
|
||||
@@ -3674,21 +3671,24 @@ gethttp (const struct url *u, struct url *original_url, struct http_stat *hs,
|
||||
#ifdef HAVE_HSTS
|
||||
if (opt.hsts && hsts_store)
|
||||
{
|
||||
- hsts_params = resp_header_strdup (resp, "Strict-Transport-Security");
|
||||
+ int64_t max_age;
|
||||
+ const char *hsts_params = resp_header_strdup (resp, "Strict-Transport-Security");
|
||||
+ bool include_subdomains;
|
||||
+
|
||||
if (parse_strict_transport_security (hsts_params, &max_age, &include_subdomains))
|
||||
{
|
||||
/* process strict transport security */
|
||||
if (hsts_store_entry (hsts_store, u->scheme, u->host, u->port, max_age, include_subdomains))
|
||||
- DEBUGP(("Added new HSTS host: %s:%u (max-age: %lu, includeSubdomains: %s)\n",
|
||||
+ DEBUGP(("Added new HSTS host: %s:%" PRIu32 " (max-age: %" PRId64 ", includeSubdomains: %s)\n",
|
||||
u->host,
|
||||
- (unsigned) u->port,
|
||||
- (unsigned long) max_age,
|
||||
+ (uint32_t) u->port,
|
||||
+ max_age,
|
||||
(include_subdomains ? "true" : "false")));
|
||||
else
|
||||
- DEBUGP(("Updated HSTS host: %s:%u (max-age: %lu, includeSubdomains: %s)\n",
|
||||
+ DEBUGP(("Updated HSTS host: %s:%" PRIu32 " (max-age: %" PRId64 ", includeSubdomains: %s)\n",
|
||||
u->host,
|
||||
- (unsigned) u->port,
|
||||
- (unsigned long) max_age,
|
||||
+ (uint32_t) u->port,
|
||||
+ max_age,
|
||||
(include_subdomains ? "true" : "false")));
|
||||
}
|
||||
xfree (hsts_params);
|
||||
|
15
wget.spec
15
wget.spec
@ -1,7 +1,7 @@
|
||||
Summary: A utility for retrieving files using the HTTP or FTP protocols
|
||||
Name: wget
|
||||
Version: 1.21.3
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: GPLv3+
|
||||
Url: http://www.gnu.org/software/wget/
|
||||
Source: ftp://ftp.gnu.org/gnu/wget/wget-%{version}.tar.gz
|
||||
@ -30,6 +30,7 @@ BuildRequires: gpgme-devel
|
||||
BuildRequires: gcc
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: libmetalink-devel
|
||||
BuildRequires: git-core
|
||||
|
||||
%description
|
||||
GNU Wget is a file retrieval utility which can use either the HTTP or
|
||||
@ -41,19 +42,12 @@ HTTP servers to retrieve files over slow or unstable connections,
|
||||
support for Proxy servers, and configurability.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%autosetup -S git
|
||||
|
||||
# modify the package string
|
||||
sed -i "s|\(PACKAGE_STRING='wget .*\)'|\1 (Red Hat modified)'|" configure
|
||||
grep "PACKAGE_STRING='wget .* (Red Hat modified)'" configure || exit 1
|
||||
|
||||
#I need to use patch2 only for x86
|
||||
%ifarch i686
|
||||
%autopatch -p1
|
||||
%else
|
||||
%patch1 -p1 -b .path
|
||||
%endif
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--with-ssl=gnutls \
|
||||
@ -89,6 +83,9 @@ make check
|
||||
%{_infodir}/*
|
||||
|
||||
%changelog
|
||||
* Mon Mar 21 2022 Michal Ruprich <mruprich@redhat.com> - 1.21.3-3
|
||||
- Changing previous 32b fix to a proper one
|
||||
|
||||
* Tue Mar 15 2022 Michal Ruprich <mruprich@redhat.com> - 1.21.3-2
|
||||
- Removing some forgotten lines from the spec
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user