New version 1.21.2
Fix for #2010039 - [abrt] wget: find_cell(): wget killed by SIGSEGV
This commit is contained in:
parent
363f21fb32
commit
5025d2c2f4
1
.gitignore
vendored
1
.gitignore
vendored
@ -19,3 +19,4 @@ wget-1.12.tar.bz2
|
||||
/wget-1.20.1.tar.gz
|
||||
/wget-1.20.3.tar.gz
|
||||
/wget-1.21.1.tar.gz
|
||||
/wget-1.21.2.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (wget-1.21.1.tar.gz) = 784efbf9fe43a1671109e32a9c36237eb2d5c19cf756bf6f6e65517fb21464d3d94b1d6f491852d23b3ddff63e38fe6b60df9125c91b139993af59875e3a0712
|
||||
SHA512 (wget-1.21.2.tar.gz) = 3e35f92604486ca459f26df97d392579f1d83a9254519e8ce249b410bacf70dddf716d6caa3b29fd4865163f60410b2b8ad1ca1f7bb3dbb2456386b7647b988d
|
||||
|
22
wget-1.21-segfault.patch
Normal file
22
wget-1.21-segfault.patch
Normal file
@ -0,0 +1,22 @@
|
||||
diff --git a/src/ftp.c b/src/ftp.c
|
||||
index a1fcaa50..e821b0f3 100644
|
||||
--- a/src/ftp.c
|
||||
+++ b/src/ftp.c
|
||||
@@ -2083,7 +2083,7 @@ ftp_loop_internal (struct url *u, struct url *original_url, struct fileinfo *f,
|
||||
/* --dont-remove-listing was specified, so do count this towards the
|
||||
number of bytes and files downloaded. */
|
||||
{
|
||||
- total_downloaded_bytes += qtyread;
|
||||
+ total_downloaded_bytes += (qtyread - restval);
|
||||
numurls++;
|
||||
}
|
||||
|
||||
@@ -2098,7 +2098,7 @@ ftp_loop_internal (struct url *u, struct url *original_url, struct fileinfo *f,
|
||||
downloaded if they're going to be deleted. People seeding proxies,
|
||||
for instance, may want to know how many bytes and files they've
|
||||
downloaded through it. */
|
||||
- total_downloaded_bytes += qtyread;
|
||||
+ total_downloaded_bytes += (qtyread - restval);
|
||||
numurls++;
|
||||
|
||||
if (opt.delete_after && !input_file_url (opt.input_filename))
|
32
wget.spec
32
wget.spec
@ -1,20 +1,35 @@
|
||||
Summary: A utility for retrieving files using the HTTP or FTP protocols
|
||||
Name: wget
|
||||
Version: 1.21.1
|
||||
Release: 4%{?dist}
|
||||
Version: 1.21.2
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Url: http://www.gnu.org/software/wget/
|
||||
Source: ftp://ftp.gnu.org/gnu/wget/wget-%{version}.tar.gz
|
||||
|
||||
Patch1: wget-1.17-path.patch
|
||||
Patch2: wget-1.21-strtol.patch
|
||||
Patch2: wget-1.21-segfault.patch
|
||||
|
||||
Provides: webclient
|
||||
Provides: bundled(gnulib)
|
||||
# needed for test suite
|
||||
BuildRequires: make
|
||||
BuildRequires: perl(lib), perl(English), perl(HTTP::Daemon), python3
|
||||
BuildRequires: gnutls-devel, pkgconfig, texinfo, gettext, autoconf, libidn2-devel, libuuid-devel, perl-podlators, libpsl-devel, libmetalink-devel, gpgme-devel, gcc, zlib-devel
|
||||
BuildRequires: perl(lib)
|
||||
BuildRequires: perl(English)
|
||||
BuildRequires: perl(HTTP::Daemon)
|
||||
BuildRequires: python3
|
||||
BuildRequires: gnutls-devel
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: texinfo
|
||||
BuildRequires: gettext
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: libidn2-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: perl-podlators
|
||||
BuildRequires: libpsl-devel
|
||||
BuildRequires: gpgme-devel
|
||||
BuildRequires: gcc
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: libmetalink-devel
|
||||
|
||||
%description
|
||||
GNU Wget is a file retrieval utility which can use either the HTTP or
|
||||
@ -45,7 +60,8 @@ grep "PACKAGE_STRING='wget .* (Red Hat modified)'" configure || exit 1
|
||||
--enable-nls \
|
||||
--enable-ipv6 \
|
||||
--disable-rpath \
|
||||
--with-metalink
|
||||
--with-metalink \
|
||||
--disable-year2038
|
||||
|
||||
%{make_build}
|
||||
|
||||
@ -68,6 +84,10 @@ make check
|
||||
%{_infodir}/*
|
||||
|
||||
%changelog
|
||||
* Mon Oct 11 2021 Michal Ruprich <mruprich@redhat.com> - 1.21.2-1
|
||||
- New version 1.21.2
|
||||
- Fix for #2010039 - [abrt] wget: find_cell(): wget killed by SIGSEGV
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.21.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user