- wget 1.11
- from micah Cowan's announcement: - Migration to the GPLv3+ license. - Improvements to the HTTP password authentication code, bringing it a little closer to RFC compliance (more is needed). - Basic support for respecting filenames specified via `Content-Disposition' headers (turned on with --content-disposition, but please read the documentation). - An --ignore-case option to make wildcard- and suffix-matching case-sensitive. - The --spider feature is working again (was broken in previous release). - Myriad bug-fixes (of course!).
This commit is contained in:
parent
1b46ff60fb
commit
44dcfb65d0
@ -1,2 +1 @@
|
||||
wget-1.10.1.tar.gz
|
||||
wget-1.10.2.tar.gz
|
||||
wget-1.11.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
795fefbb7099f93e2d346b026785c4b8 wget-1.10.2.tar.gz
|
||||
d2746aac29f2c0f661ee8e26c6b695ad wget-1.11.tar.bz2
|
||||
|
@ -1,104 +0,0 @@
|
||||
OpenSSL 0.9.7 now includes ctype.h, and because OpenSSL's headers are included
|
||||
after safe-ctype.h, compilation bombs out. We include ctype.h to force the
|
||||
double-inclusion checks in ctype.h to be triggered when we include OpenSSL's
|
||||
headers, avoiding the whole mess.
|
||||
|
||||
--- wget-1.8.2/src/ftp.c 2002-12-13 20:27:59.000000000 -0500
|
||||
+++ wget-1.8.2/src/ftp.c 2002-12-13 20:27:54.000000000 -0500
|
||||
@@ -30,6 +30,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#ifdef HAVE_STRING_H
|
||||
--- wget-1.8.2/src/ftp-basic.c 2002-12-13 20:28:18.000000000 -0500
|
||||
+++ wget-1.8.2/src/ftp-basic.c 2002-12-13 20:28:12.000000000 -0500
|
||||
@@ -29,6 +29,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <assert.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
--- wget-1.8.2/src/ftp-ls.c 2002-12-13 20:28:36.000000000 -0500
|
||||
+++ wget-1.8.2/src/ftp-ls.c 2002-12-13 20:28:31.000000000 -0500
|
||||
@@ -30,6 +30,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#ifdef HAVE_STRING_H
|
||||
--- wget-1.8.2/src/http.c 2002-12-13 20:29:07.000000000 -0500
|
||||
+++ wget-1.8.2/src/http.c 2002-12-13 20:29:13.000000000 -0500
|
||||
@@ -30,6 +30,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <sys/types.h>
|
||||
--- wget-1.8.2/src/retr.c 2002-12-13 20:29:49.000000000 -0500
|
||||
+++ wget-1.8.2/src/retr.c 2002-12-13 20:29:55.000000000 -0500
|
||||
@@ -29,6 +29,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <sys/types.h>
|
||||
--- wget-1.8.2/src/main.c 2002-12-13 20:30:14.000000000 -0500
|
||||
+++ wget-1.8.2/src/main.c 2002-12-13 20:30:17.000000000 -0500
|
||||
@@ -30,6 +30,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#ifdef HAVE_UNISTD_H
|
||||
--- wget-1.8.2/src/progress.c 2002-12-13 20:30:07.000000000 -0500
|
||||
+++ wget-1.8.2/src/progress.c 2002-12-13 20:30:03.000000000 -0500
|
||||
@@ -29,6 +29,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#ifdef HAVE_STRING_H
|
||||
--- wget-1.8.2/src/recur.c 2002-12-13 20:30:46.000000000 -0500
|
||||
+++ wget-1.8.2/src/recur.c 2002-12-13 20:30:43.000000000 -0500
|
||||
@@ -29,6 +29,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#ifdef HAVE_STRING_H
|
||||
--- wget-1.8.2/src/res.c 2002-12-13 20:31:02.000000000 -0500
|
||||
+++ wget-1.8.2/src/res.c 2002-12-13 20:30:59.000000000 -0500
|
||||
@@ -71,6 +71,8 @@
|
||||
# include <config.h>
|
||||
#endif
|
||||
|
||||
+#include <ctype.h>
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#ifdef HAVE_STRING_H
|
@ -1,137 +0,0 @@
|
||||
--- wget-1.10/doc/wget.texi.rhpath 2005-07-04 14:51:28.000000000 +0200
|
||||
+++ wget-1.10/doc/wget.texi 2005-07-04 14:59:44.000000000 +0200
|
||||
@@ -204,12 +204,12 @@
|
||||
Most of the features are fully configurable, either through command line
|
||||
options, or via the initialization file @file{.wgetrc} (@pxref{Startup
|
||||
File}). Wget allows you to define @dfn{global} startup files
|
||||
-(@file{/usr/local/etc/wgetrc} by default) for site settings.
|
||||
+(@file{/etc/wgetrc} by default) for site settings.
|
||||
|
||||
@ignore
|
||||
@c man begin FILES
|
||||
@table @samp
|
||||
-@item /usr/local/etc/wgetrc
|
||||
+@item /etc/wgetrc
|
||||
Default location of the @dfn{global} startup file.
|
||||
|
||||
@item .wgetrc
|
||||
@@ -2411,9 +2411,7 @@
|
||||
@cindex location of wgetrc
|
||||
|
||||
When initializing, Wget will look for a @dfn{global} startup file,
|
||||
-@file{/usr/local/etc/wgetrc} by default (or some prefix other than
|
||||
-@file{/usr/local}, if Wget was not installed there) and read commands
|
||||
-from there, if it exists.
|
||||
+@file{/etc/wgetrc} and read commands from there, if it exists.
|
||||
|
||||
Then it will look for the user's file. If the environmental variable
|
||||
@code{WGETRC} is set, Wget will try to load that file. Failing that, no
|
||||
@@ -2423,7 +2421,7 @@
|
||||
|
||||
The fact that user's settings are loaded after the system-wide ones
|
||||
means that in case of collision user's wgetrc @emph{overrides} the
|
||||
-system-wide wgetrc (in @file{/usr/local/etc/wgetrc} by default).
|
||||
+system-wide wgetrc (in @file{/etc/wgetrc} by default).
|
||||
Fascist admins, away!
|
||||
|
||||
@node Wgetrc Syntax
|
||||
--- wget-1.10/README.rhpath 2005-07-04 14:55:43.000000000 +0200
|
||||
+++ wget-1.10/README 2005-07-04 14:56:43.000000000 +0200
|
||||
@@ -33,7 +33,7 @@
|
||||
|
||||
Most of the features are configurable, either through command-line
|
||||
options, or via initialization file .wgetrc. Wget allows you to
|
||||
-install a global startup file (/usr/local/etc/wgetrc by default) for
|
||||
+install a global startup file (/etc/wgetrc by default) for
|
||||
site settings.
|
||||
|
||||
Wget works under almost all Unix variants in use today and, unlike
|
||||
--- wget-1.10/doc/sample.wgetrc.munged_for_texi_inclusion.rhpath 2005-07-04 14:53:58.000000000 +0200
|
||||
+++ wget-1.10/doc/sample.wgetrc.munged_for_texi_inclusion 2005-07-04 14:54:14.000000000 +0200
|
||||
@@ -7,7 +7,7 @@
|
||||
## not contain a comprehensive list of commands -- look at the manual
|
||||
## to find out what you can put into this file.
|
||||
##
|
||||
-## Wget initialization file can reside in /usr/local/etc/wgetrc
|
||||
+## Wget initialization file can reside in /etc/wgetrc
|
||||
## (global, for all users) or $HOME/.wgetrc (for a single user).
|
||||
##
|
||||
## To use the settings in this file, you will have to uncomment them,
|
||||
@@ -16,7 +16,7 @@
|
||||
|
||||
|
||||
##
|
||||
-## Global settings (useful for setting up in /usr/local/etc/wgetrc).
|
||||
+## Global settings (useful for setting up in /etc/wgetrc).
|
||||
## Think well before you change them, since they may reduce wget's
|
||||
## functionality, and make it behave contrary to the documentation:
|
||||
##
|
||||
--- wget-1.10/doc/sample.wgetrc.rhpath 2005-07-04 14:53:22.000000000 +0200
|
||||
+++ wget-1.10/doc/sample.wgetrc 2005-07-04 14:53:42.000000000 +0200
|
||||
@@ -7,7 +7,7 @@
|
||||
## not contain a comprehensive list of commands -- look at the manual
|
||||
## to find out what you can put into this file.
|
||||
##
|
||||
-## Wget initialization file can reside in /usr/local/etc/wgetrc
|
||||
+## Wget initialization file can reside in /etc/wgetrc
|
||||
## (global, for all users) or $HOME/.wgetrc (for a single user).
|
||||
##
|
||||
## To use the settings in this file, you will have to uncomment them,
|
||||
@@ -16,7 +16,7 @@
|
||||
|
||||
|
||||
##
|
||||
-## Global settings (useful for setting up in /usr/local/etc/wgetrc).
|
||||
+## Global settings (useful for setting up in /etc/wgetrc).
|
||||
## Think well before you change them, since they may reduce wget's
|
||||
## functionality, and make it behave contrary to the documentation:
|
||||
##
|
||||
--- wget-1.10/doc/wget.info.rhpath 2005-07-04 14:48:44.000000000 +0200
|
||||
+++ wget-1.10/doc/wget.info 2005-07-04 14:50:51.000000000 +0200
|
||||
@@ -121,7 +121,7 @@
|
||||
* Most of the features are fully configurable, either through
|
||||
command line options, or via the initialization file `.wgetrc'
|
||||
(*note Startup File::). Wget allows you to define "global"
|
||||
- startup files (`/usr/local/etc/wgetrc' by default) for site
|
||||
+ startup files (`/etc/wgetrc' by default) for site
|
||||
settings.
|
||||
|
||||
|
||||
@@ -2116,9 +2116,7 @@
|
||||
===================
|
||||
|
||||
When initializing, Wget will look for a "global" startup file,
|
||||
-`/usr/local/etc/wgetrc' by default (or some prefix other than
|
||||
-`/usr/local', if Wget was not installed there) and read commands from
|
||||
-there, if it exists.
|
||||
+`/etc/wgetrc' by default and read commands from there, if it exists.
|
||||
|
||||
Then it will look for the user's file. If the environmental variable
|
||||
`WGETRC' is set, Wget will try to load that file. Failing that, no
|
||||
@@ -2128,7 +2126,7 @@
|
||||
|
||||
The fact that user's settings are loaded after the system-wide ones
|
||||
means that in case of collision user's wgetrc _overrides_ the
|
||||
-system-wide wgetrc (in `/usr/local/etc/wgetrc' by default). Fascist
|
||||
+system-wide wgetrc (in `/etc/wgetrc' by default). Fascist
|
||||
admins, away!
|
||||
|
||||
|
||||
@@ -2593,7 +2591,7 @@
|
||||
## not contain a comprehensive list of commands -- look at the manual
|
||||
## to find out what you can put into this file.
|
||||
##
|
||||
- ## Wget initialization file can reside in /usr/local/etc/wgetrc
|
||||
+ ## Wget initialization file can reside in /etc/wgetrc
|
||||
## (global, for all users) or $HOME/.wgetrc (for a single user).
|
||||
##
|
||||
## To use the settings in this file, you will have to uncomment them,
|
||||
@@ -2602,7 +2600,7 @@
|
||||
|
||||
|
||||
##
|
||||
- ## Global settings (useful for setting up in /usr/local/etc/wgetrc).
|
||||
+ ## Global settings (useful for setting up in /etc/wgetrc).
|
||||
## Think well before you change them, since they may reduce wget's
|
||||
## functionality, and make it behave contrary to the documentation:
|
||||
##
|
@ -1,5 +0,0 @@
|
||||
--- wget-1.10/src/version.c.rh1
|
||||
+++ wget-1.10/src/version.c
|
||||
@@ -1 +1 @@
|
||||
-char *version_string = "1.10";
|
||||
+char *version_string = "1.10 (Red Hat modified)";
|
@ -1,15 +0,0 @@
|
||||
Fixes NULL pointer dereference (CVE-2006-6719) (bz #221483)
|
||||
|
||||
--- wget-1.10.2/src/ftp-basic.c.orig 2007-01-04 19:30:31.000000000 +0100
|
||||
+++ wget-1.10.2/src/ftp-basic.c 2007-01-04 19:31:48.000000000 +0100
|
||||
@@ -1038,7 +1038,9 @@ ftp_syst (int csock, enum stype *server_
|
||||
first word of the server response)? */
|
||||
request = strtok (NULL, " ");
|
||||
|
||||
- if (!strcasecmp (request, "VMS"))
|
||||
+ if (request == NULL)
|
||||
+ *server_type = ST_OTHER;
|
||||
+ else if (!strcasecmp (request, "VMS"))
|
||||
*server_type = ST_VMS;
|
||||
else if (!strcasecmp (request, "UNIX"))
|
||||
*server_type = ST_UNIX;
|
@ -1,34 +0,0 @@
|
||||
--- wget-1.10.2/src/http.c.escapechars 2007-02-12 06:18:40.000000000 -0500
|
||||
+++ wget-1.10.2/src/http.c 2007-02-12 06:18:20.000000000 -0500
|
||||
@@ -741,6 +741,20 @@
|
||||
xfree (resp);
|
||||
}
|
||||
|
||||
+/* Print a single line of response, the characters [b, e). We tried
|
||||
+ getting away with
|
||||
+ logprintf (LOG_VERBOSE, "%s%.*s\n", prefix, (int) (e - b), b);
|
||||
+ but that failed to escape the non-printable characters and, in fact,
|
||||
+ caused crashes in UTF-8 locales. */
|
||||
+
|
||||
+static void
|
||||
+print_response_line(const char *prefix, const char *b, const char *e)
|
||||
+{
|
||||
+ char *copy;
|
||||
+ BOUNDED_TO_ALLOCA(b, e, copy);
|
||||
+ logprintf (LOG_VERBOSE, "%s%s\n", prefix, escnonprint(copy));
|
||||
+}
|
||||
+
|
||||
/* Print the server response, line by line, omitting the trailing CRLF
|
||||
from individual header lines, and prefixed with PREFIX. */
|
||||
|
||||
@@ -759,9 +773,7 @@
|
||||
--e;
|
||||
if (b < e && e[-1] == '\r')
|
||||
--e;
|
||||
- /* This is safe even on printfs with broken handling of "%.<n>s"
|
||||
- because resp->headers ends with \0. */
|
||||
- logprintf (LOG_VERBOSE, "%s%.*s\n", prefix, e - b, b);
|
||||
+ print_response_line(prefix, b, e);
|
||||
}
|
||||
}
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- wget-1.10.2/src/ftp.c.186195 2006-12-08 12:15:20.000000000 +0100
|
||||
+++ wget-1.10.2/src/ftp.c 2006-12-08 12:17:02.000000000 +0100
|
||||
@@ -1172,7 +1172,7 @@
|
||||
len = 0;
|
||||
err = getftp (u, &len, restval, con);
|
||||
|
||||
- if (con->csock != -1)
|
||||
+ if (con->csock == -1)
|
||||
con->st &= ~DONE_CWD;
|
||||
else
|
||||
con->st |= DONE_CWD;
|
@ -1,5 +0,0 @@
|
||||
--- wget-1.10.1/src/version.c.rh1
|
||||
+++ wget-1.10.1/src/version.c
|
||||
@@ -1 +1 @@
|
||||
-char *version_string = "1.10.2";
|
||||
+char *version_string = "1.10.2 (Red Hat modified)";
|
@ -1,12 +0,0 @@
|
||||
diff -urN wget-1.10.2/doc/Makefile.in wget-1.10.2_new/doc/Makefile.in
|
||||
--- wget-1.10.2/doc/Makefile.in 2005-06-06 22:42:17.000000000 +0200
|
||||
+++ wget-1.10.2_new/doc/Makefile.in 2006-06-27 12:04:36.000000000 +0200
|
||||
@@ -48,7 +48,7 @@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
RM = rm -f
|
||||
|
||||
-TEXI2POD = texi2pod.pl
|
||||
+TEXI2POD = $(srcdir)/texi2pod.pl
|
||||
POD2MAN = @POD2MAN@
|
||||
MAN = wget.$(manext)
|
||||
WGETRC = $(sysconfdir)/wgetrc
|
37112
wget-1.10.2-to11.patch
37112
wget-1.10.2-to11.patch
File diff suppressed because it is too large
Load Diff
1888
wget-1.11-de.po
1888
wget-1.11-de.po
File diff suppressed because it is too large
Load Diff
206
wget-1.11-path.patch
Normal file
206
wget-1.11-path.patch
Normal file
@ -0,0 +1,206 @@
|
||||
diff -up wget-1.11/NEWS.rhpath wget-1.11/NEWS
|
||||
--- wget-1.11/NEWS.rhpath 2008-01-26 10:26:56.000000000 +0100
|
||||
+++ wget-1.11/NEWS 2008-01-27 00:01:56.000000000 +0100
|
||||
@@ -444,7 +444,7 @@ distributed with Wget.
|
||||
|
||||
** Compiles on pre-ANSI compilers.
|
||||
|
||||
-** Global wgetrc now goes to /usr/local/etc (i.e. $sysconfdir).
|
||||
+** Global wgetrc now goes to /etc (i.e. $sysconfdir).
|
||||
|
||||
** Lots of bugfixes.
|
||||
|
||||
@@ -507,7 +507,7 @@ Emacs, standalone info, or converted to
|
||||
** Fixed a long-standing bug, so that Wget now works over SLIP
|
||||
connections.
|
||||
|
||||
-** You can have a system-wide wgetrc (/usr/local/lib/wgetrc by
|
||||
+** You can have a system-wide wgetrc (/etc/wgetrc by
|
||||
default). Settings in $HOME/.wgetrc override the global ones, of
|
||||
course :-)
|
||||
|
||||
diff -up wget-1.11/README.rhpath wget-1.11/README
|
||||
--- wget-1.11/README.rhpath 2008-01-27 00:02:29.000000000 +0100
|
||||
+++ wget-1.11/README 2008-01-27 00:02:40.000000000 +0100
|
||||
@@ -33,7 +33,7 @@ for socks.
|
||||
|
||||
Most of the features are configurable, either through command-line
|
||||
options, or via initialization file .wgetrc. Wget allows you to
|
||||
-install a global startup file (/usr/local/etc/wgetrc by default) for
|
||||
+install a global startup file (/etc/wgetrc by default) for
|
||||
site settings.
|
||||
|
||||
Wget works under almost all Unix variants in use today and, unlike
|
||||
diff -up wget-1.11/doc/sample.wgetrc.rhpath wget-1.11/doc/sample.wgetrc
|
||||
--- wget-1.11/doc/sample.wgetrc.rhpath 2008-01-26 10:26:56.000000000 +0100
|
||||
+++ wget-1.11/doc/sample.wgetrc 2008-01-27 00:01:56.000000000 +0100
|
||||
@@ -7,7 +7,7 @@
|
||||
## not contain a comprehensive list of commands -- look at the manual
|
||||
## to find out what you can put into this file.
|
||||
##
|
||||
-## Wget initialization file can reside in /usr/local/etc/wgetrc
|
||||
+## Wget initialization file can reside in /etc/wgetrc
|
||||
## (global, for all users) or $HOME/.wgetrc (for a single user).
|
||||
##
|
||||
## To use the settings in this file, you will have to uncomment them,
|
||||
@@ -16,7 +16,7 @@
|
||||
|
||||
|
||||
##
|
||||
-## Global settings (useful for setting up in /usr/local/etc/wgetrc).
|
||||
+## Global settings (useful for setting up in /etc/wgetrc).
|
||||
## Think well before you change them, since they may reduce wget's
|
||||
## functionality, and make it behave contrary to the documentation:
|
||||
##
|
||||
diff -up wget-1.11/doc/wget.1.rhpath wget-1.11/doc/wget.1
|
||||
--- wget-1.11/doc/wget.1.rhpath 2008-01-26 10:56:05.000000000 +0100
|
||||
+++ wget-1.11/doc/wget.1 2008-01-27 00:01:56.000000000 +0100
|
||||
@@ -1706,8 +1706,8 @@ This is a useful option, since it guaran
|
||||
\&\fIbelow\fR a certain hierarchy will be downloaded.
|
||||
.SH "FILES"
|
||||
.IX Header "FILES"
|
||||
-.IP "\fB/usr/local/etc/wgetrc\fR" 4
|
||||
-.IX Item "/usr/local/etc/wgetrc"
|
||||
+.IP "\fB/etc/wgetrc\fR" 4
|
||||
+.IX Item "/etc/wgetrc"
|
||||
Default location of the \fIglobal\fR startup file.
|
||||
.IP "\fB.wgetrc\fR" 4
|
||||
.IX Item ".wgetrc"
|
||||
diff -up wget-1.11/doc/wget.texi.rhpath wget-1.11/doc/wget.texi
|
||||
--- wget-1.11/doc/wget.texi.rhpath 2008-01-26 10:26:56.000000000 +0100
|
||||
+++ wget-1.11/doc/wget.texi 2008-01-27 00:01:56.000000000 +0100
|
||||
@@ -199,12 +199,12 @@ gauge can be customized to your preferen
|
||||
Most of the features are fully configurable, either through command line
|
||||
options, or via the initialization file @file{.wgetrc} (@pxref{Startup
|
||||
File}). Wget allows you to define @dfn{global} startup files
|
||||
-(@file{/usr/local/etc/wgetrc} by default) for site settings.
|
||||
+(@file{/etc/wgetrc} by default) for site settings.
|
||||
|
||||
@ignore
|
||||
@c man begin FILES
|
||||
@table @samp
|
||||
-@item /usr/local/etc/wgetrc
|
||||
+@item /etc/wgetrc
|
||||
Default location of the @dfn{global} startup file.
|
||||
|
||||
@item .wgetrc
|
||||
@@ -465,8 +465,6 @@ administrator may have chosen to compile
|
||||
which case @samp{-d} will not work. Please note that compiling with
|
||||
debug support is always safe---Wget compiled with the debug support will
|
||||
@emph{not} print any debug info unless requested with @samp{-d}.
|
||||
-@xref{Reporting Bugs}, for more information on how to use @samp{-d} for
|
||||
-sending bug reports.
|
||||
|
||||
@cindex quiet
|
||||
@item -q
|
||||
@@ -909,7 +907,7 @@ When mode is set to ``windows'', Wget es
|
||||
@samp{>}, and the control characters in the ranges 0--31 and 128--159.
|
||||
In addition to this, Wget in Windows mode uses @samp{+} instead of
|
||||
@samp{:} to separate host and port in local file names, and uses
|
||||
-@samp{@@} instead of @samp{?} to separate the query portion of the file
|
||||
+@samp{ @@ } instead of @samp{ ? } to separate the query portion of the file
|
||||
name from the rest. Therefore, a URL that would be saved as
|
||||
@samp{www.xemacs.org:4300/search.pl?input=blah} in Unix mode would be
|
||||
saved as @samp{www.xemacs.org+4300/search.pl@@input=blah} in Windows
|
||||
@@ -1149,7 +1147,7 @@ browser sends when communicating with th
|
||||
would send in the same situation. Different browsers keep textual
|
||||
cookie files in different locations:
|
||||
|
||||
-@table @asis
|
||||
+@table @samp
|
||||
@item Netscape 4.x.
|
||||
The cookies are in @file{~/.netscape/cookies.txt}.
|
||||
|
||||
@@ -2450,9 +2448,7 @@ commands.
|
||||
@cindex location of wgetrc
|
||||
|
||||
When initializing, Wget will look for a @dfn{global} startup file,
|
||||
-@file{/usr/local/etc/wgetrc} by default (or some prefix other than
|
||||
-@file{/usr/local}, if Wget was not installed there) and read commands
|
||||
-from there, if it exists.
|
||||
+@file{/etc/wgetrc} by default and read commands from there, if it exists.
|
||||
|
||||
Then it will look for the user's file. If the environmental variable
|
||||
@code{WGETRC} is set, Wget will try to load that file. Failing that, no
|
||||
@@ -2462,8 +2458,7 @@ If @code{WGETRC} is not set, Wget will t
|
||||
|
||||
The fact that user's settings are loaded after the system-wide ones
|
||||
means that in case of collision user's wgetrc @emph{overrides} the
|
||||
-system-wide wgetrc (in @file{/usr/local/etc/wgetrc} by default).
|
||||
-Fascist admins, away!
|
||||
+system-wide wgetrc (in @file{/etc/wgetrc} by default).
|
||||
|
||||
@node Wgetrc Syntax
|
||||
@section Wgetrc Syntax
|
||||
@@ -2509,7 +2504,7 @@ Most of these commands have direct comma
|
||||
wgetrc command can be specified on the command line using the
|
||||
@samp{--execute} switch (@pxref{Basic Startup Options}.)
|
||||
|
||||
-@table @asis
|
||||
+@table @samp
|
||||
@item accept/reject = @var{string}
|
||||
Same as @samp{-A}/@samp{-R} (@pxref{Types of Files}).
|
||||
|
||||
diff -up wget-1.11/doc/wget.pod.rhpath wget-1.11/doc/wget.pod
|
||||
--- wget-1.11/doc/wget.pod.rhpath 2008-01-26 10:56:05.000000000 +0100
|
||||
+++ wget-1.11/doc/wget.pod 2008-01-27 00:01:56.000000000 +0100
|
||||
@@ -1829,7 +1829,7 @@ I<below> a certain hierarchy will be dow
|
||||
=over 4
|
||||
|
||||
|
||||
-=item B</usr/local/etc/wgetrc>
|
||||
+=item B</etc/wgetrc>
|
||||
|
||||
Default location of the I<global> startup file.
|
||||
|
||||
diff -up wget-1.11/doc/wget.info.rhpath wget-1.11/doc/wget.info
|
||||
--- wget-1.11/doc/wget.info.rhpath 2008-01-26 10:56:04.000000000 +0100
|
||||
+++ wget-1.11/doc/wget.info 2008-01-27 00:01:56.000000000 +0100
|
||||
@@ -112,7 +112,7 @@ retrieval through HTTP proxies.
|
||||
* Most of the features are fully configurable, either through
|
||||
command line options, or via the initialization file `.wgetrc'
|
||||
(*note Startup File::). Wget allows you to define "global"
|
||||
- startup files (`/usr/local/etc/wgetrc' by default) for site
|
||||
+ startup files (`/etc/wgetrc' by default) for site
|
||||
settings.
|
||||
|
||||
* Finally, GNU Wget is free software. This means that everyone may
|
||||
@@ -2144,9 +2144,7 @@ File: wget.info, Node: Wgetrc Location,
|
||||
===================
|
||||
|
||||
When initializing, Wget will look for a "global" startup file,
|
||||
-`/usr/local/etc/wgetrc' by default (or some prefix other than
|
||||
-`/usr/local', if Wget was not installed there) and read commands from
|
||||
-there, if it exists.
|
||||
+`/etc/wgetrc' by default and read commands from there, if it exists.
|
||||
|
||||
Then it will look for the user's file. If the environmental variable
|
||||
`WGETRC' is set, Wget will try to load that file. Failing that, no
|
||||
@@ -2156,8 +2154,7 @@ further attempts will be made.
|
||||
|
||||
The fact that user's settings are loaded after the system-wide ones
|
||||
means that in case of collision user's wgetrc _overrides_ the
|
||||
-system-wide wgetrc (in `/usr/local/etc/wgetrc' by default). Fascist
|
||||
-admins, away!
|
||||
+system-wide wgetrc (in `/etc/wgetrc' by default).
|
||||
|
||||
|
||||
File: wget.info, Node: Wgetrc Syntax, Next: Wgetrc Commands, Prev: Wgetrc Location, Up: Startup File
|
||||
@@ -2625,7 +2622,7 @@ its line.
|
||||
## not contain a comprehensive list of commands -- look at the manual
|
||||
## to find out what you can put into this file.
|
||||
##
|
||||
- ## Wget initialization file can reside in /usr/local/etc/wgetrc
|
||||
+ ## Wget initialization file can reside in /etc/wgetrc
|
||||
## (global, for all users) or $HOME/.wgetrc (for a single user).
|
||||
##
|
||||
## To use the settings in this file, you will have to uncomment them,
|
||||
@@ -2634,7 +2631,7 @@ its line.
|
||||
|
||||
|
||||
##
|
||||
- ## Global settings (useful for setting up in /usr/local/etc/wgetrc).
|
||||
+ ## Global settings (useful for setting up in /etc/wgetrc).
|
||||
## Think well before you change them, since they may reduce wget's
|
||||
## functionality, and make it behave contrary to the documentation:
|
||||
##
|
5
wget-1.11-rh1.patch
Normal file
5
wget-1.11-rh1.patch
Normal file
@ -0,0 +1,5 @@
|
||||
--- wget-1.10.1/src/version.c.rh1
|
||||
+++ wget-1.10.1/src/version.c
|
||||
@@ -1 +1 @@
|
||||
-char *version_string = "1.11";
|
||||
+char *version_string = "1.11 (Red Hat modified)";
|
@ -1,75 +0,0 @@
|
||||
--- wget-1.9.1/doc/wget.texi.syntax 2005-02-01 14:44:03.436977752 +0100
|
||||
+++ wget-1.9.1/doc/wget.texi 2005-02-01 15:19:16.236783360 +0100
|
||||
@@ -437,8 +437,6 @@
|
||||
which case @samp{-d} will not work. Please note that compiling with
|
||||
debug support is always safe---Wget compiled with the debug support will
|
||||
@emph{not} print any debug info unless requested with @samp{-d}.
|
||||
-@xref{Reporting Bugs}, for more information on how to use @samp{-d} for
|
||||
-sending bug reports.
|
||||
|
||||
@cindex quiet
|
||||
@item -q
|
||||
@@ -786,7 +784,7 @@
|
||||
Turn proxy support on or off. The proxy is on by default if the
|
||||
appropriate environment variable is defined.
|
||||
|
||||
-For more information about the use of proxies with Wget, @xref{Proxies}.
|
||||
+@xref{Proxies}, for more information about the use of proxies with Wget.
|
||||
|
||||
@cindex quota
|
||||
@item -Q @var{quota}
|
||||
@@ -1479,7 +1476,8 @@
|
||||
@item -A @var{acclist} --accept @var{acclist}
|
||||
@itemx -R @var{rejlist} --reject @var{rejlist}
|
||||
Specify comma-separated lists of file name suffixes or patterns to
|
||||
-accept or reject (@pxref{Types of Files} for more details).
|
||||
+accept or reject.
|
||||
+(@pxref{Types of Files}).
|
||||
|
||||
@item -D @var{domain-list}
|
||||
@itemx --domains=@var{domain-list}
|
||||
@@ -1537,13 +1535,13 @@
|
||||
@item -I @var{list}
|
||||
@itemx --include-directories=@var{list}
|
||||
Specify a comma-separated list of directories you wish to follow when
|
||||
-downloading (@pxref{Directory-Based Limits} for more details.) Elements
|
||||
+downloading. (@pxref{Directory-Based Limits}) Elements
|
||||
of @var{list} may contain wildcards.
|
||||
|
||||
@item -X @var{list}
|
||||
@itemx --exclude-directories=@var{list}
|
||||
Specify a comma-separated list of directories you wish to exclude from
|
||||
-download (@pxref{Directory-Based Limits} for more details.) Elements of
|
||||
+download. (@pxref{Directory-Based Limits}) Elements of
|
||||
@var{list} may contain wildcards.
|
||||
|
||||
@item -np
|
||||
--- wget-1.9.1/doc/wget.texi Wed Feb 2 09:05:43 2005
|
||||
+++ wget-1.9.1_new/doc/wget.texi Wed Feb 2 09:04:21 2005
|
||||
@@ -850,7 +850,7 @@
|
||||
@samp{>}, and the control characters in the ranges 0--31 and 128--159.
|
||||
In addition to this, Wget in Windows mode uses @samp{+} instead of
|
||||
@samp{:} to separate host and port in local file names, and uses
|
||||
-@samp{@@} instead of @samp{?} to separate the query portion of the file
|
||||
+@samp{ @@ } instead of @samp{ ? } to separate the query portion of the file
|
||||
name from the rest. Therefore, a URL that would be saved as
|
||||
@samp{www.xemacs.org:4300/search.pl?input=blah} in Unix mode would be
|
||||
saved as @samp{www.xemacs.org+4300/search.pl@@input=blah} in Windows
|
||||
@@ -1019,7 +1019,7 @@
|
||||
would send in the same situation. Different browsers keep textual
|
||||
cookie files in different locations:
|
||||
|
||||
-@table @asis
|
||||
+@table @samp
|
||||
@item Netscape 4.x.
|
||||
The cookies are in @file{~/.netscape/cookies.txt}.
|
||||
|
||||
@@ -2153,7 +2153,7 @@
|
||||
Most of these commands have command-line equivalents (@pxref{Invoking}),
|
||||
though some of the more obscure or rarely used ones do not.
|
||||
|
||||
-@table @asis
|
||||
+@table @samp
|
||||
@item accept/reject = @var{string}
|
||||
Same as @samp{-A}/@samp{-R} (@pxref{Types of Files}).
|
||||
|
42
wget.spec
42
wget.spec
@ -1,23 +1,17 @@
|
||||
Summary: A utility for retrieving files using the HTTP or FTP protocols
|
||||
Name: wget
|
||||
Version: 1.10.2
|
||||
Release: 17%{?dist}
|
||||
License: GPLv2+
|
||||
Version: 1.11
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Applications/Internet
|
||||
Url: http://wget.sunsite.dk/
|
||||
Source: ftp://ftp.gnu.org/gnu/wget/wget-%{version}.tar.gz
|
||||
Source2: http://people.fedora.de/rsc/wget-1.11-de.po
|
||||
Patch2: wget-1.10.2-rh1.patch
|
||||
Patch3: wget-1.10-path.patch
|
||||
Patch4: wget-1.9.1-docsyntax.patch
|
||||
Patch5: wget-1.10.1-helpfix.patch
|
||||
#Patch6: wget-1.10.2-to11.patch
|
||||
Patch7: wget-1.10.2-218211.patch
|
||||
Patch8: wget-1.10.2-retry186195.patch
|
||||
Patch9: wget-1.10.2-CVE-2006-6719.patch
|
||||
Patch10: wget-1.10.2-texipod.patch
|
||||
Patch11: wget-1.10.2-cookies,patch
|
||||
Patch12: wget-1.10.2-escapechars.patch
|
||||
Source: ftp://ftp.gnu.org/gnu/wget/wget-%{version}.tar.bz2
|
||||
#Source2: http://people.fedora.de/rsc/wget-1.11-de.po
|
||||
Patch1: wget-1.11-rh1.patch
|
||||
Patch2: wget-1.11-path.patch
|
||||
Patch3: wget-1.10.1-helpfix.patch
|
||||
Patch4: wget-1.10.2-218211.patch
|
||||
#Patch5: wget-1.10.2-cookies,patch
|
||||
Provides: webclient
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
@ -35,19 +29,13 @@ support for Proxy servers, and configurability.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
#patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
%patch12 -p1
|
||||
#patch5 -p1
|
||||
|
||||
cp %{SOURCE2} $RPM_BUILD_DIR/wget-%{version}/po/de.po
|
||||
#cp %{SOURCE2} $RPM_BUILD_DIR/wget-%{version}/po/de.po
|
||||
#chmod a+x doc/texi2pod.pl
|
||||
|
||||
%build
|
||||
@ -55,7 +43,7 @@ if pkg-config openssl ; then
|
||||
CPPFLAGS=`pkg-config --cflags openssl`; export CPPFLAGS
|
||||
LDFLAGS=`pkg-config --libs openssl`; export LDFLAGS
|
||||
fi
|
||||
%configure --with-ssl --enable-LFS
|
||||
%configure --with-ssl --enable-largefile --enable-opie --enable-digest --enable-ntlm --enable-nls --enable-ipv6 --disable-rpath
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
@ -77,7 +65,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%doc AUTHORS MAILING-LIST NEWS README PATCHES TODO COPYING
|
||||
%doc AUTHORS MAILING-LIST NEWS README COPYING doc/sample.wgetrc
|
||||
%config(noreplace) %{_sysconfdir}/wgetrc
|
||||
%{_mandir}/man1/wget.*
|
||||
%{_bindir}/wget
|
||||
|
Loading…
Reference in New Issue
Block a user