Update to 1.20
--secure-protocol=TLSv1_3 now works (#1623994) Signed-off-by: Tomas Hozza <thozza@redhat.com>
This commit is contained in:
parent
d304d4f735
commit
3862fbb154
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@ wget-1.12.tar.bz2
|
||||
/wget-1.19.4.tar.lz
|
||||
/wget-1.19.4.tar.gz
|
||||
/wget-1.19.5.tar.gz
|
||||
/wget-1.20.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (wget-1.19.5.tar.gz) = 0d4964e0f5adb0c023edc831bde9c9f13f3222f6efc1ce93250d234ab937e92b53921624532fb0e6586151ddfdee6df9a7ca91a2a99b3d16e2e68401c625301b
|
||||
SHA512 (wget-1.20.tar.gz) = 2e50b9e83c22cb342d85981f89253d9c72bb1a48152c17c4c0b6315683890075f60ad2783e4fa8c2a6d15c53820d9ecb8d0c4b81cfcef4fcc66126ed1cb7ff54
|
||||
|
@ -1,27 +0,0 @@
|
||||
From 7ddcebd61e170fb03d361f82bf8f5550ee62a1ae Mon Sep 17 00:00:00 2001
|
||||
From: Tomas Korbar <tkorbar@redhat.com>
|
||||
Date: Wed, 29 Aug 2018 12:33:43 +0200
|
||||
Subject: [PATCH] Avoid creating empty wget-log when using -O and -q in
|
||||
background
|
||||
|
||||
* src/log.c (check_redirect_output): Check for quiet mode
|
||||
---
|
||||
src/log.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/log.c b/src/log.c
|
||||
index d879dffe..e8cca2f3 100644
|
||||
--- a/src/log.c
|
||||
+++ b/src/log.c
|
||||
@@ -974,7 +974,7 @@ check_redirect_output (void)
|
||||
{
|
||||
pid_t foreground_pgrp = tcgetpgrp (STDIN_FILENO);
|
||||
|
||||
- if (foreground_pgrp != -1 && foreground_pgrp != getpgrp ())
|
||||
+ if (foreground_pgrp != -1 && foreground_pgrp != getpgrp () && !opt.quiet)
|
||||
{
|
||||
/* Process backgrounded */
|
||||
redirect_output (true,NULL);
|
||||
--
|
||||
2.17.1
|
||||
|
10
wget.spec
10
wget.spec
@ -1,14 +1,13 @@
|
||||
Summary: A utility for retrieving files using the HTTP or FTP protocols
|
||||
Name: wget
|
||||
Version: 1.19.5
|
||||
Release: 5%{?dist}
|
||||
Version: 1.20
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Applications/Internet
|
||||
Url: http://www.gnu.org/software/wget/
|
||||
Source: ftp://ftp.gnu.org/gnu/wget/wget-%{version}.tar.gz
|
||||
|
||||
Patch1: wget-1.17-path.patch
|
||||
Patch2: wget-1.19.5-no-log-when-quiet.patch
|
||||
|
||||
Provides: webclient
|
||||
Provides: bundled(gnulib)
|
||||
@ -33,7 +32,6 @@ sed -i "s|\(PACKAGE_STRING='wget .*\)'|\1 (Red Hat modified)'|" configure
|
||||
grep "PACKAGE_STRING='wget .* (Red Hat modified)'" configure || exit 1
|
||||
|
||||
%patch1 -p1 -b .path
|
||||
%patch2 -p1 -b .no_log_quiet
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -68,6 +66,10 @@ make check
|
||||
%{_infodir}/*
|
||||
|
||||
%changelog
|
||||
* Thu Dec 06 2018 Tomas Hozza <thozza@redhat.com> - 1.20-1
|
||||
- Update to 1.20
|
||||
- --secure-protocol=TLSv1_3 now works (#1623994)
|
||||
|
||||
* Thu Aug 29 2018 Tomas Hozza <thozza@redhat.com> - 1.19.5-5
|
||||
- Avoid creating empty wget-log when using -O and -q in background (#1484411)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user