update to 1.16.1
Signed-off-by: Tomas Hozza <thozza@redhat.com>
This commit is contained in:
parent
300076bc29
commit
194ca6f46f
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@ wget-1.12.tar.bz2
|
|||||||
/wget-1.14.tar.xz
|
/wget-1.14.tar.xz
|
||||||
/wget-1.15.tar.xz
|
/wget-1.15.tar.xz
|
||||||
/wget-1.16.tar.xz
|
/wget-1.16.tar.xz
|
||||||
|
/wget-1.16.1.tar.xz
|
||||||
|
@ -1,26 +0,0 @@
|
|||||||
From 8d7c4f611f8ec9e16b6345dc49e0d0b8704a8a30 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Jakub=20=C4=8Cajka?= <jcajka@redhat.com>
|
|
||||||
Date: Mon, 3 Nov 2014 10:34:48 +0100
|
|
||||||
Subject: [PATCH] Fix idn-cmd-utf8 and idn-robots-utf8 tests on architectures
|
|
||||||
with unsigned char
|
|
||||||
|
|
||||||
---
|
|
||||||
src/iri.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/iri.c b/src/iri.c
|
|
||||||
index e38edc9..11f2bda 100644
|
|
||||||
--- a/src/iri.c
|
|
||||||
+++ b/src/iri.c
|
|
||||||
@@ -279,7 +279,7 @@ remote_to_utf8 (struct iri *iri, const char *str, const char **new)
|
|
||||||
{
|
|
||||||
const char *p = str;
|
|
||||||
for (p = str; *p; p++)
|
|
||||||
- if (*p < 0)
|
|
||||||
+ if (*p < 0 || *p > 127)
|
|
||||||
{
|
|
||||||
*new = strdup (str);
|
|
||||||
return true;
|
|
||||||
--
|
|
||||||
1.9.3
|
|
||||||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
fe102975ab3a6c049777883f1bb9ad07 wget-1.16.tar.xz
|
78942cc0cce0a23e18114d982789e360 wget-1.16.1.tar.xz
|
||||||
|
@ -1,24 +1,24 @@
|
|||||||
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
diff -up wget-1.16.1/tests/Makefile.am.test wget-1.16.1/tests/Makefile.am
|
||||||
index 1248036..4b7aacd 100644
|
--- wget-1.16.1/tests/Makefile.am.test 2014-12-11 10:45:58.947499576 +0100
|
||||||
--- a/tests/Makefile.am
|
+++ wget-1.16.1/tests/Makefile.am 2014-12-11 10:47:12.736615080 +0100
|
||||||
+++ b/tests/Makefile.am
|
@@ -111,8 +111,6 @@ PX_TESTS = \
|
||||||
@@ -112,7 +112,6 @@ PX_TESTS = \
|
|
||||||
Test-O-nonexisting.px \
|
Test-O-nonexisting.px \
|
||||||
Test-O.px \
|
Test-O.px \
|
||||||
Test--post-file.px \
|
Test--post-file.px \
|
||||||
- Test-proxied-https-auth.px \
|
- Test-proxied-https-auth.px \
|
||||||
|
- Test-proxied-https-auth-keepalive.px \
|
||||||
Test-proxy-auth-basic.px \
|
Test-proxy-auth-basic.px \
|
||||||
Test-restrict-ascii.px \
|
Test-restrict-ascii.px \
|
||||||
Test-Restrict-Lowercase.px \
|
Test-Restrict-Lowercase.px \
|
||||||
diff --git a/tests/Makefile.in b/tests/Makefile.in
|
diff -up wget-1.16.1/tests/Makefile.in.test wget-1.16.1/tests/Makefile.in
|
||||||
index 3e6678d..de326c6 100644
|
--- wget-1.16.1/tests/Makefile.in.test 2014-12-11 10:45:58.947499576 +0100
|
||||||
--- a/tests/Makefile.in
|
+++ wget-1.16.1/tests/Makefile.in 2014-12-11 10:47:40.986659300 +0100
|
||||||
+++ b/tests/Makefile.in
|
@@ -1512,8 +1512,6 @@ PX_TESTS = \
|
||||||
@@ -1477,7 +1477,6 @@ PX_TESTS = \
|
|
||||||
Test-O-nonexisting.px \
|
Test-O-nonexisting.px \
|
||||||
Test-O.px \
|
Test-O.px \
|
||||||
Test--post-file.px \
|
Test--post-file.px \
|
||||||
- Test-proxied-https-auth.px \
|
- Test-proxied-https-auth.px \
|
||||||
|
- Test-proxied-https-auth-keepalive.px \
|
||||||
Test-proxy-auth-basic.px \
|
Test-proxy-auth-basic.px \
|
||||||
Test-restrict-ascii.px \
|
Test-restrict-ascii.px \
|
||||||
Test-Restrict-Lowercase.px \
|
Test-Restrict-Lowercase.px \
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
diff --git a/src/progress.c b/src/progress.c
|
|
||||||
index 5ba542d..1611599 100644
|
|
||||||
--- a/src/progress.c
|
|
||||||
+++ b/src/progress.c
|
|
||||||
@@ -907,10 +907,6 @@ create_image (struct bar_progress *bp, double dl_total_time, bool done)
|
|
||||||
char *p = bp->buffer;
|
|
||||||
wgint size = bp->initial_length + bp->count;
|
|
||||||
|
|
||||||
- const char *size_grouped = with_thousand_seps (size);
|
|
||||||
- int size_grouped_len = count_cols (size_grouped);
|
|
||||||
- /* Difference between num cols and num bytes: */
|
|
||||||
- int size_grouped_diff = strlen (size_grouped) - size_grouped_len;
|
|
||||||
int size_grouped_pad; /* Used to pad the field width for size_grouped. */
|
|
||||||
|
|
||||||
struct bar_progress_hist *hist = &bp->hist;
|
|
||||||
@@ -969,7 +965,7 @@ create_image (struct bar_progress *bp, double dl_total_time, bool done)
|
|
||||||
int *cols_ret = &col;
|
|
||||||
|
|
||||||
if (((orig_filename_cols > MAX_FILENAME_COLS) && !opt.noscroll) && !done)
|
|
||||||
- offset_cols = ((int) bp->tick) % (orig_filename_cols - MAX_FILENAME_COLS);
|
|
||||||
+ offset_cols = ((int) bp->tick) % (orig_filename_cols - MAX_FILENAME_COLS + 1);
|
|
||||||
else
|
|
||||||
offset_cols = 0;
|
|
||||||
offset_bytes = cols_to_bytes (bp->f_download, offset_cols, cols_ret);
|
|
||||||
@@ -1159,7 +1155,7 @@ create_image (struct bar_progress *bp, double dl_total_time, bool done)
|
|
||||||
move_to_end (p);
|
|
||||||
}
|
|
||||||
|
|
||||||
- while (p - bp->buffer - bytes_cols_diff - size_grouped_diff < bp->width)
|
|
||||||
+ while (p - bp->buffer - bytes_cols_diff < bp->width)
|
|
||||||
*p++ = ' ';
|
|
||||||
*p = '\0';
|
|
||||||
}
|
|
@ -1,6 +1,6 @@
|
|||||||
diff -up wget-1.15/doc/sample.wgetrc.munged_for_texi_inclusion.wgetrc1 wget-1.15/doc/sample.wgetrc.munged_for_texi_inclusion
|
diff -up wget-1.16.1/doc/sample.wgetrc.munged_for_texi_inclusion.path wget-1.16.1/doc/sample.wgetrc.munged_for_texi_inclusion
|
||||||
--- wget-1.15/doc/sample.wgetrc.munged_for_texi_inclusion.wgetrc1 2014-01-19 11:03:06.000000000 +0100
|
--- wget-1.16.1/doc/sample.wgetrc.munged_for_texi_inclusion.path 2014-12-08 11:25:08.000000000 +0100
|
||||||
+++ wget-1.15/doc/sample.wgetrc.munged_for_texi_inclusion 2014-01-22 14:27:36.834615751 +0100
|
+++ wget-1.16.1/doc/sample.wgetrc.munged_for_texi_inclusion 2014-12-11 09:51:56.286769486 +0100
|
||||||
@@ -10,7 +10,7 @@
|
@@ -10,7 +10,7 @@
|
||||||
## Or online here:
|
## Or online here:
|
||||||
## https://www.gnu.org/software/wget/manual/wget.html#Startup-File
|
## https://www.gnu.org/software/wget/manual/wget.html#Startup-File
|
||||||
@ -19,9 +19,9 @@ diff -up wget-1.15/doc/sample.wgetrc.munged_for_texi_inclusion.wgetrc1 wget-1.15
|
|||||||
## Think well before you change them, since they may reduce wget's
|
## Think well before you change them, since they may reduce wget's
|
||||||
## functionality, and make it behave contrary to the documentation:
|
## functionality, and make it behave contrary to the documentation:
|
||||||
##
|
##
|
||||||
diff -up wget-1.15/doc/sample.wgetrc.wgetrc1 wget-1.15/doc/sample.wgetrc
|
diff -up wget-1.16.1/doc/sample.wgetrc.path wget-1.16.1/doc/sample.wgetrc
|
||||||
--- wget-1.15/doc/sample.wgetrc.wgetrc1 2014-01-04 13:49:47.000000000 +0100
|
--- wget-1.16.1/doc/sample.wgetrc.path 2014-01-22 22:03:47.000000000 +0100
|
||||||
+++ wget-1.15/doc/sample.wgetrc 2014-01-22 14:27:13.763590317 +0100
|
+++ wget-1.16.1/doc/sample.wgetrc 2014-12-11 09:51:56.286769486 +0100
|
||||||
@@ -10,7 +10,7 @@
|
@@ -10,7 +10,7 @@
|
||||||
## Or online here:
|
## Or online here:
|
||||||
## https://www.gnu.org/software/wget/manual/wget.html#Startup-File
|
## https://www.gnu.org/software/wget/manual/wget.html#Startup-File
|
||||||
@ -40,9 +40,9 @@ diff -up wget-1.15/doc/sample.wgetrc.wgetrc1 wget-1.15/doc/sample.wgetrc
|
|||||||
## Think well before you change them, since they may reduce wget's
|
## Think well before you change them, since they may reduce wget's
|
||||||
## functionality, and make it behave contrary to the documentation:
|
## functionality, and make it behave contrary to the documentation:
|
||||||
##
|
##
|
||||||
diff -up wget-1.15/doc/wget.info.wgetrc1 wget-1.15/doc/wget.info
|
diff -up wget-1.16.1/doc/wget.info.path wget-1.16.1/doc/wget.info
|
||||||
--- wget-1.15/doc/wget.info.wgetrc1 2014-01-21 17:18:38.395689764 +0100
|
--- wget-1.16.1/doc/wget.info.path 2014-12-08 11:25:09.000000000 +0100
|
||||||
+++ wget-1.15/doc/wget.info 2014-01-22 14:29:58.514772363 +0100
|
+++ wget-1.16.1/doc/wget.info 2014-12-11 09:51:56.287769488 +0100
|
||||||
@@ -111,7 +111,7 @@ retrieval through HTTP proxies.
|
@@ -111,7 +111,7 @@ retrieval through HTTP proxies.
|
||||||
* Most of the features are fully configurable, either through command
|
* Most of the features are fully configurable, either through command
|
||||||
line options, or via the initialization file '.wgetrc' (*note
|
line options, or via the initialization file '.wgetrc' (*note
|
||||||
@ -52,7 +52,7 @@ diff -up wget-1.15/doc/wget.info.wgetrc1 wget-1.15/doc/wget.info
|
|||||||
also specify the location of a startup file with the -config
|
also specify the location of a startup file with the -config
|
||||||
option.
|
option.
|
||||||
|
|
||||||
@@ -2484,8 +2484,8 @@ File: wget.info, Node: Wgetrc Location,
|
@@ -2532,8 +2532,8 @@ File: wget.info, Node: Wgetrc Location,
|
||||||
===================
|
===================
|
||||||
|
|
||||||
When initializing, Wget will look for a "global" startup file,
|
When initializing, Wget will look for a "global" startup file,
|
||||||
@ -63,7 +63,7 @@ diff -up wget-1.15/doc/wget.info.wgetrc1 wget-1.15/doc/wget.info
|
|||||||
there, if it exists.
|
there, if it exists.
|
||||||
|
|
||||||
Then it will look for the user's file. If the environmental variable
|
Then it will look for the user's file. If the environmental variable
|
||||||
@@ -2496,7 +2496,7 @@ further attempts will be made.
|
@@ -2544,7 +2544,7 @@ further attempts will be made.
|
||||||
|
|
||||||
The fact that user's settings are loaded after the system-wide ones
|
The fact that user's settings are loaded after the system-wide ones
|
||||||
means that in case of collision user's wgetrc _overrides_ the
|
means that in case of collision user's wgetrc _overrides_ the
|
||||||
@ -72,7 +72,7 @@ diff -up wget-1.15/doc/wget.info.wgetrc1 wget-1.15/doc/wget.info
|
|||||||
admins, away!
|
admins, away!
|
||||||
|
|
||||||
|
|
||||||
@@ -3028,7 +3028,7 @@ its line.
|
@@ -3076,7 +3076,7 @@ its line.
|
||||||
## Or online here:
|
## Or online here:
|
||||||
## https://www.gnu.org/software/wget/manual/wget.html#Startup-File
|
## https://www.gnu.org/software/wget/manual/wget.html#Startup-File
|
||||||
##
|
##
|
||||||
@ -81,9 +81,9 @@ diff -up wget-1.15/doc/wget.info.wgetrc1 wget-1.15/doc/wget.info
|
|||||||
## (global, for all users) or $HOME/.wgetrc (for a single user).
|
## (global, for all users) or $HOME/.wgetrc (for a single user).
|
||||||
##
|
##
|
||||||
## To use the settings in this file, you will have to uncomment them,
|
## To use the settings in this file, you will have to uncomment them,
|
||||||
diff -up wget-1.15/doc/wget.texi.wgetrc1 wget-1.15/doc/wget.texi
|
diff -up wget-1.16.1/doc/wget.texi.path wget-1.16.1/doc/wget.texi
|
||||||
--- wget-1.15/doc/wget.texi.wgetrc1 2014-01-04 13:49:47.000000000 +0100
|
--- wget-1.16.1/doc/wget.texi.path 2014-11-11 15:23:33.000000000 +0100
|
||||||
+++ wget-1.15/doc/wget.texi 2014-01-21 17:18:38.396689766 +0100
|
+++ wget-1.16.1/doc/wget.texi 2014-12-11 09:51:56.288769489 +0100
|
||||||
@@ -190,14 +190,14 @@ gauge can be customized to your preferen
|
@@ -190,14 +190,14 @@ gauge can be customized to your preferen
|
||||||
Most of the features are fully configurable, either through command line
|
Most of the features are fully configurable, either through command line
|
||||||
options, or via the initialization file @file{.wgetrc} (@pxref{Startup
|
options, or via the initialization file @file{.wgetrc} (@pxref{Startup
|
||||||
@ -101,7 +101,7 @@ diff -up wget-1.15/doc/wget.texi.wgetrc1 wget-1.15/doc/wget.texi
|
|||||||
Default location of the @dfn{global} startup file.
|
Default location of the @dfn{global} startup file.
|
||||||
|
|
||||||
@item .wgetrc
|
@item .wgetrc
|
||||||
@@ -2817,8 +2817,8 @@ commands.
|
@@ -2869,8 +2869,8 @@ commands.
|
||||||
@cindex location of wgetrc
|
@cindex location of wgetrc
|
||||||
|
|
||||||
When initializing, Wget will look for a @dfn{global} startup file,
|
When initializing, Wget will look for a @dfn{global} startup file,
|
||||||
@ -112,7 +112,7 @@ diff -up wget-1.15/doc/wget.texi.wgetrc1 wget-1.15/doc/wget.texi
|
|||||||
from there, if it exists.
|
from there, if it exists.
|
||||||
|
|
||||||
Then it will look for the user's file. If the environmental variable
|
Then it will look for the user's file. If the environmental variable
|
||||||
@@ -2829,7 +2829,7 @@ If @code{WGETRC} is not set, Wget will t
|
@@ -2881,7 +2881,7 @@ If @code{WGETRC} is not set, Wget will t
|
||||||
|
|
||||||
The fact that user's settings are loaded after the system-wide ones
|
The fact that user's settings are loaded after the system-wide ones
|
||||||
means that in case of collision user's wgetrc @emph{overrides} the
|
means that in case of collision user's wgetrc @emph{overrides} the
|
||||||
@ -121,10 +121,10 @@ diff -up wget-1.15/doc/wget.texi.wgetrc1 wget-1.15/doc/wget.texi
|
|||||||
Fascist admins, away!
|
Fascist admins, away!
|
||||||
|
|
||||||
@node Wgetrc Syntax, Wgetrc Commands, Wgetrc Location, Startup File
|
@node Wgetrc Syntax, Wgetrc Commands, Wgetrc Location, Startup File
|
||||||
diff -up wget-1.15/NEWS.wgetrc1 wget-1.15/NEWS
|
diff -up wget-1.16.1/NEWS.path wget-1.16.1/NEWS
|
||||||
--- wget-1.15/NEWS.wgetrc1 2014-01-12 21:31:51.000000000 +0100
|
--- wget-1.16.1/NEWS.path 2014-12-08 11:30:12.000000000 +0100
|
||||||
+++ wget-1.15/NEWS 2014-01-21 17:18:38.394689763 +0100
|
+++ wget-1.16.1/NEWS 2014-12-11 10:30:40.022160421 +0100
|
||||||
@@ -700,7 +700,7 @@ distributed with Wget.
|
@@ -741,7 +741,7 @@ distributed with Wget.
|
||||||
|
|
||||||
** Compiles on pre-ANSI compilers.
|
** Compiles on pre-ANSI compilers.
|
||||||
|
|
||||||
@ -132,8 +132,8 @@ diff -up wget-1.15/NEWS.wgetrc1 wget-1.15/NEWS
|
|||||||
+** Global wgetrc now goes to /etc (i.e. $sysconfdir).
|
+** Global wgetrc now goes to /etc (i.e. $sysconfdir).
|
||||||
|
|
||||||
** Lots of bugfixes.
|
** Lots of bugfixes.
|
||||||
|
|
||||||
@@ -763,7 +763,7 @@ Emacs, standalone info, or converted to
|
@@ -804,7 +804,7 @@ Emacs, standalone info, or converted to
|
||||||
** Fixed a long-standing bug, so that Wget now works over SLIP
|
** Fixed a long-standing bug, so that Wget now works over SLIP
|
||||||
connections.
|
connections.
|
||||||
|
|
||||||
@ -142,9 +142,9 @@ diff -up wget-1.15/NEWS.wgetrc1 wget-1.15/NEWS
|
|||||||
default). Settings in $HOME/.wgetrc override the global ones, of
|
default). Settings in $HOME/.wgetrc override the global ones, of
|
||||||
course :-)
|
course :-)
|
||||||
|
|
||||||
diff -up wget-1.15/README.wgetrc1 wget-1.15/README
|
diff -up wget-1.16.1/README.path wget-1.16.1/README
|
||||||
--- wget-1.15/README.wgetrc1 2013-10-21 16:50:12.000000000 +0200
|
--- wget-1.16.1/README.path 2013-10-21 16:50:12.000000000 +0200
|
||||||
+++ wget-1.15/README 2014-01-21 17:18:38.394689763 +0100
|
+++ wget-1.16.1/README 2014-12-11 09:51:56.288769489 +0100
|
||||||
@@ -33,7 +33,7 @@ for socks.
|
@@ -33,7 +33,7 @@ for socks.
|
||||||
|
|
||||||
Most of the features are configurable, either through command-line
|
Most of the features are configurable, either through command-line
|
@ -3,9 +3,9 @@
|
|||||||
@@ -561,7 +561,7 @@
|
@@ -561,7 +561,7 @@
|
||||||
PACKAGE_NAME='wget'
|
PACKAGE_NAME='wget'
|
||||||
PACKAGE_TARNAME='wget'
|
PACKAGE_TARNAME='wget'
|
||||||
PACKAGE_VERSION='1.16'
|
PACKAGE_VERSION='1.16.1'
|
||||||
-PACKAGE_STRING='wget 1.16'
|
-PACKAGE_STRING='wget 1.16.1'
|
||||||
+PACKAGE_STRING='wget 1.16 (Red Hat modified)'
|
+PACKAGE_STRING='wget 1.16.1 (Red Hat modified)'
|
||||||
PACKAGE_BUGREPORT='bug-wget@gnu.org'
|
PACKAGE_BUGREPORT='bug-wget@gnu.org'
|
||||||
PACKAGE_URL=''
|
PACKAGE_URL=''
|
||||||
|
|
||||||
|
16
wget.spec
16
wget.spec
@ -1,18 +1,15 @@
|
|||||||
Summary: A utility for retrieving files using the HTTP or FTP protocols
|
Summary: A utility for retrieving files using the HTTP or FTP protocols
|
||||||
Name: wget
|
Name: wget
|
||||||
Version: 1.16
|
Version: 1.16.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
Url: http://www.gnu.org/software/wget/
|
Url: http://www.gnu.org/software/wget/
|
||||||
Source: ftp://ftp.gnu.org/gnu/wget/wget-%{version}.tar.xz
|
Source: ftp://ftp.gnu.org/gnu/wget/wget-%{version}.tar.xz
|
||||||
|
|
||||||
Patch1: wget-rh-modified.patch
|
Patch1: wget-rh-modified.patch
|
||||||
Patch2: wget-1.15-path.patch
|
Patch2: wget-1.16.1-path.patch
|
||||||
Patch3: wget-1.16-dont-run-failing-test.patch
|
Patch3: wget-1.16-dont-run-failing-test.patch
|
||||||
# sent to upstream mailing list
|
|
||||||
Patch4: 0001-Fix-idn-cmd-utf8-and-idn-robots-utf8-tests-on-archit.patch
|
|
||||||
Patch5: wget-1.16-fix_progress_bar.patch
|
|
||||||
|
|
||||||
Provides: webclient
|
Provides: webclient
|
||||||
Provides: bundled(gnulib)
|
Provides: bundled(gnulib)
|
||||||
@ -34,13 +31,11 @@ support for Proxy servers, and configurability.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p0
|
%patch1 -p0 -b .rh_modified
|
||||||
%patch2 -p1 -b .path
|
%patch2 -p1 -b .path
|
||||||
# don't run the Test-proxied-https-auth.px test since it fails with OpenSSL
|
# don't run the Test-proxied-https-auth.px test since it fails with OpenSSL
|
||||||
# upstream is working on fix and will be fixed most probably in 1.16.1
|
# upstream is working on fix and will be fixed most probably in 1.16.1
|
||||||
%patch3 -p1 -b .test
|
%patch3 -p1 -b .test
|
||||||
%patch4 -p1 -b .char
|
|
||||||
%patch5 -p1 -b .progress_bar
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
if pkg-config openssl ; then
|
if pkg-config openssl ; then
|
||||||
@ -80,6 +75,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_infodir}/*
|
%{_infodir}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 11 2014 Tomas Hozza <thozza@redhat.com> - 1.16.1-1
|
||||||
|
- update to 1.16.1
|
||||||
|
|
||||||
* Tue Nov 18 2014 Tomas Hozza <thozza@redhat.com> - 1.16-3
|
* Tue Nov 18 2014 Tomas Hozza <thozza@redhat.com> - 1.16-3
|
||||||
- Fix the progress bar issue (#1159643)
|
- Fix the progress bar issue (#1159643)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user