RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/waypipe#9ac858fa4f7c30a5a5cb86342f662848c38f0715
This commit is contained in:
parent
426b1ba624
commit
f30d64e16e
2
.gitignore
vendored
2
.gitignore
vendored
@ -0,0 +1,2 @@
|
||||
/waypipe-v0.6.0.tar.gz
|
||||
/waypipe-v0.6.1.tar.gz
|
57
0001-Use-subprocess.Popen-for-startup-failure-test.patch
Normal file
57
0001-Use-subprocess.Popen-for-startup-failure-test.patch
Normal file
@ -0,0 +1,57 @@
|
||||
From 68e6782cb5ebe9f9a17cc28f23687ec2ebc54af0 Mon Sep 17 00:00:00 2001
|
||||
From: Manuel Stoeckl <code@mstoeckl.com>
|
||||
Date: Thu, 28 Nov 2019 12:01:16 -0500
|
||||
Subject: [PATCH] Use subprocess.Popen for startup failure test
|
||||
|
||||
According to the Python documentation, the new usage should be valid
|
||||
for Python >=3.3, covering a wider range than the >=3.5 for
|
||||
subprocess.Popen. Also, this change avoids a possible regression
|
||||
with Python 3.8.0 in which the TimeoutExpired exception no longer
|
||||
provides a non-None .output field.
|
||||
---
|
||||
test/startup_failure.py | 24 ++++++++++++------------
|
||||
1 file changed, 12 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/test/startup_failure.py b/test/startup_failure.py
|
||||
index 3d4117a..ae988b2 100755
|
||||
--- a/test/startup_failure.py
|
||||
+++ b/test/startup_failure.py
|
||||
@@ -53,23 +53,23 @@ def run_test(name, command, env, use_socketpair, expect_success):
|
||||
pfds = []
|
||||
|
||||
timed_out = False
|
||||
+ proc = subprocess.Popen(
|
||||
+ command,
|
||||
+ env=env,
|
||||
+ stdin=subprocess.DEVNULL,
|
||||
+ stdout=subprocess.PIPE,
|
||||
+ stderr=subprocess.STDOUT,
|
||||
+ pass_fds=pfds,
|
||||
+ )
|
||||
try:
|
||||
- proc = subprocess.run(
|
||||
- command,
|
||||
- env=env,
|
||||
- stdin=subprocess.DEVNULL,
|
||||
- stdout=subprocess.PIPE,
|
||||
- stderr=subprocess.STDOUT,
|
||||
- timeout=0.25,
|
||||
- pass_fds=pfds,
|
||||
- )
|
||||
+ output, none = proc.communicate(timeout=0.25)
|
||||
except subprocess.TimeoutExpired as e:
|
||||
- timed_out = True
|
||||
- output = e.output
|
||||
# Program began to wait for a connection
|
||||
+ proc.kill()
|
||||
+ output, none = proc.communicate()
|
||||
retcode = 0 if "client" in command else (0 if expect_success else 1)
|
||||
+ timed_out = True
|
||||
else:
|
||||
- output = proc.stdout
|
||||
retcode = proc.returncode
|
||||
|
||||
if use_socketpair:
|
||||
--
|
||||
2.26.2
|
||||
|
1
sources
Normal file
1
sources
Normal file
@ -0,0 +1 @@
|
||||
SHA512 (waypipe-v0.6.1.tar.gz) = 7b7cdc6d808f8f9e3720425af6ca1a75b81ffadc990e181f52940320efab6d5c6b55dcc10adb36c90b784426a71fab2a037206f4cb2634775628b52dc27cb830
|
78
waypipe.spec
Normal file
78
waypipe.spec
Normal file
@ -0,0 +1,78 @@
|
||||
Name: waypipe
|
||||
Version: 0.6.1
|
||||
Release: 7%{?dist}
|
||||
Summary: Wayland forwarding proxy
|
||||
|
||||
License: MIT
|
||||
URL: https://gitlab.freedesktop.org/mstoeckl/%{name}
|
||||
Source0: https://gitlab.freedesktop.org/mstoeckl/%{name}/-/archive/v%{version}/%{name}-v%{version}.tar.gz
|
||||
Patch0: 0001-Use-subprocess.Popen-for-startup-failure-test.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: meson
|
||||
BuildRequires: scdoc
|
||||
BuildRequires: pkgconfig(gbm)
|
||||
BuildRequires: pkgconfig(libdrm)
|
||||
BuildRequires: pkgconfig(liblz4)
|
||||
BuildRequires: pkgconfig(libzstd)
|
||||
BuildRequires: pkgconfig(libva)
|
||||
BuildRequires: pkgconfig(wayland-protocols)
|
||||
BuildRequires: pkgconfig(wayland-client)
|
||||
BuildRequires: pkgconfig(wayland-server)
|
||||
|
||||
%description
|
||||
Waypipe is a proxy for Wayland clients. It forwards Wayland messages and
|
||||
serializes changes to shared memory buffers over a single socket. This makes
|
||||
application forwarding similar to "ssh -X" feasible.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-v%{version}
|
||||
%patch0 -p1
|
||||
|
||||
|
||||
%build
|
||||
%meson -Dwith_video=disabled -Dwerror=false
|
||||
%meson_build
|
||||
|
||||
|
||||
%install
|
||||
%meson_install
|
||||
|
||||
|
||||
%check
|
||||
%meson_test
|
||||
|
||||
|
||||
%files
|
||||
%{_bindir}/waypipe
|
||||
%{_mandir}/man1/waypipe.1*
|
||||
%doc CONTRIBUTING.md README.md
|
||||
%license COPYING
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Sep 28 2020 Jeff Law <law@redhat.com> - 0.6.1-7
|
||||
- Re-enable LTO as upstream GCC target/96939 has been fixed
|
||||
|
||||
* Mon Aug 10 2020 Jeff Law <law@redhat.com> - 0.6.1-6
|
||||
- Disable LTO for now.
|
||||
|
||||
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1-5
|
||||
- Second attempt - Rebuilt for
|
||||
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon May 11 2020 Dominique Martinet <asmadeus@codewreck.org> - 0.6.1-3
|
||||
- Fix FTBS (test failure)
|
||||
|
||||
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Wed Aug 28 2019 Lubomir Rintel <lkundrak@v3.sk> - 0.6.1-1
|
||||
- Update to version 0.6.1
|
||||
|
||||
* Thu Aug 22 2019 Lubomir Rintel <lkundrak@v3.sk> - 0.6.0-1
|
||||
- Initial packaging
|
Loading…
Reference in New Issue
Block a user