Update to 1.13.91
This commit is contained in:
parent
8e4b8384e7
commit
5a86549969
1
.gitignore
vendored
1
.gitignore
vendored
@ -41,3 +41,4 @@
|
|||||||
/wayland-1.12.0.tar.xz
|
/wayland-1.12.0.tar.xz
|
||||||
/wayland-1.12.91.tar.xz
|
/wayland-1.12.91.tar.xz
|
||||||
/wayland-1.13.0.tar.xz
|
/wayland-1.13.0.tar.xz
|
||||||
|
/wayland-1.13.91.tar.xz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (wayland-1.13.0.tar.xz) = 163bae2c2c2e79e03dda9a57b1e3a1060eff9e0b053b70ad00a6949a1d40f4c40d0244340c2603109fcbfe919533c2ce196338b27587fd3bda996e615d51e543
|
SHA512 (wayland-1.13.91.tar.xz) = 510772ab7e5dd89853b58ea5314f8eb4be7edbb3933589e3a6d82561967b767e85f37b008648b2cd04b63121b0544156d897b89b004af9579d007f8e39fc9ba6
|
||||||
|
@ -1,55 +0,0 @@
|
|||||||
From patchwork Thu Feb 23 12:47:41 2017
|
|
||||||
Content-Type: text/plain; charset="utf-8"
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Transfer-Encoding: 7bit
|
|
||||||
Subject: tests: Fix "new ID" type handling in argument_from_va_list test
|
|
||||||
From: Carlos Garnacho <carlosg@gnome.org>
|
|
||||||
X-Patchwork-Id: 140495
|
|
||||||
Message-Id: <20170223124741.471-1-carlosg@gnome.org>
|
|
||||||
To: wayland-devel@lists.freedesktop.org
|
|
||||||
Cc: Carlos Garnacho <carlosg@gnome.org>
|
|
||||||
Date: Thu, 23 Feb 2017 13:47:41 +0100
|
|
||||||
|
|
||||||
New IDs are internally dealt with as objects, however this test
|
|
||||||
expected to deal with 'n' as the uint32_t type that's just seen
|
|
||||||
through the wire. We should give it an object instead, and
|
|
||||||
expect an object from it.
|
|
||||||
|
|
||||||
https://bugs.freedesktop.org/show_bug.cgi?id=99899
|
|
||||||
|
|
||||||
Signed-off-by: Carlos Garnacho <carlosg@gnome.org>
|
|
||||||
Reviewed-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
|
|
||||||
Tested-by: Kalev Lember <kalevlember@gmail.com>
|
|
||||||
---
|
|
||||||
tests/connection-test.c | 6 +++---
|
|
||||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/tests/connection-test.c b/tests/connection-test.c
|
|
||||||
index 1c688f1..8be6c38 100644
|
|
||||||
--- a/tests/connection-test.c
|
|
||||||
+++ b/tests/connection-test.c
|
|
||||||
@@ -142,7 +142,7 @@ va_list_wrapper(const char *signature, union wl_argument *args, int count, ...)
|
|
||||||
TEST(argument_from_va_list)
|
|
||||||
{
|
|
||||||
union wl_argument args[WL_CLOSURE_MAX_ARGS];
|
|
||||||
- struct wl_object fake_object;
|
|
||||||
+ struct wl_object fake_object, fake_new_object;
|
|
||||||
struct wl_array fake_array;
|
|
||||||
|
|
||||||
va_list_wrapper("i", args, 1, 100);
|
|
||||||
@@ -154,13 +154,13 @@ TEST(argument_from_va_list)
|
|
||||||
|
|
||||||
va_list_wrapper("?iuf?sonah", args, 8,
|
|
||||||
102, 103, wl_fixed_from_int(104), "value",
|
|
||||||
- &fake_object, 105, &fake_array, 106);
|
|
||||||
+ &fake_object, &fake_new_object, &fake_array, 106);
|
|
||||||
assert(args[0].i == 102);
|
|
||||||
assert(args[1].u == 103);
|
|
||||||
assert(args[2].f == wl_fixed_from_int(104));
|
|
||||||
assert(strcmp(args[3].s, "value") == 0);
|
|
||||||
assert(args[4].o == &fake_object);
|
|
||||||
- assert(args[5].n == 105);
|
|
||||||
+ assert(args[5].o == &fake_new_object);
|
|
||||||
assert(args[6].a == &fake_array);
|
|
||||||
assert(args[7].h == 106);
|
|
||||||
}
|
|
10
wayland.spec
10
wayland.spec
@ -1,13 +1,11 @@
|
|||||||
Name: wayland
|
Name: wayland
|
||||||
Version: 1.13.0
|
Version: 1.13.91
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Wayland Compositor Infrastructure
|
Summary: Wayland Compositor Infrastructure
|
||||||
|
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://wayland.freedesktop.org/
|
URL: http://wayland.freedesktop.org/
|
||||||
Source0: http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
|
Source0: http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
|
||||||
# Fix the tests to pass on ppc64
|
|
||||||
Patch0: tests-Fix-new-ID-type-handling-in-argument_from_va_list-test.patch
|
|
||||||
# https://lists.freedesktop.org/archives/wayland-devel/2017-June/034218.html
|
# https://lists.freedesktop.org/archives/wayland-devel/2017-June/034218.html
|
||||||
Patch1: Switch-graphviz-files-to-use-HTML-style-labels.patch
|
Patch1: Switch-graphviz-files-to-use-HTML-style-labels.patch
|
||||||
|
|
||||||
@ -71,7 +69,6 @@ Wayland server library
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
|
||||||
|
|
||||||
@ -133,6 +130,9 @@ XDG_RUNTIME_DIR=$PWD/tests/run make check || \
|
|||||||
%{_libdir}/libwayland-server.so.0*
|
%{_libdir}/libwayland-server.so.0*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 19 2017 Kalev Lember <klember@redhat.com> - 1.13.91-1
|
||||||
|
- Update to 1.13.91
|
||||||
|
|
||||||
* Thu Jun 1 2017 Owen Taylor otaylor@redhat.com> - 1.13.0-2
|
* Thu Jun 1 2017 Owen Taylor otaylor@redhat.com> - 1.13.0-2
|
||||||
- Add a patch fixing a build error with newer versions of graphviz
|
- Add a patch fixing a build error with newer versions of graphviz
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user