import watchdog-5.16-1.el9
This commit is contained in:
commit
dfbfffff6f
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/watchdog-5.16.tar.gz
|
1
.watchdog.metadata
Normal file
1
.watchdog.metadata
Normal file
@ -0,0 +1 @@
|
||||
22eb80e1d29ba5b8c98d644d8358e2cf6535bcf1 SOURCES/watchdog-5.16.tar.gz
|
@ -0,0 +1,43 @@
|
||||
From 80468a84ea3044a5227c57a258dc6e508c88d468 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Wed, 6 Feb 2019 13:25:47 +0000
|
||||
Subject: [PATCH] Choose libtirpc or another RPC library for XDR headers and
|
||||
library.
|
||||
|
||||
Signed-off-by: Richard W.M. Jones <rjones@redhat.com>
|
||||
---
|
||||
configure.ac | 20 ++++++++++++++++++++
|
||||
1 file changed, 20 insertions(+)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 4294146..be62260 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -158,4 +158,24 @@ AC_ARG_WITH(randomseed,
|
||||
AC_MSG_RESULT("/var/run/random-seed")
|
||||
])
|
||||
|
||||
+# Check for an RPC library, starting with libtirpc.
|
||||
+PKG_CHECK_MODULES([RPC], [libtirpc], [], [
|
||||
+ # If we don't have libtirpc, then we must have <rpc/rpc.h> and
|
||||
+ # some library to link to in libdir.
|
||||
+ RPC_CFLAGS=""
|
||||
+ AC_CHECK_HEADER([rpc/rpc.h],[],[
|
||||
+ AC_MSG_ERROR([XDR header files are required])
|
||||
+ ],
|
||||
+ [#include <rpc/types.h>])
|
||||
+
|
||||
+ old_LIBS="$LIBS"
|
||||
+ LIBS=""
|
||||
+ AC_SEARCH_LIBS([xdrmem_create],[rpc xdr nsl])
|
||||
+ RPC_LIBS="$LIBS"
|
||||
+ LIBS="$old_LIBS"
|
||||
+
|
||||
+ AC_SUBST([RPC_CFLAGS])
|
||||
+ AC_SUBST([RPC_LIBS])
|
||||
+])
|
||||
+
|
||||
AC_OUTPUT([Makefile src/Makefile])
|
||||
--
|
||||
2.31.1
|
||||
|
142
SOURCES/0099-watchdog-5.16-rhseldoc.patch
Normal file
142
SOURCES/0099-watchdog-5.16-rhseldoc.patch
Normal file
@ -0,0 +1,142 @@
|
||||
diff --git a/watchdog.8 b/watchdog.8
|
||||
index 9b7c6e7..052b1e1 100644
|
||||
--- a/watchdog.8
|
||||
+++ b/watchdog.8
|
||||
@@ -216,6 +216,7 @@ by
|
||||
.BR watchdog .
|
||||
So you can for instance restart the server from your
|
||||
.IR repair-binary .
|
||||
+See the Systemd section below for additinal information.
|
||||
.PP
|
||||
.B watchdog
|
||||
will try periodically to fork itself to see whether the process
|
||||
@@ -242,6 +243,8 @@ a given interface for traffic. If no traffic arrives the network is
|
||||
considered unreachable causing a soft reboot or action from the
|
||||
repair binary.
|
||||
.PP
|
||||
+To start the watchdog when network is available see the Systemd section below.
|
||||
+.PP
|
||||
.B watchdog
|
||||
can run an external command for user-defined tests. A return code not equal 0
|
||||
means an error occurred and watchdog should react. If the external command is
|
||||
@@ -348,6 +351,9 @@ Child process did not return in time.
|
||||
246
|
||||
Free for personal watchdog-specific use (was \-10 as an unsigned 8\-bit
|
||||
number).
|
||||
+.PP
|
||||
+With enforcing SELinux policy please use the /usr/libexec/watchdog/scripts/
|
||||
+for your test-binary configuration.
|
||||
.TP
|
||||
245
|
||||
Reserved for an unknown result, for example a slow background test that is
|
||||
@@ -375,6 +381,9 @@ repair-maximum
|
||||
controls the number of successive repair attempts that report 0 (i.e. success) but
|
||||
fail to clear the tested fault. If this is exceeded then a reboot takes place. If set
|
||||
to zero then a reboot can always be blocked by the repair program reporting success.
|
||||
+.PP
|
||||
+With enforcing SELinux policy please use the /usr/libexec/watchdog/scripts/
|
||||
+for your repair-binary configuration.
|
||||
.SH "TEST DIRECTORY"
|
||||
Executables placed in the test directory are discovered by watchdog on
|
||||
startup and are automatically executed. They are bounded time-wise by
|
||||
@@ -413,6 +422,27 @@ As for the repair binary, the configuration parameter
|
||||
repair-maximum
|
||||
also controls the number of successive repair attempts that report success
|
||||
(return 0) but fail to clear the fault.
|
||||
+.SH SYSTEMD
|
||||
+To start watchdog after the network is available:
|
||||
+.PP
|
||||
+.br
|
||||
+systemctl disable watchdog
|
||||
+.br
|
||||
+systemctl enable NetworkManager-wait-online
|
||||
+.br
|
||||
+systemctl enable watchdog-ping
|
||||
+.PP
|
||||
+
|
||||
+When using custom service pid check with custom service
|
||||
+systemd unit file please be aware the "Requires="
|
||||
+does dependent service deactivation.
|
||||
+Using "Before=watchdog.service" or "Before=watchdog-ping.service"
|
||||
+in the custom service unit file may be the desired operation instead.
|
||||
+See systemd.unit documentation for more details.
|
||||
+
|
||||
+.SH SELINUX
|
||||
+The directories /etc/watchdog.d/ and /usr/libexec/watchdog/scripts/ are
|
||||
+recognized locations for custom executables.
|
||||
.SH BUGS
|
||||
None known so far.
|
||||
.SH AUTHORS
|
||||
@@ -431,4 +461,4 @@ The watchdog device.
|
||||
The pid file of the running
|
||||
.BR watchdog .
|
||||
.SH "SEE ALSO"
|
||||
-.BR watchdog.conf (5)
|
||||
+.BR watchdog.conf (5), systemd.unit (5)
|
||||
diff --git a/watchdog.conf b/watchdog.conf
|
||||
index 207da3e..7dd3cb3 100644
|
||||
--- a/watchdog.conf
|
||||
+++ b/watchdog.conf
|
||||
@@ -75,7 +75,9 @@ priority = 1
|
||||
# If you have a custom binary/script to handle errors then uncomment
|
||||
# this line and provide the path. For 'v1' test binary files they also
|
||||
# handle error cases.
|
||||
-
|
||||
+# With enforcing SELinux policy please use the /usr/libexec/watchdog/scripts/
|
||||
+
|
||||
+# or /etc/watchdog.d/ for your test-binary and repair-binary configuration.
|
||||
#repair-binary = /usr/sbin/repair
|
||||
#repair-timeout = 60
|
||||
|
||||
@@ -175,6 +177,13 @@ priority = 1
|
||||
#temperature-sensor =
|
||||
#max-temperature = 90
|
||||
|
||||
+# When using custom service pid check with custom service
|
||||
+# systemd unit file please be aware the "Requires="
|
||||
+# does dependent service deactivation.
|
||||
+# Using "Before=watchdog.service" or "Before=watchdog-ping.service"
|
||||
+# in the custom service unit file may be the desired operation instead.
|
||||
+# See man 5 systemd.unit for more details.
|
||||
+#
|
||||
# Check for a running process/daemon by its PID file. For example,
|
||||
# check if rsyslogd is still running by enabling the following line:
|
||||
|
||||
diff --git a/watchdog.conf.5 b/watchdog.conf.5
|
||||
index edf7c8b..72c3bc2 100644
|
||||
--- a/watchdog.conf.5
|
||||
+++ b/watchdog.conf.5
|
||||
@@ -130,6 +130,7 @@ pidfile = <pidfilename>
|
||||
Set pidfile name for daemon test mode.
|
||||
This option can be given as often as you like to check several daemons, assuming
|
||||
they write their post-forking PID to the specified files.
|
||||
+See the Systemd section in watchdog (8) for more information.
|
||||
.TP
|
||||
ping = <ip-addr>
|
||||
Set IPv4 address for ping mode.
|
||||
@@ -147,6 +148,8 @@ aliased IP interfaces.
|
||||
.TP
|
||||
test-binary = <testbin>
|
||||
Execute the given binary to do some user defined tests.
|
||||
+With enforcing SELinux policy please use the /usr/libexec/watchdog/scripts/
|
||||
+for your test-binary configuration.
|
||||
.TP
|
||||
test-timeout = <timeout in seconds>
|
||||
User defined tests may only run for <timeout> seconds. Set to 0 for unlimited.
|
||||
@@ -154,6 +157,8 @@ User defined tests may only run for <timeout> seconds. Set to 0 for unlimited.
|
||||
repair-binary = <repbin>
|
||||
Execute the given binary in case of a problem instead of shutting down the
|
||||
system.
|
||||
+With enforcing SELinux policy please use the /usr/libexec/watchdog/scripts/
|
||||
+for your repair-binary configuration.
|
||||
.TP
|
||||
repair-timeout = <timeout in seconds>
|
||||
repair command may only run for <timeout> seconds. Set to 0 for 'unlimited', but
|
||||
@@ -188,6 +193,7 @@ Set the schedule priority for realtime mode passed to sched_setscheduler().
|
||||
.TP
|
||||
test-directory = <test directory>
|
||||
Set the directory to run user test/repair scripts. Default is '/etc/watchdog.d'
|
||||
+The /etc/watchdog.d/ is recognized by SELinux policy.
|
||||
See the Test Directory section in watchdog(8) for more information.
|
||||
.TP
|
||||
log-dir = <log directory>
|
34
SOURCES/README.Fedora
Normal file
34
SOURCES/README.Fedora
Normal file
@ -0,0 +1,34 @@
|
||||
This is the watchdog package for Fedora. It implements a userspace
|
||||
daemon which periodically pings (usually hardware) to tell the
|
||||
hardware that the machine is alive. If the hardware times out without
|
||||
receiving a ping, it assumes userspace is dead and reboots the
|
||||
machine.
|
||||
|
||||
There are several major classes of watchdog available:
|
||||
|
||||
- watchdog hardware implementing the Linux /dev/watchdog API
|
||||
|
||||
* drivers in /lib/modules/$(uname -r)/kernel/drivers/watchdog/
|
||||
* http://lxr.linux.no/linux/Documentation/watchdog/watchdog-api.txt
|
||||
|
||||
- softdog
|
||||
|
||||
* software watchdog (just runs inside the kernel)
|
||||
* implements the Linux /dev/watchdog API
|
||||
* won't help you if the kernel fails (obvious, right?)
|
||||
|
||||
- IPMI
|
||||
|
||||
* a heavyweight standard for all things server-management
|
||||
* separate Linux driver
|
||||
* ipmitool to control it
|
||||
* see README.watchdog.ipmi for how to use this daemon together
|
||||
with IPMI
|
||||
|
||||
You can also use watchdogs inside recent QEMU/KVM virtual machines.
|
||||
When running qemu, specify "-watchdog i6300esb" on the qemu command
|
||||
line (or use libvirt). Inside the guest, the i6300esb watchdog driver
|
||||
should automatically load and provide you with a Linux /dev/watchdog-
|
||||
compatible API.
|
||||
|
||||
- Richard W.M. Jones (rjones@redhat.com) 2009-02-26
|
107
SOURCES/README.watchdog.ipmi
Normal file
107
SOURCES/README.watchdog.ipmi
Normal file
@ -0,0 +1,107 @@
|
||||
|
||||
Instructions for how to set up the watchdog daemon to work with IPMI's hardware watchdog
|
||||
----------------------------------------------------------------------------------------
|
||||
|
||||
First, verify that the ipmitool utility is present on the system to allow
|
||||
the watchdog timer to be turned off via the command line (which ipmitool).
|
||||
This will allow the hardware watchdog timer to be turned off gracefully
|
||||
should it ever become necessary. If ipmitool is not present, install
|
||||
it or download the latest version from http://ipmitool.sourceforge.net and
|
||||
build and install it on your system.
|
||||
|
||||
Next, prior to starting up the watchdog daemon, the BMC BIOS should be set
|
||||
to enable the IPMI/BMC hardware watchdog timer, the OpenIPMI watchdog driver
|
||||
module should be inserted with the desired configuration/startup settings,
|
||||
and the watchdog daemon's configuration file should be modified to use /dev/watchdog:
|
||||
|
||||
1. To setup the IPMI/BMC BIOS to enable the hardware watchdog
|
||||
timer, see BMC documentation. The main settings in the BMC BIOS
|
||||
requiring modification to turn on the IPMI watchdog timer are:
|
||||
|
||||
- Set the BMC POST Watchdog to "ENABLED".
|
||||
- Set the BMC POST Watchdog Timeout to "5 Minutes".
|
||||
|
||||
2. To insert the OpenIPMI watchdog driver module with the
|
||||
desired configuration settings, two steps are necessary:
|
||||
|
||||
i.) Configure the OpenIPMI watchdog driver by editing the
|
||||
/etc/sysconfig/ipmi configuration file:
|
||||
|
||||
- Set "IPMI_WATCHDOG=yes".
|
||||
- Set desired options via the IPMI_WATCHDOG_OPTIONS
|
||||
config entry.
|
||||
|
||||
EXAMPLE: 'IPMI_WATCHDOG_OPTIONS="timeout=60 start_now=1 \
|
||||
preop=preop_give_data action=power_cycle pretimeout=1" '
|
||||
|
||||
Execute "modinfo ipmi_watchdog" for more detailed information
|
||||
on the available ipmi watchdog timer options.
|
||||
|
||||
- Execute "service ipmi start" (the watchdog driver starts
|
||||
automatically along with the other ipmi drivers).
|
||||
|
||||
IMPORTANT: If "start_now=1" has been set as one of the
|
||||
configuration options, be sure to start up the watchdog
|
||||
daemon before the BMC timer expires!
|
||||
|
||||
ii.) Set the OpenIPMI daemon and watchdog to start during bootup:
|
||||
|
||||
- chkconfig ipmi on
|
||||
- chkconfig watchdog on
|
||||
|
||||
|
||||
3. Configure the watchdog daemon by editing the
|
||||
/etc/watchdog.conf configuration file:
|
||||
|
||||
- Uncomment the "watchdog-device = /dev/watchdog" line.
|
||||
- Ensure that "realtime = yes" and "priority = 1" are set and not
|
||||
commented-out.
|
||||
- Uncomment the "interval" line, and set the interval to be less
|
||||
than what you set the timeout option to be in the /etc/sysconfig/ipmi
|
||||
file (ex "timeout=60" so you might set interval to 50).
|
||||
|
||||
So in the example described herein, the BMC BIOS setting is in
|
||||
minutes (5), and the "interval" and ipmi_watchdog "timeout" settings
|
||||
are both in seconds (50 and 60 respectively). Therefore, the BMC
|
||||
hardware watchdog timer is set to expire and trigger a system power
|
||||
cycle unless reset by the watchdog daemon within 5 minutes, and the
|
||||
watchdog daemon will reset the timer every 60 seconds.
|
||||
|
||||
|
||||
4. Start the Watchdog daemon:
|
||||
|
||||
- execute "service watchdog start"
|
||||
|
||||
|
||||
IMPORTANT: To gracefully stop/kill the watchdog daemon, be sure
|
||||
to use "service watchdog stop" (which executes "kill -s SIGTERM <pid>")
|
||||
and do *not* use "kill -9 <pid>". Using "kill -9 <pid>" will cause the
|
||||
daemon to be shut off without stopping the BMC's watchdog timer, thus
|
||||
a system reboot will be triggered when the BMC's watchdog timer expires.
|
||||
|
||||
Alternately, or in case the watchdog daemon is killed "ungracefully",
|
||||
you can stop the BMC timer by executing the following ipmitool utility
|
||||
command before the watchdog timer expires:
|
||||
|
||||
# ipmitool -v raw 0x06 0x24 0x04 0x01 0x00 0x10 0x00 0x0a
|
||||
|
||||
----------------------------------------------------------------------
|
||||
|
||||
To test the watchdog after system configuration and setup:
|
||||
|
||||
. Use kill -9 on the watchdog daemon so it doesn't shut down the watchdog daemon
|
||||
gracefully. Verify that the system gets reset after the BMC timer expires.
|
||||
|
||||
. Use "service watchdog stop" and verify that the watchdog daemon shuts off
|
||||
the BMC watchdog timer gracefully (the system doesn't get reset).
|
||||
|
||||
. Set the timer on the watchdog daemon to be greater than the time set in
|
||||
the BMC BIOS for system reset and verify that the system is reset.
|
||||
|
||||
. Set the timer on the daemon to be less than the time set in the
|
||||
BMC timer and verify that the BMC watchdog is poked regularly and the
|
||||
system is not reset.
|
||||
|
||||
. Test some of the other actions the BMC can take when the watchdog timer
|
||||
goes off (see modinfo ipmi_watchdog for some other settings to try).
|
||||
|
11
SOURCES/watchdog-ping.service
Normal file
11
SOURCES/watchdog-ping.service
Normal file
@ -0,0 +1,11 @@
|
||||
[Unit]
|
||||
Description=watchdog daemon for use with ping test / network dependency
|
||||
After=network.target
|
||||
Conflicts=watchdog.service
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
ExecStart=/usr/sbin/watchdog
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
11
SOURCES/watchdog.service
Normal file
11
SOURCES/watchdog.service
Normal file
@ -0,0 +1,11 @@
|
||||
[Unit]
|
||||
Description=watchdog daemon
|
||||
# man systemd.special
|
||||
# auto added After=basic.target
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
ExecStart=/usr/sbin/watchdog
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
300
SPECS/watchdog.spec
Normal file
300
SPECS/watchdog.spec
Normal file
@ -0,0 +1,300 @@
|
||||
Summary: Software and/or Hardware watchdog daemon
|
||||
Name: watchdog
|
||||
Version: 5.16
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
|
||||
URL: http://sourceforge.net/projects/watchdog/
|
||||
Source0: http://downloads.sourceforge.net/watchdog/watchdog-%{version}.tar.gz
|
||||
Source2: README.watchdog.ipmi
|
||||
Source3: README.Fedora
|
||||
Source4: watchdog.service
|
||||
Source5: watchdog-ping.service
|
||||
|
||||
# Fixes building on glibc without RPC. Sent upstream 2019-02-06.
|
||||
Patch1: 0001-Choose-libtirpc-or-another-RPC-library-for-XDR-heade.patch
|
||||
|
||||
# Non-upstream patch to document SELinux support.
|
||||
Patch99: 0099-watchdog-5.16-rhseldoc.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
BuildRequires: libtirpc-devel
|
||||
BuildRequires: systemd-units
|
||||
# Required because patches touch configure.ac and Makefile.am:
|
||||
BuildRequires: autoconf, automake
|
||||
|
||||
Requires(post): systemd
|
||||
Requires(preun): systemd
|
||||
Requires(postun): systemd
|
||||
|
||||
|
||||
%description
|
||||
The watchdog program can be used as a powerful software watchdog daemon
|
||||
or may be alternately used with a hardware watchdog device such as the
|
||||
IPMI hardware watchdog driver interface to a resident Baseboard
|
||||
Management Controller (BMC). watchdog periodically writes to /dev/watchdog;
|
||||
the interval between writes to /dev/watchdog is configurable through settings
|
||||
in the watchdog config file. This configuration file is also used to
|
||||
set the watchdog to be used as a hardware watchdog instead of its default
|
||||
software watchdog operation. In either case, if the device is open but not
|
||||
written to within the configured time period, the watchdog timer expiration
|
||||
will trigger a machine reboot. When operating as a software watchdog, the
|
||||
ability to reboot will depend on the state of the machine and interrupts.
|
||||
When operating as a hardware watchdog, the machine will experience a hard
|
||||
reset (or whatever action was configured to be taken upon watchdog timer
|
||||
expiration) initiated by the BMC.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch1 -p1
|
||||
%patch99 -p1 -b .rhseldoc
|
||||
autoreconf -i
|
||||
|
||||
cp %{SOURCE2} .
|
||||
cp %{SOURCE3} .
|
||||
%if 0%{?rhel}
|
||||
mv README.Fedora README.RHEL
|
||||
%endif
|
||||
|
||||
mv README README.orig
|
||||
iconv -f ISO-8859-1 -t UTF-8 < README.orig > README
|
||||
|
||||
|
||||
%build
|
||||
%configure \
|
||||
CFLAGS="%{__global_cflags} -I/usr/include/tirpc" \
|
||||
LDFLAGS="%{__global_ldflags} -ltirpc"
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
install -d -m0755 ${RPM_BUILD_ROOT}%{_sysconfdir}
|
||||
install -d -m0755 ${RPM_BUILD_ROOT}%{_sysconfdir}/watchdog.d
|
||||
make DESTDIR=${RPM_BUILD_ROOT} install
|
||||
install -Dp -m0644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_unitdir}/watchdog.service
|
||||
install -Dp -m0644 %{SOURCE5} ${RPM_BUILD_ROOT}%{_unitdir}/watchdog-ping.service
|
||||
install -Dd -m0755 ${RPM_BUILD_ROOT}%{_libexecdir}/watchdog/scripts
|
||||
rm %{name}.sysconfig
|
||||
|
||||
|
||||
%post
|
||||
%systemd_post watchdog.service
|
||||
|
||||
%preun
|
||||
%systemd_preun watchdog.service
|
||||
%systemd_preun watchdog.ping.service
|
||||
|
||||
%postun
|
||||
%systemd_postun_with_restart watchdog.service
|
||||
%systemd_postun_with_restart watchdog.ping.service
|
||||
|
||||
%triggerun -- watchdog < 5.9-4
|
||||
# Save the current service runlevel info
|
||||
# User must manually run systemd-sysv-convert --apply watchdog
|
||||
# to migrate them to systemd targets
|
||||
/usr/bin/systemd-sysv-convert --save watchdog >/dev/null 2>&1 ||:
|
||||
|
||||
# Run these because the SysV package being removed won't do them
|
||||
/sbin/chkconfig --del watchdog >/dev/null 2>&1 || :
|
||||
/bin/systemctl try-restart watchdog.service >/dev/null 2>&1 || :
|
||||
/bin/systemctl try-restart watchdog-ping.service >/dev/null 2>&1 || :
|
||||
|
||||
|
||||
%files
|
||||
%doc AUTHORS ChangeLog COPYING examples/ IAFA-PACKAGE NEWS README TODO README.watchdog.ipmi
|
||||
%if 0%{?rhel}
|
||||
%doc README.RHEL
|
||||
%else
|
||||
%doc README.Fedora
|
||||
%endif
|
||||
%config(noreplace) %{_sysconfdir}/watchdog.conf
|
||||
%{_sysconfdir}/watchdog.d
|
||||
%{_sbindir}/watchdog
|
||||
%{_sbindir}/wd_identify
|
||||
%{_sbindir}/wd_keepalive
|
||||
%{_mandir}/man5/watchdog.conf.5*
|
||||
%{_mandir}/man8/watchdog.8*
|
||||
%{_mandir}/man8/wd_identify.8*
|
||||
%{_mandir}/man8/wd_keepalive.8*
|
||||
%{_unitdir}/watchdog.service
|
||||
%{_unitdir}/watchdog-ping.service
|
||||
%{_libexecdir}/watchdog/scripts
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Aug 10 2021 Josef Ridky <jridky@redhat.com> - 5.16-1
|
||||
- New upstream release 5.16
|
||||
|
||||
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 5.15-13
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Mon Aug 09 2021 Josef Ridky <jridky@redhat.com> - 5.15-12
|
||||
- bump for gating.yaml file
|
||||
|
||||
* Mon Aug 09 2021 Josef Ridky <jridky@redhat.com> - 5.15-11
|
||||
- Rebuild for import to RHEL9 (#1978263)
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 5.15-10
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 5.15-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.15-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Feb 03 2020 Václav Doležal <vdolezal@redhat.com> - 5.15-7
|
||||
- Clean up old SysV-init related files
|
||||
|
||||
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.15-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.15-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Wed Feb 06 2019 Richard W.M. Jones <rjones@redhat.com> - 5.15-5
|
||||
- Add all upstream patches since 5.15.
|
||||
- Fix RPC/libtirpc (again?).
|
||||
- Remove .rhsel patch. Equivalent added upstream in 7310afccc1.
|
||||
|
||||
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.15-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Mon Dec 03 2018 Josef Ridky <jridky@redhat.com> - 5.15-3
|
||||
- update service files (#1542632)
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.15-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Tue Feb 13 2018 Richard W.M. Jones <rjones@redhat.com> - 5.15-1
|
||||
- Rebase to watchdog 5.15.
|
||||
- Remove upstream patches.
|
||||
- Modify code to use libtirpc.
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.13-19
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.13-18
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.13-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon Mar 06 2017 Josef Ridky <jridky@redhat.com> - 5.13-16
|
||||
- Scriptlets replaced with new systemd macros (#850364)
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.13-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.13-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.13-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Thu Aug 21 2014 Kevin Fenzi <kevin@scrye.com> - 5.13-12
|
||||
- Rebuild for rpm bug 1131960
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.13-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.13-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Thu Nov 7 2013 Ales Ledvinka <aledvink@redhat.com> - 5.13-9
|
||||
- SELinux: Add /usr/libexec/watchdog/scripts/ for test-bin and repair-bin to inherit from.
|
||||
- systemd: service with network available dependency
|
||||
- systemd: correct cgroup for realtime settings
|
||||
- Document SELinux and systemd.
|
||||
|
||||
* Thu Oct 24 2013 Ales Ledvinka <aledvink@redhat.com> - 5.13-5
|
||||
- SELinux: do not reopen descriptors for reading when only appending.
|
||||
|
||||
* Fri Aug 9 2013 Richard W.M. Jones <rjones@redhat.com> - 5.13-4
|
||||
- Fix License field (software is GPLv2+, not "GPL+").
|
||||
|
||||
* Thu Aug 8 2013 Richard W.M. Jones <rjones@redhat.com> - 5.13-3
|
||||
- Rename README.Fedora to README.RHEL on RHEL.
|
||||
|
||||
* Tue Jul 30 2013 Richard W.M. Jones <rjones@redhat.com> - 5.13-2
|
||||
- Enable /etc/watchdog.d directory for storing test binaries
|
||||
(RHBZ#657750, RHBZ#831190).
|
||||
- Missing BR systemd-units.
|
||||
- Update .gitignore.
|
||||
- Drop Group line, not required by modern RPM.
|
||||
|
||||
* Thu May 16 2013 Richard W.M. Jones <rjones@redhat.com> - 5.13-1
|
||||
- New upstream version 5.13.
|
||||
- Various documentation fixes (RHBZ#948883).
|
||||
|
||||
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.12-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.12-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Fri Jul 06 2012 Richard W.M. Jones <rjones@redhat.com> - 5.12-1
|
||||
- New upstream version 5.12 (RHBZ#837949).
|
||||
- Bring specfile up to modern standards.
|
||||
- Remove commented sections from previous commit.
|
||||
- Remove both patches (equivalent changes now upstream).
|
||||
|
||||
* Wed Mar 14 2012 Jon Ciesla <limburgher@gmail.com> - 5.9-4
|
||||
- Migrate to systemd, BZ 661220.
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.9-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.9-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Mon Jan 17 2011 Richard W.M. Jones <rjones@redhat.com> - 5.9-1
|
||||
- New upstream version 5.9 (RHBZ#645541).
|
||||
- Package new wd_identify program.
|
||||
- Drop old cleanup patch, most of it is now upstream.
|
||||
- Add newer cleanup patch, sent upstream.
|
||||
- Fix some problems with the initscript (RHBZ#523391).
|
||||
- Add systemd service (file installed but not used) (RHBZ#661220).
|
||||
|
||||
* Wed Jan 13 2010 Richard W.M. Jones <rjones@redhat.com> - 5.5-7
|
||||
- Fix Source0 URL.
|
||||
|
||||
* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.5-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Fri Mar 13 2009 Richard W.M. Jones <rjones@redhat.com> - 5.5-5
|
||||
- Updated the cleanup patch and sent upstream.
|
||||
|
||||
* Fri Mar 13 2009 Richard W.M. Jones <rjones@redhat.com> - 5.5-3
|
||||
- Remove dubious "cleanup-nfs" patch.
|
||||
|
||||
* Thu Mar 5 2009 Richard W.M. Jones <rjones@redhat.com> - 5.5-2
|
||||
- Use '-' in defattr line instead of explicit file mode.
|
||||
|
||||
* Thu Feb 26 2009 Richard W.M. Jones <rjones@redhat.com> - 5.5-1
|
||||
- New upstream version 5.5.
|
||||
- Prepared the package for Fedora review.
|
||||
|
||||
* Mon Jun 11 2007 Lon Hohberger <lhh@redhat.com> - 5.3.1-7
|
||||
- Rebuild for RHEL5 Update 1 - Resolves: 227401
|
||||
|
||||
* Wed May 30 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-6
|
||||
- Fixed the init script file.
|
||||
|
||||
* Tue May 29 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-5
|
||||
- Fixed a compile warning in nfsmount_xdr file.
|
||||
|
||||
* Wed May 23 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-4
|
||||
- Fixed rpmlint warnings.
|
||||
|
||||
* Wed May 16 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-3
|
||||
- Changes to spec, init script and README file per Carol Hebert recommendation.
|
||||
|
||||
* Thu Apr 19 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-2
|
||||
- Added README.watchdog.ipmi
|
||||
|
||||
* Mon Apr 16 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-1
|
||||
- Initial copy.
|
Loading…
Reference in New Issue
Block a user