Auto sync2gitlab import of watchdog-5.15-2.el8.src.rpm
This commit is contained in:
parent
e68a39ef19
commit
4e025e650a
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
/watchdog-5.15.tar.gz
|
34
0003-watchdog-5.13-rhsel.patch
Normal file
34
0003-watchdog-5.13-rhsel.patch
Normal file
@ -0,0 +1,34 @@
|
||||
diff -ur watchdog-5.15.old/src/test_binary.c watchdog-5.15/src/test_binary.c
|
||||
--- watchdog-5.15.old/src/test_binary.c 2016-02-26 12:05:00.000000000 +0000
|
||||
+++ watchdog-5.15/src/test_binary.c 2018-02-13 08:51:27.292750445 +0000
|
||||
@@ -263,11 +263,11 @@
|
||||
* to cause trouble, so make them go to their respective files */
|
||||
strcpy(filename_buf, logdir);
|
||||
strcat(filename_buf, "/test-bin.stdout");
|
||||
- if (!freopen(filename_buf, "a+", stdout))
|
||||
+ if (!freopen(filename_buf, "a", stdout))
|
||||
exit(errno);
|
||||
strcpy(filename_buf, logdir);
|
||||
strcat(filename_buf, "/test-bin.stderr");
|
||||
- if (!freopen(filename_buf, "a+", stderr))
|
||||
+ if (!freopen(filename_buf, "a", stderr))
|
||||
exit(errno);
|
||||
|
||||
/* now start binary */
|
||||
diff -ur watchdog-5.15.old/src/watchdog.c watchdog-5.15/src/watchdog.c
|
||||
--- watchdog-5.15.old/src/watchdog.c 2016-02-26 12:05:00.000000000 +0000
|
||||
+++ watchdog-5.15/src/watchdog.c 2018-02-13 08:51:43.747738628 +0000
|
||||
@@ -86,11 +86,11 @@
|
||||
* So make stdout and stderr go to their respective files */
|
||||
strcpy(filename_buf, logdir);
|
||||
strcat(filename_buf, "/repair-bin.stdout");
|
||||
- if (!freopen(filename_buf, "a+", stdout))
|
||||
+ if (!freopen(filename_buf, "a", stdout))
|
||||
exit(errno);
|
||||
strcpy(filename_buf, logdir);
|
||||
strcat(filename_buf, "/repair-bin.stderr");
|
||||
- if (!freopen(filename_buf, "a+", stderr))
|
||||
+ if (!freopen(filename_buf, "a", stderr))
|
||||
exit(errno);
|
||||
|
||||
/* now start binary */
|
136
0004-watchdog-5.13-rhseldoc.patch
Normal file
136
0004-watchdog-5.13-rhseldoc.patch
Normal file
@ -0,0 +1,136 @@
|
||||
diff -ur watchdog-5.15.old/watchdog.8 watchdog-5.15/watchdog.8
|
||||
--- watchdog-5.15.old/watchdog.8 2016-02-26 12:05:00.000000000 +0000
|
||||
+++ watchdog-5.15/watchdog.8 2018-02-13 08:54:00.860681339 +0000
|
||||
@@ -215,6 +215,7 @@
|
||||
.BR watchdog .
|
||||
So you can for instance restart the server from your
|
||||
.IR repair-binary .
|
||||
+See the Systemd section below for additinal information.
|
||||
.PP
|
||||
.B watchdog
|
||||
will try periodically to fork itself to see whether the process
|
||||
@@ -241,6 +242,8 @@
|
||||
considered unreachable causing a soft reboot or action from the
|
||||
repair binary.
|
||||
.PP
|
||||
+To start the watchdog when network is available see the Systemd section below.
|
||||
+.PP
|
||||
.B watchdog
|
||||
can run an external command for user-defined tests. A return code not equal 0
|
||||
means an error occurred and watchdog should react. If the external command is
|
||||
@@ -350,6 +353,9 @@
|
||||
246
|
||||
Free for personal watchdog-specific use (was \-10 as an unsigned 8\-bit
|
||||
number).
|
||||
+.PP
|
||||
+With enforcing SELinux policy please use the /usr/libexec/watchdog/scripts/
|
||||
+for your test-binary configuration.
|
||||
.TP
|
||||
245
|
||||
Reserved for an unknown result, for example a slow background test that is
|
||||
@@ -377,6 +383,9 @@
|
||||
controls the number of successive repair attempts that report 0 (i.e. success) but
|
||||
fail to clear the tested fault. If this is exceeded then a reboot takes place. If set
|
||||
to zero then a reboot can always be blocked by the repair program reporting success.
|
||||
+.PP
|
||||
+With enforcing SELinux policy please use the /usr/libexec/watchdog/scripts/
|
||||
+for your repair-binary configuration.
|
||||
.SH "TEST DIRECTORY"
|
||||
Executables placed in the test directory are discovered by watchdog on
|
||||
startup and are automatically executed. They are bounded time-wise by
|
||||
@@ -415,6 +424,27 @@
|
||||
repair-maximum
|
||||
also controls the number of successive repair attempts that report success
|
||||
(return 0) but fail to clear the fault.
|
||||
+.SH SYSTEMD
|
||||
+To start watchdog after the network is available:
|
||||
+.PP
|
||||
+.br
|
||||
+systemctl disable watchdog
|
||||
+.br
|
||||
+systemctl enable NetworkManager-wait-online
|
||||
+.br
|
||||
+systemctl enable watchdog-ping
|
||||
+.PP
|
||||
+
|
||||
+When using custom service pid check with custom service
|
||||
+systemd unit file please be aware the "Requires="
|
||||
+does dependent service deactivation.
|
||||
+Using "Before=watchdog.service" or "Before=watchdog-ping.service"
|
||||
+in the custom service unit file may be the desired operation instead.
|
||||
+See systemd.unit documentation for more details.
|
||||
+
|
||||
+.SH SELINUX
|
||||
+The directories /etc/watchdog.d/ and /usr/libexec/watchdog/scripts/ are
|
||||
+recognized locations for custom executables.
|
||||
.SH BUGS
|
||||
None known so far.
|
||||
.SH AUTHORS
|
||||
@@ -433,4 +463,4 @@
|
||||
The pid file of the running
|
||||
.BR watchdog .
|
||||
.SH "SEE ALSO"
|
||||
-.BR watchdog.conf (5)
|
||||
+.BR watchdog.conf (5), systemd.unit (5)
|
||||
diff -ur watchdog-5.15.old/watchdog.conf watchdog-5.15/watchdog.conf
|
||||
--- watchdog-5.15.old/watchdog.conf 2016-02-26 12:05:00.000000000 +0000
|
||||
+++ watchdog-5.15/watchdog.conf 2018-02-13 08:52:18.899721271 +0000
|
||||
@@ -16,6 +16,8 @@
|
||||
#min-memory = 1
|
||||
#allocatable-memory = 1
|
||||
|
||||
+# With enforcing SELinux policy please use the /usr/libexec/watchdog/scripts/
|
||||
+# or /etc/watchdog.d/ for your test-binary and repair-binary configuration.
|
||||
#repair-binary = /usr/sbin/repair
|
||||
#repair-timeout = 60
|
||||
#test-binary =
|
||||
@@ -45,5 +47,12 @@
|
||||
realtime = yes
|
||||
priority = 1
|
||||
|
||||
+# When using custom service pid check with custom service
|
||||
+# systemd unit file please be aware the "Requires="
|
||||
+# does dependent service deactivation.
|
||||
+# Using "Before=watchdog.service" or "Before=watchdog-ping.service"
|
||||
+# in the custom service unit file may be the desired operation instead.
|
||||
+# See man 5 systemd.unit for more details.
|
||||
+#
|
||||
# Check if rsyslogd is still running by enabling the following line
|
||||
#pidfile = /var/run/rsyslogd.pid
|
||||
diff -ur watchdog-5.15.old/watchdog.conf.5 watchdog-5.15/watchdog.conf.5
|
||||
--- watchdog-5.15.old/watchdog.conf.5 2016-02-26 12:05:00.000000000 +0000
|
||||
+++ watchdog-5.15/watchdog.conf.5 2018-02-13 08:52:18.898721271 +0000
|
||||
@@ -105,6 +105,7 @@
|
||||
pidfile = <pidfilename>
|
||||
Set pidfile name for server test mode.
|
||||
This option can be given as often as you like to check several servers.
|
||||
+See the Systemd section in watchdog (8) for more information.
|
||||
.TP
|
||||
ping = <ip-addr>
|
||||
Set IPv4 address for ping mode.
|
||||
@@ -119,6 +120,8 @@
|
||||
.TP
|
||||
test-binary = <testbin>
|
||||
Execute the given binary to do some user defined tests.
|
||||
+With enforcing SELinux policy please use the /usr/libexec/watchdog/scripts/
|
||||
+for your test-binary configuration.
|
||||
.TP
|
||||
test-timeout = <timeout in seconds>
|
||||
User defined tests may only run for <timeout> seconds. Set to 0 for unlimited.
|
||||
@@ -126,6 +129,8 @@
|
||||
repair-binary = <repbin>
|
||||
Execute the given binary in case of a problem instead of shutting down the
|
||||
system.
|
||||
+With enforcing SELinux policy please use the /usr/libexec/watchdog/scripts/
|
||||
+for your repair-binary configuration.
|
||||
.TP
|
||||
repair-timeout = <timeout in seconds>
|
||||
repair command may only run for <timeout> seconds. Set to 0 for 'unlimited', but
|
||||
@@ -156,6 +161,7 @@
|
||||
.TP
|
||||
test-directory = <test directory>
|
||||
Set the directory to run user test/repair scripts. Default is '/etc/watchdog.d'
|
||||
+The /etc/watchdog.d/ is recognized by SELinux policy.
|
||||
See the Test Directory section in watchdog(8) for more information.
|
||||
.TP
|
||||
log-dir = <log directory>
|
34
README.Fedora
Normal file
34
README.Fedora
Normal file
@ -0,0 +1,34 @@
|
||||
This is the watchdog package for Fedora. It implements a userspace
|
||||
daemon which periodically pings (usually hardware) to tell the
|
||||
hardware that the machine is alive. If the hardware times out without
|
||||
receiving a ping, it assumes userspace is dead and reboots the
|
||||
machine.
|
||||
|
||||
There are several major classes of watchdog available:
|
||||
|
||||
- watchdog hardware implementing the Linux /dev/watchdog API
|
||||
|
||||
* drivers in /lib/modules/$(uname -r)/kernel/drivers/watchdog/
|
||||
* http://lxr.linux.no/linux/Documentation/watchdog/watchdog-api.txt
|
||||
|
||||
- softdog
|
||||
|
||||
* software watchdog (just runs inside the kernel)
|
||||
* implements the Linux /dev/watchdog API
|
||||
* won't help you if the kernel fails (obvious, right?)
|
||||
|
||||
- IPMI
|
||||
|
||||
* a heavyweight standard for all things server-management
|
||||
* separate Linux driver
|
||||
* ipmitool to control it
|
||||
* see README.watchdog.ipmi for how to use this daemon together
|
||||
with IPMI
|
||||
|
||||
You can also use watchdogs inside recent QEMU/KVM virtual machines.
|
||||
When running qemu, specify "-watchdog i6300esb" on the qemu command
|
||||
line (or use libvirt). Inside the guest, the i6300esb watchdog driver
|
||||
should automatically load and provide you with a Linux /dev/watchdog-
|
||||
compatible API.
|
||||
|
||||
- Richard W.M. Jones (rjones@redhat.com) 2009-02-26
|
107
README.watchdog.ipmi
Normal file
107
README.watchdog.ipmi
Normal file
@ -0,0 +1,107 @@
|
||||
|
||||
Instructions for how to set up the watchdog daemon to work with IPMI's hardware watchdog
|
||||
----------------------------------------------------------------------------------------
|
||||
|
||||
First, verify that the ipmitool utility is present on the system to allow
|
||||
the watchdog timer to be turned off via the command line (which ipmitool).
|
||||
This will allow the hardware watchdog timer to be turned off gracefully
|
||||
should it ever become necessary. If ipmitool is not present, install
|
||||
it or download the latest version from http://ipmitool.sourceforge.net and
|
||||
build and install it on your system.
|
||||
|
||||
Next, prior to starting up the watchdog daemon, the BMC BIOS should be set
|
||||
to enable the IPMI/BMC hardware watchdog timer, the OpenIPMI watchdog driver
|
||||
module should be inserted with the desired configuration/startup settings,
|
||||
and the watchdog daemon's configuration file should be modified to use /dev/watchdog:
|
||||
|
||||
1. To setup the IPMI/BMC BIOS to enable the hardware watchdog
|
||||
timer, see BMC documentation. The main settings in the BMC BIOS
|
||||
requiring modification to turn on the IPMI watchdog timer are:
|
||||
|
||||
- Set the BMC POST Watchdog to "ENABLED".
|
||||
- Set the BMC POST Watchdog Timeout to "5 Minutes".
|
||||
|
||||
2. To insert the OpenIPMI watchdog driver module with the
|
||||
desired configuration settings, two steps are necessary:
|
||||
|
||||
i.) Configure the OpenIPMI watchdog driver by editing the
|
||||
/etc/sysconfig/ipmi configuration file:
|
||||
|
||||
- Set "IPMI_WATCHDOG=yes".
|
||||
- Set desired options via the IPMI_WATCHDOG_OPTIONS
|
||||
config entry.
|
||||
|
||||
EXAMPLE: 'IPMI_WATCHDOG_OPTIONS="timeout=60 start_now=1 \
|
||||
preop=preop_give_data action=power_cycle pretimeout=1" '
|
||||
|
||||
Execute "modinfo ipmi_watchdog" for more detailed information
|
||||
on the available ipmi watchdog timer options.
|
||||
|
||||
- Execute "service ipmi start" (the watchdog driver starts
|
||||
automatically along with the other ipmi drivers).
|
||||
|
||||
IMPORTANT: If "start_now=1" has been set as one of the
|
||||
configuration options, be sure to start up the watchdog
|
||||
daemon before the BMC timer expires!
|
||||
|
||||
ii.) Set the OpenIPMI daemon and watchdog to start during bootup:
|
||||
|
||||
- chkconfig ipmi on
|
||||
- chkconfig watchdog on
|
||||
|
||||
|
||||
3. Configure the watchdog daemon by editing the
|
||||
/etc/watchdog.conf configuration file:
|
||||
|
||||
- Uncomment the "watchdog-device = /dev/watchdog" line.
|
||||
- Ensure that "realtime = yes" and "priority = 1" are set and not
|
||||
commented-out.
|
||||
- Uncomment the "interval" line, and set the interval to be less
|
||||
than what you set the timeout option to be in the /etc/sysconfig/ipmi
|
||||
file (ex "timeout=60" so you might set interval to 50).
|
||||
|
||||
So in the example described herein, the BMC BIOS setting is in
|
||||
minutes (5), and the "interval" and ipmi_watchdog "timeout" settings
|
||||
are both in seconds (50 and 60 respectively). Therefore, the BMC
|
||||
hardware watchdog timer is set to expire and trigger a system power
|
||||
cycle unless reset by the watchdog daemon within 5 minutes, and the
|
||||
watchdog daemon will reset the timer every 60 seconds.
|
||||
|
||||
|
||||
4. Start the Watchdog daemon:
|
||||
|
||||
- execute "service watchdog start"
|
||||
|
||||
|
||||
IMPORTANT: To gracefully stop/kill the watchdog daemon, be sure
|
||||
to use "service watchdog stop" (which executes "kill -s SIGTERM <pid>")
|
||||
and do *not* use "kill -9 <pid>". Using "kill -9 <pid>" will cause the
|
||||
daemon to be shut off without stopping the BMC's watchdog timer, thus
|
||||
a system reboot will be triggered when the BMC's watchdog timer expires.
|
||||
|
||||
Alternately, or in case the watchdog daemon is killed "ungracefully",
|
||||
you can stop the BMC timer by executing the following ipmitool utility
|
||||
command before the watchdog timer expires:
|
||||
|
||||
# ipmitool -v raw 0x06 0x24 0x04 0x01 0x00 0x10 0x00 0x0a
|
||||
|
||||
----------------------------------------------------------------------
|
||||
|
||||
To test the watchdog after system configuration and setup:
|
||||
|
||||
. Use kill -9 on the watchdog daemon so it doesn't shut down the watchdog daemon
|
||||
gracefully. Verify that the system gets reset after the BMC timer expires.
|
||||
|
||||
. Use "service watchdog stop" and verify that the watchdog daemon shuts off
|
||||
the BMC watchdog timer gracefully (the system doesn't get reset).
|
||||
|
||||
. Set the timer on the watchdog daemon to be greater than the time set in
|
||||
the BMC BIOS for system reset and verify that the system is reset.
|
||||
|
||||
. Set the timer on the daemon to be less than the time set in the
|
||||
BMC timer and verify that the BMC watchdog is poked regularly and the
|
||||
system is not reset.
|
||||
|
||||
. Test some of the other actions the BMC can take when the watchdog timer
|
||||
goes off (see modinfo ipmi_watchdog for some other settings to try).
|
||||
|
1
sources
Normal file
1
sources
Normal file
@ -0,0 +1 @@
|
||||
SHA512 (watchdog-5.15.tar.gz) = a675cfadf3296d583b9163193297038fb19459daf7c6681289392d613e775e75b7afd42a3e01b136a955f25b2f45818033b56e10de9050075d7dc015535a6e75
|
11
watchdog-ping.service
Normal file
11
watchdog-ping.service
Normal file
@ -0,0 +1,11 @@
|
||||
[Unit]
|
||||
Description=watchdog daemon for use with ping test / network dependency
|
||||
After=network.target
|
||||
Conflicts=watchdog.service
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
ExecStart=/usr/sbin/watchdog
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
91
watchdog.init
Normal file
91
watchdog.init
Normal file
@ -0,0 +1,91 @@
|
||||
#! /bin/sh
|
||||
#
|
||||
# watchdog - a watchdog daemon
|
||||
#
|
||||
# chkconfig: - 27 46
|
||||
# description: A watchdog daemon
|
||||
#
|
||||
# rc file author: Marc Merlin <marcsoft@merlins.org>
|
||||
# Henning P. Schmiedehausen <hps@tanstaafl.de>
|
||||
# Richard W.M. Jones <rjones@redhat.com>
|
||||
|
||||
# Source function library.
|
||||
. /etc/rc.d/init.d/functions
|
||||
|
||||
[ -x /usr/sbin/watchdog -a -e /etc/watchdog.conf ] || exit 0
|
||||
|
||||
VERBOSE="no"
|
||||
if [ -f /etc/sysconfig/watchdog ]; then
|
||||
. /etc/sysconfig/watchdog
|
||||
fi
|
||||
|
||||
RETVAL=0
|
||||
prog=watchdog
|
||||
pidfile=/var/run/watchdog.pid
|
||||
lockfile=/var/lock/subsys/watchdog
|
||||
|
||||
start() {
|
||||
|
||||
echo -n $"Starting $prog: "
|
||||
if [ -n "$(pidofproc $prog)" ]; then
|
||||
echo -n $"$prog: already running"
|
||||
echo_failure
|
||||
echo
|
||||
return 1
|
||||
fi
|
||||
if [ "$VERBOSE" = "yes" ]; then
|
||||
daemon /usr/sbin/${prog} -v
|
||||
else
|
||||
daemon /usr/sbin/${prog}
|
||||
fi
|
||||
RETVAL=$?
|
||||
echo
|
||||
[ $RETVAL -eq 0 ] && touch $lockfile
|
||||
[ $RETVAL -eq 0 ] && echo_success
|
||||
[ $RETVAL -ne 0 ] && echo_failure
|
||||
return $RETVAL
|
||||
}
|
||||
|
||||
stop() {
|
||||
echo -n "Stopping $prog: "
|
||||
# We are forcing it to _only_ use -TERM as killproc could use
|
||||
# -KILL which would result in BMC timer not being set properly
|
||||
# and reboot the box.
|
||||
killproc $prog -TERM
|
||||
RETVAL=$?
|
||||
echo
|
||||
[ $RETVAL -eq 0 ] && rm -f $lockfile $pidfile
|
||||
return $RETVAL
|
||||
}
|
||||
|
||||
restart() {
|
||||
stop
|
||||
sleep 6
|
||||
start
|
||||
}
|
||||
|
||||
case "$1" in
|
||||
start)
|
||||
start
|
||||
;;
|
||||
stop)
|
||||
stop
|
||||
;;
|
||||
reload|restart)
|
||||
restart
|
||||
;;
|
||||
condrestart)
|
||||
if [ -f $lockfile ]; then
|
||||
restart
|
||||
fi
|
||||
;;
|
||||
status)
|
||||
status $prog
|
||||
RETVAL=$?
|
||||
;;
|
||||
*)
|
||||
echo $"Usage: $0 {start|stop|restart|status|condrestart}"
|
||||
exit 1
|
||||
esac
|
||||
|
||||
exit $RETVAL
|
11
watchdog.service
Normal file
11
watchdog.service
Normal file
@ -0,0 +1,11 @@
|
||||
[Unit]
|
||||
Description=watchdog daemon
|
||||
# man systemd.special
|
||||
# auto added After=basic.target
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
ExecStart=/usr/sbin/watchdog
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
252
watchdog.spec
Normal file
252
watchdog.spec
Normal file
@ -0,0 +1,252 @@
|
||||
Summary: Software and/or Hardware watchdog daemon
|
||||
Name: watchdog
|
||||
Version: 5.15
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2+
|
||||
|
||||
URL: http://sourceforge.net/projects/watchdog/
|
||||
Source0: http://downloads.sourceforge.net/watchdog/watchdog-%{version}.tar.gz
|
||||
Source1: watchdog.init
|
||||
Source2: README.watchdog.ipmi
|
||||
Source3: README.Fedora
|
||||
Source4: watchdog.service
|
||||
Source5: watchdog-ping.service
|
||||
|
||||
Patch3: 0003-watchdog-5.13-rhsel.patch
|
||||
Patch4: 0004-watchdog-5.13-rhseldoc.patch
|
||||
|
||||
BuildRequires: libtirpc-devel
|
||||
BuildRequires: systemd-units
|
||||
|
||||
Requires(post): systemd
|
||||
Requires(preun): systemd
|
||||
Requires(postun): systemd
|
||||
|
||||
|
||||
%description
|
||||
The watchdog program can be used as a powerful software watchdog daemon
|
||||
or may be alternately used with a hardware watchdog device such as the
|
||||
IPMI hardware watchdog driver interface to a resident Baseboard
|
||||
Management Controller (BMC). watchdog periodically writes to /dev/watchdog;
|
||||
the interval between writes to /dev/watchdog is configurable through settings
|
||||
in the watchdog sysconfig file. This configuration file is also used to
|
||||
set the watchdog to be used as a hardware watchdog instead of its default
|
||||
software watchdog operation. In either case, if the device is open but not
|
||||
written to within the configured time period, the watchdog timer expiration
|
||||
will trigger a machine reboot. When operating as a software watchdog, the
|
||||
ability to reboot will depend on the state of the machine and interrupts.
|
||||
When operating as a hardware watchdog, the machine will experience a hard
|
||||
reset (or whatever action was configured to be taken upon watchdog timer
|
||||
expiration) initiated by the BMC.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch3 -p1 -b .rhsel
|
||||
%patch4 -p1 -b .rhseldoc
|
||||
|
||||
cp %{SOURCE2} .
|
||||
cp %{SOURCE3} .
|
||||
%if 0%{?rhel}
|
||||
mv README.Fedora README.RHEL
|
||||
%endif
|
||||
|
||||
mv README README.orig
|
||||
iconv -f ISO-8859-1 -t UTF-8 < README.orig > README
|
||||
|
||||
|
||||
%build
|
||||
%configure \
|
||||
CFLAGS="%{__global_cflags} -I/usr/include/tirpc" \
|
||||
LDFLAGS="%{__global_ldflags} -ltirpc"
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
install -d -m0755 ${RPM_BUILD_ROOT}%{_sysconfdir}
|
||||
install -d -m0755 ${RPM_BUILD_ROOT}%{_sysconfdir}/watchdog.d
|
||||
make DESTDIR=${RPM_BUILD_ROOT} install
|
||||
install -Dp -m0644 %{name}.sysconfig ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/watchdog
|
||||
install -Dp -m0644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_unitdir}/watchdog.service
|
||||
install -Dp -m0644 %{SOURCE5} ${RPM_BUILD_ROOT}%{_unitdir}/watchdog-ping.service
|
||||
install -Dd -m0755 ${RPM_BUILD_ROOT}%{_libexecdir}/watchdog/scripts
|
||||
|
||||
|
||||
%post
|
||||
%systemd_post watchdog.service
|
||||
|
||||
%preun
|
||||
%systemd_preun watchdog.service
|
||||
%systemd_preun watchdog.ping.service
|
||||
|
||||
%postun
|
||||
%systemd_postun_with_restart watchdog.service
|
||||
%systemd_postun_with_restart watchdog.ping.service
|
||||
|
||||
%triggerun -- watchdog < 5.9-4
|
||||
# Save the current service runlevel info
|
||||
# User must manually run systemd-sysv-convert --apply watchdog
|
||||
# to migrate them to systemd targets
|
||||
/usr/bin/systemd-sysv-convert --save watchdog >/dev/null 2>&1 ||:
|
||||
|
||||
# Run these because the SysV package being removed won't do them
|
||||
/sbin/chkconfig --del watchdog >/dev/null 2>&1 || :
|
||||
/bin/systemctl try-restart watchdog.service >/dev/null 2>&1 || :
|
||||
/bin/systemctl try-restart watchdog-ping.service >/dev/null 2>&1 || :
|
||||
|
||||
|
||||
%files
|
||||
%doc AUTHORS ChangeLog COPYING examples/ IAFA-PACKAGE NEWS README TODO README.watchdog.ipmi
|
||||
%if 0%{?rhel}
|
||||
%doc README.RHEL
|
||||
%else
|
||||
%doc README.Fedora
|
||||
%endif
|
||||
%config(noreplace) %{_sysconfdir}/watchdog.conf
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/watchdog
|
||||
%{_sysconfdir}/watchdog.d
|
||||
%{_sbindir}/watchdog
|
||||
%{_sbindir}/wd_identify
|
||||
%{_sbindir}/wd_keepalive
|
||||
%{_mandir}/man5/watchdog.conf.5*
|
||||
%{_mandir}/man8/watchdog.8*
|
||||
%{_mandir}/man8/wd_identify.8*
|
||||
%{_mandir}/man8/wd_keepalive.8*
|
||||
%{_unitdir}/watchdog.service
|
||||
%{_unitdir}/watchdog-ping.service
|
||||
%{_libexecdir}/watchdog/scripts
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Apr 21 2021 Than Ngo <than@redhat.com> - 5.15-2
|
||||
- Resolves: #1846110 - remove deprecated stanza in unit files
|
||||
|
||||
* Tue Feb 13 2018 Richard W.M. Jones <rjones@redhat.com> - 5.15-1
|
||||
- Rebase to watchdog 5.15.
|
||||
- Remove upstream patches.
|
||||
- Modify code to use libtirpc.
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.13-19
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.13-18
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.13-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon Mar 06 2017 Josef Ridky <jridky@redhat.com> - 5.13-16
|
||||
- Scriptlets replaced with new systemd macros (#850364)
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.13-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.13-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.13-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Thu Aug 21 2014 Kevin Fenzi <kevin@scrye.com> - 5.13-12
|
||||
- Rebuild for rpm bug 1131960
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.13-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.13-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Thu Nov 7 2013 Ales Ledvinka <aledvink@redhat.com> - 5.13-9
|
||||
- SELinux: Add /usr/libexec/watchdog/scripts/ for test-bin and repair-bin to inherit from.
|
||||
- systemd: service with network available dependency
|
||||
- systemd: correct cgroup for realtime settings
|
||||
- Document SELinux and systemd.
|
||||
|
||||
* Thu Oct 24 2013 Ales Ledvinka <aledvink@redhat.com> - 5.13-5
|
||||
- SELinux: do not reopen descriptors for reading when only appending.
|
||||
|
||||
* Fri Aug 9 2013 Richard W.M. Jones <rjones@redhat.com> - 5.13-4
|
||||
- Fix License field (software is GPLv2+, not "GPL+").
|
||||
|
||||
* Thu Aug 8 2013 Richard W.M. Jones <rjones@redhat.com> - 5.13-3
|
||||
- Rename README.Fedora to README.RHEL on RHEL.
|
||||
|
||||
* Tue Jul 30 2013 Richard W.M. Jones <rjones@redhat.com> - 5.13-2
|
||||
- Enable /etc/watchdog.d directory for storing test binaries
|
||||
(RHBZ#657750, RHBZ#831190).
|
||||
- Missing BR systemd-units.
|
||||
- Update .gitignore.
|
||||
- Drop Group line, not required by modern RPM.
|
||||
|
||||
* Thu May 16 2013 Richard W.M. Jones <rjones@redhat.com> - 5.13-1
|
||||
- New upstream version 5.13.
|
||||
- Various documentation fixes (RHBZ#948883).
|
||||
|
||||
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.12-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.12-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Fri Jul 06 2012 Richard W.M. Jones <rjones@redhat.com> - 5.12-1
|
||||
- New upstream version 5.12 (RHBZ#837949).
|
||||
- Bring specfile up to modern standards.
|
||||
- Remove commented sections from previous commit.
|
||||
- Remove both patches (equivalent changes now upstream).
|
||||
|
||||
* Wed Mar 14 2012 Jon Ciesla <limburgher@gmail.com> - 5.9-4
|
||||
- Migrate to systemd, BZ 661220.
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.9-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.9-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Mon Jan 17 2011 Richard W.M. Jones <rjones@redhat.com> - 5.9-1
|
||||
- New upstream version 5.9 (RHBZ#645541).
|
||||
- Package new wd_identify program.
|
||||
- Drop old cleanup patch, most of it is now upstream.
|
||||
- Add newer cleanup patch, sent upstream.
|
||||
- Fix some problems with the initscript (RHBZ#523391).
|
||||
- Add systemd service (file installed but not used) (RHBZ#661220).
|
||||
|
||||
* Wed Jan 13 2010 Richard W.M. Jones <rjones@redhat.com> - 5.5-7
|
||||
- Fix Source0 URL.
|
||||
|
||||
* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.5-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Fri Mar 13 2009 Richard W.M. Jones <rjones@redhat.com> - 5.5-5
|
||||
- Updated the cleanup patch and sent upstream.
|
||||
|
||||
* Fri Mar 13 2009 Richard W.M. Jones <rjones@redhat.com> - 5.5-3
|
||||
- Remove dubious "cleanup-nfs" patch.
|
||||
|
||||
* Thu Mar 5 2009 Richard W.M. Jones <rjones@redhat.com> - 5.5-2
|
||||
- Use '-' in defattr line instead of explicit file mode.
|
||||
|
||||
* Thu Feb 26 2009 Richard W.M. Jones <rjones@redhat.com> - 5.5-1
|
||||
- New upstream version 5.5.
|
||||
- Prepared the package for Fedora review.
|
||||
|
||||
* Mon Jun 11 2007 Lon Hohberger <lhh@redhat.com> - 5.3.1-7
|
||||
- Rebuild for RHEL5 Update 1 - Resolves: 227401
|
||||
|
||||
* Wed May 30 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-6
|
||||
- Fixed the init script file.
|
||||
|
||||
* Tue May 29 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-5
|
||||
- Fixed a compile warning in nfsmount_xdr file.
|
||||
|
||||
* Wed May 23 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-4
|
||||
- Fixed rpmlint warnings.
|
||||
|
||||
* Wed May 16 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-3
|
||||
- Changes to spec, init script and README file per Carol Hebert recommendation.
|
||||
|
||||
* Thu Apr 19 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-2
|
||||
- Added README.watchdog.ipmi
|
||||
|
||||
* Mon Apr 16 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-1
|
||||
- Initial copy.
|
Loading…
Reference in New Issue
Block a user