Update to 1.1.82.0

This commit is contained in:
leigh123linux 2018-08-07 14:15:54 +01:00
parent 965d3e660e
commit de5b2f9007
4 changed files with 38 additions and 11 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/Vulkan-ValidationLayers-sdk-1.1.77.0.tar.gz
/Vulkan-ValidationLayers-sdk-1.1.82.0.tar.gz

12
fix_shared.patch Normal file
View File

@ -0,0 +1,12 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -300,7 +300,7 @@
add_library(VkLayer_utils STATIC ${VALIDATION_LAYER_UTILS_SOURCES})
target_compile_definitions(VkLayer_utils PUBLIC _CRT_SECURE_NO_WARNINGS)
else()
- add_library(VkLayer_utils STATIC ${VALIDATION_LAYER_UTILS_SOURCES})
+ add_library(VkLayer_utils SHARED ${VALIDATION_LAYER_UTILS_SOURCES})
endif()
install(TARGETS VkLayer_utils DESTINATION ${CMAKE_INSTALL_LIBDIR})
set_target_properties(VkLayer_utils PROPERTIES LINKER_LANGUAGE CXX)

View File

@ -1 +1 @@
SHA512 (Vulkan-ValidationLayers-sdk-1.1.77.0.tar.gz) = 7207f0375145facf6526124764f57183d3b63de6b9ee5c35e0ca646f5dafecf6cd5639f81171151f9666fab19b79e3491bea9ad0db1806914971d174059de81e
SHA512 (Vulkan-ValidationLayers-sdk-1.1.82.0.tar.gz) = 57ad54f119e2000cb288098edf1dac2ac62708596b45d7dd317e52d6c6cd4a3408fed8f4b23b0d64a1fb203c144227cf2e1ad66fb1b6b404243e3c3d5f2151ef

View File

@ -1,11 +1,12 @@
Name: vulkan-validation-layers
Version: 1.1.77.0
Release: 4%{?dist}
Version: 1.1.82.0
Release: 1%{?dist}
Summary: Vulkan validation layers
License: ASL 2.0
URL: https://github.com/KhronosGroup/Vulkan-ValidationLayers
Source0: %url/archive/sdk-%{version}.tar.gz#/Vulkan-ValidationLayers-sdk-%{version}.tar.gz
Patch0: fix_shared.patch
BuildRequires: gcc
BuildRequires: gcc-c++
@ -26,21 +27,29 @@ BuildRequires: pkgconfig(xcb)
%description
Vulkan validation layers
%package devel
Summary: Development files for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: vulkan-headers
%description devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%prep
%autosetup -n Vulkan-ValidationLayers-sdk-%{version}
%autosetup -p1 -n Vulkan-ValidationLayers-sdk-%{version}
%build
# Decrease debuginfo even on ix86 because of:
%ifarch %{ix86}
# Decrease debuginfo verbosity to reduce memory consumption even more
%global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
%endif
%cmake3 -GNinja -DCMAKE_BUILD_TYPE=Release -DGLSLANG_INSTALL_DIR=%{_bindir} .
# Use two threads as build uses mega amounts of RAM
# It still requires at least 16Gb to compile with 2 threads
ninja -v -j2
%cmake3 -GNinja \
-DCMAKE_BUILD_TYPE=Release \
-DGLSLANG_INSTALL_DIR=%{_bindir} \
-DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}/vulkan/ .
%ninja_build
%install
@ -56,8 +65,13 @@ ninja -v -j2
%{_datadir}/vulkan/explicit_layer.d/*.json
%{_libdir}/libVkLayer_*.so
%files devel
%{_includedir}/vulkan/
%changelog
* Tue Aug 07 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.82.0-1
- Update to 1.1.82.0
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.77.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild