just disable werrors
This commit is contained in:
parent
e6ef573239
commit
c9c62d0da1
14
disable-werror.patch
Normal file
14
disable-werror.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -up Vulkan-ValidationLayers-sdk-1.3.231.1/CMakeLists.txt.dave Vulkan-ValidationLayers-sdk-1.3.231.1/CMakeLists.txt
|
||||||
|
--- Vulkan-ValidationLayers-sdk-1.3.231.1/CMakeLists.txt.dave 2022-11-10 13:45:38.130379846 +1000
|
||||||
|
+++ Vulkan-ValidationLayers-sdk-1.3.231.1/CMakeLists.txt 2022-11-10 13:45:54.135656036 +1000
|
||||||
|
@@ -171,9 +171,7 @@ if(${CMAKE_C_COMPILER_ID} MATCHES "(GNU|
|
||||||
|
-fno-builtin-memcmp)
|
||||||
|
|
||||||
|
# Treat warnings as errors for versions of GCC and c++11-compliant Clang versions that are shipped on Ubuntu 18.04 or older.
|
||||||
|
- if(BUILD_WERROR OR
|
||||||
|
- (${CMAKE_CXX_COMPILER_ID} STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS_EQUAL 7.3.0) OR
|
||||||
|
- (${CMAKE_CXX_COMPILER_ID} STREQUAL "Clang" AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 6.0.0))
|
||||||
|
+ if(BUILD_WERROR)
|
||||||
|
add_compile_options(-Werror)
|
||||||
|
endif()
|
||||||
|
|
@ -8,7 +8,8 @@ URL: https://github.com/KhronosGroup/Vulkan-ValidationLayers
|
|||||||
Source0: %url/archive/sdk-%{version}.tar.gz#/Vulkan-ValidationLayers-sdk-%{version}.tar.gz
|
Source0: %url/archive/sdk-%{version}.tar.gz#/Vulkan-ValidationLayers-sdk-%{version}.tar.gz
|
||||||
Patch0: fix_shared.patch
|
Patch0: fix_shared.patch
|
||||||
|
|
||||||
Patch1: warning-fix.patch
|
# it appears there is a warning with rawhide gcc
|
||||||
|
Patch1: disable-werror.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up Vulkan-ValidationLayers-sdk-1.3.224.0/layers/best_practices_utils.cpp.dma Vulkan-ValidationLayers-sdk-1.3.224.0/layers/best_practices_utils.cpp
|
|
||||||
--- Vulkan-ValidationLayers-sdk-1.3.224.0/layers/best_practices_utils.cpp.dma 2022-08-20 02:26:32.000000000 +1000
|
|
||||||
+++ Vulkan-ValidationLayers-sdk-1.3.224.0/layers/best_practices_utils.cpp 2022-11-10 13:23:37.383472546 +1000
|
|
||||||
@@ -1966,7 +1966,7 @@ void BestPractices::RecordCmdBeginRender
|
|
||||||
} else {
|
|
||||||
RecordUnbindZcullScope(*cmd_state);
|
|
||||||
}
|
|
||||||
- if (load_op) {
|
|
||||||
+ if (*load_op) {
|
|
||||||
if (*load_op == VK_ATTACHMENT_LOAD_OP_CLEAR || *load_op == VK_ATTACHMENT_LOAD_OP_DONT_CARE) {
|
|
||||||
RecordResetScopeZcullDirection(*cmd_state);
|
|
||||||
}
|
|
Loading…
Reference in New Issue
Block a user