Auto sync2gitlab import of vulkan-validation-layers-1.2.189.0-2.el8.src.rpm
This commit is contained in:
parent
289859702a
commit
a8a43a2183
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
/Vulkan-ValidationLayers-sdk-1.2.189.0.tar.gz
|
24
add-missing-export.patch
Normal file
24
add-missing-export.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -up Vulkan-ValidationLayers-sdk-1.2.182.0/layers/vk_layer_config.cpp.dma Vulkan-ValidationLayers-sdk-1.2.182.0/layers/vk_layer_config.cpp
|
||||||
|
--- Vulkan-ValidationLayers-sdk-1.2.182.0/layers/vk_layer_config.cpp.dma 2021-08-07 08:13:46.344320103 +1000
|
||||||
|
+++ Vulkan-ValidationLayers-sdk-1.2.182.0/layers/vk_layer_config.cpp 2021-08-07 08:14:22.130893289 +1000
|
||||||
|
@@ -68,7 +68,7 @@ class ConfigFile {
|
||||||
|
|
||||||
|
static ConfigFile layer_config;
|
||||||
|
|
||||||
|
-string GetEnvironment(const char *variable) {
|
||||||
|
+VK_LAYER_EXPORT string GetEnvironment(const char *variable) {
|
||||||
|
#if !defined(__ANDROID__) && !defined(_WIN32)
|
||||||
|
const char *output = getenv(variable);
|
||||||
|
return output == NULL ? "" : output;
|
||||||
|
diff -up Vulkan-ValidationLayers-sdk-1.2.182.0/layers/vk_layer_config.h.dma Vulkan-ValidationLayers-sdk-1.2.182.0/layers/vk_layer_config.h
|
||||||
|
--- Vulkan-ValidationLayers-sdk-1.2.182.0/layers/vk_layer_config.h.dma 2021-08-07 08:14:04.352608540 +1000
|
||||||
|
+++ Vulkan-ValidationLayers-sdk-1.2.182.0/layers/vk_layer_config.h 2021-08-07 08:14:15.237782885 +1000
|
||||||
|
@@ -33,7 +33,7 @@
|
||||||
|
#define SECONDARY_VK_REGISTRY_HIVE_STR "HKEY_CURRENT_USER"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-std::string GetEnvironment(const char *variable);
|
||||||
|
+VK_LAYER_EXPORT std::string GetEnvironment(const char *variable);
|
||||||
|
|
||||||
|
#ifdef __cplusplus
|
||||||
|
extern "C" {
|
12
fix_shared.patch
Normal file
12
fix_shared.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up Vulkan-ValidationLayers-sdk-1.1.92.0/CMakeLists.txt.dma Vulkan-ValidationLayers-sdk-1.1.92.0/CMakeLists.txt
|
||||||
|
--- Vulkan-ValidationLayers-sdk-1.1.92.0/CMakeLists.txt.dma 2019-02-13 09:20:44.590959278 +1000
|
||||||
|
+++ Vulkan-ValidationLayers-sdk-1.1.92.0/CMakeLists.txt 2019-02-13 09:21:29.178151673 +1000
|
||||||
|
@@ -294,7 +294,7 @@ set_target_properties(generate_helper_fi
|
||||||
|
# files directly in layers.
|
||||||
|
|
||||||
|
add_library(VkLayer_utils
|
||||||
|
- STATIC
|
||||||
|
+ SHARED
|
||||||
|
layers/vk_layer_config.cpp
|
||||||
|
layers/vk_layer_extension_utils.cpp
|
||||||
|
layers/vk_layer_utils.cpp
|
1
sources
Normal file
1
sources
Normal file
@ -0,0 +1 @@
|
|||||||
|
SHA512 (Vulkan-ValidationLayers-sdk-1.2.189.0.tar.gz) = 2e398e47887147038122fed1f4abdfbd4f44ebdbc4d79640def48384202b37886d15f01784b57f62adfb6da0643abb65169fc4a6709b14f602d21d360dd68dd9
|
119
vulkan-validation-layers.spec
Normal file
119
vulkan-validation-layers.spec
Normal file
@ -0,0 +1,119 @@
|
|||||||
|
Name: vulkan-validation-layers
|
||||||
|
Version: 1.2.189.0
|
||||||
|
Release: 2%{?dist}
|
||||||
|
Summary: Vulkan validation layers
|
||||||
|
|
||||||
|
License: ASL 2.0
|
||||||
|
URL: https://github.com/KhronosGroup/Vulkan-ValidationLayers
|
||||||
|
Source0: %url/archive/sdk-%{version}.tar.gz#/Vulkan-ValidationLayers-sdk-%{version}.tar.gz
|
||||||
|
Patch0: fix_shared.patch
|
||||||
|
Patch1: add-missing-export.patch
|
||||||
|
|
||||||
|
BuildRequires: gcc
|
||||||
|
BuildRequires: gcc-c++
|
||||||
|
BuildRequires: cmake
|
||||||
|
BuildRequires: glslang-devel
|
||||||
|
BuildRequires: ninja-build
|
||||||
|
BuildRequires: python%{python3_pkgversion}-devel
|
||||||
|
BuildRequires: spirv-tools-devel
|
||||||
|
BuildRequires: spirv-headers-devel
|
||||||
|
BuildRequires: vulkan-loader-devel
|
||||||
|
BuildRequires: pkgconfig(wayland-client)
|
||||||
|
BuildRequires: pkgconfig(wayland-cursor)
|
||||||
|
BuildRequires: pkgconfig(wayland-server)
|
||||||
|
BuildRequires: pkgconfig(wayland-egl)
|
||||||
|
BuildRequires: pkgconfig(x11)
|
||||||
|
BuildRequires: pkgconfig(xrandr)
|
||||||
|
BuildRequires: pkgconfig(xcb)
|
||||||
|
|
||||||
|
Requires: spirv-tools-libs >= 2019.4-1.20191109
|
||||||
|
%description
|
||||||
|
Vulkan validation layers
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
Requires: vulkan-headers
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The %{name}-devel package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -p1 -n Vulkan-ValidationLayers-sdk-%{version}
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
# Decrease debuginfo verbosity to reduce memory consumption even more
|
||||||
|
%global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
|
||||||
|
%global optflags %(echo %{optflags} | sed 's/-O2 /-O1 /')
|
||||||
|
|
||||||
|
|
||||||
|
%cmake -GNinja \
|
||||||
|
-DCMAKE_BUILD_TYPE=Release \
|
||||||
|
-DGLSLANG_INSTALL_DIR=%{_prefix} \
|
||||||
|
-DBUILD_LAYER_SUPPORT_FILES:BOOL=ON \
|
||||||
|
-DUSE_ROBIN_HOOD_HASHING:BOOL=OFF \
|
||||||
|
-DSPIRV_HEADERS_INSTALL_DIR=%{_includedir}/spirv/ \
|
||||||
|
-DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}/vulkan/ .
|
||||||
|
%ninja_build
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%ninja_install
|
||||||
|
|
||||||
|
|
||||||
|
%ldconfig_scriptlets
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%license LICENSE.txt
|
||||||
|
%doc README.md CONTRIBUTING.md
|
||||||
|
%{_datadir}/vulkan/explicit_layer.d/*.json
|
||||||
|
%{_libdir}/libVkLayer_*.so
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_includedir}/vulkan/
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Sep 08 2021 Dave Airlie <airlied@redhat.com> - 1.2.189.0-2
|
||||||
|
- Update to 1.2.189.0 SDK
|
||||||
|
|
||||||
|
* Mon Feb 01 2021 Dave Airlie <airlied@redhat.com> - 1.2.162.0-1
|
||||||
|
- Update to 1.2.162.0
|
||||||
|
|
||||||
|
* Wed Aug 05 2020 Dave Airlie <airlied@redhat.com> - 1.2.148.0-1
|
||||||
|
- Update to 1.2.148.0
|
||||||
|
|
||||||
|
* Wed Jan 29 2020 Dave Airlie <airlied@redhat.com> - 1.2.131.1-1
|
||||||
|
- Update for 8.2.0 for vulkan 1.2
|
||||||
|
|
||||||
|
* Sat Dec 07 2019 Dave Airlie <airlied@redhat.com> - 1.1.126.0-3
|
||||||
|
- Update for 8.2.0
|
||||||
|
|
||||||
|
* Fri Nov 29 2019 Dave Airlie <airlied@redhat.com> - 1.1.126.0-2
|
||||||
|
- Add explicit spirv toos libs requires
|
||||||
|
|
||||||
|
* Wed Nov 13 2019 Dave Airlie <airlied@redhat.com> - 1.1.126.0-1
|
||||||
|
- Update validation layers to 1.1.126.0
|
||||||
|
|
||||||
|
* Wed Jul 31 2019 Dave Airlie <airlied@redhat.com> - 1.1.114.0-1
|
||||||
|
- Update validation layers to 1.1.114.0
|
||||||
|
|
||||||
|
* Wed Mar 06 2019 Dave Airlie <airlied@redhat.com> - 1.1.101.0-1
|
||||||
|
- Update valdiation layers to 1.1.101.0
|
||||||
|
|
||||||
|
* Tue Aug 07 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.82.0-1
|
||||||
|
- Update to 1.1.82.0
|
||||||
|
|
||||||
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.77.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jun 26 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.77.0-3
|
||||||
|
- Workaround i686 build issue
|
||||||
|
|
||||||
|
* Tue Jun 26 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.77.0-2
|
||||||
|
- Exclude i686 due to 'virtual memory exhausted' FTBFS
|
||||||
|
|
||||||
|
* Sat Jun 23 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.77.0-1
|
||||||
|
- Initial package
|
Loading…
Reference in New Issue
Block a user