vvl: drop the shared util library, no longer used.
This commit is contained in:
parent
0335441c25
commit
5d5c5f1bcb
53
0001-add-missing-VK_LAYER_EXPORTs.patch
Normal file
53
0001-add-missing-VK_LAYER_EXPORTs.patch
Normal file
@ -0,0 +1,53 @@
|
||||
From f519c98e77ae1e48efeda49db144e786dd99339b Mon Sep 17 00:00:00 2001
|
||||
From: Dave Airlie <airlied@redhat.com>
|
||||
Date: Wed, 15 Feb 2023 17:37:08 +1000
|
||||
Subject: [PATCH] add missing VK_LAYER_EXPORTs
|
||||
|
||||
---
|
||||
layers/layer_options.h | 2 +-
|
||||
layers/stateless_validation.h | 2 +-
|
||||
scripts/layer_chassis_generator.py | 2 +-
|
||||
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/layers/layer_options.h b/layers/layer_options.h
|
||||
index 97909a5ed..d19e42c01 100644
|
||||
--- a/layers/layer_options.h
|
||||
+++ b/layers/layer_options.h
|
||||
@@ -22,7 +22,7 @@
|
||||
|
||||
#include "chassis.h"
|
||||
|
||||
-extern std::vector<std::pair<uint32_t, uint32_t>> custom_stype_info;
|
||||
+VK_LAYER_EXPORT extern std::vector<std::pair<uint32_t, uint32_t>> custom_stype_info;
|
||||
|
||||
// Process validation features, flags and settings specified through extensions, a layer settings file, or environment variables
|
||||
|
||||
diff --git a/layers/stateless_validation.h b/layers/stateless_validation.h
|
||||
index e0f21b7a6..2fb8c6142 100644
|
||||
--- a/layers/stateless_validation.h
|
||||
+++ b/layers/stateless_validation.h
|
||||
@@ -31,7 +31,7 @@
|
||||
[[maybe_unused]] static const char *kVUID_PVError_ExtensionNotEnabled = "UNASSIGNED-GeneralParameterError-ExtensionNotEnabled";
|
||||
[[maybe_unused]] static const char *kVUID_PVError_ApiVersionViolation = "UNASSIGNED-API-Version-Violation";
|
||||
|
||||
-extern std::vector<std::pair<uint32_t, uint32_t>> custom_stype_info;
|
||||
+VK_LAYER_EXPORT extern std::vector<std::pair<uint32_t, uint32_t>> custom_stype_info;
|
||||
|
||||
// String returned by string_VkStructureType for an unrecognized type.
|
||||
const std::string UnsupportedStructureTypeString = "Unhandled VkStructureType";
|
||||
diff --git a/scripts/layer_chassis_generator.py b/scripts/layer_chassis_generator.py
|
||||
index be76d4204..62b442e8b 100644
|
||||
--- a/scripts/layer_chassis_generator.py
|
||||
+++ b/scripts/layer_chassis_generator.py
|
||||
@@ -600,7 +600,7 @@ bool wrap_handles = true;
|
||||
#include "chassis_dispatch_helper.h"
|
||||
|
||||
// Global list of sType,size identifiers
|
||||
-std::vector<std::pair<uint32_t, uint32_t>> custom_stype_info{};
|
||||
+VK_LAYER_EXPORT std::vector<std::pair<uint32_t, uint32_t>> custom_stype_info{};
|
||||
"""
|
||||
|
||||
inline_custom_source_preamble_2 = """
|
||||
--
|
||||
2.39.1
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up Vulkan-ValidationLayers-sdk-1.3.239.0/layers/CMakeLists.txt.dma Vulkan-ValidationLayers-sdk-1.3.239.0/layers/CMakeLists.txt
|
||||
--- Vulkan-ValidationLayers-sdk-1.3.239.0/layers/CMakeLists.txt.dma 2023-01-31 12:05:35.414802790 +1000
|
||||
+++ Vulkan-ValidationLayers-sdk-1.3.239.0/layers/CMakeLists.txt 2023-01-31 12:06:54.380001391 +1000
|
||||
@@ -23,7 +23,7 @@
|
||||
# https://github.com/KhronosGroup/Vulkan-ValidationLayers/issues/4640
|
||||
add_compile_definitions(XXH_NO_LONG_LONG)
|
||||
|
||||
-add_library(VkLayer_utils STATIC)
|
||||
+add_library(VkLayer_utils SHARED)
|
||||
target_sources(VkLayer_utils PRIVATE
|
||||
generated/vk_format_utils.h
|
||||
generated/vk_format_utils.cpp
|
@ -6,7 +6,6 @@ Summary: Vulkan validation layers
|
||||
License: ASL 2.0
|
||||
URL: https://github.com/KhronosGroup/Vulkan-ValidationLayers
|
||||
Source0: %url/archive/sdk-%{version}.tar.gz#/Vulkan-ValidationLayers-sdk-%{version}.tar.gz
|
||||
Patch0: fix_shared.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
|
Loading…
Reference in New Issue
Block a user