import vulkan-validation-layers-1.3.204.0-1.el8
This commit is contained in:
parent
0f3568bf37
commit
5cc78a8986
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/Vulkan-ValidationLayers-sdk-1.2.198.0.tar.gz
|
SOURCES/Vulkan-ValidationLayers-sdk-1.3.204.0.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
63bf7f912945912def63a309b86ce05a432df564 SOURCES/Vulkan-ValidationLayers-sdk-1.2.198.0.tar.gz
|
ee1bf12c2c1998a7a0495a1380b74f72ce276db4 SOURCES/Vulkan-ValidationLayers-sdk-1.3.204.0.tar.gz
|
||||||
|
12
SOURCES/fix-spirv-tools-shared.patch
Normal file
12
SOURCES/fix-spirv-tools-shared.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up Vulkan-ValidationLayers-sdk-1.3.204.0/layers/CMakeLists.txt.dma Vulkan-ValidationLayers-sdk-1.3.204.0/layers/CMakeLists.txt
|
||||||
|
--- Vulkan-ValidationLayers-sdk-1.3.204.0/layers/CMakeLists.txt.dma 2022-02-16 12:57:50.396556235 +1000
|
||||||
|
+++ Vulkan-ValidationLayers-sdk-1.3.204.0/layers/CMakeLists.txt 2022-02-16 12:57:54.312630300 +1000
|
||||||
|
@@ -315,7 +315,7 @@ if(BUILD_LAYERS)
|
||||||
|
target_include_directories(VkLayer_khronos_validation PRIVATE ${SPIRV_HEADERS_INCLUDE_DIR})
|
||||||
|
endif()
|
||||||
|
|
||||||
|
- target_link_libraries(VkLayer_khronos_validation PRIVATE SPIRV-Tools-static SPIRV-Tools-opt)
|
||||||
|
+ target_link_libraries(VkLayer_khronos_validation PRIVATE SPIRV-Tools SPIRV-Tools-opt)
|
||||||
|
|
||||||
|
|
||||||
|
# The output file needs Unix "/" separators or Windows "\" separators On top of that, Windows separators actually need to be doubled
|
11
SOURCES/try-fix-headers.patch
Normal file
11
SOURCES/try-fix-headers.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -up Vulkan-ValidationLayers-sdk-1.3.204.0/CMakeLists.txt.dma Vulkan-ValidationLayers-sdk-1.3.204.0/CMakeLists.txt
|
||||||
|
--- Vulkan-ValidationLayers-sdk-1.3.204.0/CMakeLists.txt.dma 2022-02-16 12:29:43.131617038 +1000
|
||||||
|
+++ Vulkan-ValidationLayers-sdk-1.3.204.0/CMakeLists.txt 2022-02-16 12:29:48.095711141 +1000
|
||||||
|
@@ -256,7 +256,6 @@ if (USE_ROBIN_HOOD_HASHING)
|
||||||
|
endif()
|
||||||
|
endif()
|
||||||
|
|
||||||
|
-set(SPIRV_HEADERS_INCLUDE_DIR "" CACHE STRING "")
|
||||||
|
if(BUILD_LAYERS OR BUILD_TESTS)
|
||||||
|
if (SPIRV_HEADERS_INCLUDE_DIR STREQUAL "")
|
||||||
|
find_package(SPIRV-Headers REQUIRED CONFIG)
|
@ -1,6 +1,6 @@
|
|||||||
Name: vulkan-validation-layers
|
Name: vulkan-validation-layers
|
||||||
Version: 1.2.198.0
|
Version: 1.3.204.0
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Vulkan validation layers
|
Summary: Vulkan validation layers
|
||||||
|
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
@ -8,6 +8,9 @@ URL: https://github.com/KhronosGroup/Vulkan-ValidationLayers
|
|||||||
Source0: %url/archive/sdk-%{version}.tar.gz#/Vulkan-ValidationLayers-sdk-%{version}.tar.gz
|
Source0: %url/archive/sdk-%{version}.tar.gz#/Vulkan-ValidationLayers-sdk-%{version}.tar.gz
|
||||||
Patch0: fix_shared.patch
|
Patch0: fix_shared.patch
|
||||||
Patch1: add-missing-export.patch
|
Patch1: add-missing-export.patch
|
||||||
|
Patch2: try-fix-headers.patch
|
||||||
|
Patch3: fix-spirv-tools-shared.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
@ -45,7 +48,6 @@ developing applications that use %{name}.
|
|||||||
%build
|
%build
|
||||||
# Decrease debuginfo verbosity to reduce memory consumption even more
|
# Decrease debuginfo verbosity to reduce memory consumption even more
|
||||||
%global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
|
%global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
|
||||||
%global optflags %(echo %{optflags} | sed 's/-O2 /-O1 /')
|
|
||||||
|
|
||||||
|
|
||||||
%cmake -GNinja \
|
%cmake -GNinja \
|
||||||
@ -75,17 +77,8 @@ developing applications that use %{name}.
|
|||||||
%{_includedir}/vulkan/
|
%{_includedir}/vulkan/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Fri Dec 10 2021 Dave Airlie <airlied@redhat.com> - 1.2.198.0-4
|
* Tue Feb 22 2022 Dave Airlie <airlied@redhat.com> - 1.3.204.0-1
|
||||||
- Rebuild for spirv-tools ABI
|
- Update to 1.3.204.0
|
||||||
|
|
||||||
* Thu Dec 09 2021 Dave Airlie <airlied@redhat.com> - 1.2.198.0-3
|
|
||||||
- Rebuild for spirv-tools
|
|
||||||
|
|
||||||
* Wed Dec 01 2021 Dave Airlie <airlied@redhat.com> - 1.2.198.0-2
|
|
||||||
- Update to 1.2.198.0
|
|
||||||
|
|
||||||
* Wed Sep 08 2021 Dave Airlie <airlied@redhat.com> - 1.2.189.0-2
|
|
||||||
- Update to 1.2.189.0 SDK
|
|
||||||
|
|
||||||
* Mon Feb 01 2021 Dave Airlie <airlied@redhat.com> - 1.2.162.0-1
|
* Mon Feb 01 2021 Dave Airlie <airlied@redhat.com> - 1.2.162.0-1
|
||||||
- Update to 1.2.162.0
|
- Update to 1.2.162.0
|
||||||
|
Loading…
Reference in New Issue
Block a user