import vulkan-validation-layers-1.3.224.0-1.el8
This commit is contained in:
parent
2e44e702df
commit
2f68536ee3
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/Vulkan-ValidationLayers-sdk-1.3.204.0.tar.gz
|
||||
SOURCES/Vulkan-ValidationLayers-sdk-1.3.224.0.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
ee1bf12c2c1998a7a0495a1380b74f72ce276db4 SOURCES/Vulkan-ValidationLayers-sdk-1.3.204.0.tar.gz
|
||||
93eb219605496efd9e772a950f9024ecb5817f36 SOURCES/Vulkan-ValidationLayers-sdk-1.3.224.0.tar.gz
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff -up Vulkan-ValidationLayers-sdk-1.2.182.0/layers/vk_layer_config.cpp.dma Vulkan-ValidationLayers-sdk-1.2.182.0/layers/vk_layer_config.cpp
|
||||
--- Vulkan-ValidationLayers-sdk-1.2.182.0/layers/vk_layer_config.cpp.dma 2021-08-07 08:13:46.344320103 +1000
|
||||
+++ Vulkan-ValidationLayers-sdk-1.2.182.0/layers/vk_layer_config.cpp 2021-08-07 08:14:22.130893289 +1000
|
||||
@@ -68,7 +68,7 @@ class ConfigFile {
|
||||
|
||||
static ConfigFile layer_config;
|
||||
|
||||
-string GetEnvironment(const char *variable) {
|
||||
+VK_LAYER_EXPORT string GetEnvironment(const char *variable) {
|
||||
#if !defined(__ANDROID__) && !defined(_WIN32)
|
||||
const char *output = getenv(variable);
|
||||
return output == NULL ? "" : output;
|
||||
diff -up Vulkan-ValidationLayers-sdk-1.2.182.0/layers/vk_layer_config.h.dma Vulkan-ValidationLayers-sdk-1.2.182.0/layers/vk_layer_config.h
|
||||
--- Vulkan-ValidationLayers-sdk-1.2.182.0/layers/vk_layer_config.h.dma 2021-08-07 08:14:04.352608540 +1000
|
||||
+++ Vulkan-ValidationLayers-sdk-1.2.182.0/layers/vk_layer_config.h 2021-08-07 08:14:15.237782885 +1000
|
||||
@@ -33,7 +33,7 @@
|
||||
#define SECONDARY_VK_REGISTRY_HIVE_STR "HKEY_CURRENT_USER"
|
||||
#endif
|
||||
|
||||
-std::string GetEnvironment(const char *variable);
|
||||
+VK_LAYER_EXPORT std::string GetEnvironment(const char *variable);
|
||||
|
||||
#ifdef __cplusplus
|
||||
extern "C" {
|
@ -1,12 +0,0 @@
|
||||
diff -up Vulkan-ValidationLayers-sdk-1.3.204.0/layers/CMakeLists.txt.dma Vulkan-ValidationLayers-sdk-1.3.204.0/layers/CMakeLists.txt
|
||||
--- Vulkan-ValidationLayers-sdk-1.3.204.0/layers/CMakeLists.txt.dma 2022-02-16 12:57:50.396556235 +1000
|
||||
+++ Vulkan-ValidationLayers-sdk-1.3.204.0/layers/CMakeLists.txt 2022-02-16 12:57:54.312630300 +1000
|
||||
@@ -315,7 +315,7 @@ if(BUILD_LAYERS)
|
||||
target_include_directories(VkLayer_khronos_validation PRIVATE ${SPIRV_HEADERS_INCLUDE_DIR})
|
||||
endif()
|
||||
|
||||
- target_link_libraries(VkLayer_khronos_validation PRIVATE SPIRV-Tools-static SPIRV-Tools-opt)
|
||||
+ target_link_libraries(VkLayer_khronos_validation PRIVATE SPIRV-Tools SPIRV-Tools-opt)
|
||||
|
||||
|
||||
# The output file needs Unix "/" separators or Windows "\" separators On top of that, Windows separators actually need to be doubled
|
@ -1,11 +0,0 @@
|
||||
diff -up Vulkan-ValidationLayers-sdk-1.3.204.0/CMakeLists.txt.dma Vulkan-ValidationLayers-sdk-1.3.204.0/CMakeLists.txt
|
||||
--- Vulkan-ValidationLayers-sdk-1.3.204.0/CMakeLists.txt.dma 2022-02-16 12:29:43.131617038 +1000
|
||||
+++ Vulkan-ValidationLayers-sdk-1.3.204.0/CMakeLists.txt 2022-02-16 12:29:48.095711141 +1000
|
||||
@@ -256,7 +256,6 @@ if (USE_ROBIN_HOOD_HASHING)
|
||||
endif()
|
||||
endif()
|
||||
|
||||
-set(SPIRV_HEADERS_INCLUDE_DIR "" CACHE STRING "")
|
||||
if(BUILD_LAYERS OR BUILD_TESTS)
|
||||
if (SPIRV_HEADERS_INCLUDE_DIR STREQUAL "")
|
||||
find_package(SPIRV-Headers REQUIRED CONFIG)
|
@ -1,5 +1,5 @@
|
||||
Name: vulkan-validation-layers
|
||||
Version: 1.3.204.0
|
||||
Version: 1.3.224.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Vulkan validation layers
|
||||
|
||||
@ -7,9 +7,6 @@ License: ASL 2.0
|
||||
URL: https://github.com/KhronosGroup/Vulkan-ValidationLayers
|
||||
Source0: %url/archive/sdk-%{version}.tar.gz#/Vulkan-ValidationLayers-sdk-%{version}.tar.gz
|
||||
Patch0: fix_shared.patch
|
||||
Patch1: add-missing-export.patch
|
||||
Patch2: try-fix-headers.patch
|
||||
Patch3: fix-spirv-tools-shared.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
@ -55,7 +52,7 @@ developing applications that use %{name}.
|
||||
-DGLSLANG_INSTALL_DIR=%{_prefix} \
|
||||
-DBUILD_LAYER_SUPPORT_FILES:BOOL=ON \
|
||||
-DUSE_ROBIN_HOOD_HASHING:BOOL=OFF \
|
||||
-DSPIRV_HEADERS_INSTALL_DIR=%{_includedir}/spirv/ \
|
||||
-DSPIRV_HEADERS_INCLUDE_DIR=%{_includedir} \
|
||||
-DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}/vulkan/ .
|
||||
%ninja_build
|
||||
|
||||
@ -77,6 +74,12 @@ developing applications that use %{name}.
|
||||
%{_includedir}/vulkan/
|
||||
|
||||
%changelog
|
||||
* Wed Aug 24 2022 Dave Airlie <airlied@redhat.com> - 1.3.224.0-1
|
||||
- Update to 1.3.224.0
|
||||
|
||||
* Mon Jun 20 2022 Dave Airlie <airlied@redhat.com> - 1.3.216.0-1
|
||||
- Update to 1.3.216.0
|
||||
|
||||
* Tue Feb 22 2022 Dave Airlie <airlied@redhat.com> - 1.3.204.0-1
|
||||
- Update to 1.3.204.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user