Update to 1.3.216.0
Resolves: rhbz#2070287
This commit is contained in:
parent
984d0ee0a3
commit
cc9331aa42
1
.gitignore
vendored
1
.gitignore
vendored
@ -16,3 +16,4 @@
|
||||
/Vulkan-Loader-sdk-1.2.162.0.tar.gz
|
||||
/Vulkan-Loader-sdk-1.2.182.0.tar.gz
|
||||
/Vulkan-Loader-sdk-1.3.204.0.tar.gz
|
||||
/Vulkan-Loader-sdk-1.3.216.0.tar.gz
|
||||
|
@ -1,34 +0,0 @@
|
||||
From fb93d3ff8b63bdfdf88a8f25a715f816a52d5dd8 Mon Sep 17 00:00:00 2001
|
||||
From: Dave Airlie <airlied@redhat.com>
|
||||
Date: Mon, 13 Dec 2021 14:50:06 +1000
|
||||
Subject: [PATCH] loader/aarch64: attempt to avoid text relocations in the
|
||||
unknown code
|
||||
|
||||
The commit below added a TEXTREL into the loader library, TEXTRELs
|
||||
and security people don't get on well, so we'd like to avoid that.
|
||||
|
||||
This is my attempt at fixing it, I'm not an aarch64 expert at all,
|
||||
so I'd really appreciate someone who is to take a look.
|
||||
|
||||
Fixes: 4f78f14c0533 ("loader: Add aarch64 unknown ext chain implementation")
|
||||
---
|
||||
loader/unknown_ext_chain_gas_aarch64.S | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/loader/unknown_ext_chain_gas_aarch64.S b/loader/unknown_ext_chain_gas_aarch64.S
|
||||
index 1e065007d..a1fa46205 100644
|
||||
--- a/loader/unknown_ext_chain_gas_aarch64.S
|
||||
+++ b/loader/unknown_ext_chain_gas_aarch64.S
|
||||
@@ -50,7 +50,8 @@ terminError\num:
|
||||
mov x0, x11 // Vulkan instance pointer (first arg)
|
||||
mov x1, VK_DEBUG_REPORT_ERROR_BIT_EXT // The error logging bit (second arg)
|
||||
mov x2, #0 // Zero (third arg)
|
||||
- ldr x3, =termin_error_string // The error string (fourth arg)
|
||||
+ adrp x9, termin_error_string
|
||||
+ ldr x3, [x9, #:lo12:termin_error_string] // The error string (fourth arg)
|
||||
ldr x4, [x11, x10] // The function name (fifth arg)
|
||||
bl loader_log // Log the error message before we crash
|
||||
mov x0, #0
|
||||
--
|
||||
2.33.1
|
||||
|
12
add-notes.patch
Normal file
12
add-notes.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up Vulkan-Loader-sdk-1.3.216.0/loader/CMakeLists.txt.dma Vulkan-Loader-sdk-1.3.216.0/loader/CMakeLists.txt
|
||||
--- Vulkan-Loader-sdk-1.3.216.0/loader/CMakeLists.txt.dma 2022-06-20 12:14:17.371384329 +1000
|
||||
+++ Vulkan-Loader-sdk-1.3.216.0/loader/CMakeLists.txt 2022-06-20 12:14:25.743510904 +1000
|
||||
@@ -178,7 +178,7 @@ else() # i.e.: Linux
|
||||
if(USE_GAS)
|
||||
enable_language(ASM)
|
||||
|
||||
- set(CMAKE_ASM_FLAGS "${CMAKE_C_FLAGS}")
|
||||
+ set(CMAKE_ASM_FLAGS "${CMAKE_C_FLAGS} -Wa,--generate-missing-build-notes=yes")
|
||||
set(CMAKE_TRY_COMPILE_TARGET_TYPE STATIC_LIBRARY)
|
||||
|
||||
if (${CMAKE_SYSTEM_PROCESSOR} STREQUAL "aarch64")
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (Vulkan-Loader-sdk-1.3.204.0.tar.gz) = d15f51173cd2618ab65569c7d375e2afdd91b7cece46e9528d7709011382946b181fb52f210f2ad3a676b0ae7c0d4dc374f052705f55b5ffc5f4e8aef8c38e7a
|
||||
SHA512 (Vulkan-Loader-sdk-1.3.216.0.tar.gz) = 2acc3385c68c6c256febf2d66f3ae39dc7e60dca98fcedd9239ead163b9580c7bb226a4e4108da742c96e158e1c0ca3fc6ce4dec77225c7f832baf8b4f54ddbd
|
||||
|
@ -1,13 +1,13 @@
|
||||
Name: vulkan-loader
|
||||
Version: 1.3.204.0
|
||||
Release: 2%{?dist}
|
||||
Version: 1.3.216.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Vulkan ICD desktop loader
|
||||
|
||||
License: ASL 2.0
|
||||
URL: https://github.com/KhronosGroup/Vulkan-Loader
|
||||
Source0: %url/archive/sdk-%{version}.tar.gz#/Vulkan-Loader-sdk-%{version}.tar.gz
|
||||
|
||||
Patch0: 0001-loader-aarch64-attempt-to-avoid-text-relocations-in-.patch
|
||||
Patch0: add-notes.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
@ -93,6 +93,9 @@ mkdir -p %{buildroot}%{_sysconfdir}/vulkan/{explicit,implicit}_layer.d/ \
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jun 22 2022 Dave Airlie <airlied@redhat.com> - 1.3.216.0-1
|
||||
- Update to 1.3.216.0
|
||||
|
||||
* Fri Feb 25 2022 Dave Airlie <airlied@redhat.com>\ - 1.3.204.0-2
|
||||
- Fix aarch64 textrel
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user