import from CS git vulkan-loader-1.3.283.0-1.el8
This commit is contained in:
parent
636874f22b
commit
91f1d840e7
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/Vulkan-Loader-sdk-1.3.250.1.tar.gz
|
||||
SOURCES/Vulkan-Loader-sdk-1.3.283.0.tar.gz
|
1
.vulkan-loader.metadata
Normal file
1
.vulkan-loader.metadata
Normal file
@ -0,0 +1 @@
|
||||
23a6ddf29216fb8b1a45bab8723b79079c6ab0e3 SOURCES/Vulkan-Loader-sdk-1.3.283.0.tar.gz
|
@ -1,12 +0,0 @@
|
||||
diff -up Vulkan-Loader-sdk-1.3.216.0/loader/CMakeLists.txt.dma Vulkan-Loader-sdk-1.3.216.0/loader/CMakeLists.txt
|
||||
--- Vulkan-Loader-sdk-1.3.216.0/loader/CMakeLists.txt.dma 2022-06-20 12:14:17.371384329 +1000
|
||||
+++ Vulkan-Loader-sdk-1.3.216.0/loader/CMakeLists.txt 2022-06-20 12:14:25.743510904 +1000
|
||||
@@ -178,7 +178,7 @@ else() # i.e.: Linux
|
||||
if(USE_GAS)
|
||||
enable_language(ASM)
|
||||
|
||||
- set(CMAKE_ASM_FLAGS "${CMAKE_C_FLAGS}")
|
||||
+ set(CMAKE_ASM_FLAGS "${CMAKE_C_FLAGS} -Wa,--generate-missing-build-notes=yes")
|
||||
set(CMAKE_TRY_COMPILE_TARGET_TYPE STATIC_LIBRARY)
|
||||
|
||||
if (${CMAKE_SYSTEM_PROCESSOR} STREQUAL "aarch64")
|
@ -1,18 +1,15 @@
|
||||
Name: vulkan-loader
|
||||
Version: 1.3.250.1
|
||||
Version: 1.3.283.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Vulkan ICD desktop loader
|
||||
|
||||
License: ASL 2.0
|
||||
URL: https://github.com/KhronosGroup/Vulkan-Loader
|
||||
Source0: %url/archive/sdk-%{version}.tar.gz#/Vulkan-Loader-sdk-%{version}.tar.gz
|
||||
|
||||
# hard code adding notes to the one asm file compilation.
|
||||
Patch1: add-notes.patch
|
||||
Source0: %url/archive/vulkan-sdk-%{version}.tar.gz#/Vulkan-Loader-sdk-%{version}.tar.gz
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: cmake
|
||||
BuildRequires: cmake3
|
||||
BuildRequires: ninja-build
|
||||
BuildRequires: python%{python3_pkgversion}-devel
|
||||
BuildRequires: vulkan-headers = %{version}
|
||||
@ -55,16 +52,16 @@ developing applications that use %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -n Vulkan-Loader-sdk-%{version} -p1
|
||||
%autosetup -p1 -n Vulkan-Loader-vulkan-sdk-%{version}
|
||||
|
||||
|
||||
%build
|
||||
%cmake -GNinja -DCMAKE_BUILD_TYPE=Release .
|
||||
%ninja_build
|
||||
%cmake3 -GNinja -DCMAKE_BUILD_TYPE=Release
|
||||
%cmake_build
|
||||
|
||||
|
||||
%install
|
||||
%ninja_install
|
||||
%cmake_install
|
||||
|
||||
# create the filesystem
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/vulkan/{explicit,implicit}_layer.d/ \
|
||||
@ -91,9 +88,13 @@ mkdir -p %{buildroot}%{_sysconfdir}/vulkan/{explicit,implicit}_layer.d/ \
|
||||
%files devel
|
||||
%{_libdir}/pkgconfig/vulkan.pc
|
||||
%{_libdir}/*.so
|
||||
|
||||
%{_libdir}/cmake/VulkanLoader/*.cmake
|
||||
|
||||
%changelog
|
||||
* Tue Sep 10 2024 José Expósito <jexposit@redhat.com> - 1.3.283.0-1
|
||||
- Update to 1.3.283.0 SDK
|
||||
Resolves: https://issues.redhat.com/browse/RHEL-54287
|
||||
|
||||
* Wed Jul 12 2023 Dave Airlie <airlied@redhat.com> - 1.3.250.1-1
|
||||
- Update to 1.3.250.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user