import vulkan-loader-1.2.162.0-1.el8
This commit is contained in:
parent
1109db6c95
commit
41fa93a69d
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/Vulkan-Loader-sdk-1.2.154.1.tar.gz
|
SOURCES/Vulkan-Loader-sdk-1.2.162.0.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
c29fba4de3b31e2284567d364a1c9ad2eabd516f SOURCES/Vulkan-Loader-sdk-1.2.154.1.tar.gz
|
df585c26d3a04fa521bf5c051f04a3e2e8a8b088 SOURCES/Vulkan-Loader-sdk-1.2.162.0.tar.gz
|
||||||
|
37
SOURCES/fix-vulkan-loader.patch
Normal file
37
SOURCES/fix-vulkan-loader.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
From 66a23ac8c566299343668f094de50798a5f4a0e4 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Michel Zou <xantares09@hotmail.com>
|
||||||
|
Date: Wed, 16 Dec 2020 15:03:23 +0100
|
||||||
|
Subject: [PATCH] Rename LIB_SUFFIX to VULKAN_LIB_SUFFIX
|
||||||
|
|
||||||
|
Closes #527
|
||||||
|
---
|
||||||
|
loader/CMakeLists.txt | 2 +-
|
||||||
|
loader/vulkan.pc.in | 2 +-
|
||||||
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/loader/CMakeLists.txt b/loader/CMakeLists.txt
|
||||||
|
index 659511855..ba9f460f1 100644
|
||||||
|
--- a/loader/CMakeLists.txt
|
||||||
|
+++ b/loader/CMakeLists.txt
|
||||||
|
@@ -327,7 +327,7 @@ if(PKG_CONFIG_FOUND)
|
||||||
|
set(PRIVATE_LIBS "${PRIVATE_LIBS} -l${LIB}")
|
||||||
|
endforeach()
|
||||||
|
if(WIN32)
|
||||||
|
- set(LIB_SUFFIX "-1")
|
||||||
|
+ set(VULKAN_LIB_SUFFIX "-1")
|
||||||
|
endif ()
|
||||||
|
configure_file("vulkan.pc.in" "vulkan.pc" @ONLY)
|
||||||
|
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/vulkan.pc" DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
|
||||||
|
diff --git a/loader/vulkan.pc.in b/loader/vulkan.pc.in
|
||||||
|
index fc17cb1f3..44049ee34 100644
|
||||||
|
--- a/loader/vulkan.pc.in
|
||||||
|
+++ b/loader/vulkan.pc.in
|
||||||
|
@@ -6,7 +6,7 @@ includedir=@CMAKE_INSTALL_FULL_INCLUDEDIR@
|
||||||
|
Name: @CMAKE_PROJECT_NAME@
|
||||||
|
Description: Vulkan Loader
|
||||||
|
Version: @VK_API_VERSION@
|
||||||
|
-Libs: -L${libdir} -lvulkan@LIB_SUFFIX@
|
||||||
|
+Libs: -L${libdir} -lvulkan@VULKAN_LIB_SUFFIX@
|
||||||
|
Libs.private: @PRIVATE_LIBS@
|
||||||
|
Cflags: -I${includedir}
|
||||||
|
|
@ -1,5 +1,5 @@
|
|||||||
Name: vulkan-loader
|
Name: vulkan-loader
|
||||||
Version: 1.2.154.1
|
Version: 1.2.162.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Vulkan ICD desktop loader
|
Summary: Vulkan ICD desktop loader
|
||||||
|
|
||||||
@ -9,13 +9,15 @@ Source0: %url/archive/sdk-%{version}.tar.gz#/Vulkan-Loader-sdk-%{version}
|
|||||||
|
|
||||||
# hard code adding notes to the one asm file compilation.
|
# hard code adding notes to the one asm file compilation.
|
||||||
Patch1: add-notes.patch
|
Patch1: add-notes.patch
|
||||||
|
# vulkan loader fix from github
|
||||||
|
Patch2: fix-vulkan-loader.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: cmake3
|
BuildRequires: cmake
|
||||||
BuildRequires: ninja-build
|
BuildRequires: ninja-build
|
||||||
BuildRequires: python%{python3_pkgversion}-devel
|
BuildRequires: python%{python3_pkgversion}-devel
|
||||||
BuildRequires: vulkan-headers = 1.2.154.0
|
BuildRequires: vulkan-headers = %{version}
|
||||||
BuildRequires: pkgconfig(wayland-client)
|
BuildRequires: pkgconfig(wayland-client)
|
||||||
BuildRequires: pkgconfig(wayland-cursor)
|
BuildRequires: pkgconfig(wayland-cursor)
|
||||||
BuildRequires: pkgconfig(wayland-server)
|
BuildRequires: pkgconfig(wayland-server)
|
||||||
@ -59,7 +61,7 @@ developing applications that use %{name}.
|
|||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake3 -GNinja -DCMAKE_BUILD_TYPE=Release .
|
%cmake -GNinja -DCMAKE_BUILD_TYPE=Release .
|
||||||
%ninja_build
|
%ninja_build
|
||||||
|
|
||||||
|
|
||||||
@ -94,8 +96,8 @@ mkdir -p %{buildroot}%{_sysconfdir}/vulkan/{explicit,implicit}_layer.d/ \
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Nov 04 2020 Dave Airlie <airlied@redhat.com> - 1.2.154.1-1
|
* Mon Feb 01 2021 Dave Airlie <airlied@redhat.com> - 1.2.162.0-1
|
||||||
- Update to 1.2.154.1
|
- Update to 1.2.162.0
|
||||||
|
|
||||||
* Wed Aug 05 2020 Dave Airlie <airlied@redhat.com> - 1.2.148.0-1
|
* Wed Aug 05 2020 Dave Airlie <airlied@redhat.com> - 1.2.148.0-1
|
||||||
- Update to 1.2.148.0
|
- Update to 1.2.148.0
|
||||||
|
Loading…
Reference in New Issue
Block a user