import vulkan-loader-1.2.148.0-1.el8
This commit is contained in:
commit
0444f35fc2
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/Vulkan-Loader-sdk-1.2.148.0.tar.gz
|
1
.vulkan-loader.metadata
Normal file
1
.vulkan-loader.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
20ade39c9329d7854401bca89671e36993159798 SOURCES/Vulkan-Loader-sdk-1.2.148.0.tar.gz
|
12
SOURCES/add-notes.patch
Normal file
12
SOURCES/add-notes.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up Vulkan-Loader-sdk-1.1.114.0/loader/CMakeLists.txt.da Vulkan-Loader-sdk-1.1.114.0/loader/CMakeLists.txt
|
||||||
|
--- Vulkan-Loader-sdk-1.1.114.0/loader/CMakeLists.txt.da 2019-08-08 11:12:09.817782355 +1000
|
||||||
|
+++ Vulkan-Loader-sdk-1.1.114.0/loader/CMakeLists.txt 2019-08-08 11:13:10.812416417 +1000
|
||||||
|
@@ -149,7 +149,7 @@ elseif(APPLE)
|
||||||
|
add_custom_target(loader_asm_gen_files) # This causes no assembly files to be generated.
|
||||||
|
else(UNIX AND NOT APPLE) # i.e.: Linux
|
||||||
|
enable_language(ASM)
|
||||||
|
- set(CMAKE_ASM_FLAGS "${CMAKE_C_FLAGS}")
|
||||||
|
+ set(CMAKE_ASM_FLAGS "${CMAKE_C_FLAGS} -Wa,--generate-missing-build-notes=yes")
|
||||||
|
|
||||||
|
check_include_file("cet.h" HAVE_CET_H)
|
||||||
|
if(HAVE_CET_H)
|
138
SPECS/vulkan-loader.spec
Normal file
138
SPECS/vulkan-loader.spec
Normal file
@ -0,0 +1,138 @@
|
|||||||
|
Name: vulkan-loader
|
||||||
|
Version: 1.2.148.0
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Vulkan ICD desktop loader
|
||||||
|
|
||||||
|
License: ASL 2.0
|
||||||
|
URL: https://github.com/KhronosGroup/Vulkan-Loader
|
||||||
|
Source0: %url/archive/sdk-%{version}.tar.gz#/Vulkan-Loader-sdk-%{version}.tar.gz
|
||||||
|
|
||||||
|
# hard code adding notes to the one asm file compilation.
|
||||||
|
Patch1: add-notes.patch
|
||||||
|
|
||||||
|
BuildRequires: gcc
|
||||||
|
BuildRequires: gcc-c++
|
||||||
|
BuildRequires: cmake3
|
||||||
|
BuildRequires: ninja-build
|
||||||
|
BuildRequires: python%{python3_pkgversion}-devel
|
||||||
|
BuildRequires: vulkan-headers = %{version}
|
||||||
|
BuildRequires: pkgconfig(wayland-client)
|
||||||
|
BuildRequires: pkgconfig(wayland-cursor)
|
||||||
|
BuildRequires: pkgconfig(wayland-server)
|
||||||
|
BuildRequires: pkgconfig(wayland-egl)
|
||||||
|
BuildRequires: pkgconfig(x11)
|
||||||
|
BuildRequires: pkgconfig(xrandr)
|
||||||
|
|
||||||
|
Provides: vulkan%{?_isa} = %{version}-%{release}
|
||||||
|
Provides: vulkan = %{version}-%{release}
|
||||||
|
Obsoletes: vulkan < %{version}-%{release}
|
||||||
|
Provides: vulkan-filesystem = %{version}-%{release}
|
||||||
|
Obsoletes: vulkan-filesystem < %{version}-%{release}
|
||||||
|
|
||||||
|
%if 0%{?fedora} <= 27
|
||||||
|
%ifarch x86_64 i686
|
||||||
|
Requires: mesa-vulkan-drivers%{?_isa}
|
||||||
|
%endif
|
||||||
|
%else
|
||||||
|
Requires: mesa-vulkan-drivers%{?_isa}
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%description
|
||||||
|
This project provides the Khronos official Vulkan ICD desktop
|
||||||
|
loader for Windows, Linux, and MacOS.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
Requires: vulkan-headers
|
||||||
|
Provides: vulkan-devel%{?_isa} = %{version}-%{release}
|
||||||
|
Provides: vulkan-devel = %{version}-%{release}
|
||||||
|
Obsoletes: vulkan-devel < %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The %{name}-devel package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n Vulkan-Loader-sdk-%{version} -p1
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cmake3 -GNinja -DCMAKE_BUILD_TYPE=Release .
|
||||||
|
%ninja_build
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%ninja_install
|
||||||
|
|
||||||
|
# create the filesystem
|
||||||
|
mkdir -p %{buildroot}%{_sysconfdir}/vulkan/{explicit,implicit}_layer.d/ \
|
||||||
|
%{buildroot}%{_datadir}/vulkan/{explicit,implicit}_layer.d/ \
|
||||||
|
%{buildroot}{%{_sysconfdir},%{_datadir}}/vulkan/icd.d
|
||||||
|
|
||||||
|
|
||||||
|
%ldconfig_scriptlets
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%license LICENSE.txt
|
||||||
|
%doc README.md CONTRIBUTING.md
|
||||||
|
%dir %{_sysconfdir}/vulkan/
|
||||||
|
%dir %{_sysconfdir}/vulkan/explicit_layer.d/
|
||||||
|
%dir %{_sysconfdir}/vulkan/icd.d/
|
||||||
|
%dir %{_sysconfdir}/vulkan/implicit_layer.d/
|
||||||
|
%dir %{_datadir}/vulkan/
|
||||||
|
%dir %{_datadir}/vulkan/explicit_layer.d/
|
||||||
|
%dir %{_datadir}/vulkan/icd.d/
|
||||||
|
%dir %{_datadir}/vulkan/implicit_layer.d/
|
||||||
|
%{_libdir}/*.so.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_libdir}/pkgconfig/vulkan.pc
|
||||||
|
%{_libdir}/*.so
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Aug 05 2020 Dave Airlie <airlied@redhat.com> - 1.2.148.0-1
|
||||||
|
- Update to 1.2.148.0
|
||||||
|
|
||||||
|
* Wed Jan 29 2020 Dave Airlie <airlied@redhat.com> - 1.2.131.1-1
|
||||||
|
- Update to 1.2.131.1
|
||||||
|
|
||||||
|
* Sat Dec 07 2019 Dave Airlie <airlied@redhat.com> - 1.1.126.0-2
|
||||||
|
- Rebuild for 8.2.0
|
||||||
|
|
||||||
|
* Tue Nov 12 2019 Dave Airlie <airlied@redhat.com> - 1.1.126.0-1
|
||||||
|
- Update to 1.1.126.0
|
||||||
|
|
||||||
|
* Thu Aug 08 2019 Dave Airlie <airlied@redhat.com> - 1.1.114.0-3
|
||||||
|
- Add notes to avoid annobin gaps warning on i686
|
||||||
|
|
||||||
|
* Thu Aug 08 2019 Dave Airlie <airlied@redhat.com> - 1.1.114.0-2
|
||||||
|
- Add support to asm files for -fcf-protection
|
||||||
|
|
||||||
|
* Mon Aug 05 2019 Dave Airlie <airlied@redhat.com> - 1.1.114.0-1
|
||||||
|
- Update to 1.1.114.0
|
||||||
|
|
||||||
|
* Wed Mar 06 2019 Dave Airlie <airlied@redhat.com> - 1.1.101.0-0
|
||||||
|
- Update to 1.1.101.0
|
||||||
|
|
||||||
|
* Tue Aug 07 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.82.0-1
|
||||||
|
- Update to 1.1.82.0
|
||||||
|
|
||||||
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.77.0-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 27 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.77.0-4
|
||||||
|
- Fix update path
|
||||||
|
|
||||||
|
* Tue Jun 26 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.77.0-3
|
||||||
|
- Add conditional for mesa-vulkan-drivers requires
|
||||||
|
|
||||||
|
* Tue Jun 26 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.77.0-2
|
||||||
|
- Improve description and summary
|
||||||
|
- Set release
|
||||||
|
|
||||||
|
* Sat Jun 23 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.77.0-1
|
||||||
|
- Initial package
|
Loading…
Reference in New Issue
Block a user