update to latest upstream 3.0.1
fixes #851441 - Introduce new systemd-rpm macros in vsftpd spec file fixes #845980 - vsftpd seccomp filter is too strict
This commit is contained in:
parent
bd7f8ceba2
commit
ebf9be68f7
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@ vsftpd-2.3.2.tar.gz
|
|||||||
/vsftpd-2.3.4.tar.gz
|
/vsftpd-2.3.4.tar.gz
|
||||||
/vsftpd-2.3.5.tar.gz
|
/vsftpd-2.3.5.tar.gz
|
||||||
/vsftpd-3.0.0.tar.gz
|
/vsftpd-3.0.0.tar.gz
|
||||||
|
/vsftpd-3.0.1.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
ad9fa952558c2c5b0426ccaccff0f972 vsftpd-3.0.0.tar.gz
|
6a9c235f60313d2eeb7c46730fd6cd56 vsftpd-3.0.1.tar.gz
|
||||||
|
@ -15,7 +15,7 @@ diff -up vsftpd-2.2.0/sysdeputil.c.pam_hostname vsftpd-2.2.0/sysdeputil.c
|
|||||||
@@ -325,6 +329,10 @@ vsf_sysdep_check_auth(struct mystr* p_us
|
@@ -325,6 +329,10 @@ vsf_sysdep_check_auth(struct mystr* p_us
|
||||||
const struct mystr* p_remote_host)
|
const struct mystr* p_remote_host)
|
||||||
{
|
{
|
||||||
int retval;
|
int retval = -1;
|
||||||
+#ifdef PAM_RHOST
|
+#ifdef PAM_RHOST
|
||||||
+ struct sockaddr_in sin;
|
+ struct sockaddr_in sin;
|
||||||
+ struct hostent *host;
|
+ struct hostent *host;
|
||||||
|
30
vsftpd.spec
30
vsftpd.spec
@ -1,8 +1,8 @@
|
|||||||
%{!?tcp_wrappers:%define tcp_wrappers 1}
|
%{!?tcp_wrappers:%define tcp_wrappers 1}
|
||||||
|
|
||||||
Name: vsftpd
|
Name: vsftpd
|
||||||
Version: 3.0.0
|
Version: 3.0.1
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Very Secure Ftp Daemon
|
Summary: Very Secure Ftp Daemon
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -28,8 +28,9 @@ BuildRequires: tcp_wrappers-devel
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Requires: logrotate
|
Requires: logrotate
|
||||||
Requires (preun): /sbin/chkconfig
|
Requires (post): systemd-units
|
||||||
Requires (post): /sbin/chkconfig
|
Requires (preun): systemd-units
|
||||||
|
Requires (postun): systemd-units
|
||||||
|
|
||||||
# Build patches
|
# Build patches
|
||||||
Patch1: vsftpd-2.1.0-libs.patch
|
Patch1: vsftpd-2.1.0-libs.patch
|
||||||
@ -132,23 +133,13 @@ mkdir -p $RPM_BUILD_ROOT/%{_var}/ftp/pub
|
|||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
%post
|
%post
|
||||||
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
|
%systemd_post vsftpd.service
|
||||||
|
|
||||||
%preun
|
%preun
|
||||||
if [ $1 = 0 ]; then
|
%systemd_preun vsftpd.service
|
||||||
/bin/systemctl disable vsftpd.service > /dev/null 2>&1 || :
|
|
||||||
/bin/systemctl stop vsftpd.service > /dev/null 2>&1 || :
|
|
||||||
fi
|
|
||||||
|
|
||||||
%postun
|
%postun
|
||||||
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
|
%systemd_postun_with_restart vsftpd.service
|
||||||
|
|
||||||
%triggerun -- %{name} < 2.3.4-5
|
|
||||||
/sbin/chkconfig --del vsftpd >/dev/null 2>&1 || :
|
|
||||||
/bin/systemctl try-restart vsftpd.service >/dev/null 2>&1 || :
|
|
||||||
|
|
||||||
%triggerpostun -n %{name}-sysvinit -- %{name} < 2.3.4-5
|
|
||||||
/sbin/chkconfig --add vsftpd >/dev/null 2>&1 || :
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -171,6 +162,11 @@ fi
|
|||||||
%{_sysconfdir}/rc.d/init.d/vsftpd
|
%{_sysconfdir}/rc.d/init.d/vsftpd
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 17 2012 Jiri Skala <jskala@redhat.com> - 3.0.1-1
|
||||||
|
- update to latest upstream 3.0.1
|
||||||
|
- fixes #851441 - Introduce new systemd-rpm macros in vsftpd spec file
|
||||||
|
- fixes #845980 - vsftpd seccomp filter is too strict
|
||||||
|
|
||||||
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.0-4
|
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.0-4
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user