- updated to latest upstream version
This commit is contained in:
parent
1a7313fc35
commit
afaeec30c2
@ -1 +1 @@
|
||||
vsftpd-2.1.1pre1.tar.gz
|
||||
vsftpd-2.1.2.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
ea57505bf438eef6d4f53d4dc7fe8574 vsftpd-2.1.1pre1.tar.gz
|
||||
6a8c8579d50adf0d0fc07226c03bfb52 vsftpd-2.1.2.tar.gz
|
||||
|
@ -49,8 +49,8 @@ diff -up vsftpd-2.1.0/parseconf.c.userlist_log vsftpd-2.1.0/parseconf.c
|
||||
diff -up vsftpd-2.1.0/prelogin.c.userlist_log vsftpd-2.1.0/prelogin.c
|
||||
--- vsftpd-2.1.0/prelogin.c.userlist_log 2009-02-18 23:23:53.000000000 +0100
|
||||
+++ vsftpd-2.1.0/prelogin.c 2009-02-24 09:17:41.000000000 +0100
|
||||
@@ -219,6 +219,20 @@ handle_user_command(struct vsf_session*
|
||||
{
|
||||
@@ -220,6 +220,20 @@ handle_user_command(struct vsf_session*
|
||||
check_login_delay();
|
||||
vsf_cmdio_write(p_sess, FTP_LOGINERR, "Permission denied.");
|
||||
check_login_fails(p_sess);
|
||||
+ if (tunable_userlist_log)
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -pruN vsftpd-2.1.0.orig/prelogin.c vsftpd-2.1.0/prelogin.c
|
||||
--- vsftpd-2.1.0.orig/prelogin.c 2009-04-12 16:00:09.000000000 +0200
|
||||
+++ vsftpd-2.1.0/prelogin.c 2009-04-12 16:13:57.000000000 +0200
|
||||
@@ -217,6 +217,7 @@ handle_user_command(struct vsf_session*
|
||||
if ((located && tunable_userlist_deny) ||
|
||||
(!located && !tunable_userlist_deny))
|
||||
{
|
||||
+ check_login_delay();
|
||||
vsf_cmdio_write(p_sess, FTP_LOGINERR, "Permission denied.");
|
||||
check_login_fails(p_sess);
|
||||
if (tunable_userlist_log)
|
@ -81,7 +81,7 @@ diff -up vsftpd-2.1.1/standalone.c.daemonize_plus vsftpd-2.1.1/standalone.c
|
||||
diff -up vsftpd-2.1.1/sysutil.c.daemonize_plus vsftpd-2.1.1/sysutil.c
|
||||
--- vsftpd-2.1.1/sysutil.c.daemonize_plus 2009-05-10 22:11:24.000000000 +0200
|
||||
+++ vsftpd-2.1.1/sysutil.c 2009-05-10 22:11:59.000000000 +0200
|
||||
@@ -201,6 +201,9 @@ vsf_sysutil_translate_sig(const enum EVS
|
||||
@@ -202,6 +202,9 @@ vsf_sysutil_translate_sig(const enum EVS
|
||||
case kVSFSysUtilSigHUP:
|
||||
realsig = SIGHUP;
|
||||
break;
|
||||
@ -91,7 +91,7 @@ diff -up vsftpd-2.1.1/sysutil.c.daemonize_plus vsftpd-2.1.1/sysutil.c
|
||||
default:
|
||||
bug("unknown signal in vsf_sysutil_translate_sig");
|
||||
break;
|
||||
@@ -538,6 +541,12 @@ vsf_sysutil_getpid(void)
|
||||
@@ -539,6 +542,12 @@ vsf_sysutil_getpid(void)
|
||||
return (unsigned int) s_current_pid;
|
||||
}
|
||||
|
||||
@ -104,9 +104,9 @@ diff -up vsftpd-2.1.1/sysutil.c.daemonize_plus vsftpd-2.1.1/sysutil.c
|
||||
int
|
||||
vsf_sysutil_fork(void)
|
||||
{
|
||||
@@ -2786,3 +2795,53 @@ vsf_sysutil_set_no_fds()
|
||||
die("setrlimit NOFILE");
|
||||
}
|
||||
@@ -2807,3 +2816,53 @@ vsf_sysutil_set_no_fds()
|
||||
{
|
||||
s_current_pid = -1;
|
||||
}
|
||||
+
|
||||
+static struct sigaction sigalr, sigusr1;
|
||||
@ -171,15 +171,15 @@ diff -up vsftpd-2.1.1/sysutil.h.daemonize_plus vsftpd-2.1.1/sysutil.h
|
||||
};
|
||||
enum EVSFSysUtilInterruptContext
|
||||
{
|
||||
@@ -164,6 +165,7 @@ void vsf_sysutil_free(void* p_ptr);
|
||||
@@ -165,6 +165,7 @@ void vsf_sysutil_free(void* p_ptr);
|
||||
|
||||
/* Process creation/exit/process handling */
|
||||
unsigned int vsf_sysutil_getpid(void);
|
||||
+unsigned int vsf_sysutil_getppid(void);
|
||||
void vsf_sysutil_clear_pid_cache(void);
|
||||
int vsf_sysutil_fork(void);
|
||||
int vsf_sysutil_fork_failok(void);
|
||||
void vsf_sysutil_exit(int exit_code);
|
||||
@@ -180,6 +182,9 @@ int vsf_sysutil_wait_exited_normally(
|
||||
@@ -182,6 +184,9 @@ int vsf_sysutil_wait_exited_normally(
|
||||
const struct vsf_sysutil_wait_retval* p_waitret);
|
||||
int vsf_sysutil_wait_get_exitcode(
|
||||
const struct vsf_sysutil_wait_retval* p_waitret);
|
||||
|
13
vsftpd.spec
13
vsftpd.spec
@ -1,16 +1,15 @@
|
||||
%{!?tcp_wrappers:%define tcp_wrappers 1}
|
||||
%{!?pretag:%define pretag pre1}
|
||||
|
||||
Name: vsftpd
|
||||
Version: 2.1.1
|
||||
Release: 0.3.%{pretag}%{?dist}
|
||||
Version: 2.1.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Very Secure Ftp Daemon
|
||||
|
||||
Group: System Environment/Daemons
|
||||
# OpenSSL link exception
|
||||
License: GPLv2 with exceptions
|
||||
URL: http://vsftpd.beasts.org/
|
||||
Source0: ftp://vsftpd.beasts.org/users/cevans/%{name}-%{version}%{pretag}.tar.gz
|
||||
Source0: ftp://vsftpd.beasts.org/users/cevans/%{name}-%{version}.tar.gz
|
||||
Source1: vsftpd.xinetd
|
||||
Source2: vsftpd.pam
|
||||
Source3: vsftpd.ftpusers
|
||||
@ -48,7 +47,6 @@ Patch8: vsftpd-2.0.5-greedy.patch
|
||||
Patch9: vsftpd-2.1.0-userlist_log.patch
|
||||
|
||||
Patch10: vsftpd-2.1.0-trim.patch
|
||||
Patch11: vsftpd-2.1.0-userlistdelay.patch
|
||||
Patch12: vsftpd-2.1.1-daemonize_plus.patch
|
||||
|
||||
%description
|
||||
@ -72,10 +70,8 @@ cp %{SOURCE1} .
|
||||
%patch8 -p1 -b .greedy
|
||||
%patch9 -p1 -b .userlist_log
|
||||
%patch10 -p1 -b .trim
|
||||
%patch11 -p1 -b .userlistdelay
|
||||
%patch12 -p1 -b .daemonize_plus
|
||||
|
||||
|
||||
%build
|
||||
%ifarch s390x sparcv9 sparc64
|
||||
make CFLAGS="$RPM_OPT_FLAGS -fPIE -pipe -Wextra -Werror" \
|
||||
@ -139,6 +135,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jun 02 2009 Jiri Skala <jskala@redhat.com> - 2.1.2-1
|
||||
- updated to latest upstream version
|
||||
|
||||
* Thu May 21 2009 Jiri Skala <jskala@redhat.com> - 2.1.1-0.3
|
||||
- fixed daemonize_plus patch
|
||||
- fixed test in initscript [ -z "CONFS" ]
|
||||
|
Loading…
Reference in New Issue
Block a user