updated to latest upstream 3.0.0
This commit is contained in:
parent
05fc0d3b9d
commit
88e239f25f
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ vsftpd-2.2.2.tar.gz
|
|||||||
vsftpd-2.3.2.tar.gz
|
vsftpd-2.3.2.tar.gz
|
||||||
/vsftpd-2.3.4.tar.gz
|
/vsftpd-2.3.4.tar.gz
|
||||||
/vsftpd-2.3.5.tar.gz
|
/vsftpd-2.3.5.tar.gz
|
||||||
|
/vsftpd-3.0.0.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
01398a5bef8e85b6cf2c213a4b011eca vsftpd-2.3.5.tar.gz
|
ad9fa952558c2c5b0426ccaccff0f972 vsftpd-3.0.0.tar.gz
|
||||||
|
@ -1,12 +1,12 @@
|
|||||||
diff -up vsftpd-2.1.0/Makefile.libs vsftpd-2.1.0/Makefile
|
diff -up vsftpd-3.0.0/Makefile.libs vsftpd-3.0.0/Makefile
|
||||||
--- vsftpd-2.1.0/Makefile.libs 2009-01-08 18:55:39.000000000 +0100
|
--- vsftpd-3.0.0/Makefile.libs 2012-04-03 09:21:18.000000000 +0200
|
||||||
+++ vsftpd-2.1.0/Makefile 2009-01-08 18:55:57.000000000 +0100
|
+++ vsftpd-3.0.0/Makefile 2012-04-10 21:20:39.377248990 +0200
|
||||||
@@ -5,7 +5,7 @@ IFLAGS = -idirafter dummyinc
|
@@ -8,7 +8,7 @@ CFLAGS = -O2 -fPIE -fstack-protector --p
|
||||||
#CFLAGS = -g
|
-D_FORTIFY_SOURCE=2 \
|
||||||
CFLAGS = -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion
|
#-pedantic -Wconversion
|
||||||
|
|
||||||
-LIBS = `./vsf_findlibs.sh`
|
-LIBS = `./vsf_findlibs.sh`
|
||||||
+LIBS = -lwrap -lnsl -lpam -lcap -ldl -lcrypto
|
+LIBS = -lwrap -lnsl -lpam -lcap -ldl -lcrypto
|
||||||
LINK = -Wl,-s
|
LINK = -Wl,-s
|
||||||
|
LDFLAGS = -fPIE -pie -Wl,-z,relro -Wl,-z,now
|
||||||
|
|
||||||
OBJS = main.o utility.o prelogin.o ftpcmdio.o postlogin.o privsock.o \
|
|
||||||
|
@ -1,15 +0,0 @@
|
|||||||
diff -up vsftpd-2.2.0/ssl.c.openssl vsftpd-2.2.0/ssl.c
|
|
||||||
--- vsftpd-2.2.0/ssl.c.openssl 2009-01-09 21:47:05.000000000 +0100
|
|
||||||
+++ vsftpd-2.2.0/ssl.c 2009-08-22 20:41:58.000000000 +0200
|
|
||||||
@@ -537,7 +537,11 @@ get_ssl(struct vsf_session* p_sess, int
|
|
||||||
if (tunable_debug_ssl)
|
|
||||||
{
|
|
||||||
const char* p_ssl_version = SSL_get_cipher_version(p_ssl);
|
|
||||||
+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
|
|
||||||
+ const SSL_CIPHER* p_ssl_cipher = SSL_get_current_cipher(p_ssl);
|
|
||||||
+#else
|
|
||||||
SSL_CIPHER* p_ssl_cipher = SSL_get_current_cipher(p_ssl);
|
|
||||||
+#endif
|
|
||||||
const char* p_cipher_name = SSL_CIPHER_get_name(p_ssl_cipher);
|
|
||||||
X509* p_ssl_cert = SSL_get_peer_certificate(p_ssl);
|
|
||||||
int reused = SSL_session_reused(p_ssl);
|
|
@ -1,8 +1,8 @@
|
|||||||
%{!?tcp_wrappers:%define tcp_wrappers 1}
|
%{!?tcp_wrappers:%define tcp_wrappers 1}
|
||||||
|
|
||||||
Name: vsftpd
|
Name: vsftpd
|
||||||
Version: 2.3.5
|
Version: 3.0.0
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Very Secure Ftp Daemon
|
Summary: Very Secure Ftp Daemon
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -47,7 +47,6 @@ Patch9: vsftpd-2.1.0-userlist_log.patch
|
|||||||
|
|
||||||
Patch10: vsftpd-2.1.0-trim.patch
|
Patch10: vsftpd-2.1.0-trim.patch
|
||||||
Patch12: vsftpd-2.1.1-daemonize_plus.patch
|
Patch12: vsftpd-2.1.1-daemonize_plus.patch
|
||||||
Patch13: vsftpd-2.2.0-openssl.patch
|
|
||||||
Patch14: vsftpd-2.2.0-wildchar.patch
|
Patch14: vsftpd-2.2.0-wildchar.patch
|
||||||
|
|
||||||
Patch16: vsftpd-2.2.2-clone.patch
|
Patch16: vsftpd-2.2.2-clone.patch
|
||||||
@ -86,7 +85,6 @@ cp %{SOURCE1} .
|
|||||||
%patch9 -p1 -b .userlist_log
|
%patch9 -p1 -b .userlist_log
|
||||||
%patch10 -p1 -b .trim
|
%patch10 -p1 -b .trim
|
||||||
%patch12 -p1 -b .daemonize_plus
|
%patch12 -p1 -b .daemonize_plus
|
||||||
%patch13 -p1 -b .openssl
|
|
||||||
%patch14 -p1 -b .wildchar
|
%patch14 -p1 -b .wildchar
|
||||||
%patch16 -p1 -b .clone
|
%patch16 -p1 -b .clone
|
||||||
%patch19 -p1 -b .sd
|
%patch19 -p1 -b .sd
|
||||||
@ -167,6 +165,9 @@ fi
|
|||||||
%{_sysconfdir}/rc.d/init.d/vsftpd
|
%{_sysconfdir}/rc.d/init.d/vsftpd
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 10 2012 Jiri Skala <jskala@redhat.com> - 3.0.0-1
|
||||||
|
- updated to latest upstream 3.0.0
|
||||||
|
|
||||||
* Thu Feb 09 2012 Jiri Skala <jskala@redhat.com> - 2.3.5-3
|
* Thu Feb 09 2012 Jiri Skala <jskala@redhat.com> - 2.3.5-3
|
||||||
- fixes #788812 - authentication failure on x86_64 when using nss_pgsql
|
- fixes #788812 - authentication failure on x86_64 when using nss_pgsql
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user