auto-import changelog data from vsftpd-1.2.0-5.src.rpm
Sun Oct 12 2003 Florian La Roche <Florian.LaRoche@redhat.de> - allow compiling without tcp_wrappers support Mon Sep 15 2003 Bill Nottingham <notting@redhat.com> 1.2.0-4 - fix errant newline (#104443) Fri Aug 08 2003 Bill Nottingham <notting@redhat.com> 1.2.0-3 - tweak man page (#84584, #72798) - buildprereqs for pie (#99336) - free ride through the build system to fix (#101582) Thu Jun 26 2003 Bill Nottingham <notting@redhat.com> 1.2.0-2 - update to 1.2.0 Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> - rebuilt Mon Apr 28 2003 Bill Nottingham <notting@redhat.com> 1.1.3-9 - fix tcp_wrappers usage (#89765, <dale@riyescott.com>)
This commit is contained in:
parent
3940fcf38a
commit
61466ee516
@ -1 +1 @@
|
|||||||
vsftpd-1.1.3.tar.gz
|
vsftpd-1.2.0.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
3f5f59be09a6f89e516a75ad0d1e3802 vsftpd-1.1.3.tar.gz
|
19c1818c102b63e4b0fea8d5b8b7c51f vsftpd-1.2.0.tar.gz
|
||||||
|
@ -36,10 +36,3 @@
|
|||||||
+#enable for standalone mode
|
+#enable for standalone mode
|
||||||
+listen=YES
|
+listen=YES
|
||||||
+tcp_wrappers=YES
|
+tcp_wrappers=YES
|
||||||
--- vsftpd-1.1.3/vsftpd.8.foo Fri Dec 13 19:17:02 2002
|
|
||||||
+++ vsftpd-1.1.3/vsftpd.8 Fri Dec 13 19:17:13 2002
|
|
||||||
@@ -23,4 +23,3 @@
|
|
||||||
.Pa /etc/vsftpd.conf .
|
|
||||||
.Sh SEE ALSO
|
|
||||||
.Xr vsftpd.conf 5
|
|
||||||
-
|
|
||||||
|
@ -1,4 +1,3 @@
|
|||||||
|
|
||||||
#!/bin/bash
|
#!/bin/bash
|
||||||
#
|
#
|
||||||
# vsftpd This shell script takes care of starting and stopping
|
# vsftpd This shell script takes care of starting and stopping
|
||||||
|
47
vsftpd.spec
47
vsftpd.spec
@ -1,10 +1,13 @@
|
|||||||
|
%{!?tcp_wrappers:%define tcp_wrappers 1}
|
||||||
|
|
||||||
Summary: vsftpd - Very Secure Ftp Daemon
|
Summary: vsftpd - Very Secure Ftp Daemon
|
||||||
Name: vsftpd
|
Name: vsftpd
|
||||||
Version: 1.1.3
|
Version: 1.2.0
|
||||||
Release: 8
|
Release: 5
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source: ftp://ferret.lmh.ox.ac.uk/pub/linux/%{name}-%{version}.tar.gz
|
URL: http://vsftpd.beasts.org/
|
||||||
|
Source: ftp://vsftpd.beasts.org/users/cevans/%{name}-%{version}.tar.gz
|
||||||
Source1: vsftpd.xinetd
|
Source1: vsftpd.xinetd
|
||||||
Source2: vsftpd.pam
|
Source2: vsftpd.pam
|
||||||
Source3: vsftpd.ftpusers
|
Source3: vsftpd.ftpusers
|
||||||
@ -12,9 +15,14 @@ Source4: vsftpd.user_list
|
|||||||
Source5: vsftpd.init
|
Source5: vsftpd.init
|
||||||
Patch1: vsftpd-1.1.3-rh.patch
|
Patch1: vsftpd-1.1.3-rh.patch
|
||||||
Patch2: vsftpd-1.0.1-missingok.patch
|
Patch2: vsftpd-1.0.1-missingok.patch
|
||||||
Patch3: vsftpd-1.1.3-tcp_wrappers.patch
|
Patch3: vsftpd-1.2.0-tcp_wrappers.patch
|
||||||
|
Patch4: vsftpd-1.2.0-man.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
|
%if %{tcp_wrappers}
|
||||||
BuildPrereq: tcp_wrappers
|
BuildPrereq: tcp_wrappers
|
||||||
|
%endif
|
||||||
|
# for -fpie
|
||||||
|
BuildPrereq: gcc > gcc-3.2.3-13, binutils > binutils-2.14.90.0.4-24, glibc-devel >= 2.3.2-45
|
||||||
Requires: logrotate
|
Requires: logrotate
|
||||||
Prereq: /sbin/chkconfig, /sbin/service, /usr/sbin/usermod
|
Prereq: /sbin/chkconfig, /sbin/service, /usr/sbin/usermod
|
||||||
Obsoletes: anonftp
|
Obsoletes: anonftp
|
||||||
@ -28,12 +36,19 @@ scratch.
|
|||||||
%setup -q -n %{name}-%{version}
|
%setup -q -n %{name}-%{version}
|
||||||
%patch1 -p1 -b .rh
|
%patch1 -p1 -b .rh
|
||||||
%patch2 -p1 -b .mok
|
%patch2 -p1 -b .mok
|
||||||
|
%if %{tcp_wrappers}
|
||||||
%patch3 -p1 -b .tcp_wrappers
|
%patch3 -p1 -b .tcp_wrappers
|
||||||
|
%endif
|
||||||
|
%patch4 -p1 -b .manpage
|
||||||
cp %{SOURCE1} .
|
cp %{SOURCE1} .
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make CFLAGS="$RPM_OPT_FLAGS -pipe" \
|
%ifarch s390x
|
||||||
LINK="" \
|
make CFLAGS="$RPM_OPT_FLAGS -fPIE -pipe" \
|
||||||
|
%else
|
||||||
|
make CFLAGS="$RPM_OPT_FLAGS -fpie -pipe" \
|
||||||
|
%endif
|
||||||
|
LINK="-pie" \
|
||||||
%{?_smp_mflags}
|
%{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -83,6 +98,26 @@ fi
|
|||||||
/var/ftp
|
/var/ftp
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Oct 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||||
|
- allow compiling without tcp_wrappers support
|
||||||
|
|
||||||
|
* Mon Sep 15 2003 Bill Nottingham <notting@redhat.com> 1.2.0-4
|
||||||
|
- fix errant newline (#104443)
|
||||||
|
|
||||||
|
* Fri Aug 8 2003 Bill Nottingham <notting@redhat.com> 1.2.0-3
|
||||||
|
- tweak man page (#84584, #72798)
|
||||||
|
- buildprereqs for pie (#99336)
|
||||||
|
- free ride through the build system to fix (#101582)
|
||||||
|
|
||||||
|
* Thu Jun 26 2003 Bill Nottingham <notting@redhat.com> 1.2.0-2
|
||||||
|
- update to 1.2.0
|
||||||
|
|
||||||
|
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Mon Apr 28 2003 Bill Nottingham <notting@redhat.com> 1.1.3-9
|
||||||
|
- fix tcp_wrappers usage (#89765, <dale@riyescott.com>)
|
||||||
|
|
||||||
* Fri Feb 28 2003 Nalin Dahyabhai <nalin@redhat.com> 1.1.3-8
|
* Fri Feb 28 2003 Nalin Dahyabhai <nalin@redhat.com> 1.1.3-8
|
||||||
- enable use of tcp_wrappers
|
- enable use of tcp_wrappers
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user