auto-import changelog data from vsftpd-1.2.1-1.src.rpm
Mon Nov 24 2003 Karsten Hopp <karsten@redhat.de> 1.2.1-1 - update to 1.2.1, which fixes #89765 and lot of other issues - remove manpage patch, it isn't required anymore - clean up init script - don't use script to find libs to link with (lib64 issues)
This commit is contained in:
parent
61466ee516
commit
5f53d3d034
@ -1 +1 @@
|
|||||||
vsftpd-1.2.0.tar.gz
|
vsftpd-1.2.1.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
19c1818c102b63e4b0fea8d5b8b7c51f vsftpd-1.2.0.tar.gz
|
3dd254f9c9c1aea370b2f1ff6212af6e vsftpd-1.2.1.tar.gz
|
||||||
|
12
vsftpd-1.5.1-libs.patch
Normal file
12
vsftpd-1.5.1-libs.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
--- vsftpd-1.2.1/Makefile.rh1 2003-11-25 15:58:11.000000000 +0100
|
||||||
|
+++ vsftpd-1.2.1/Makefile 2003-11-25 15:58:33.000000000 +0100
|
||||||
|
@@ -5,7 +5,8 @@
|
||||||
|
#CFLAGS = -g
|
||||||
|
CFLAGS = -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion
|
||||||
|
|
||||||
|
-LIBS = `./vsf_findlibs.sh`
|
||||||
|
+#LIBS = `./vsf_findlibs.sh`
|
||||||
|
+LIBS = -lwrap -lnsl -lpam -lcap -ldl
|
||||||
|
LINK = -Wl,-s
|
||||||
|
|
||||||
|
OBJS = main.o utility.o prelogin.o ftpcmdio.o postlogin.o privsock.o \
|
18
vsftpd.init
18
vsftpd.init
@ -27,20 +27,16 @@ start() {
|
|||||||
# Start daemons.
|
# Start daemons.
|
||||||
|
|
||||||
if [ -d /etc/vsftpd ] ; then
|
if [ -d /etc/vsftpd ] ; then
|
||||||
declare -a sites
|
for i in `ls /etc/vsftpd/*.conf`; do
|
||||||
sites=(`ls /etc/vsftpd/*.conf`)
|
site=`basename $i .conf`
|
||||||
site_count=${#sites[@]}
|
|
||||||
index=0
|
|
||||||
|
|
||||||
while [ "${index}" -lt "${site_count}" ] ; do
|
|
||||||
site=`basename ${sites[${index}]} .conf`
|
|
||||||
echo -n $"Starting $prog for $site: "
|
echo -n $"Starting $prog for $site: "
|
||||||
( /usr/sbin/vsftpd ${sites[${index}]} &)
|
/usr/sbin/vsftpd $i &
|
||||||
daemon true
|
|
||||||
RETVAL=$?
|
RETVAL=$?
|
||||||
|
[ $RETVAL -eq 0 ] && {
|
||||||
|
touch /var/lock/subsys/$prog
|
||||||
|
success $"$prog $site"
|
||||||
|
}
|
||||||
echo
|
echo
|
||||||
[ $RETVAL -eq 0 ] && touch /var/lock/subsys/$prog
|
|
||||||
let "index = index + 1"
|
|
||||||
done
|
done
|
||||||
else
|
else
|
||||||
RETVAL=1
|
RETVAL=1
|
||||||
|
14
vsftpd.spec
14
vsftpd.spec
@ -2,8 +2,8 @@
|
|||||||
|
|
||||||
Summary: vsftpd - Very Secure Ftp Daemon
|
Summary: vsftpd - Very Secure Ftp Daemon
|
||||||
Name: vsftpd
|
Name: vsftpd
|
||||||
Version: 1.2.0
|
Version: 1.2.1
|
||||||
Release: 5
|
Release: 1
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://vsftpd.beasts.org/
|
URL: http://vsftpd.beasts.org/
|
||||||
@ -16,7 +16,7 @@ Source5: vsftpd.init
|
|||||||
Patch1: vsftpd-1.1.3-rh.patch
|
Patch1: vsftpd-1.1.3-rh.patch
|
||||||
Patch2: vsftpd-1.0.1-missingok.patch
|
Patch2: vsftpd-1.0.1-missingok.patch
|
||||||
Patch3: vsftpd-1.2.0-tcp_wrappers.patch
|
Patch3: vsftpd-1.2.0-tcp_wrappers.patch
|
||||||
Patch4: vsftpd-1.2.0-man.patch
|
Patch4: vsftpd-1.5.1-libs.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
%if %{tcp_wrappers}
|
%if %{tcp_wrappers}
|
||||||
BuildPrereq: tcp_wrappers
|
BuildPrereq: tcp_wrappers
|
||||||
@ -39,7 +39,7 @@ scratch.
|
|||||||
%if %{tcp_wrappers}
|
%if %{tcp_wrappers}
|
||||||
%patch3 -p1 -b .tcp_wrappers
|
%patch3 -p1 -b .tcp_wrappers
|
||||||
%endif
|
%endif
|
||||||
%patch4 -p1 -b .manpage
|
%patch4 -p1 -b .libs
|
||||||
cp %{SOURCE1} .
|
cp %{SOURCE1} .
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -98,6 +98,12 @@ fi
|
|||||||
/var/ftp
|
/var/ftp
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 24 2003 Karsten Hopp <karsten@redhat.de> 1.2.1-1
|
||||||
|
- update to 1.2.1, which fixes #89765 and lot of other issues
|
||||||
|
- remove manpage patch, it isn't required anymore
|
||||||
|
- clean up init script
|
||||||
|
- don't use script to find libs to link with (lib64 issues)
|
||||||
|
|
||||||
* Sun Oct 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
|
* Sun Oct 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||||
- allow compiling without tcp_wrappers support
|
- allow compiling without tcp_wrappers support
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user