* Fri Aug 20 2010 Jiri Skala <jskala@redhat.com> - 2.3.2-1

- fixes #625404 - vsftpd-2.3.1 is available
- joined patches (libs+dso, wildchar+greedy)
This commit is contained in:
Jiri Skala 2010-08-20 13:45:38 +02:00
parent f98f0189c6
commit 217ef8daae
5 changed files with 17 additions and 71 deletions

View File

@ -1,29 +0,0 @@
diff -up vsftpd-2.0.5/ls.c.greedy vsftpd-2.0.5/ls.c
--- vsftpd-2.0.5/ls.c.greedy 2007-12-03 12:03:50.000000000 +0100
+++ vsftpd-2.0.5/ls.c 2007-12-03 12:12:05.000000000 +0100
@@ -303,6 +303,25 @@ vsf_filename_passes_filter(const struct
{
goto out;
}
+ if (!must_match_at_current_pos)
+ {
+ struct mystr scan_fwd = INIT_MYSTR;
+
+ str_mid_to_end(&name_remain_str, &scan_fwd,
+ indexx + str_getlen(&s_match_needed_str));
+ /* We're allowed to be greedy, test if it match further along
+ * keep advancing indexx while we can still match.
+ */
+ while( (locate_result = str_locate_str(&scan_fwd, &s_match_needed_str)),
+ locate_result.found )
+ {
+ indexx += locate_result.index + str_getlen(&s_match_needed_str);
+ str_mid_to_end(&scan_fwd, &temp_str,
+ locate_result.index + str_getlen(&s_match_needed_str));
+ str_copy(&scan_fwd, &temp_str);
+ }
+ str_free(&scan_fwd);
+ }
/* Chop matched string out of remainder */
str_mid_to_end(&name_remain_str, &temp_str,
indexx + str_getlen(&s_match_needed_str));

View File

@ -6,7 +6,7 @@ diff -up vsftpd-2.1.0/Makefile.libs vsftpd-2.1.0/Makefile
CFLAGS = -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion CFLAGS = -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion
-LIBS = `./vsf_findlibs.sh` -LIBS = `./vsf_findlibs.sh`
+LIBS = -lwrap -lnsl -lpam -lcap -ldl +LIBS = -lwrap -lnsl -lpam -lcap -ldl -lcrypto
LINK = -Wl,-s LINK = -Wl,-s
OBJS = main.o utility.o prelogin.o ftpcmdio.o postlogin.o privsock.o \ OBJS = main.o utility.o prelogin.o ftpcmdio.o postlogin.o privsock.o \

View File

@ -1,37 +1,24 @@
diff -up vsftpd-2.2.0/ls.c.wildchar vsftpd-2.2.0/ls.c diff -up vsftpd-2.3.2/ls.c.tmp vsftpd-2.3.2/ls.c
--- vsftpd-2.2.0/ls.c.wildchar 2009-09-08 12:49:51.679476554 +0200 --- vsftpd-2.3.2/ls.c.tmp 2010-08-20 13:18:54.397583558 +0200
+++ vsftpd-2.2.0/ls.c 2009-09-08 12:52:53.778427990 +0200 +++ vsftpd-2.3.2/ls.c 2010-08-20 13:14:59.047831385 +0200
@@ -303,24 +303,19 @@ vsf_filename_passes_filter(const struct @@ -305,6 +305,20 @@ vsf_filename_passes_filter(const struct
{ {
goto out; goto out;
} }
- if (!must_match_at_current_pos)
+ if (!must_match_at_current_pos && last_token == 0) + if (!must_match_at_current_pos && last_token == 0)
{ + {
- struct mystr scan_fwd = INIT_MYSTR;
+ struct mystr last_str = INIT_MYSTR; + struct mystr last_str = INIT_MYSTR;
+ str_mid_to_end(&name_remain_str, &last_str, + str_mid_to_end(&name_remain_str, &last_str,
+ str_getlen(&name_remain_str) - str_getlen(&s_match_needed_str)); + str_getlen(&name_remain_str) - str_getlen(&s_match_needed_str));
+ locate_result = str_locate_str(&last_str, &s_match_needed_str); + locate_result = str_locate_str(&last_str, &s_match_needed_str);
+ str_free(&last_str); + str_free(&last_str);
+
- str_mid_to_end(&name_remain_str, &scan_fwd,
- indexx + str_getlen(&s_match_needed_str));
- /* We're allowed to be greedy, test if it match further along
- * keep advancing indexx while we can still match.
- */
- while( (locate_result = str_locate_str(&scan_fwd, &s_match_needed_str)),
- locate_result.found )
+ if (locate_result.found) + if (locate_result.found)
{ + {
- indexx += locate_result.index + str_getlen(&s_match_needed_str);
- str_mid_to_end(&scan_fwd, &temp_str,
- locate_result.index + str_getlen(&s_match_needed_str));
- str_copy(&scan_fwd, &temp_str);
+ ret = 1; + ret = 1;
} + }
- str_free(&scan_fwd);
+ goto out; + goto out;
} + }
/* Chop matched string out of remainder */ /* Chop matched string out of remainder */
str_mid_to_end(&name_remain_str, &temp_str, str_mid_to_end(&name_remain_str, &temp_str,
indexx + str_getlen(&s_match_needed_str));

View File

@ -1,12 +0,0 @@
diff -up vsftpd-2.2.2/Makefile.dso vsftpd-2.2.2/Makefile
--- vsftpd-2.2.2/Makefile.dso 2010-02-15 14:22:36.107319983 +0100
+++ vsftpd-2.2.2/Makefile 2010-02-15 14:37:45.760066748 +0100
@@ -5,7 +5,7 @@ IFLAGS = -idirafter dummyinc
#CFLAGS = -g
CFLAGS = -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion
-LIBS = -lwrap -lnsl -lpam -lcap -ldl
+LIBS = -lwrap -lnsl -lpam -lcap -ldl -lcrypto
LINK = -Wl,-s
OBJS = main.o utility.o prelogin.o ftpcmdio.o postlogin.o privsock.o \

View File

@ -1,8 +1,8 @@
%{!?tcp_wrappers:%define tcp_wrappers 1} %{!?tcp_wrappers:%define tcp_wrappers 1}
Name: vsftpd Name: vsftpd
Version: 2.2.2 Version: 2.3.2
Release: 8%{?dist} Release: 1%{?dist}
Summary: Very Secure Ftp Daemon Summary: Very Secure Ftp Daemon
Group: System Environment/Daemons Group: System Environment/Daemons
@ -43,7 +43,6 @@ Patch4: vsftpd-2.1.0-configuration.patch
Patch5: vsftpd-2.1.0-pam_hostname.patch Patch5: vsftpd-2.1.0-pam_hostname.patch
Patch6: vsftpd-close-std-fds.patch Patch6: vsftpd-close-std-fds.patch
Patch7: vsftpd-2.1.0-filter.patch Patch7: vsftpd-2.1.0-filter.patch
Patch8: vsftpd-2.0.5-greedy.patch
Patch9: vsftpd-2.1.0-userlist_log.patch Patch9: vsftpd-2.1.0-userlist_log.patch
Patch10: vsftpd-2.1.0-trim.patch Patch10: vsftpd-2.1.0-trim.patch
@ -51,7 +50,6 @@ Patch12: vsftpd-2.1.1-daemonize_plus.patch
Patch13: vsftpd-2.2.0-openssl.patch Patch13: vsftpd-2.2.0-openssl.patch
Patch14: vsftpd-2.2.0-wildchar.patch Patch14: vsftpd-2.2.0-wildchar.patch
Patch15: vsftpd-2.2.2-dso.patch
Patch16: vsftpd-2.2.2-clone.patch Patch16: vsftpd-2.2.2-clone.patch
Patch17: vsftpd-2.2.2-v6only.patch Patch17: vsftpd-2.2.2-v6only.patch
@ -73,13 +71,11 @@ cp %{SOURCE1} .
%patch5 -p1 -b .pam_hostname %patch5 -p1 -b .pam_hostname
%patch6 -p1 -b .close_fds %patch6 -p1 -b .close_fds
%patch7 -p1 -b .filter %patch7 -p1 -b .filter
%patch8 -p1 -b .greedy
%patch9 -p1 -b .userlist_log %patch9 -p1 -b .userlist_log
%patch10 -p1 -b .trim %patch10 -p1 -b .trim
%patch12 -p1 -b .daemonize_plus %patch12 -p1 -b .daemonize_plus
%patch13 -p1 -b .openssl %patch13 -p1 -b .openssl
%patch14 -p1 -b .wildchar %patch14 -p1 -b .wildchar
%patch15 -p1 -b .dso
%patch16 -p1 -b .clone %patch16 -p1 -b .clone
%patch17 -p1 -b .v6only %patch17 -p1 -b .v6only
@ -146,6 +142,10 @@ fi
%changelog %changelog
* Fri Aug 20 2010 Jiri Skala <jskala@redhat.com> - 2.3.2-1
- fixes #625404 - vsftpd-2.3.1 is available
- joined patches (libs+dso, wildchar+greedy)
* Fri Aug 06 2010 Jiri Skala <jskala@redhat.com> - 2.2.2-8 * Fri Aug 06 2010 Jiri Skala <jskala@redhat.com> - 2.2.2-8
- fixes #472880 - Configuration can cause confusion because of selinux labels - fixes #472880 - Configuration can cause confusion because of selinux labels