- update to 1.2.0
- remove libcurl and oggdec patches, applied upstream - drop unneeded autoconf BR - fix BuildRoot
This commit is contained in:
parent
ec74e148d0
commit
f0bb4f744e
@ -1,12 +0,0 @@
|
|||||||
--- vorbis-tools-1.1.1.svn20070412/configure.ac.libcurl 2007-05-16 13:04:09.000000000 -0400
|
|
||||||
+++ vorbis-tools-1.1.1.svn20070412/configure.ac 2007-05-16 12:56:40.000000000 -0400
|
|
||||||
@@ -165,6 +165,9 @@ if test "x$HAVE_PKG_CONFIG" = "xyes"; th
|
|
||||||
else
|
|
||||||
AM_PATH_CURL(HAVE_CURL=yes, HAVE_CURL=no; AC_MSG_WARN(libcurl missing))
|
|
||||||
fi
|
|
||||||
+if test "x$HAVE_CURL" = "xyes"; then
|
|
||||||
+ AC_DEFINE(HAVE_CURL,1,[Defined if we have libcurl])
|
|
||||||
+fi
|
|
||||||
|
|
||||||
if test "x$build_ogg123" = xyes; then
|
|
||||||
AC_MSG_RESULT([checking for ogg123 requirements])
|
|
@ -1,28 +0,0 @@
|
|||||||
See https://trac.xiph.org/ticket/1209 for the bug report. This patch comes
|
|
||||||
from: https://trac.xiph.org/changeset/13263?format=diff&new=13263
|
|
||||||
|
|
||||||
Index: /trunk/vorbis-tools/oggdec/oggdec.c
|
|
||||||
===================================================================
|
|
||||||
--- vorbis-tools/oggdec/oggdec.c (revision 12221)
|
|
||||||
+++ vorbis-tools/oggdec/oggdec.c (revision 13263)
|
|
||||||
@@ -256,4 +256,5 @@
|
|
||||||
int bs = 0;
|
|
||||||
char buf[8192], outbuf[8192];
|
|
||||||
+ char *p_outbuf;
|
|
||||||
int buflen = 8192;
|
|
||||||
unsigned int written = 0;
|
|
||||||
@@ -325,7 +326,11 @@
|
|
||||||
/* Then permute! */
|
|
||||||
permute_channels(buf, outbuf, ret, channels, bits/8);
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
- if(fwrite(outbuf, 1, ret, out) != ret) {
|
|
||||||
+ p_outbuf = outbuf;
|
|
||||||
+ }
|
|
||||||
+ else {
|
|
||||||
+ p_outbuf = buf;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ if(fwrite(p_outbuf, 1, ret, out) != ret) {
|
|
||||||
fprintf(stderr, "Error writing to file: %s\n", strerror(errno));
|
|
||||||
ov_clear(&vf);
|
|
@ -1,7 +1,7 @@
|
|||||||
Summary: The Vorbis General Audio Compression Codec tools
|
Summary: The Vorbis General Audio Compression Codec tools
|
||||||
Name: vorbis-tools
|
Name: vorbis-tools
|
||||||
Version: 1.1.1.svn20070412
|
Version: 1.2.0
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
@ -9,9 +9,7 @@ URL: http://www.xiph.org/
|
|||||||
Source: http://www.xiph.org/ogg/vorbis/download/%{name}-%{version}.tar.gz
|
Source: http://www.xiph.org/ogg/vorbis/download/%{name}-%{version}.tar.gz
|
||||||
Patch0: vorbis-tools-1.0-build.patch
|
Patch0: vorbis-tools-1.0-build.patch
|
||||||
Patch1: vorbis-tools-1.0-curlconfig.patch
|
Patch1: vorbis-tools-1.0-curlconfig.patch
|
||||||
Patch2: vorbis-tools-svn20070412-libcurl.patch
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Patch3: vorbis-tools-svn20070412-oggdec.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
Requires: libogg >= 2:1.1
|
Requires: libogg >= 2:1.1
|
||||||
Requires: libvorbis >= 1:%{version}
|
Requires: libvorbis >= 1:%{version}
|
||||||
Requires: libao >= 0.8.4
|
Requires: libao >= 0.8.4
|
||||||
@ -23,9 +21,6 @@ BuildRequires: flac-devel
|
|||||||
BuildRequires: libtool
|
BuildRequires: libtool
|
||||||
BuildRequires: libogg-devel
|
BuildRequires: libogg-devel
|
||||||
|
|
||||||
# For vorbis-tools-svn20070412-libcurl.patch
|
|
||||||
BuildRequires: autoconf
|
|
||||||
|
|
||||||
Obsoletes: vorbis < %{epoch}:%{version}-%{release}
|
Obsoletes: vorbis < %{epoch}:%{version}-%{release}
|
||||||
Provides: vorbis = %{epoch}:%{version}-%{release}
|
Provides: vorbis = %{epoch}:%{version}-%{release}
|
||||||
|
|
||||||
@ -41,8 +36,6 @@ comment editor.
|
|||||||
%setup -q -n %{name}-%{version}
|
%setup -q -n %{name}-%{version}
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
|
||||||
%patch3 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoconf
|
autoconf
|
||||||
@ -70,6 +63,12 @@ make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
|
|||||||
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 11 2008 Jindrich Novy <jnovy@redhat.com> - 1:1.2.0-1
|
||||||
|
- update to 1.2.0
|
||||||
|
- remove libcurl and oggdec patches, applied upstream
|
||||||
|
- drop unneeded autoconf BR
|
||||||
|
- fix BuildRoot
|
||||||
|
|
||||||
* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1:1.1.1.svn20070412-6
|
* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1:1.1.1.svn20070412-6
|
||||||
- Autorebuild for GCC 4.3
|
- Autorebuild for GCC 4.3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user