Add support for LUKS2 and more
Minor changes: - volume_key.spec: fix License tag
This commit is contained in:
parent
a407d142bc
commit
860134b642
24
volume_key-0.3.12-support_LUKS2_and_more.patch
Normal file
24
volume_key-0.3.12-support_LUKS2_and_more.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff --git a/lib/volume_luks.c b/lib/volume_luks.c
|
||||
index f4bf2c8..d1c5d47 100644
|
||||
--- a/lib/volume_luks.c
|
||||
+++ b/lib/volume_luks.c
|
||||
@@ -30,6 +30,10 @@ Author: Miloslav Trmač <mitr@redhat.com> */
|
||||
#include "volume.h"
|
||||
#include "volume_luks.h"
|
||||
|
||||
+#ifndef CRYPT_LUKS
|
||||
+#define CRYPT_LUKS NULL
|
||||
+#endif
|
||||
+
|
||||
/* LUKS - specific code */
|
||||
|
||||
/* Return an error message for ERR_NO, for g_free (). */
|
||||
@@ -105,7 +109,7 @@ open_crypt_device (const char *path, char **last_log_entry, GError **error)
|
||||
if (r < 0)
|
||||
goto err;
|
||||
crypt_set_log_callback(cd, record_cryptsetup_log_entry, last_log_entry);
|
||||
- r = crypt_load (cd, CRYPT_LUKS1, NULL);
|
||||
+ r = crypt_load (cd, CRYPT_LUKS, NULL);
|
||||
if (r < 0)
|
||||
goto err_cd;
|
||||
return cd;
|
@ -32,14 +32,17 @@
|
||||
Summary: An utility for manipulating storage encryption keys and passphrases
|
||||
Name: volume_key
|
||||
Version: 0.3.12
|
||||
Release: 1%{?dist}
|
||||
# lib/{SECerrs,SSLerrs}.h are both licensed under MPLv1.1 and GPLv2
|
||||
License: GPLv2 and (MPLv1.1 or GPLv2)
|
||||
Release: 2%{?dist}
|
||||
# lib/{SECerrs,SSLerrs}.h are both licensed under MPLv1.1, GPLv2 and LGPLv2
|
||||
License: GPLv2 and (MPLv1.1 or GPLv2 or LGPLv2)
|
||||
Group: Applications/System
|
||||
URL: https://pagure.io/%{name}/
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
|
||||
Source0: https://releases.pagure.org/%{name}/%{name}-%{version}.tar.xz
|
||||
# Support all LUKS devices
|
||||
# - backport of 26c09768662d8958debe8c9410dae9fda02292c3
|
||||
Patch0: volume_key-0.3.12-support_LUKS2_and_more.patch
|
||||
BuildRequires: gcc
|
||||
BuildRequires: cryptsetup-luks-devel, gettext-devel, glib2-devel, /usr/bin/gpg2
|
||||
BuildRequires: gpgme-devel, libblkid-devel, nss-devel, python3-devel
|
||||
@ -117,6 +120,7 @@ Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure %{?with_pythons}
|
||||
@ -128,6 +132,8 @@ make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
|
||||
# Remove libtool archive
|
||||
find %{buildroot} -type f -name "*.la" -delete
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%check
|
||||
make check || { \
|
||||
echo "======================== ./test-suite.log ========================"; \
|
||||
@ -136,8 +142,6 @@ echo "=================================================================="; \
|
||||
exit 1; \
|
||||
}
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%ldconfig_scriptlets libs
|
||||
|
||||
%files
|
||||
@ -167,6 +171,10 @@ exit 1; \
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jan 23 2019 Jiri Kucera <jkucera@redhat.com> - 0.3.12-2
|
||||
- Add support for LUKS2 and more
|
||||
- Fix License tag
|
||||
|
||||
* Mon Oct 08 2018 Jiri Kucera <jkucera@redhat.com> - 0.3.12-1
|
||||
- Update to volume_key-0.3.12
|
||||
Resolves: #1634850
|
||||
|
Loading…
Reference in New Issue
Block a user