Show OS-ID + Clear auth entry fields
Show OS-ID when running 'remote-viewer -V' Resolves: rhbz#1953282 Clear auth entry fields Resolves: rhbz#1953933
This commit is contained in:
parent
e8d6be90b1
commit
f2ed8c31d1
31
0003-config.h-avoid-extra-hyphen-in-build-ID-value.patch
Normal file
31
0003-config.h-avoid-extra-hyphen-in-build-ID-value.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From d07b1e5badb7624298d4bcfdcb6764b2a5d8a9de Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Daniel=20P=2E=20Berrang=C3=A9?= <berrange@redhat.com>
|
||||
Date: Mon, 26 Apr 2021 11:00:15 +0100
|
||||
Subject: [PATCH] config.h: avoid extra hyphen in build ID value
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
The meson.build file already adds a hyphen.
|
||||
|
||||
Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
|
||||
---
|
||||
config.h.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/config.h.in b/config.h.in
|
||||
index 1d72f7e..eb4f03b 100644
|
||||
--- a/config.h.in
|
||||
+++ b/config.h.in
|
||||
@@ -16,7 +16,7 @@
|
||||
#define _GNU_SOURCE
|
||||
|
||||
/* Build version details */
|
||||
-#define BUILDID "-@BUILDID@"
|
||||
+#define BUILDID "@BUILDID@"
|
||||
|
||||
/* Define to the full name and version of this package. */
|
||||
#define PACKAGE_STRING "virt-viewer @VERSION@"
|
||||
--
|
||||
2.31.1
|
||||
|
48
0004-config.h-conditionally-define-REMOTE_VIEWER_OS_ID.patch
Normal file
48
0004-config.h-conditionally-define-REMOTE_VIEWER_OS_ID.patch
Normal file
@ -0,0 +1,48 @@
|
||||
From 65fe7379f85924b5bc3770fa9be5b08ba9a8704f Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Daniel=20P=2E=20Berrang=C3=A9?= <berrange@redhat.com>
|
||||
Date: Mon, 26 Apr 2021 11:01:31 +0100
|
||||
Subject: [PATCH] config.h: conditionally define REMOTE_VIEWER_OS_ID
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
It should only be set in config.h if it is not the empty string
|
||||
|
||||
Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
|
||||
---
|
||||
config.h.in | 2 +-
|
||||
meson.build | 5 ++++-
|
||||
2 files changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/config.h.in b/config.h.in
|
||||
index eb4f03b..0af0fa4 100644
|
||||
--- a/config.h.in
|
||||
+++ b/config.h.in
|
||||
@@ -25,7 +25,7 @@
|
||||
#define PACKAGE_VERSION "@VERSION@"
|
||||
|
||||
/* OS ID for this build */
|
||||
-#define REMOTE_VIEWER_OS_ID "@OS_ID@"
|
||||
+#mesondefine REMOTE_VIEWER_OS_ID
|
||||
|
||||
/* Version number of package */
|
||||
#define VERSION "@VERSION@"
|
||||
diff --git a/meson.build b/meson.build
|
||||
index e5ed47b..2c92d75 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -478,7 +478,10 @@ if id != ''
|
||||
else
|
||||
conf_data.set('BUILDID', '')
|
||||
endif
|
||||
-conf_data.set('OS_ID', get_option('os-id'))
|
||||
+osid = get_option('os-id')
|
||||
+if osid != ''
|
||||
+ conf_data.set('REMOTE_VIEWER_OS_ID', '"' + osid + '"')
|
||||
+endif
|
||||
|
||||
arr_version = meson.project_version().split('.')
|
||||
|
||||
--
|
||||
2.31.1
|
||||
|
33
0007-src-ensure-auth-entry-fields-are-cleared.patch
Normal file
33
0007-src-ensure-auth-entry-fields-are-cleared.patch
Normal file
@ -0,0 +1,33 @@
|
||||
From 73f567ea94eec04e6eb8bbac72d5c40518bca2b1 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Daniel=20P=2E=20Berrang=C3=A9?= <berrange@redhat.com>
|
||||
Date: Tue, 27 Apr 2021 11:28:57 +0100
|
||||
Subject: [PATCH] src: ensure auth entry fields are cleared
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
If authentication fails we reshow the same authentication dialog box
|
||||
again. Rather than leaving the previous incorrect information in the
|
||||
text entry boxes we need to clear them.
|
||||
|
||||
Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
|
||||
---
|
||||
src/virt-viewer-auth.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/virt-viewer-auth.c b/src/virt-viewer-auth.c
|
||||
index 119d7f1..dbb3d25 100644
|
||||
--- a/src/virt-viewer-auth.c
|
||||
+++ b/src/virt-viewer-auth.c
|
||||
@@ -114,6 +114,8 @@ virt_viewer_auth_collect_credentials(VirtViewerAuth *self,
|
||||
int response;
|
||||
char *message;
|
||||
|
||||
+ gtk_entry_set_text(GTK_ENTRY(self->credUsername), "");
|
||||
+ gtk_entry_set_text(GTK_ENTRY(self->credPassword), "");
|
||||
if (username) {
|
||||
gtk_widget_show(self->credUsername);
|
||||
gtk_widget_show(self->promptUsername);
|
||||
--
|
||||
2.31.1
|
||||
|
@ -10,13 +10,22 @@
|
||||
|
||||
Name: virt-viewer
|
||||
Version: 10.0
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: Virtual Machine Viewer
|
||||
License: GPLv2+
|
||||
URL: https://gitlab.com/virt-viewer/virt-viewer
|
||||
Source0: https://virt-manager.org/download/sources/%{name}/%{name}-%{version}.tar.xz
|
||||
Requires: openssh-clients
|
||||
|
||||
# Patches are numbered according to upstream order
|
||||
# rhbz#1953282, upstream mr!94
|
||||
Patch0003: 0003-config.h-avoid-extra-hyphen-in-build-ID-value.patch
|
||||
Patch0004: 0004-config.h-conditionally-define-REMOTE_VIEWER_OS_ID.patch
|
||||
|
||||
# rhbz#1953933, upstream mr!95
|
||||
Patch0007: 0007-src-ensure-auth-entry-fields-are-cleared.patch
|
||||
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: meson
|
||||
BuildRequires: pkgconfig(glib-2.0)
|
||||
@ -46,8 +55,15 @@ the display, and libvirt for looking up VNC/SPICE server details.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0003 -p1
|
||||
%patch0004 -p1
|
||||
|
||||
%patch0007 -p1
|
||||
|
||||
%build
|
||||
|
||||
%define buildid_opt -Dbuild-id=%{release}
|
||||
|
||||
%if !%{with_govirt}
|
||||
%define ovirt_opt -Dovirt=disabled
|
||||
%endif
|
||||
@ -56,7 +72,11 @@ the display, and libvirt for looking up VNC/SPICE server details.
|
||||
%define spice_opt -Dspice=disabled
|
||||
%endif
|
||||
|
||||
%meson -Dbuild-id=%{release} %{?ovirt_opt} %{?spice_opt}
|
||||
%if 0%{?rhel} > 0
|
||||
%define osid_opt -Dos-id=rhel%{?rhel}
|
||||
%endif
|
||||
|
||||
%meson %{buildid_opt} %{?ovirt_opt} %{?spice_opt} %{?osid_opt}
|
||||
%meson_build
|
||||
|
||||
%install
|
||||
@ -77,6 +97,12 @@ the display, and libvirt for looking up VNC/SPICE server details.
|
||||
%{_datadir}/bash-completion/completions/virt-viewer
|
||||
|
||||
%changelog
|
||||
* Thu Aug 19 2021 Uri Lublin <uril@redhat.com> - 10.0-3
|
||||
- Show OS-ID when running 'remote-viewer -V'
|
||||
Resolves: rhbz#1953282
|
||||
- Clear auth entry fields
|
||||
Resolves: rhbz#1953933
|
||||
|
||||
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 10.0-2
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
Loading…
Reference in New Issue
Block a user