58 lines
1.8 KiB
Diff
58 lines
1.8 KiB
Diff
commit e34a8c0911f53cff64f9a33d3802ac7361f3fe19
|
|
Author: Matthew Booth <mbooth@redhat.com>
|
|
Date: Wed May 11 16:05:18 2011 +0100
|
|
|
|
p2v-client: Drop echoe for build
|
|
|
|
echoe changes incompatibly from F14->F15. We're not using the vast majority of
|
|
its features, and it remains completely undocumented as far as I can tell. This
|
|
patch drops it in favour of a simple, explicit gem build task.
|
|
|
|
diff --git a/p2v/client/Rakefile b/p2v/client/Rakefile
|
|
index d190f08..23c26f5 100644
|
|
--- a/p2v/client/Rakefile
|
|
+++ b/p2v/client/Rakefile
|
|
@@ -14,24 +14,10 @@
|
|
# along with this program; if not, write to the Free Software
|
|
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
|
|
|
|
-require 'rubygems'
|
|
-require 'echoe'
|
|
+require 'rake'
|
|
+require 'rake/gempackagetask'
|
|
|
|
-Echoe.new("virt-p2v") do |p|
|
|
- p.project = "Virt P2V"
|
|
- p.version = `../../Build version`
|
|
- p.author = "Matthew Booth"
|
|
- p.summary = "Send a machine's storage and metadata to virt-p2v-server"
|
|
- p.description = <<EOF
|
|
-virt-p2v is a client which connects to a virt-p2v-server and transfer's the host
|
|
-machine's storage and metadata. virt-p2v is intended to be run from a live
|
|
-image, so it is unlikely you want to install it.
|
|
-EOF
|
|
- p.url = "http://libguestfs.org"
|
|
- p.email = "libguestfs@redhat.com"
|
|
- p.runtime_dependencies = [
|
|
- 'gtk2',
|
|
- 'gettext',
|
|
- 'net-ssh'
|
|
- ]
|
|
-end
|
|
+task :default => :gem
|
|
+
|
|
+load 'virt-p2v.gemspec'
|
|
+Rake::GemPackageTask.new(GEMSPEC) {}
|
|
diff --git a/virt-v2v.spec.PL b/virt-v2v.spec.PL
|
|
index 2249b01..6a155e2 100644
|
|
--- a/virt-v2v.spec.PL
|
|
+++ b/virt-v2v.spec.PL
|
|
@@ -79,7 +79,6 @@ BuildRequires: perl-hivex >= 1.2.2
|
|
|
|
# virt-p2v build requirements
|
|
BuildRequires: rubygem(rake)
|
|
-BuildRequires: rubygem(echoe)
|
|
|
|
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
|
|
|