- Revert OL changes

- Update common submodule
This commit is contained in:
eabdullin 2025-02-19 17:14:35 +03:00
parent e3040af9e3
commit d939921ef6
3 changed files with 84 additions and 311 deletions

View File

@ -0,0 +1,79 @@
From 60785259a8bea65663da270b25ea6f46be42aa0f Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sun, 9 Feb 2025 17:35:14 +0000
Subject: [PATCH] Update common submodule
Pulls in the following fix:
commit 38315604596ac747e44e38db79496610efee49f8
Author: Richard W.M. Jones <rjones@redhat.com>
Date: Thu Feb 6 08:04:38 2025 +0000
mldrivers/linux_bootloaders.ml: Don't overwrite EFI grub2 wrapper
Fedora 34+ and RHEL 9.0+ unified BIOS and UEFI grub configuration into
a single file. This leaves /boot/efi/EFI/<OS>/grub.cfg as a so-called
"wrapper" which just loads the real grub2 configuration at
/boot/grub2/grub.cfg.
Running '/sbin/grub2-mkconfig -o /boot/efi/EFI/<OS>/grub.cfg'
overwrites the wrapper instead of the real configuration file.
RHEL 9.5 added a hard error if you try to do this, which broke
virt-v2v. The error message was:
commandrvf: /sbin/grub2-mkconfig -o /boot/efi/EFI/redhat/grub.cfg
Running `grub2-mkconfig -o /boot/efi/EFI/redhat/grub.cfg' will
overwrite the GRUB wrapper. Please run `grub2-mkconfig -o
/boot/grub2/grub.cfg' instead to update grub.cfg.
Try to detect this situation and substitute the real grub
configuration file instead.
Reported-by: Robert Knipp, Fabian Deutsch
Thanks: Nijin Ashok, Marta Lewandowska
Fixes: https://issues.redhat.com/browse/RHEL-77989
Related: https://issues.redhat.com/browse/RHEL-32099
Related: https://fedoraproject.org/wiki/Changes/UnifyGrubConfig
Fixes: https://issues.redhat.com/browse/RHEL-77989
Related: https://issues.redhat.com/browse/RHEL-32099
(cherry picked from commit 17610d1c9b37424fec55c39fbf83c971a843f45f)
---
common | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Submodule common faee2645..2bb8c83c:
diff --git a/common/mldrivers/linux_bootloaders.ml b/common/mldrivers/linux_bootloaders.ml
index 91c5ab9e..a821a3f3 100644
--- a/common/mldrivers/linux_bootloaders.ml
+++ b/common/mldrivers/linux_bootloaders.ml
@@ -410,6 +410,28 @@ let detect_bootloader (g : G.guestfs) root i_firmware =
in
loop paths in
+ (* If we found a grub2 boot config called /boot/efi/EFI/<OS>/grub.cfg
+ * check if it's a "wrapper" that redirects to /boot/grub2/grub.cfg.
+ * This is needed for Fedora 34+ and RHEL 9.0+. See:
+ * https://issues.redhat.com/browse/RHEL-32099
+ * https://issues.redhat.com/browse/RHEL-77989
+ * https://github.com/libguestfs/libguestfs-common/pull/6
+ *)
+ let grub_config =
+ match typ with
+ | Grub1 -> grub_config
+ | Grub2 ->
+ let grub2_efi_rex = PCRE.compile "^/boot/efi/EFI/.*/grub.cfg$" in
+ let grub2_real = "/boot/grub2/grub.cfg" in
+
+ if PCRE.matches grub2_efi_rex grub_config &&
+ (* does it look like the "wrapper"? *)
+ g#grep "configfile \\$prefix/grub\\.cfg" grub_config <> [||] &&
+ g#exists grub2_real then
+ grub2_real
+ else
+ grub_config in
+
let bl =
match typ with
| Grub1 -> new bootloader_grub1 g root grub_config

View File

@ -1,304 +0,0 @@
From a0b0015b884015b20a86cbc896ba55448f05e855 Mon Sep 17 00:00:00 2001
From: Craig Guiller <craig.guiller@oracle.com>
Date: Fri, 5 Apr 2024 12:34:09 +0100
Subject: [PATCH] replaced upstream references
Signed-off-by: Craig Guiller <craig.guiller@oracle.com>
---
po/Makefile.am | 2 +-
po/cs.po | 3 +--
po/de.po | 3 +--
po/es.po | 3 +--
po/fr.po | 3 +--
po/gu.po | 3 +--
po/hi.po | 3 +--
po/ja.po | 3 +--
po/kn.po | 3 +--
po/ml.po | 3 +--
po/mr.po | 3 +--
po/nl.po | 3 +--
po/or.po | 3 +--
po/pa.po | 3 +--
po/pl.po | 3 +--
po/uk.po | 3 +--
po/virt-v2v.pot | 3 +--
podwrapper.pl.in | 4 ++--
website/index.html.in | 6 +++---
19 files changed, 22 insertions(+), 38 deletions(-)
diff --git a/po/Makefile.am b/po/Makefile.am
index f1509d6..db4a502 100644
--- a/po/Makefile.am
+++ b/po/Makefile.am
@@ -19,7 +19,7 @@ include $(top_srcdir)/subdir-rules.mk
DOMAIN = $(PACKAGE_NAME)
COPYRIGHT_HOLDER = Red Hat Inc.
-MSGID_BUGS_ADDRESS = https://bugzilla.redhat.com/enter_bug.cgi?component=libguestfs&product=Virtualization+Tools
+MSGID_BUGS_ADDRESS = https://github.com/oracle/oracle-linux
# Languages.
# Don't use LINGUAS (uppercase) as Gentoo defines it (RHBZ#804464).
diff --git a/po/cs.po b/po/cs.po
index 415a9b9..bf996ff 100644
--- a/po/cs.po
+++ b/po/cs.po
@@ -2,8 +2,7 @@
msgid ""
msgstr ""
"Project-Id-Version: libguestfs 1.39.12\n"
-"Report-Msgid-Bugs-To: https://bugzilla.redhat.com/enter_bug.cgi?"
-"component=libguestfs&product=Virtualization+Tools\n"
+"Report-Msgid-Bugs-To: https://github.com/oracle/oracle-linux\n"
"POT-Creation-Date: 2024-01-04 17:06+0000\n"
"PO-Revision-Date: 2023-04-08 18:20+0000\n"
"Last-Translator: Pavel Borecki <pavel.borecki@gmail.com>\n"
diff --git a/po/de.po b/po/de.po
index 19a5513..7b64f55 100644
--- a/po/de.po
+++ b/po/de.po
@@ -9,8 +9,7 @@
msgid ""
msgstr ""
"Project-Id-Version: libguestfs 1.39.12\n"
-"Report-Msgid-Bugs-To: https://bugzilla.redhat.com/enter_bug.cgi?"
-"component=libguestfs&product=Virtualization+Tools\n"
+"Report-Msgid-Bugs-To: https://github.com/oracle/oracle-linux\n"
"POT-Creation-Date: 2024-01-04 17:06+0000\n"
"PO-Revision-Date: 2015-02-21 10:48+0000\n"
"Last-Translator: Copied by Zanata <copied-by-zanata@zanata.org>\n"
diff --git a/po/es.po b/po/es.po
index 065cd2b..051af40 100644
--- a/po/es.po
+++ b/po/es.po
@@ -10,8 +10,7 @@
msgid ""
msgstr ""
"Project-Id-Version: libguestfs 1.39.12\n"
-"Report-Msgid-Bugs-To: https://bugzilla.redhat.com/enter_bug.cgi?"
-"component=libguestfs&product=Virtualization+Tools\n"
+"Report-Msgid-Bugs-To: https://github.com/oracle/oracle-linux\n"
"POT-Creation-Date: 2024-01-04 17:06+0000\n"
"PO-Revision-Date: 2015-03-16 07:04+0000\n"
"Last-Translator: Alex Puchades <alex94puchades@gmail.com>\n"
diff --git a/po/fr.po b/po/fr.po
index 7b0864b..41b9db7 100644
--- a/po/fr.po
+++ b/po/fr.po
@@ -10,8 +10,7 @@
msgid ""
msgstr ""
"Project-Id-Version: libguestfs 1.39.12\n"
-"Report-Msgid-Bugs-To: https://bugzilla.redhat.com/enter_bug.cgi?"
-"component=libguestfs&product=Virtualization+Tools\n"
+"Report-Msgid-Bugs-To: https://github.com/oracle/oracle-linux\n"
"POT-Creation-Date: 2024-01-04 17:06+0000\n"
"PO-Revision-Date: 2023-03-21 09:20+0000\n"
"Last-Translator: grimst <grimaitres@gmail.com>\n"
diff --git a/po/gu.po b/po/gu.po
index 02643ec..d53329c 100644
--- a/po/gu.po
+++ b/po/gu.po
@@ -8,8 +8,7 @@
msgid ""
msgstr ""
"Project-Id-Version: libguestfs 1.39.12\n"
-"Report-Msgid-Bugs-To: https://bugzilla.redhat.com/enter_bug.cgi?"
-"component=libguestfs&product=Virtualization+Tools\n"
+"Report-Msgid-Bugs-To: https://github.com/oracle/oracle-linux\n"
"POT-Creation-Date: 2024-01-04 17:06+0000\n"
"PO-Revision-Date: 2015-02-21 10:49+0000\n"
"Last-Translator: Copied by Zanata <copied-by-zanata@zanata.org>\n"
diff --git a/po/hi.po b/po/hi.po
index 11f334c..303063d 100644
--- a/po/hi.po
+++ b/po/hi.po
@@ -8,8 +8,7 @@
msgid ""
msgstr ""
"Project-Id-Version: libguestfs 1.39.12\n"
-"Report-Msgid-Bugs-To: https://bugzilla.redhat.com/enter_bug.cgi?"
-"component=libguestfs&product=Virtualization+Tools\n"
+"Report-Msgid-Bugs-To: https://github.com/oracle/oracle-linux\n"
"POT-Creation-Date: 2024-01-04 17:06+0000\n"
"PO-Revision-Date: 2015-02-21 10:49+0000\n"
"Last-Translator: Copied by Zanata <copied-by-zanata@zanata.org>\n"
diff --git a/po/ja.po b/po/ja.po
index 7c806c1..227b17e 100644
--- a/po/ja.po
+++ b/po/ja.po
@@ -9,8 +9,7 @@
msgid ""
msgstr ""
"Project-Id-Version: libguestfs 1.39.12\n"
-"Report-Msgid-Bugs-To: https://bugzilla.redhat.com/enter_bug.cgi?"
-"component=libguestfs&product=Virtualization+Tools\n"
+"Report-Msgid-Bugs-To: https://github.com/oracle/oracle-linux\n"
"POT-Creation-Date: 2024-01-04 17:06+0000\n"
"PO-Revision-Date: 2017-02-24 07:33+0000\n"
"Last-Translator: Copied by Zanata <copied-by-zanata@zanata.org>\n"
diff --git a/po/kn.po b/po/kn.po
index 430af05..66b794b 100644
--- a/po/kn.po
+++ b/po/kn.po
@@ -7,8 +7,7 @@
msgid ""
msgstr ""
"Project-Id-Version: libguestfs 1.39.12\n"
-"Report-Msgid-Bugs-To: https://bugzilla.redhat.com/enter_bug.cgi?"
-"component=libguestfs&product=Virtualization+Tools\n"
+"Report-Msgid-Bugs-To: https://github.com/oracle/oracle-linux\n"
"POT-Creation-Date: 2024-01-04 17:06+0000\n"
"PO-Revision-Date: 2015-02-21 10:50+0000\n"
"Last-Translator: Copied by Zanata <copied-by-zanata@zanata.org>\n"
diff --git a/po/ml.po b/po/ml.po
index 172994f..0195197 100644
--- a/po/ml.po
+++ b/po/ml.po
@@ -7,8 +7,7 @@
msgid ""
msgstr ""
"Project-Id-Version: libguestfs 1.39.12\n"
-"Report-Msgid-Bugs-To: https://bugzilla.redhat.com/enter_bug.cgi?"
-"component=libguestfs&product=Virtualization+Tools\n"
+"Report-Msgid-Bugs-To: https://github.com/oracle/oracle-linux\n"
"POT-Creation-Date: 2024-01-04 17:06+0000\n"
"PO-Revision-Date: 2015-02-21 10:50+0000\n"
"Last-Translator: Copied by Zanata <copied-by-zanata@zanata.org>\n"
diff --git a/po/mr.po b/po/mr.po
index cfa072d..49e5e6d 100644
--- a/po/mr.po
+++ b/po/mr.po
@@ -8,8 +8,7 @@
msgid ""
msgstr ""
"Project-Id-Version: libguestfs 1.39.12\n"
-"Report-Msgid-Bugs-To: https://bugzilla.redhat.com/enter_bug.cgi?"
-"component=libguestfs&product=Virtualization+Tools\n"
+"Report-Msgid-Bugs-To: https://github.com/oracle/oracle-linux\n"
"POT-Creation-Date: 2024-01-04 17:06+0000\n"
"PO-Revision-Date: 2015-02-21 10:51+0000\n"
"Last-Translator: Copied by Zanata <copied-by-zanata@zanata.org>\n"
diff --git a/po/nl.po b/po/nl.po
index 7757ba3..c91e1b0 100644
--- a/po/nl.po
+++ b/po/nl.po
@@ -9,8 +9,7 @@
msgid ""
msgstr ""
"Project-Id-Version: libguestfs 1.39.12\n"
-"Report-Msgid-Bugs-To: https://bugzilla.redhat.com/enter_bug.cgi?"
-"component=libguestfs&product=Virtualization+Tools\n"
+"Report-Msgid-Bugs-To: https://github.com/oracle/oracle-linux\n"
"POT-Creation-Date: 2024-01-04 17:06+0000\n"
"PO-Revision-Date: 2015-02-21 10:51+0000\n"
"Last-Translator: Copied by Zanata <copied-by-zanata@zanata.org>\n"
diff --git a/po/or.po b/po/or.po
index cb0b6f9..11ee73f 100644
--- a/po/or.po
+++ b/po/or.po
@@ -7,8 +7,7 @@
msgid ""
msgstr ""
"Project-Id-Version: libguestfs 1.39.12\n"
-"Report-Msgid-Bugs-To: https://bugzilla.redhat.com/enter_bug.cgi?"
-"component=libguestfs&product=Virtualization+Tools\n"
+"Report-Msgid-Bugs-To: https://github.com/oracle/oracle-linux\n"
"POT-Creation-Date: 2024-01-04 17:06+0000\n"
"PO-Revision-Date: 2015-02-21 10:51+0000\n"
"Last-Translator: Copied by Zanata <copied-by-zanata@zanata.org>\n"
diff --git a/po/pa.po b/po/pa.po
index 9b4e9bc..c34e00d 100644
--- a/po/pa.po
+++ b/po/pa.po
@@ -8,8 +8,7 @@
msgid ""
msgstr ""
"Project-Id-Version: libguestfs 1.39.12\n"
-"Report-Msgid-Bugs-To: https://bugzilla.redhat.com/enter_bug.cgi?"
-"component=libguestfs&product=Virtualization+Tools\n"
+"Report-Msgid-Bugs-To: https://github.com/oracle/oracle-linux\n"
"POT-Creation-Date: 2024-01-04 17:06+0000\n"
"PO-Revision-Date: 2015-02-21 10:52+0000\n"
"Last-Translator: Copied by Zanata <copied-by-zanata@zanata.org>\n"
diff --git a/po/pl.po b/po/pl.po
index d46571c..01f5206 100644
--- a/po/pl.po
+++ b/po/pl.po
@@ -11,8 +11,7 @@
msgid ""
msgstr ""
"Project-Id-Version: libguestfs 1.39.12\n"
-"Report-Msgid-Bugs-To: https://bugzilla.redhat.com/enter_bug.cgi?"
-"component=libguestfs&product=Virtualization+Tools\n"
+"Report-Msgid-Bugs-To: https://github.com/oracle/oracle-linux\n"
"POT-Creation-Date: 2024-01-04 17:06+0000\n"
"PO-Revision-Date: 2024-01-15 13:36+0000\n"
"Last-Translator: Weblate Translation Memory <noreply-mt-weblate-translation-"
diff --git a/po/uk.po b/po/uk.po
index 5a80267..043d1c8 100644
--- a/po/uk.po
+++ b/po/uk.po
@@ -12,8 +12,7 @@
msgid ""
msgstr ""
"Project-Id-Version: libguestfs 1.39.12\n"
-"Report-Msgid-Bugs-To: https://bugzilla.redhat.com/enter_bug.cgi?"
-"component=libguestfs&product=Virtualization+Tools\n"
+"Report-Msgid-Bugs-To: https://github.com/oracle/oracle-linux\n"
"POT-Creation-Date: 2024-01-04 17:06+0000\n"
"PO-Revision-Date: 2023-06-05 07:20+0000\n"
"Last-Translator: Yuri Chornoivan <yurchor@ukr.net>\n"
diff --git a/podwrapper.pl.in b/podwrapper.pl.in
index c99563c..14198cf 100755
--- a/podwrapper.pl.in
+++ b/podwrapper.pl.in
@@ -432,10 +432,10 @@ my $reporting_bugs =
"=head1 BUGS
To get a list of bugs against libguestfs, use this link:
-L<https://bugzilla.redhat.com/buglist.cgi?component=libguestfs&product=Virtualization+Tools>
+L<https://github.com/oracle/oracle-linux>
To report a new bug against libguestfs, use this link:
-L<https://bugzilla.redhat.com/enter_bug.cgi?component=libguestfs&product=Virtualization+Tools>
+L<https://github.com/oracle/oracle-linux>
When reporting a bug, please supply:
diff --git a/website/index.html.in b/website/index.html.in
index f578523..e1e1592 100644
--- a/website/index.html.in
+++ b/website/index.html.in
@@ -160,12 +160,12 @@ For testers:
<h2>Bug reports</h2>
<p>
-<a href="https://bugzilla.redhat.com/buglist.cgi?component=libguestfs&product=Virtualization+Tools">List of bugs in libguestfs</a> and
-<a href="https://bugzilla.redhat.com/buglist.cgi?component=libguestfs&product=Fedora">in Fedora packaging of libguestfs</a>
+<a href="https://github.com/oracle/oracle-linux">List of bugs in libguestfs</a> and
+<a href="https://github.com/oracle/oracle-linux">in Community packaging of libguestfs</a>
</p>
<p>
-<a href="https://bugzilla.redhat.com/enter_bug.cgi?component=libguestfs&product=Virtualization+Tools">Enter a new bug report</a>
+<a href="https://github.com/oracle/oracle-linux">Enter a new bug report</a>
</p>
</div>
diff --git a/po/virt-v2v.pot b/po/virt-v2v.pot
index 9642515..a82187a 100644
--- a/po/virt-v2v.pot
+++ b/po/virt-v2v.pot
@@ -7,8 +7,7 @@
msgid ""
msgstr ""
"Project-Id-Version: virt-v2v 2.5.6\n"
-"Report-Msgid-Bugs-To: https://bugzilla.redhat.com/enter_bug.cgi?"
-"component=libguestfs&product=Virtualization+Tools\n"
+"Report-Msgid-Bugs-To: https://github.com/oracle/oracle-linux\n"
"POT-Creation-Date: 2024-07-30 16:57+0100\n"
"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
--
2.31.1

View File

@ -8,7 +8,7 @@
Name: virt-v2v
Epoch: 1
Version: 2.5.6
Release: 8.0.1%{?dist}
Release: 8%{?dist}
Summary: Convert a virtual machine to run on KVM
License: GPL-2.0-or-later AND LGPL-2.0-or-later
@ -51,9 +51,8 @@ Patch0020: 0020-RHEL-Add-warning-about-virt-v2v-in-place-not-being-s.patch
Patch0021: 0021-convert-windows-Online-all-virtio-disks-at-first-boo.patch
Patch0022: 0022-convert-windows-Ignore-sriov-drivers-on-virtio-win-d.patch
Patch0023: 0023-convert-Use-yum-apt-.-for-package-removals-not-rpm-d.patch
# Oracle patch
Patch1001: 1001-replaced-upstream-references.patch
# https://gitlab.com/redhat/centos-stream/rpms/virt-v2v/-/commit/7e0bcda907e5f2b69566387f5b283186cb7ed62e
Patch0024: 0024-Update-common-submodule.patch
%if !0%{?rhel}
# libguestfs hasn't been built on i686 for a while since there is no
@ -357,9 +356,8 @@ make -C tests TESTS=test-v2v-fedora-luks-on-lvm-conversion.sh check
%changelog
* Mon Feb 17 2025 Darren Archibald <darren.archibald@oracle.com> - 1:2.5.6-8.0.1
- Replaced bugzilla.oracle.com references [Orabug: 34202300]
- replaced upstream references [Orabug:34089586]
* Wed Feb 19 2025 Eduard Abdullin <eabdullin@almalinux.org> - 1:2.5.6-8
- Update common submodule
* Mon Feb 17 2025 Darren Archibald <darren.archibald@oracle.com> - 1:2.5.6-8
- Migration Plan / vddk pod cannot remove open-vm-tools in case of dependencies