New upstream development version 1.45.3.

Rebase RHEL patches.
resolves: rhbz#1950634

(cherry picked from commit c8d08693ef2ea67d480ec9fb74f469dd41b92c2c)
This commit is contained in:
Richard W.M. Jones 2021-08-06 13:11:05 +01:00
parent fd1f10a5fe
commit d61af35693
13 changed files with 195 additions and 68 deletions

View File

@ -0,0 +1,123 @@
From 4d5509a98823cc0b8930678716b862adbd2c0b81 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Fri, 6 Aug 2021 13:01:28 +0100
Subject: [PATCH 01/11] Revert "v2v: Remove -o rhv-upload -oa preallocated"
This reverts commit 18084f90d9dd9092831cb3487039328981796291.
---
v2v/cmdline.ml | 2 +-
v2v/output_rhv_upload.ml | 22 ++++++++++++++++++++--
v2v/output_rhv_upload.mli | 7 ++++---
v2v/rhv-upload-transfer.py | 1 +
4 files changed, 26 insertions(+), 6 deletions(-)
diff --git a/v2v/cmdline.ml b/v2v/cmdline.ml
index 79d943df..5e7c01f8 100644
--- a/v2v/cmdline.ml
+++ b/v2v/cmdline.ml
@@ -699,7 +699,7 @@ read the man page virt-v2v(1).
| Some os -> os in
if qemu_boot then
error_option_cannot_be_used_in_output_mode "rhv-upload" "--qemu-boot";
- Output_rhv_upload.output_rhv_upload output_conn
+ Output_rhv_upload.output_rhv_upload output_alloc output_conn
output_password os
rhv_options,
output_format, output_alloc
diff --git a/v2v/output_rhv_upload.ml b/v2v/output_rhv_upload.ml
index 6a632eaa..50baa595 100644
--- a/v2v/output_rhv_upload.ml
+++ b/v2v/output_rhv_upload.ml
@@ -146,11 +146,22 @@ let error_unless_nbdkit_compiled_with_selinux config =
error (f_"nbdkit was compiled without SELinux support. You will have to recompile nbdkit with libselinux-devel installed, or else set SELinux to Permissive mode while doing the conversion.")
)
+(* Output sparse must be sparse. We may be able to
+ * lift this limitation in future, but it requires changes on the
+ * RHV side. See TODO file for details. XXX
+ *)
+let error_current_limitation required_param =
+ error (f_"rhv-upload: currently you must use %s. This restriction will be loosened in a future version.") required_param
+
+let error_unless_output_alloc_sparse output_alloc =
+ if output_alloc <> Sparse then
+ error_current_limitation "-oa sparse"
+
let json_optstring = function
| Some s -> JSON.String s
| None -> JSON.Null
-class output_rhv_upload output_conn
+class output_rhv_upload output_alloc output_conn
output_password output_storage
rhv_options =
(* Create a temporary directory which will be deleted on exit. *)
@@ -189,6 +200,9 @@ class output_rhv_upload output_conn
"output_conn", JSON.String output_conn;
"output_password", JSON.String output_password;
"output_storage", JSON.String output_storage;
+ "output_sparse", JSON.Bool (match output_alloc with
+ | Sparse -> true
+ | Preallocated -> false);
"rhv_cafile", json_optstring rhv_options.rhv_cafile;
"rhv_cluster",
JSON.String (Option.default "Default" rhv_options.rhv_cluster);
@@ -257,6 +271,7 @@ object
error_unless_nbdkit_min_version config;
error_unless_nbdkit_python_plugin_working plugin_script;
error_unless_nbdkit_compiled_with_selinux config;
+ error_unless_output_alloc_sparse output_alloc;
(* Python code prechecks. *)
let json_params = match rhv_options.rhv_disk_uuids with
@@ -282,6 +297,9 @@ object
method as_options =
"-o rhv-upload" ^
+ (match output_alloc with
+ | Sparse -> "" (* default, don't need to print it *)
+ | Preallocated -> " -oa preallocated") ^
sprintf " -oc %s -op %s -os %s"
output_conn output_password output_storage
@@ -449,7 +467,7 @@ object
(* Create the metadata. *)
let ovf =
Create_ovf.create_ovf source inspect target_meta targets
- Sparse sd_uuid disk_uuids vol_uuids vm_uuid
+ output_alloc sd_uuid disk_uuids vol_uuids vm_uuid
OVirt in
let ovf = DOM.doc_to_string ovf in
diff --git a/v2v/output_rhv_upload.mli b/v2v/output_rhv_upload.mli
index 01507dff..eb85a57d 100644
--- a/v2v/output_rhv_upload.mli
+++ b/v2v/output_rhv_upload.mli
@@ -25,8 +25,9 @@ val print_output_options : unit -> unit
val parse_output_options : (string * string) list -> rhv_options
(** Print and parse rhv-upload -oo options. *)
-val output_rhv_upload : string -> string -> string -> rhv_options ->
- Types.output
-(** [output_rhv_upload output_conn output_password output_storage rhv_options]
+val output_rhv_upload : Types.output_allocation -> string -> string ->
+ string -> rhv_options -> Types.output
+(** [output_rhv_upload output_alloc output_conn output_password output_storage
+ rhv_options]
creates and returns a new {!Types.output} object specialized for writing
output to oVirt or RHV directly via RHV APIs. *)
diff --git a/v2v/rhv-upload-transfer.py b/v2v/rhv-upload-transfer.py
index cf4f8807..5aebcd1d 100644
--- a/v2v/rhv-upload-transfer.py
+++ b/v2v/rhv-upload-transfer.py
@@ -111,6 +111,7 @@ def create_disk(connection):
# size, based on qemu-img measure of the overlay.
initial_size=params['disk_size'],
provisioned_size=params['disk_size'],
+ # XXX Ignores params['output_sparse'].
# Handling this properly will be complex, see:
# https://www.redhat.com/archives/libguestfs/2018-March/msg00177.html
sparse=True,
--
2.31.1

View File

@ -1,7 +1,7 @@
From 0eb7d51c403a81837a58537257202bece4e116e0 Mon Sep 17 00:00:00 2001
From abe3c7539b6221e8ab3cc35ee3d58b1aa06bbef4 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Mon, 14 May 2018 10:16:58 +0100
Subject: [PATCH 08/10] RHEL: v2v: rhv-upload: Remove restriction on -oa
Subject: [PATCH 02/11] RHEL: v2v: rhv-upload: Remove restriction on -oa
sparse.
See: https://bugzilla.redhat.com/show_bug.cgi?id=1565681
@ -9,7 +9,7 @@ and the v2v-devel private thread "Do we already support migration using FC?"
---
docs/virt-v2v-output-rhv.pod | 8 +-------
v2v/output_rhv_upload.ml | 10 +---------
v2v/rhv-upload-plugin.py | 4 +---
v2v/rhv-upload-transfer.py | 4 +---
3 files changed, 3 insertions(+), 19 deletions(-)
diff --git a/docs/virt-v2v-output-rhv.pod b/docs/virt-v2v-output-rhv.pod
@ -39,10 +39,10 @@ index dc6b2c0a..7b8fdc0f 100644
A file containing a password to be used when connecting to the oVirt
diff --git a/v2v/output_rhv_upload.ml b/v2v/output_rhv_upload.ml
index 466de38d..34caaa6a 100644
index 50baa595..be5e9851 100644
--- a/v2v/output_rhv_upload.ml
+++ b/v2v/output_rhv_upload.ml
@@ -147,17 +147,10 @@ let error_unless_nbdkit_compiled_with_selinux config =
@@ -146,17 +146,10 @@ let error_unless_nbdkit_compiled_with_selinux config =
error (f_"nbdkit was compiled without SELinux support. You will have to recompile nbdkit with libselinux-devel installed, or else set SELinux to Permissive mode while doing the conversion.")
)
@ -61,7 +61,7 @@ index 466de38d..34caaa6a 100644
let json_optstring = function
| Some s -> JSON.String s
| None -> JSON.Null
@@ -265,7 +258,6 @@ object
@@ -271,7 +264,6 @@ object
error_unless_nbdkit_min_version config;
error_unless_nbdkit_python_plugin_working plugin_script;
error_unless_nbdkit_compiled_with_selinux config;
@ -69,11 +69,11 @@ index 466de38d..34caaa6a 100644
(* Python code prechecks. *)
let json_params = match rhv_options.rhv_disk_uuids with
diff --git a/v2v/rhv-upload-plugin.py b/v2v/rhv-upload-plugin.py
index 2b0178a9..d817d915 100644
--- a/v2v/rhv-upload-plugin.py
+++ b/v2v/rhv-upload-plugin.py
@@ -491,10 +491,8 @@ def create_disk(connection):
diff --git a/v2v/rhv-upload-transfer.py b/v2v/rhv-upload-transfer.py
index 5aebcd1d..f38cd9c0 100644
--- a/v2v/rhv-upload-transfer.py
+++ b/v2v/rhv-upload-transfer.py
@@ -111,10 +111,8 @@ def create_disk(connection):
# size, based on qemu-img measure of the overlay.
initial_size=params['disk_size'],
provisioned_size=params['disk_size'],

View File

@ -1,7 +1,7 @@
From 9f5965837da442e4402aae1f40b322070a4f060a Mon Sep 17 00:00:00 2001
From 0839ba57487b73cfb684ea495280db5d946f667a Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sun, 28 Sep 2014 19:14:43 +0100
Subject: [PATCH 01/10] RHEL: v2v: Select correct qemu binary for -o qemu mode
Subject: [PATCH 03/11] RHEL: v2v: Select correct qemu binary for -o qemu mode
(RHBZ#1147313).
RHEL does not have qemu-system-x86_64 (etc), and in addition the

View File

@ -1,7 +1,7 @@
From 8a58d716ba714ddd9198e726b422bcd236fee2b5 Mon Sep 17 00:00:00 2001
From bb55b78b68e6e8039734eb1d7af22b455f8fbdc2 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 30 Sep 2014 10:50:27 +0100
Subject: [PATCH 02/10] RHEL: v2v: Disable the --qemu-boot option
Subject: [PATCH 04/11] RHEL: v2v: Disable the --qemu-boot option
(RHBZ#1147313).
This cannot work because there is no Gtk or SDL output mode

View File

@ -1,7 +1,7 @@
From 0b12d6b45295cb4e1f06be2463e93fef2a793681 Mon Sep 17 00:00:00 2001
From 49385571ce5967f8d9a102e935f201ee9c22326d Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Fri, 24 Apr 2015 09:45:41 -0400
Subject: [PATCH 03/10] RHEL: Fix list of supported sound cards to match RHEL
Subject: [PATCH 05/11] RHEL: Fix list of supported sound cards to match RHEL
qemu (RHBZ#1176493).
---

View File

@ -1,7 +1,7 @@
From ca035dde2b4efaea38563660a51102e96e9e85e5 Mon Sep 17 00:00:00 2001
From db2150a5d790c35fb23c6d9d6b29e602482ce555 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sun, 30 Aug 2015 03:21:57 -0400
Subject: [PATCH 04/10] RHEL: Fix tests for libguestfs-winsupport.
Subject: [PATCH 06/11] RHEL: Fix tests for libguestfs-winsupport.
It doesn't let us use guestfish for arbitrary Windows edits.
---
@ -23,10 +23,10 @@ index 30908a91..73cf5144 100755
run
diff --git a/tests/test-v2v-virtio-win-iso.sh b/tests/test-v2v-virtio-win-iso.sh
index 6e99f0f1..a8e572c5 100755
index 69f6f414..b9b806fb 100755
--- a/tests/test-v2v-virtio-win-iso.sh
+++ b/tests/test-v2v-virtio-win-iso.sh
@@ -79,6 +79,12 @@ mktest ()
@@ -82,6 +82,12 @@ mktest ()
:> "$script"
:> "$expected"
@ -39,20 +39,18 @@ index 6e99f0f1..a8e572c5 100755
firstboot_dir="/Program Files/Guestfs/Firstboot"
mktest "is-dir \"$firstboot_dir\"" true
mktest "is-file \"$firstboot_dir/firstboot.bat\"" true
@@ -91,7 +97,7 @@ for drv in netkvm vioscsi viostor; do
@@ -94,5 +100,5 @@ for drv in netkvm vioscsi viostor; do
done
done
-guestfish --ro -a "$d/windows-sda" -i < "$script" > "$response"
+guestfish --ro -a "$d/windows-sda" < "$script" > "$response"
diff -u "$expected" "$response"
rm -r $d
diff --git a/tests/test-v2v-windows-conversion.sh b/tests/test-v2v-windows-conversion.sh
index f1da222a..ff94fe39 100755
index aeab9a48..4b422c5b 100755
--- a/tests/test-v2v-windows-conversion.sh
+++ b/tests/test-v2v-windows-conversion.sh
@@ -73,6 +73,12 @@ mktest ()
@@ -76,6 +76,12 @@ mktest ()
:> "$script"
:> "$expected"
@ -65,7 +63,7 @@ index f1da222a..ff94fe39 100755
firstboot_dir="/Program Files/Guestfs/Firstboot"
mktest "is-dir \"$firstboot_dir\"" true
mktest "is-file \"$firstboot_dir/firstboot.bat\"" true
@@ -85,7 +91,7 @@ for drv in netkvm qxl vioscsi viostor; do
@@ -88,7 +94,7 @@ for drv in netkvm qxl vioscsi viostor; do
done
done

View File

@ -1,7 +1,7 @@
From 44d88b1170601c31f6199667a6f23cbac4364654 Mon Sep 17 00:00:00 2001
From 3b69cfa365c7b014ca81b09e857ab294cff04914 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 14 Jan 2016 11:53:42 -0500
Subject: [PATCH 05/10] RHEL: v2v: Disable the virt-v2v --in-place option.
Subject: [PATCH 07/11] RHEL: v2v: Disable the virt-v2v --in-place option.
This disables the virt-v2v --in-place option which we do not
wish to support in RHEL.
@ -16,10 +16,10 @@ wish to support in RHEL.
delete mode 100755 tests/test-v2v-in-place.sh
diff --git a/docs/test-v2v-docs.sh b/docs/test-v2v-docs.sh
index dd2b1233..8fef46cc 100755
index 465df26f..ae1a6c68 100755
--- a/docs/test-v2v-docs.sh
+++ b/docs/test-v2v-docs.sh
@@ -27,6 +27,7 @@ $top_srcdir/podcheck.pl virt-v2v.pod virt-v2v \
@@ -30,6 +30,7 @@ $srcdir/../podcheck.pl virt-v2v.pod virt-v2v \
--debug-overlay,\
--ic,\
--if,\
@ -117,10 +117,10 @@ index 83f6fd4d..719a95b5 100644
The I<--machine-readable> option can be used to make the output more
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f08ea69a..5fb7898c 100644
index 41d38d30..9bbd86d6 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -76,7 +76,6 @@ TESTS = \
@@ -77,7 +77,6 @@ TESTS = \
test-v2v-floppy.sh \
test-v2v-i-disk.sh \
test-v2v-i-ova.sh \
@ -128,7 +128,7 @@ index f08ea69a..5fb7898c 100644
test-v2v-mac.sh \
test-v2v-machine-readable.sh \
test-v2v-networks-and-bridges.sh \
@@ -224,7 +223,6 @@ EXTRA_DIST += \
@@ -226,7 +225,6 @@ EXTRA_DIST += \
test-v2v-i-vmx-3.vmx \
test-v2v-i-vmx-4.vmx \
test-v2v-i-vmx-5.vmx \
@ -138,7 +138,7 @@ index f08ea69a..5fb7898c 100644
test-v2v-mac-expected.xml \
diff --git a/tests/test-v2v-in-place.sh b/tests/test-v2v-in-place.sh
deleted file mode 100755
index 6f7d78f3..00000000
index 9da8fa63..00000000
--- a/tests/test-v2v-in-place.sh
+++ /dev/null
@@ -1,108 +0,0 @@
@ -167,18 +167,21 @@ index 6f7d78f3..00000000
-export LANG=C
-set -e
-
-$TEST_FUNCTIONS
-source ./functions.sh
-set -e
-set -x
-
-skip_if_skipped
-skip_if_backend uml
-skip_unless_phony_guest windows.img
-requires test -f ../test-data/phony-guests/windows.img
-
-img_base="$abs_top_builddir/test-data/phony-guests/windows.img"
-
-export VIRT_TOOLS_DATA_DIR="$top_srcdir/test-data/fake-virt-tools"
-export VIRTIO_WIN="$top_srcdir/test-data/fake-virtio-win"
-export VIRT_TOOLS_DATA_DIR="$srcdir/../test-data/fake-virt-tools"
-export VIRTIO_WIN="$srcdir/../test-data/fake-virtio-win"
-
-d=$PWD/test-v2v-in-place.d
-rm -rf $d
-cleanup_fn rm -r $d
-mkdir $d
-
-img="$d/test.qcow2"
@ -247,9 +250,6 @@ index 6f7d78f3..00000000
-
-# Test the base image remained untouched
-test "$md5" = "$(do_md5 $img_base)"
-
-# Clean up.
-rm -r $d
diff --git a/v2v/cmdline.ml b/v2v/cmdline.ml
index ac10ec31..01314580 100644
--- a/v2v/cmdline.ml

View File

@ -1,7 +1,7 @@
From a3054b424c417d89b92d1f55aa1f59adcf7779c8 Mon Sep 17 00:00:00 2001
From e57a5dafc00b3b5737824977aad0feb0ec497a1f Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 2 Mar 2017 14:21:37 +0100
Subject: [PATCH 06/10] RHEL: v2v: -i disk: force VNC as display (RHBZ#1372671)
Subject: [PATCH 08/11] RHEL: v2v: -i disk: force VNC as display (RHBZ#1372671)
The SDL output mode is not supported in RHEL's qemu-kvm.
---

View File

@ -1,7 +1,7 @@
From 28ab3e6e5e76678c4656dbb9cd54893f7ccdf21d Mon Sep 17 00:00:00 2001
From aa5cf3ba5d10400ee6d6c63dd77c711b6fdec116 Mon Sep 17 00:00:00 2001
From: Pino Toscano <ptoscano@redhat.com>
Date: Wed, 8 Mar 2017 11:03:40 +0100
Subject: [PATCH 07/10] RHEL: v2v: do not mention SUSE Xen hosts (RHBZ#1430203)
Subject: [PATCH 09/11] RHEL: v2v: do not mention SUSE Xen hosts (RHBZ#1430203)
They are not supported in RHEL.
---

View File

@ -1,7 +1,7 @@
From 02c4ae37bec8c0dddfa92cd324f92ac32a928384 Mon Sep 17 00:00:00 2001
From ccaae02ef3f081b544eca82f3652ca50ac5566a9 Mon Sep 17 00:00:00 2001
From: Pino Toscano <ptoscano@redhat.com>
Date: Tue, 26 Mar 2019 09:42:25 +0100
Subject: [PATCH 09/10] RHEL: point to KB for supported v2v hypervisors/guests
Subject: [PATCH 10/11] RHEL: point to KB for supported v2v hypervisors/guests
---
docs/virt-v2v-support.pod | 104 ++------------------------------------

View File

@ -1,7 +1,7 @@
From e425f0836c502799c05cdcd6e215de4fff994e70 Mon Sep 17 00:00:00 2001
From 7edb403ee54153c64205915c0bd1d177c0094ee0 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Wed, 30 Jun 2021 11:15:52 +0100
Subject: [PATCH 10/10] RHEL 9: Disable -o glance
Subject: [PATCH 11/11] RHEL 9: Disable -o glance
Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=1977539
---
@ -151,7 +151,7 @@ index 719a95b5..2f4fe86c 100644
This normally requires root. See the next section.
diff --git a/tests/test-v2v-o-glance.sh b/tests/test-v2v-o-glance.sh
index 162c397e..48d45dce 100755
index c0db9115..074b5e16 100755
--- a/tests/test-v2v-o-glance.sh
+++ b/tests/test-v2v-o-glance.sh
@@ -20,6 +20,9 @@
@ -161,9 +161,9 @@ index 162c397e..48d45dce 100755
+# Feature is disabled in RHEL 9.
+exit 77
+
$TEST_FUNCTIONS
skip_if_skipped
skip_if_backend uml
source ./functions.sh
set -e
set -x
diff --git a/v2v/cmdline.ml b/v2v/cmdline.ml
index 01314580..e6c86b6f 100644
--- a/v2v/cmdline.ml

View File

@ -1,2 +1,2 @@
SHA512 (virt-v2v-1.45.2.tar.gz) = 908c762b2200ca2125b7623fe4d14253e0d91de6e7691e540b1e70f68d4a18b8c21de75c894240cf6a0ae5296845dec5cd4cbac5f30c614ffa2c293649a3e6e1
SHA512 (virt-v2v-1.45.2.tar.gz.sig) = 89c19dcc995472b958a1a6f5b5769331e014fc1d2fafd1abddb5edf78b32baf93135e2a57bee5c33de9f782c30970101921aea4b965ff308da9117850d717ba6
SHA512 (virt-v2v-1.45.3.tar.gz) = 24606acb039e630d8cbe4befe232bf9f3e8a2064e931d9064adc59704d34b67269933e2b24cb9f996c31b8c16b4e4f2ebdd7f40c9d29bb0f4a9f3df98d8edf34
SHA512 (virt-v2v-1.45.3.tar.gz.sig) = efbeb0b925b403e6973936a89125b169c7522fc5073a0b8978326de861819a3b8756e219a381e3eac3ee40d97cc16919286a797557e6391e301a0871b38628e7

View File

@ -14,7 +14,7 @@
Name: virt-v2v
Epoch: 1
Version: 1.45.2
Version: 1.45.3
Release: 1%{?dist}
Summary: Convert a virtual machine to run on KVM
@ -50,16 +50,17 @@ ExclusiveArch: x86_64
# Downstream (RHEL-only) patches.
%if 0%{?rhel}
Patch9001: 0001-RHEL-v2v-Select-correct-qemu-binary-for-o-qemu-mode-.patch
Patch9002: 0002-RHEL-v2v-Disable-the-qemu-boot-option-RHBZ-1147313.patch
Patch9003: 0003-RHEL-Fix-list-of-supported-sound-cards-to-match-RHEL.patch
Patch9004: 0004-RHEL-Fix-tests-for-libguestfs-winsupport.patch
Patch9005: 0005-RHEL-v2v-Disable-the-virt-v2v-in-place-option.patch
Patch9006: 0006-RHEL-v2v-i-disk-force-VNC-as-display-RHBZ-1372671.patch
Patch9007: 0007-RHEL-v2v-do-not-mention-SUSE-Xen-hosts-RHBZ-1430203.patch
Patch9008: 0008-RHEL-v2v-rhv-upload-Remove-restriction-on-oa-sparse.patch
Patch9009: 0009-RHEL-point-to-KB-for-supported-v2v-hypervisors-guest.patch
Patch9010: 0010-RHEL-9-Disable-o-glance.patch
Patch9001: 0001-Revert-v2v-Remove-o-rhv-upload-oa-preallocated.patch
Patch9002: 0002-RHEL-v2v-rhv-upload-Remove-restriction-on-oa-sparse.patch
Patch9003: 0003-RHEL-v2v-Select-correct-qemu-binary-for-o-qemu-mode-.patch
Patch9004: 0004-RHEL-v2v-Disable-the-qemu-boot-option-RHBZ-1147313.patch
Patch9005: 0005-RHEL-Fix-list-of-supported-sound-cards-to-match-RHEL.patch
Patch9006: 0006-RHEL-Fix-tests-for-libguestfs-winsupport.patch
Patch9007: 0007-RHEL-v2v-Disable-the-virt-v2v-in-place-option.patch
Patch9008: 0008-RHEL-v2v-i-disk-force-VNC-as-display-RHBZ-1372671.patch
Patch9009: 0009-RHEL-v2v-do-not-mention-SUSE-Xen-hosts-RHBZ-1430203.patch
Patch9010: 0010-RHEL-point-to-KB-for-supported-v2v-hypervisors-guest.patch
Patch9011: 0011-RHEL-9-Disable-o-glance.patch
%endif
%if 0%{patches_touch_autotools}
@ -286,6 +287,11 @@ popd
%changelog
* Fri Aug 06 2021 Richard W.M. Jones <rjones@redhat.com> - 1:1.45.3-1
- New upstream development version 1.45.3.
- Rebase RHEL patches.
resolves: rhbz#1950634
* Wed Jun 30 2021 Richard W.M. Jones <rjones@redhat.com> - 1:1.45.2-1
- New upstream development version 1.45.2.
- Remove --debug-overlays and --print-estimate options.