Fix bytecode compilation (RHBZ#2274708)

(cherry picked from commit 5d4370f7888a20b2b953ad92db59dc4999b4df61)
This commit is contained in:
Richard W.M. Jones 2024-04-12 22:12:58 +01:00
parent ef7323ad39
commit bfa658401f
2 changed files with 34 additions and 0 deletions

View File

@ -0,0 +1,31 @@
From 5eeae696b2c56230d5d5fed5c86b7bf2b3942d4e Mon Sep 17 00:00:00 2001
From: Jerry James <loganjerry@gmail.com>
Date: Fri, 12 Apr 2024 20:11:50 +0100
Subject: [PATCH] Fix bytecode compilation to output whole exe instead of using
-custom
These binaries are more resistant to being stripped.
Reported-by: Ilya Leoshkevich
Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=2274708
(cherry picked from guestfs-tools commit c249fd5caca8f1eed439f83e2bb1af46c8a28a27)
---
subdir-rules.mk | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/subdir-rules.mk b/subdir-rules.mk
index 78d574a813..e969f357b7 100644
--- a/subdir-rules.mk
+++ b/subdir-rules.mk
@@ -47,7 +47,7 @@ $(top_builddir)/generator/generator:
if !HAVE_OCAMLOPT
MLARCHIVE = cma
-LINK_CUSTOM_OCAMLC_ONLY = -custom
+LINK_CUSTOM_OCAMLC_ONLY = -output-complete-exe
BEST = c
else
MLARCHIVE = cmxa
--
2.44.0

View File

@ -23,6 +23,9 @@ Source2: libguestfs.keyring
# Maintainer script which helps with handling patches.
Source3: copy-patches.sh
# Fix bytecode compilation (RHBZ#2274708)
Patch: 0001-Fix-bytecode-compilation-to-output-whole-exe-instead.patch
%if !0%{?rhel}
# libguestfs hasn't been built on i686 for a while since there is no
# kernel built for this architecture any longer and libguestfs rather