Rebase to virt-v2v 2.7.1

resolves: RHEL-56814
Replace Jansson with json-c
resolves: RHEL-65297
Find drivers for win2025 guests
resolves: RHEL-65009
This commit is contained in:
Richard W.M. Jones 2024-10-30 12:33:59 +00:00
parent 7e8507c992
commit b773a874a8
16 changed files with 106 additions and 49 deletions

View File

@ -0,0 +1,60 @@
From 8dd5577174fe23ace5ecba7a81d2516315a0b301 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Wed, 30 Oct 2024 10:16:35 +0000
Subject: [PATCH] lib: OVF: Add preliminary support for Windows Server 2025
Unfortunately support has not yet been added to oVirt. However I have
inferred the correct ostype value based on existing entries.
Also pull in the following commit from the common submodule:
Richard W.M. Jones (1):
mlcustomize: Add heuristic support for Windows Server 2025
Related: https://issues.redhat.com/browse/RHEL-65009
Related: https://issues.redhat.com/browse/RHEL-65010
Reported-by: Ming Xie
---
common | 2 +-
lib/create_ovf.ml | 4 +++-
2 files changed, 4 insertions(+), 2 deletions(-)
Submodule common e9eea65a..2d42128e:
diff --git a/common/mlcustomize/inject_virtio_win.ml b/common/mlcustomize/inject_virtio_win.ml
index 88c1c8cf..7e46f318 100644
--- a/common/mlcustomize/inject_virtio_win.ml
+++ b/common/mlcustomize/inject_virtio_win.ml
@@ -522,6 +522,8 @@ and virtio_iso_path_matches_guest_os t path =
(10, 0, not_client, ((=) "win2k19"))
else if pathelem "2k22" || pathelem "win2022" then
(10, 0, not_client, ((=) "win2k22"))
+ else if pathelem "2k25" || pathelem "win2025" then
+ (10, 0, not_client, ((=) "win2k25"))
else
raise Not_found in
diff --git a/lib/create_ovf.ml b/lib/create_ovf.ml
index f0b32e01..e2c19b08 100644
--- a/lib/create_ovf.ml
+++ b/lib/create_ovf.ml
@@ -242,10 +242,11 @@ and get_ostype = function
| "win2k16" -> "windows_2016x64"
| "win2k19" -> "windows_2019x64"
| "win2k22" -> "windows_2022"
+ | "win2k25" -> "windows_2025"
| _ ->
warning (f_"unknown Windows 10 variant: %s (%s)")
osinfo product;
- "windows_2022"
+ "windows_2025"
)
| { i_type = typ; i_distro = distro;
@@ -448,6 +449,7 @@ and get_ovirt_osid = function
| "win2k16" -> (* windows_2016x64 *) 29
| "win2k19" -> (* windows_2019x64 *) 31
| "win2k22" -> (* windows_2022 *) 37
+ (*| "win2k25" -> (* windows_2025 *) not yet known - 2024/10 *)
| _ ->
warning (f_"unknown Windows 10 variant: %s (%s)")
osinfo product;

View File

@ -1,4 +1,4 @@
From 2a509aaffa688b65fef784037d5828c7ede0bd80 Mon Sep 17 00:00:00 2001
From 8d792ee85d5fc188cba79faff477ef5f73d73022 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sun, 28 Sep 2014 19:14:43 +0100
Subject: [PATCH] RHEL: v2v: Select correct qemu binary for -o qemu mode

View File

@ -1,4 +1,4 @@
From b73da142eebe536682ca3cd915fdecf3baff3167 Mon Sep 17 00:00:00 2001
From f2dbe2f1c595c1201b0f404950b3c4c57f11c04b Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 30 Sep 2014 10:50:27 +0100
Subject: [PATCH] RHEL: v2v: Disable the --qemu-boot / -oo qemu-boot option

View File

@ -1,4 +1,4 @@
From 3a35716e78ff51342942e77a6dfe228b3cb9c6b4 Mon Sep 17 00:00:00 2001
From c9da5056aa7b0d939724b325808a587f79fdb01e Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Fri, 24 Apr 2015 09:45:41 -0400
Subject: [PATCH] RHEL: Fix list of supported sound cards to match RHEL qemu

View File

@ -1,4 +1,4 @@
From a4c21bcb10cd13f4cfe330d479c1e9d70e5836a7 Mon Sep 17 00:00:00 2001
From de77ecd123658dd28362da72783424f4a3ff5deb Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sun, 30 Aug 2015 03:21:57 -0400
Subject: [PATCH] RHEL: Fixes for libguestfs-winsupport.

View File

@ -1,4 +1,4 @@
From e730683c6e0eb9ae71e8b05a1f12fbaf43a3300b Mon Sep 17 00:00:00 2001
From 1c85b582fc38f379b54efe344dc2323db95acc78 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 2 Mar 2017 14:21:37 +0100
Subject: [PATCH] RHEL: v2v: -i disk: force VNC as display (RHBZ#1372671)

View File

@ -1,17 +1,17 @@
From 1acf2b8a7ef9dc10ae95830f884e98df5b624e7b Mon Sep 17 00:00:00 2001
From 6b7b2934d54d5273bb6c444ddabccef3a64c5eee Mon Sep 17 00:00:00 2001
From: Pino Toscano <ptoscano@redhat.com>
Date: Tue, 26 Mar 2019 09:42:25 +0100
Subject: [PATCH] RHEL: point to KB for supported v2v hypervisors/guests
---
docs/virt-v2v-support.pod | 104 ++------------------------------------
1 file changed, 4 insertions(+), 100 deletions(-)
docs/virt-v2v-support.pod | 96 ++-------------------------------------
1 file changed, 4 insertions(+), 92 deletions(-)
diff --git a/docs/virt-v2v-support.pod b/docs/virt-v2v-support.pod
index 8b64a5ea..1ffc0f9d 100644
index e6415692..1ffc0f9d 100644
--- a/docs/virt-v2v-support.pod
+++ b/docs/virt-v2v-support.pod
@@ -8,106 +8,10 @@ systems and guests in virt-v2v
@@ -8,98 +8,10 @@ systems and guests in virt-v2v
This page documents which foreign hypervisors, virtualization
management systems and guest types that L<virt-v2v(1)> can support.
@ -84,9 +84,9 @@ index 8b64a5ea..1ffc0f9d 100644
-
-=over 4
-
-=item Red Hat Enterprise Linux 4, 5, 6, 7
-=item Red Hat Enterprise Linux 4, 5, 6, 7, 8, 9, 10
-
-=item CentOS 4, 5, 6, 7
-=item CentOS 4, 5, 6, 7, 8, 9, 10
-
-=item Scientific Linux 4, 5, 6, 7
-
@ -104,15 +104,7 @@ index 8b64a5ea..1ffc0f9d 100644
-
-=item Ubuntu 10.04, 12.04, 14.04, 16.04, and up
-
-=item Windows XP to Windows 10 / Windows Server 2016
-
-We use Windows internal version numbers, see
-L<https://en.wikipedia.org/wiki/List_of_Microsoft_Windows_versions>
-
-Currently NT 5.2 to NT 6.3 are supported.
-
-See L</WINDOWS> below for additional notes on converting Windows
-guests.
-=item Windows XP to Windows 11 / Windows Server 2025
-
-=back
+For more information on supported hypervisors, and guest types in

View File

@ -1,4 +1,4 @@
From 72e5733e70870a66e8b8132bbfe56d2d688eab41 Mon Sep 17 00:00:00 2001
From 0b4fc69b54bf5a8fafc9bed62749ff2c91eeb21d Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Mon, 8 Jul 2024 09:35:54 +0100
Subject: [PATCH] RHEL: Remove input from Xen

View File

@ -1,4 +1,4 @@
From 30a1e0a8b6cfa21a2e24c3d4aca85f5682f63df5 Mon Sep 17 00:00:00 2001
From dce2fe3c583cb6a8259667337df31c6c361fa670 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Wed, 30 Jun 2021 11:15:52 +0100
Subject: [PATCH] RHEL: Remove -o glance

View File

@ -1,4 +1,4 @@
From e9d68fe110428f1d24c4cbb45cae744fd644fdea Mon Sep 17 00:00:00 2001
From af62ac81540fc6baf10c572ae5440dd4b678b073 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 2 Dec 2021 11:56:05 +0000
Subject: [PATCH] RHEL: Remove the --in-place option

View File

@ -1,4 +1,4 @@
From 2400571532f5dfbef847762f284144b13780f5af Mon Sep 17 00:00:00 2001
From b7614e03e7e6584296fb4b74d951997bfd24b848 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 5 Jul 2022 11:58:09 +0100
Subject: [PATCH] RHEL: tests: Remove btrfs test

View File

@ -1,4 +1,4 @@
From 4bcc65e7f7a63ee6f1117e104f92462b9ee3a885 Mon Sep 17 00:00:00 2001
From e0af932e291fdb9f87b071a873152f757f8ad71c Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Fri, 28 Apr 2023 12:28:19 +0100
Subject: [PATCH] RHEL: Remove --block-driver option

View File

@ -1,4 +1,4 @@
From f2313ec6c8025b0172984911715bd9846d51457c Mon Sep 17 00:00:00 2001
From 4a460f0ae97f59d9bff9ff568d45588fe4241b7e Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Mon, 8 Jul 2024 09:56:54 +0100
Subject: [PATCH] RHEL: Remove -o rhv, -o rhv-upload and -o vdsm modes
@ -641,7 +641,7 @@ index eb7da9ca..de92db84 100644
[...]
output:local
diff --git a/output/Makefile.am b/output/Makefile.am
index 9663acb1..d53a2280 100644
index 1e6799c3..09638c25 100644
--- a/output/Makefile.am
+++ b/output/Makefile.am
@@ -17,14 +17,7 @@

View File

@ -1,4 +1,4 @@
From 86c4f39cdbf53b5e874eb7da3ddc199072db2153 Mon Sep 17 00:00:00 2001
From fe167d94ed81b41b025f55cbd6ca97ce404986ce Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 9 Jul 2024 11:30:09 +0100
Subject: [PATCH] RHEL: Add warning about virt-v2v-in-place not being supported

View File

@ -1,2 +1,2 @@
SHA512 (virt-v2v-2.6.0.tar.gz) = bc7ecf99e66bae057eaf5d7c82ca38ded4aa6ef8732544bc7079f2894c9c79542a415fede02cf8c2cb7e83756683457c705f816b1da57e5ca9565350b9376a73
SHA512 (virt-v2v-2.6.0.tar.gz.sig) = 630166caf41d48ac2efca646611248263e58a4e7e644a7606b647911164a39a449ae3916d05248d48e80925f3f9179b1cfb850001b0f3dd30a48c301d62b11a0
SHA512 (virt-v2v-2.7.1.tar.gz) = 11f5528a48208050fda9c64c8aa6dcfd28352e26c96f15059ef66230577e87cae79286dbe035ee5fdf3c43398cba1f94569e11ff3871b26f21e7a6265a4bfa6d
SHA512 (virt-v2v-2.7.1.tar.gz.sig) = a73bce78f116f68565e1288c130c0ea4adc4e1d87174f72fc9aeff747c541afd16404d59d12d0431d50b83a9d0dbe5ff12dddbfed97d2e1d431212a895078cad

View File

@ -2,11 +2,11 @@
%global verify_tarball_signature 1
# The source directory.
%global source_directory 2.6-stable
%global source_directory 2.7-development
Name: virt-v2v
Epoch: 1
Version: 2.6.0
Version: 2.7.1
Release: 1%{?dist}
Summary: Convert a virtual machine to run on KVM
@ -27,19 +27,20 @@ Source3: copy-patches.sh
# https://github.com/libguestfs/virt-v2v/commits/rhel-10.0
# Patches.
Patch0001: 0001-RHEL-v2v-Select-correct-qemu-binary-for-o-qemu-mode-.patch
Patch0002: 0002-RHEL-v2v-Disable-the-qemu-boot-oo-qemu-boot-option-R.patch
Patch0003: 0003-RHEL-Fix-list-of-supported-sound-cards-to-match-RHEL.patch
Patch0004: 0004-RHEL-Fixes-for-libguestfs-winsupport.patch
Patch0005: 0005-RHEL-v2v-i-disk-force-VNC-as-display-RHBZ-1372671.patch
Patch0006: 0006-RHEL-point-to-KB-for-supported-v2v-hypervisors-guest.patch
Patch0007: 0007-RHEL-Remove-input-from-Xen.patch
Patch0008: 0008-RHEL-Remove-o-glance.patch
Patch0009: 0009-RHEL-Remove-the-in-place-option.patch
Patch0010: 0010-RHEL-tests-Remove-btrfs-test.patch
Patch0011: 0011-RHEL-Remove-block-driver-option.patch
Patch0012: 0012-RHEL-Remove-o-rhv-o-rhv-upload-and-o-vdsm-modes.patch
Patch0013: 0013-RHEL-Add-warning-about-virt-v2v-in-place-not-being-s.patch
Patch0001: 0001-lib-OVF-Add-preliminary-support-for-Windows-Server-2.patch
Patch0002: 0002-RHEL-v2v-Select-correct-qemu-binary-for-o-qemu-mode-.patch
Patch0003: 0003-RHEL-v2v-Disable-the-qemu-boot-oo-qemu-boot-option-R.patch
Patch0004: 0004-RHEL-Fix-list-of-supported-sound-cards-to-match-RHEL.patch
Patch0005: 0005-RHEL-Fixes-for-libguestfs-winsupport.patch
Patch0006: 0006-RHEL-v2v-i-disk-force-VNC-as-display-RHBZ-1372671.patch
Patch0007: 0007-RHEL-point-to-KB-for-supported-v2v-hypervisors-guest.patch
Patch0008: 0008-RHEL-Remove-input-from-Xen.patch
Patch0009: 0009-RHEL-Remove-o-glance.patch
Patch0010: 0010-RHEL-Remove-the-in-place-option.patch
Patch0011: 0011-RHEL-tests-Remove-btrfs-test.patch
Patch0012: 0012-RHEL-Remove-block-driver-option.patch
Patch0013: 0013-RHEL-Remove-o-rhv-o-rhv-upload-and-o-vdsm-modes.patch
Patch0014: 0014-RHEL-Add-warning-about-virt-v2v-in-place-not-being-s.patch
%if !0%{?rhel}
# libguestfs hasn't been built on i686 for a while since there is no
@ -69,7 +70,7 @@ BuildRequires: augeas-devel
BuildRequires: bash-completion
BuildRequires: file-devel
BuildRequires: gettext-devel
BuildRequires: jansson-devel
BuildRequires: json-c-devel
BuildRequires: libnbd-devel
BuildRequires: libosinfo-devel
BuildRequires: libvirt-daemon-kvm
@ -325,9 +326,13 @@ done
%changelog
* Wed Oct 09 2024 Richard W.M. Jones <rjones@redhat.com> - 1:2.6.0-1
- Rebase to virt-v2v 2.6.0
* Wed Oct 30 2024 Richard W.M. Jones <rjones@redhat.com> - 1:2.7.1-1
- Rebase to virt-v2v 2.7.1
resolves: RHEL-56814
- Replace Jansson with json-c
resolves: RHEL-65297
- Find drivers for win2025 guests
resolves: RHEL-65009
* Wed Aug 28 2024 Richard W.M. Jones <rjones@redhat.com> - 1:2.5.6-2
- convert: windows: Online all virtio disks at first boot